-June 2024 Special Lease Deals-

2024 Chevy Blazer EV lease from Bayway Auto Group Click here

2024 Jeep Grand Cherokee lease from Mark Dodge Click here

2025 Ram 1500 Factory Order Discounts from Mark Dodge Click here
Options

Lincoln Town Car engine acts like it's misfiring when cold on acceleration.

doblick74doblick74 Member Posts: 1
edited July 2016 in Lincoln
My 95 TC (Big Granny) has 270K. Lately the engine acts like it's misfiring when I first put it in drive in the morning. At idle, it runs smooth with no problems, only on acceleration when it's first started. Once the car warms up, it runs fine. I have replaced the spark plugs (I used Motorcraft) and today installed new air filter and cleaned the MAF sensor. The car still has the issue. Where/what do I try next? Thank you in advance for your assistance.

Comments

  • Options
    willietcwillietc Member Posts: 3
    try cleaning the throttle body and check the throttle position sensor.
  • Options
    Mr_ShiftrightMr_Shiftright Member Posts: 64,481
    edited July 2016
    With that many miles, it could be so many things. I believe your car is OBD-II complaint, so hook up a scanner or code reader. Also check for vacuum leaks in your PCV hose, especially as it runs back to the firewall just before it makes its connection to the intake plenum.
  • Options
    SNU88YSNU88Y Member Posts: 3
    does it have the coil-on-plug system......Most of the time when I have had issues like that one of the coils is going bad. Intermittent miss at low speeds is a sign
Sign In or Register to comment.