Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Have you recently tried to purchase a new vehicle after being out of the market for a while and found that prices were much higher than you expected? A reporter would like to talk to you; please reach out to [email protected] by 1/22 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Weird starter issue

buttermerckbuttermerck Posts: 2
edited November 2014 in Chevrolet
I have a question. My 1998 chev 1500 ignition or something is acting up. I have to turn my truck off when it's still in drive because when input it in park or neutral it tries to start even when the truck is on and also when truck is off and key out of ignition. When I want to start it I put my key in the ignition and turn it forward to the on position then I have to quickly put the truck in neutral so it turns over and then put it in drive once it started. I have to keep truck in drive because when it's in neutral or park it's always trying to start. Even without the key in. So when I want to start it I just put the key in, turn the key on, put it in neutral or park for a couple seconds the straight into drive so that the truck doesn't keep trying to start. Runs perfect when im on the road just starting is a chore. 

Answers

  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,490
    Why don't you disconnect the neutral safety switch connector on the transmission just briefly for test purposes. If the problem goes away, then replace that switch. BE CAREFUL as your car might start in gear. You may have to jump over the switch entirely in order to complete the circuit to the starter motor. The neutral switch could have some kind of internal short.

    Just a guess here.
  • When I went out I my vehicle this morning the problem wasn't there. Frustrating! If it does it again I'll try this solution. Someone told me it could be my ignition switch. I'll try this first and continue from there. 
Sign In or Register to comment.