Van keeps overheating!

sedonaowner1sedonaowner1 Member Posts: 5
edited January 2015 in Kia
My van started overheating on Christmas Eve and I had a coolant leak about a year or so ago from the rear heater pipes, so I assumed that was the issue again and stopped and quickly added coolant, which seemed to fix the issue. I didn't see a coolant leak the following days and my reservor was full and the over heating stopped initially. After driving pretty far a week later, I over heated again....This time, I went and got some stop leak and the pellets just got stuck in the radiator......I added more coolant, still didn't see a leak, so I googled issues and checked to see if a gasket was blown, but it didn't overheat in idle. So, we changed out the thermostat and pulled the pellets out of the radiator, let coolant flow through the system and the issue seemed to be fixed. Then my van statred making a whoosh, whoosh, whoosh sound when in idle and started to barely overheat, then go back down. My check engine light came on and went off, so I stopped by Auto Zone to get a diagnostics and they said it seemed the air sensor was dirty and we pulled that off, cleaned it and plugged it back in. The check engine light has stayed off, but the whooshing would come and go mostly while in idle, and my heat has come and gone with it. Last night, I drove around more than usual and I overheated right before I got home (along with whooshing noises)....This morning, I noticed a ton of coolant on the ground at the rear of my van, so I assume the rear heater pipes have failed again....I checked my reservoir and tried to make it to work.....My car had been warming up awhile and I didn't get far before over heating again...I added more coolant and caustiously drove to work while running pretty warm. I checked my reservoir and coolant cap for a milky substance and don't see any, I am considering just bypassing the rear heat altogether, but am not sure if the whooshing sound is a part of the corroded pipes or a seperate issue altogether. When I have the hood up and van running, it sounds as if all fans are running. I need to know the cheapest and easiest way to fix this. Iam on one income, and this is my only way to and from my new job. Please help. My brother is mechanically inclined and will help me, but I need to know the issue first.

Comments

  • sedonaowner1sedonaowner1 Member Posts: 5
    Forgot to mention....Got an oil change two days ago and added engine Restore.
  • ray80ray80 Member Posts: 1,655
    edited January 2015
    I am not familar with cooling system on Kia's but the whosshing sound has me thinking about air in the system which should be bled out by proper procedure for your vehicle

    Oh and hopefully its not because coolant is tired or weak and some freezing going on.
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaMember Posts: 64,482
    First thing you should probably do as Ray80 suggests and properly bleed the system of air. Then get a pressure pump (pretty inexpensive at Autozone) or borrow one and pressurize your cooling system to look for leaks. If you see no external leaks you can keep the system pressurized and extract the spark plugs one by one--if you see any coolant on their tips, the the head gasket is toast (or maybe the head itself).

    And stay away from stopleaks and engine additives. Waste of money.
  • sedonaowner1sedonaowner1 Member Posts: 5
    There is definitely a leak...There was tons of coolant on the ground this morning. How do I bleed the system of air? And, thank you!
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaMember Posts: 64,482
    edited January 2015
    Normally you just start the engine, wait until the thermostat opens, then slowly pour coolant into the radiator...very slowly, allowing it to "burp" out the air. When it's full and there's no more burping, then it should be pretty well bled of air.

    I suggest the pressure pump because the leak could be just from the overheating pushing water out the reservoir.

    Another inexpensive thing you can do to check for a head gasket problem is buy a chemical test kit at Autozone, which checks for combustion gases in the coolant.
  • sedonaowner1sedonaowner1 Member Posts: 5
    • Whooshing sound coming from under hood, mainly in idle
    • Over heated on Christmas Eve….added coolant and it was fine….Didn’t see any leaks
    • Kept over heating, so replaced thermostat, seemed to fix problem, noticed oil was low so added oil
    • A week later,-Whooshing sound came back, van overheated again, check engine light came on and went off, heat started to go in and out. AutoZone ran engine diagnostics and said it was air valve, cleaned valve and engine light never came back on. Slight squealing sound that is rare
    • Checked for sludge in coolant or oil
    • Got oil change at Valvoline and had engine Restore added
    • Noticed giant coolant leak in back of van, van kept overheating and heat wouldn’t work
    • Friend cut pipes to rear heater and bypassed the rear heat by moving a pipe over, heat came back on, whooshing stopped and made it home fine
    • Next day, noticed small coolant leak under bypass site
    • Drove van to friend’s house and when parked the coolant was bubbling out at bypass site, even making a hissing and popping sound
    • Friend said he used an all weather sealant to fix problem
    • Drove it home and coolant leaked, hissed and popped at bypass site, …….added coolant
    • Drove to work in the morning, heat was going in and out, started to over heat, whooshing sound was back, and oil light flickered on and off. Hissing, popping and leaking at by-pass site when parked again.
  • ray80ray80 Member Posts: 1,655
    Kind of sounds like your right where you started, a leak . One way or another that needs to be fixed
Sign In or Register to comment.