Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Have you recently tried to purchase a new vehicle after being out of the market for a while and found that prices were much higher than you expected? A reporter would like to talk to you; please reach out to [email protected] by 1/22 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Unsure of this issue need help!

presto013presto013 Posts: 1
edited April 2015 in Dodge
I have a 1994 Dodge Ram 1500
when driving to my parents house one day (they live 8 miles from me) my truck starting running really rough acted like it wasn't getting gas or something. Basically choked out did this jerking motion and died. It took it a couple min started back up ran rough again and then drove perfectly fine! This has progressive worstened in about 1 month time. I changed spark plugs wires crank posion sensor is replaced has brand new battery checked O2 sensors there is no  cad. converter so there is no clogs. The truck will now sit in the garage all day long and run  but when you go to drive it it will make it .5 mile and choke out and run rough! Please help I'm so confused 

Comments

  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,490
    So many possibilities here, which is why methodical diagnosis is the only way to solve this. What you need to do first is test fuel pressure in the injection rail to see if that's up to standard. You may need a technician to test the MAP sensor and the wiring harness to the PCM. There's also a cam sensor that needs looking at, and, on a truck this old, basic things like fuel filter. It may be necessary to have test equipment hooked up so that the tech can observe or "freeze" the data at the exact moment of failure.
  • druss71druss71 Posts: 7
    I have a 92 jeep wrangler that had similar problems, it would idle fine but die as soon as I got going, my problem ended up being the wire to the coil was loose I figured that If I even touched the wire the car would shutter, so I could make sense that if a wire is loose that when the car moves and the wires start shaking it could break any connections, just look in that area
Sign In or Register to comment.