Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Did you get a great deal? Let us know in the Values & Prices Paid section!
Have you recently used your tax refund (or are you planning on using your tax refund) toward the payment of a new or used vehicle? Or, are you planning on using your tax refund toward any expenses related to your car?
If so, a reporter would like to talk to you. Please reach out to [email protected] by Friday, January 25 and the Edmunds PR team may connect you with the journalist.

Are you the parent of a generation Z child (born in the mid-1990s to the early 2000s)? Do you have differing opinions on the importance of buying a car, what types of vehicles you're interested in, or just how you view cars in general? If so, a reporter would like to speak with you and your child. Please reach out to [email protected] by Friday, January 25 and the Edmunds PR team may connect you with the journalist.

2003 Chevy Trailblazer Transmission Problems

airmanhinkleyairmanhinkley Posts: 1
edited May 2015 in Chevrolet
I have a 2003 Chevy Trailblazer with 15500 miles. While trying to pull out at a stop sign the transmission would not shift into gear. The RPMs went up but it did not move at all. I shut the vehicle off and let it sit for a minute, and then it worked fine for another 5 min, until the same thing happened. I had the car towed to my house, as it arrived I got in it and drove it right into its parking spot. all gears worked fine. after parking it i put it in drive and once again the car would not move, just an increase in RPM with no movement. Long story short, after running for a minute the truck will not shift into gear, after letting it sit for a couple minutes (not even enough time to cool down) it works for another minute. It seems like the computer may be cutting it off, to prevent damage, but I don't know why. I have talked to a few people who say they have had the same problem (Trailblazer wont move, after cool down moves again) but mine seems to work again shortly after shutdown. It will shift through all the gears when working including reverse, until it stops. then nothing. Ive never had this problem where as long as its working its fine, but cuts off until you restart car. It will not work immediately after shutting off it does take a few minutes, (5 tops) no where near enough time to cool down, also it goes out right after a minute or two of use not enough time to get hot.. Any help would be greatly appreciated.

Comments

  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 63,027
    Sounds like some kind of pressure issue---maybe if you're lucky a valve body problem and not some internal damage. By all means get it pressure tested at a qualified shop and perhaps drop the pan to see if there are any signs of debris or burning.

    MODERATOR --Need help with anything? Click on my name!

    Share Your Vehicle Reviews Here

  • Airmanhinkley did you ever find out what the issue is
  • Im having same problem with my 2003 trailblazer LT. Stops going but the RPM's go way up. Got towed home & drive it into garage no problem. Tried to go up driveway & it wouldn't move again. Anyone ever find out what's going on here? 
Sign In or Register to comment.