Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Transmission shift problem - solenoid?

marquis97marquis97 Posts: 4
edited July 2015 in Mazda
On my 2002 protege with O/D off the transmission shifts fine.

When the O/D switch is on the transmission shifts okay until you hit about 40 mph. It seems like it shifts to neutral and the rpms go up.

There are no codes.

Anyone know if this may be a shift solenoid problem and which one?

No codes. Transmission Fluid level is good. Fluid looks brand new.

Car has 103,000 miles on it.

Comments

  • Did you try going higher in speed and than put on the O/D to see what happens?
  • marquis97marquis97 Posts: 4
    No the transmission drops out at about 40 mph and I can only turn o /d on when in park. I did order the A & B solenoids which cost about $50 and are replacing this week to see if it solves the problem.
  • marquis97marquis97 Posts: 4
    Okay replaced two solenoids that were supposedly the A & B. They were the only two that had one wire going to them, they also had the highest resistance. Just test drive it and this is the first time where I can leave it in O/D and it doesn't drop out at about 40. You can see it shifting right on the tach. Mileage was horrible, I expect it to improve. Was less then $100 which included fluid, filter and two solenoid. Was getting ready to junk car because you bring to transmission repair shop and they only will rebuild/replace transmission.
  • kyfdxkyfdx Posts: 119,728
    Nice job!

    Did you get a good deal? Be sure to come back and share!

    Edmunds Moderator

Sign In or Register to comment.