Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

42re whines and doesn't go in gear or slips, only when warm.

67j300067j3000 Posts: 6
edited September 2015 in Jeep
My 02 grand cherokee is fine when it's cold but as it warms up it starts to whine from pan area in every gear but park. Then it starts to slip and not go into gear. Changed pan filter and fluid helped for about 30 miles. I was thinking trans pump or converter but it doesn't chatter like converters normally do so I'm not sure. Either way I'd like to figure it out before I pull the tranny and replace it.

Answers

  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 63,925
    Any debris in the pan or filter? Have you scanned for codes in the TCM?

    MODERATOR --Need help with anything? Click on my name!

    Share Your Vehicle Reviews Here

  • Not more then some normal build up on the magnet.
  • I didn't scan it but I did check dash codes would trans codes show there?
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 63,925
    yes, some anyway---probably you'd need a "deeper" scan for further results.

    MODERATOR --Need help with anything? Click on my name!

    Share Your Vehicle Reviews Here

  • Thanks I'll have to look into it further. I was thinking about pulling the trans coolant lines and seeing if it's pumping it through. Good idea or bad? I would put return in a container of fluid to draw from.
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 63,925
    I don't know what exactly that would tell you because it might pump but not at the proper pressures.

    MODERATOR --Need help with anything? Click on my name!

    Share Your Vehicle Reviews Here

  • What pressure should it pump at?
  • No codes.
Sign In or Register to comment.