2014 Nissan Altima S stalling

mohind5666mohind5666 Member Posts: 1
edited June 2019 in Nissan
I have 2014 Altima S that has no problem starting but as soon as I try to put it in gear (Shift...it is automatic transmission) it stalls. Also if I apply brakes to stop the car it stalls too after giving couple of strong jolts. When running I dont feel anything wrong. I took it to the dealer and he says its CVT transmiision has gone bad which I dont feel right since when it is running there is no problem of any kind. All this is random.

Answers

  • prowler_mq5qm_prowler_mq5qm_ Member Posts: 12
    Is it still under warranty? If so, and at no cost to you, let the dealership fix it. I'm new to CVT's, myself, but if it were a standard automatic transmission, I would guess something was wrong with the torque converter. Do CVT's have a torque converter?
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaMember Posts: 64,482
    No CVTs dont' have a torque converter but they do have a hydraulically activated clutch pack to engage and disengage the drive pulley so there may indeed be some relationship between a defective CVT and your stalling issue.
  • 2014NAltimaS2014NAltimaS Member Posts: 1
    @mohind5666 , OP any update on this? I am having the exact issue that you described? What was the finding and fix?
  • InamInam Member Posts: 1
    @mohind5666 and @2014NAltimaS hey guys I'm having the same problem. My car does not give any error code but jerks at stop sign and then dies. How did you guys fix it ? What was the problem? I do not have warranty
Sign In or Register to comment.