Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Chevy Suburban Electrical issues

jakeeatmonjakeeatmon Posts: 2
edited July 2016 in Chevrolet
Have a 2002 suburban 5.3L. Everything works except odometer, windshield wipers, fuel gauge, ac/heater, and the battery light stays on. Battery and alternator are good, had them tested. All fuses to relating problems are good. OBII not reading any codes. Not sure what else to check or what another problem could be. Suggestions or solutions are highly appreciated. Thank you. 

Comments

  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,490
    Not much to do here except wild guessing. A pro scan tool to read data in freeze frame and real time might be the only way to track down what's going on--some kind of communication problem seems to me, since these components must all be networked to some module or modules.

    Have you tried the ol' "jiggle test" by getting underneath the dash and moving the harnesses around a bit--to see if anything changes?

  • I have not done that. OBII turns on and reads, but just doesn't give me any information. Reads as if all is perfect on it. 
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,490
    Well a code reader won't tell you much.
Sign In or Register to comment.