Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Did you get a great deal? Let us know in the Values & Prices Paid section!
Have you recently used your tax refund (or are you planning on using your tax refund) toward the payment of a new or used vehicle? Or, are you planning on using your tax refund toward any expenses related to your car?
If so, a reporter would like to talk to you. Please reach out to [email protected] by Friday, January 25 and the Edmunds PR team may connect you with the journalist.

Are you the parent of a generation Z child (born in the mid-1990s to the early 2000s)? Do you have differing opinions on the importance of buying a car, what types of vehicles you're interested in, or just how you view cars in general? If so, a reporter would like to speak with you and your child. Please reach out to [email protected] by Friday, January 25 and the Edmunds PR team may connect you with the journalist.

Tps issue cel P0122

LkmaryFlaLkmaryFla Orange CityPosts: 4
edited January 4 in Mercury
Yesterday my 1997 had no cel codes when i checked but it was shuddering at idle slighlty here and there. About a month ago i had the Iac , Maf sensor and throttle body changed and cleaned which helped alot. So yesterday I unplugged battery and changed the Tps. Now my car has cel P0122 code? How could it go from not having cel code to having one after putting a new Tps on? Please any information is greatly appreciated, my only vehicle

Comments

  • LkmaryFlaLkmaryFla Orange CityPosts: 4
    It also is running worse, and makes no difference if i unplug it, runs the same. I changed it back to the previous Tps and same thing?
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 63,010
    I'd carefully check the TPS connector and wiring, first thing, especially if you swapped out components and had the same result. Also some cars require the TPS to be adjusted or aligned.

    MODERATOR --Need help with anything? Click on my name!

    Share Your Vehicle Reviews Here

  • LkmaryFlaLkmaryFla Orange CityPosts: 4
    I checked the wiring and connector and they seem fine? I guess i change out the connector. I read that the Grand Marquis doesnt need to be adjusted. That and i tried to loosen and wiggles and it doesnt affect it, like it does in adjustable cars. Thanks
  • thecardoc3thecardoc3 Posts: 4,836
    The code sets if the closed throttle voltage isn't between .66 and 1.2v during the self test. Was the throttle plate adjusted?
  • LkmaryFlaLkmaryFla Orange CityPosts: 4
    I ended up fixing it yesterday. It ended up being the connector that plugs into the tps. I changed tps with 3 different brands none made a difference so i bought a connector and cut the wires and connected the new and it worked. Thanks
Sign In or Register to comment.