Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

numerous issues

Kerry17Kerry17 North CarolinaPosts: 1
edited February 6 in Jeep
99 jeep cherokee classic 4.0 started out running rough bucking and jerking . have changed crank position sensor , plugs wires disrtibutor cam position sensor . cleaned throttle body fixed some wires . now it will drive then stalls and wont start back up till it cools down . ive seen where people have had same problem and changed pcm but nothing says that will fix it for sure . any ideas Im sick of throwing parts at it . and now it has P0340 code no cam referance to pcm

Comments

  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 63,914
    some suggestions:

    Possible reasons:

    A wire or connector in the circuit could be grounded/shorted or broken.

    The camshaft position sensor may have failed

    The PCM may have failed

    There's an open circuit

    Things you could possibly do:

    Visually inspect all the wiring and connectors in the circuit

    Check for continuity in the circuit wiring

    Check the operation (voltage) of the camshaft position sensor

    Replace the camshaft position sensor as required

    Check the crankshaft position circuit as well

    Replace circuit wiring and/or connectors as required

    Diagnose/replace the PCM as required


    MODERATOR --Need help with anything? Click on my name!

    Share Your Vehicle Reviews Here

Sign In or Register to comment.