Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Car stalls when I turn on climate control.

marcusmo172marcusmo172 Posts: 2
edited March 24 in Ford
When I first start vehicle, The dash lights for turn signal and high beam illuminate. The dimmer on the dash does not illuminate. The wipers only work on high speed. The car stalls when I turn on fan for climate control. The car will not allow me to put in drive. Sometimes I have to re-start vehicle a few times to get shifter to Drive. Any suggestions?

Comments

  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,459
    Whenever there are multiple electrical failures first thing I always advise is to clean your battery cables and also, very important, any engine to frame grounds.

    After that, check your fuse box for corrosion, water, rodent damage, etc.

    After that, check the alternator charge rate and have the battery load tested.

    After that, learn how to, or pay someone to, do a voltage drop test on the battery cables.


    MODERATOR --Need help with anything? Click on my name!

    Share Your Vehicle Reviews Here

  • Thank you Mr_Shiftright. Very helpful info. Right below the fuse box was a ground wire that was loose. Once I tightened the ground wire back up, All my issues were resolved. At first; I replaced ground and positive terminals on Battery and then even followed ground to frame to clean up. I wasnt even thinking about the fuse box considering all the relays and fuses were good. Thanks for all your help....
Sign In or Register to comment.