Are you shopping for a new vehicle and having trouble finding one, or have you been waiting a long time for a factory order? A reporter would like to speak with you; please reach out to [email protected] by Tues. 5/11 for more details.

I have a question about oil pressure

olacubmolacubm Mesa, AZMember Posts: 2
edited October 2020 in Ford
I have a 99 Taurus Wagon with the 24 V Duratec engine. I have noticed recently that after driving at highway speeds for a while, when i get off the highway and stop for traffic signals, etc., my oil light will flash or come on. when I accelerate, it goes back out. Most recently, I drove at moderately higher speeds (75mph), and the light came on when I stopped and ther valve train sounded noisy. When i increased engine speed the noise went away and engine sounded normal. I stopped to check oil level, which was fine after letting the car sit for a few minutes. Upon restarting, no oil light, no noises. I am wondering if the oil passages in the engine may be restricted, or if the pickup screen is clogged. Under normal driving, no issues.

Answers

  • olacubmolacubm Mesa, AZMember Posts: 2
    The vehicle has about 146,xxx miles, and has had regular maintenance.
  • oldfarmer50oldfarmer50 Member Posts: 17,786
    edited December 2020
    Could be a defective oil pressure sensor. Cheap fix. That Duratec engine is pretty reliable as long as you don’t overheat it. With regular oil changes you shouldn’t have clogged oil passages. You could try one of the engine flush products to see if that helps.

    2019 Kia Soul+, 2015 Mustang GT, 2004 Chevy Van, 2000 Chrysler Sebring convertible

Sign In or Register to comment.