Are you (or someone in your family) a first-time car buyer who is struggling to find an affordable used vehicle? A reporter would like to speak with you; please reach out to [email protected] by 1/21 for more details.

Isuzu Trooper Engine Misfire

krowekrowe Member Posts: 1
edited October 2014 in Isuzu
I am trying to fix a problem with a '01 Trooper Limited 4WD. The vehicle has 75,000 miles and started to sound rather rough. My wife had the vehicle checked at a shop and was told the EGR valve was bad. I replaced the part as well as a new set of plugs, reset the OBD codes and the car runs a lot better. I am still getting a P0300 code (multilple engine misfire) and the check engine light blinks only when the car is moving. It does not blink when the car is not moving even if the same RPM level is reached. What is causing this misfire?


  • boxtrooperboxtrooper Member Posts: 843
    When changing the EGR valve make sure to clean out the carbon buildup inside. The original EGR valve on some 01's is known to go bad. The replacement EGR valve is an improved design and should not need replacing again. Both the original and replacement versions are GM parts.
    The other known occasionally >60K miles failing part on the 01 Trooper 3.5L engine is the intake manifold gaskets. These are thick composite insulating gaskets, and they can sometimes crack allowing air into the engine. Air input into the engine at a gasket leak bypasses the air filter and engine computer monitoring. This can cause damage from dirt sucked in and poor engine performance because the computer cannot adjust the fuel mix properly to account for the extra air. The replacement gaskets are supposed to also be better than original so the problem will not happen again.
  • laparka55laparka55 Member Posts: 8
    I've been having the same stalling issues. How much does it cost to have intake manifold gaskets replaced?
  • boxtrooperboxtrooper Member Posts: 843
    I don't remember the cost, but the labor was a lot and the gaskets are complicated since they are a thermal barrier so they were not inexpensive either. I had mine done here: 919-872-1999
  • marknrollmarknroll Member Posts: 1
    Alright I've searched the history and dug as far back as I can to find an answer with no luck! My Trooper has 173K on it, timing belt done at 120K and regular service done always. I was driving for a while, maybe 2 months, with an intermittent check engine light. It would only come on while driving around 50-60 mph then when it would come down to idle speed it would go off. Then one day it started misfiring and bellowing black smoke!!! I had an oil change , fuel and air filter done and she ran fine, FOR A WHILE!!! :mad: Then all the sudden it's back the bogging, the smoke. I've replaced plug wires, new Bosch platinum plus 2 spark plugs and new O2 sensor(it was black as were the plugs) and it still is missing???
    Any ideas what to check next? :confuse:
  • boxtrooperboxtrooper Member Posts: 843
    Black smoke means it is not burning the fuel completely, maybe loss of spark or too much fuel. Maybe the plugs are all firing, but the computer is sending too much fuel.
    Is the loss of power extreme when it smokes? That might favor the not firing scenario.
    Paison I think, had a failed catalytic converter slowing down the air flow and that caused power problems.
  • atfdmikeatfdmike Member Posts: 414
    Hi, did you check the ECM for codes when this started? I would hazard an EGR valve/module issue. Good luck.
  • landfilllandfill Member Posts: 4
    My 92 trooper has the same problem. Have you found a solution?
  • mdenman1mdenman1 Member Posts: 7
    I've had an ongoing problem with the engine having a intermittant misfire, i have cleaned the egr valve and tube, replaced 2 O2 sensors, replaced spark plugs, replaced 1 coil pack, and all tube and valve cover gaskets, but my problem persists. I'm now noticing a rusty oily material in the spark plug tubes. It appears as though the oil and water conbined and evaporated in the tube. I was thinking head gasket, but it seems to me the gasket should not be involve in the spark plug tube, so now i am at a loss. the codes read misfire # 4 cylinder and i replaced that spark plug. Any suggestion would be a good suggestion at this point
  • atfdmikeatfdmike Member Posts: 414
    What engine are you having this problem with? Generally, I have only heard of antifreeze in the spark plug tubes when the head is cracked. It does happen but pretty rare. More likely the spark plug wire tube seals are letting moisture in. How about spark plug old and what condition are they? They may look OK, but age and use can cause their conductance to deteriorate.
    HTH One guys opinion.
  • landfilllandfill Member Posts: 4
    Your opinion for mdenman may be right on mine. My 3.2 sohc is stalling, huffing and puffing clouds of black smoke intermitenty. The wires are old. When I pulled one, the seal stayed on the plug. The tube came out though, but the plug could not be removed. Any ideas on how to get that seal off the plug would be helpful.
    The 5 plugs are still out and I haven't tried to restart it since I replaced the o2 sensor.

    Also, where is the connector for the code reader ( i looked )and the location of the crank sensor?
  • mdenman1mdenman1 Member Posts: 7
    I'm sorry my trooper is a 1999, there are no plug wires and each cyclinder has a coil pack, the liquid is water/oil mixture and maybe condensation could be part of the problem, i have bought a new coil pack and replaced the old one but still have the problem. Also can anyone tell me how to change my email address? I just switched to comcast and my address has changed
  • steverstever Guest Posts: 52,457
    If you go to Forum Profile on the upper right, there's a tab for Change Email/Password.
  • atfdmikeatfdmike Member Posts: 414
    A trick that works when you have a sticky boot is to take an air nozzle and blow air into the be while pulling on the boot with a twisting motion. When reinstalling, apply a dielectric grease to the boot end where it fits over the plug. That will insure it does not stick again. Most parts stores have the grease.
    Early Troopers had the plug tucked behind console where it meets the dash. Carpet may be over it. Later Troopers had it in the LH kick panel behind the trim. Try a search, may help on both questions. Include your year, model and trans when posting, makes it easier to be specific good luck.
  • atfdmikeatfdmike Member Posts: 414
    The new pack pretty much rules out the coil or wire being the problem. Have you had the codes read.....there are codes that set that don't trigger the CEL to come on. Even a momentary code will generally be stored for a period of time. I am not too familiar with the ignitions setup on the newer trooprs. Try having the codes scanned at a parts store that does it for free to make sure no surprises. If none, check compression on that cylinder and a couple others to see if low compression is problem. Good luck.
  • mdenman1mdenman1 Member Posts: 7
    The problem continues, last night i swapped out the coil pack again, and had the cel codes re checked at autozone i had three codes; 1171 (lean mixture during acceleration), 0157 (O2 sensor bank 2 sensor 2) and 0304 (misfire #4 cyclinder) I'm beginning to think i may have a problem with my fuel injector on cyclinder 4. Does anyone have any thoughts, I've no heard of any problems with that part. It doesn't seem that difficult to take off and check, or replace for that matter. The first two codes are a result of a cyclinder misfire, but in my mind the last (0304) could be the root problem and it seems the injector is the only item i haven't replaced yet.
  • atfdmikeatfdmike Member Posts: 414
    I believe that you can have the fuel injectors tested and cleaned by some auto service places. My only question would be if you are not familiar with them or don't know their reputation, then you may end up with a new set of injectors based on their evaluation when you may only need one. Regardless, injectors do wear out or are damaged and need replacement, so that is definitely a possiblity. Have you done a fuel pressure test to verify that adequate fuel pressure is available? Assuming there is, then a good shop should be able to fix or recommend replacement of the injector. I know they don't come cheap, but you seem to have eliminated most of the common causes. HTH Good luck.
  • dravin21dravin21 Member Posts: 4
    if you like offroad asmuch as i do check for bent/dented fuel lines.... i get that alot
  • steven56steven56 Member Posts: 3
    I'm having a similar misfire problem with my '98 Trooper. For a few weeks it had an emissions problem which we finally found to be a broken air line above the gas tank. I don't drive it much, since I use a company truck daily, so the battery keeps running down. One day I jumped it with a charger and may have left it too long on "start". The battery was really dead. I had to do the same thing the next day. Then took it into Autozone and they replaced the battery saying it wouldn't hold a charge. They checked the codes then.. Could leaving the charger on start too long have burned out something? Never got the P0300 code until then. After the emissions problem it ran fine until the new battery died and I tried to charge it. It will run, but I used $30.00 of gas in two days just going 26 miles round trip on the weekend. It ran really rough both days, trying to stall all the time. Help, PLEASE!!!???
  • steven56steven56 Member Posts: 3
    RE: msg. 19, Any response to this?????
  • steverstever Guest Posts: 52,457
    I had a P0300 on my Nissan a couple of weeks ago and that's a random or multiple misfire. In my case, the knock sensor and some injectors went bad. MPG was poor and it ran real rough too.

    Could be a coincidence that your battery went bad too. I'm not enough of a mechanic to begin to tell you where to start troubleshooting. Plugs and wires or the coil maybe?
  • landfilllandfill Member Posts: 4
    sounds like the o2 sensor(s), that was the problem with my 92 trooper. i had changed it a few months earlier and that o2 sensor was putting up black smoke, running rough and using at least twice as much fuel. i replaced the o2 sensor again and it has been running fine ever since. the code for mine was 17, but its the old style computer, the o2 light never came on, neither did the check engine light, but the code was there. after changing the sensor, the codes were clear. i hope the problem with yours is that simple
  • paisanpaisan Member Posts: 21,181
    When did you change your plugs last? Could need new plugs and/or wires?

  • steven56steven56 Member Posts: 3
    Just had the plugs replaced. Still doing it. Checking next week on the O2 sensors and the coil packs. Check engine light came back on less than 5 minutes after being reset at shop. Any other ideas? I'll let y'all know. Thanks!
  • wlbrown9wlbrown9 Member Posts: 867
    Not sure about the '98 but 2000 Trooper will only like the 3 specific plugs listed in the manual. Using any other plug will probably trigger the CEL pronto. I have these listed in my notes as being recommended in the manual. My '00 had the 3rd one listed, Champion. That is what I used for replacement

  • metroawdmetroawd Member Posts: 4
    Change the timing belt & timing belt tensioner. I'd also change the water pump while I was in there. Problem solved. (Been there, done that).
  • tropper5tropper5 Member Posts: 1
    my bother is have a problem with his trooper his number five cyl does not have any spark all the rest seem ok he took the plugs out in check them they all look good but number five plug.He move the coil pack from a good cyl to number five still no spark change plugs.Number five plug is wet with gas when he take it out. it a 95 anybody have these kind of problems. :mad:
  • successisformesuccessisforme Member Posts: 3
    I have a 2001 trooper . i am getting the p300 EGR and p1340 ignition controle have read the topics of the egr and i took the egr off and cleaned it well.....cleaned the tube thinking im gonna have to buy a egr.....but what is the p1340 the engine seems to run great....i went by auto zone and had them reset the codes and the engine light came on right after leaving the parking gonna go back and get them to do it again......but what is the misfire code telling me other than just there anyone out there with details of their issues.....thanks....
  • atfdmikeatfdmike Member Posts: 414
    I could not find specific code but it is a misfire. Your trooper may have that fancy ion sensing system for ignition....fussy about misfires and plugs.
    found this on another site: "If you have a 2000-2004 Isuzu, make sure you only use Denso K16PR-P11 spark plugs. The 2000-2004 engines have the GM/delphi "ion sensing" ignition system where the spark plugs are used as a sensor (when they are not firing) to measure the electrical resistance of the gasses in the combustion chamber. Other plugs may cause the ECU to register a code (misfire code: P1340). Also, it has been noted that some 00 trucks came with champion plugs from the factory, which cause knocking, due to to ion sense coils.

    If you have 1998-1999, the suggested plugs are NGK or Denso or Champion double platinum plugs"

  • wlbrown9wlbrown9 Member Posts: 867
    I have a '00 Trooper with the Champion plugs from the factory. Replaced them with the exact same and have never had an issue with knocking. The following are what the manual shows for '00:

    RC10PYP4 (Champion I believe)

  • diesel3333diesel3333 Member Posts: 1
    I hate to dredge up an old thread but came across your experience while researching about a similar experience I'm having with my 2000 Trooper. The engine bogs at 40-45 mph and won't maintain speed (65-75 mph) in top gear on the highway. An abrupt downshift brings back the power and speed but after the resulting upshift back to fourth gear, no amount of throttle will maintain speed. After about two cycles of this shifting and bogging/lugging, the CEL will flash but doesn't leave a code. Upon slowing down, the CEL goes off and the engine stalls when I come to a stop. A compression test shows 150-155 psig on five cylinders and about 135 on the passenger side front cylinder. All plugs look fine (dry with a little black on the end) and the plug wires/coils also appear to be in decent shape. I will clean the EGR and PCV tonight. The trooper has about 55k miles (unless a previous owner has messed with the odo) so I'm a bit baffled by this lack of performance. Lastly, the fuel mileage has dropped from about 14 mpg to less than 12. Any help would be appreciated. Thanks in advance.
  • wlbrown9wlbrown9 Member Posts: 867
    I'm no expert and this is a shot in the dark...but how is you cat converter? It might be possible that it is starting to plug and back pressure could cause the problem with maintaining speed on the hwy. But if you can downshift and get decent performance in 3rd that might make that possibility a no. Good luck on finding a resolution.
  • richcogginsrichcoggins Member Posts: 3
    This problem showed up about 8 months ago. since i have replaced all spark plugs with ngk and then again with champions, i replaced fuel injector, coil over plug, muffler, and battery. ive cleaned egr valve and maf, and throttle body. intake gasket is fine had a shop replace the timing belt and checked compression in all cylinders. compression is 170 - 172 in all 6 cylinders. when i change something it runs 2 - 3 weeks then bam code p0303. any ideas would be greatly appreciated.
  • 9millileter9millileter Member Posts: 1
    1996 3.2,which cylider is 3 if u are standing in front of car looking at engine?
  • atfdmikeatfdmike Member Posts: 414
    #3 is on passenger side (Right), middle cylinder

    5 6
    3 4
    1 2
  • lemon19lemon19 Member Posts: 8
    HELP.... I recently change out the motor on my 2000 trooper 3.5L and change the water pump and timing belt and retime. The engine would start but run really rough. I can take out plugs 2,4,6 and the car wouldn't stall or act like its losing power or die out, but if you take out 1,3,5 it die out right away. Is this normal????? Also no power when driving the car. I check for compression and sparks everything there. Really confuse, what could be wrong? Please help....
  • catfuzzcatfuzz Member Posts: 1
    You have timed the engine wrong. If you followed a Haynes or Chilton manual, this is the result. They don't have the correct procedure for these engines. Tear it back down, line up the crank mark with the mark on the oil pump. Now, locate the timing mark on the passenger side head. Turn the cam and it will thunk thunk into certain spots. Keep thunking it around until the mark on the sprocket naturally lines up with the mark on the head. It may take several turns. Then go the drivers side. There are TWO marks on the head for this one. One that is in a similar location to the passenger side and another one about 90 degrees to the LEFT. Thunk, thunk the cam until it naturally lines up with the second mark mentioned. Now, turn the sprocket to the right 90 degrees to line it up with the top mark. It may not want to stay there. Install your belt with the marks on the belt lining up with the timing marks and hold it in place with some clips. reset your tensioner and install. You can install the lower crank pulley temporarily and start the engine to confirm you got it right.
  • lemon19lemon19 Member Posts: 8
    Catfuzz your the greatest. You are a pro... Next time they should let you write the book.. Thanks for your help. I did tried it 3 times and it didn't work. My friends thought I was crazy bout only one side of the head working. Again thanks.
This discussion has been closed.