Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Buick Rainier Electrical Problems

my speed odometer will register the wrong speed I am traveling, sometimes it will freeze and I lightly tape on the dashboard, sometimes this helps and sometimes not. This is inconsistent as many days everything is working great, the buick dealership recommends a $500 replacement part. Could a wire be loose, a bad fuse, poor batteries. poor connection somewhere in the dashboard, could condensation and or different outdoor temperture intefer with accuracy????

Comments

  • libre1libre1 Posts: 3
    It seem to me that all Rainiers have the same problem. I said this becaused I bought one from 2005 and I just came from the dealer with the same problem and they want to charge me almost $ 600 to fix it. I guest Biuck knows about the problem and not want to do anything about it. I will be sending a very angry letter to Buick.
  • Anyone have an idea?
    Truck would not start (dim lights, starter "clicking")...replaced battery. Everything fine. 3 days later... "battery not charging" warning light comes on. I charge battery, light goes off. I take it to the dealer figuring the alternator is bad. Electrical check shows alternator and battery good. Nothing showing "drawing" on battery. Can anyone offer a suggestion what the issue is?
  • yqdyqd Posts: 1
    :mad: I have an 05 one and just found out about the same problem. The speedometer doesn't pass 30 mph and the needle drops way below 0 when I drive slow or the car is stopped. I'm hoping it might be a bad sensor (yeah right ...........)
    Were you able to get any other diagnosis of your problem ?? :lemon:
  • My friend had a similar problem. Turned out the "ace" mechanic who installed his new battery did not tighten the battery cables correctly. It might be worth a look...
  • we are still having the same problems, have you found any solutions?
  • Somebody from Buick did call me at my home last week and they only told me to take my Buick back to the dealer from whom I bought it and to let them fix it, that the dealer will charge me half the $600 they told me it will cost to fix it. Iam checking with a lawyer to see if we can join forces to make Buick do the repairs at GM cost. I will keep you guys posted on this. It seems to me that this is a commont problem on this type of vehicle and GM is ignoring it.
  • The Speedo on my "new" 04 Rainier died during a 600+ mile road trip yesterday. Had to use my portable GPS to determine my speed and then just set the cruise. My dealer quoted me $230.00(dealer employee price because I just bought it on the 14th.) for the part plus labor. So I think 1/2 of $600 is still not a fair deal in your case. I would try and get them to charge you 1/2 of actual dealer cost and pay for the labor. I think you would come out ahead. The only good thing is that I believe the replacement will come with a lifetime warranty.

    P.S. My first symptom was 2 days prior with a oil pressure gage that was reading 160 psi. 180 degrees to the right of 0 psi. I believe that the "stepper motor" on each gage is what fails. It sounds like gm has a new stepper motor version on the replacement cluster.
  • Wondering if anyone else has had an issue with the 2005 Rainer headlights flickering & flashing at night? They first did it after the car was about 8 months old, dealer said it was because I didnt' let the car warm up enough and give it time to cycle through all it's check points? Sounds fishy to me....
    Well, it started again 18 months later, at first just a few times per night. Now it is crazy, they flicker so badly it has cars in front of me are wondering why I am flashing my lights like a crazy person.
    Does anyone have any idea or has had the same problem?
    Have had other problems too....alternator was replaced, A/C & Heating vents not blowing enough air, they've been worked on several times, still a problem. Crazy A/C & Heating unit is terrible to adjust to right temp., it's either blowing hot or cold....always at the wrong time. They can keep these automatic climate control units....just give me the old-fashioned type, they work great. And several other items....
    The vehicle had zero issues, not in the shop once (except for service), until it approached 30,000 miles, now it seems we are in the dealer's shop often....Does the Rainier fall about as it ages? Is the future going to be like this?
    Any input is appreciated. Thank you.
  • I have a 2004 rainier that went crazy last night. Yes I had a speedometer that went bad and the shop changed it out without charging me. But does anyone know why the Rainier has two check engine lights? One with a down arrow and one that's just an engine outline? Both went on last night and the car just sat there and idled. I could put it in drive but it wouldn't go faster than 1000 rpms. Once I got it home ( yes Onstar was called and they sent a wrecker), the engine started and I got a gas pedal again! Next morning, it started and no engine lights! Any thoughts?
  • As a followup, I went to Checker and got the code out of the computer. It's P1680.No one knows what it's suppose to tell me...
  • jchurchjchurch Posts: 1
    My Rainier had all of the gauges stop working, and the driver information center went blank after 50000 miles. I've taken it to the dealer and am looking at $1000 in repairs if I decide to go with it. Still runs fine, just no idea how much gas, oil pressure, or engine temp! Anybody have any ideas?

    Jed
  • jblaisjblais Posts: 2
    Couples months ago I had an electrical tourble with my gage, the Alternator batteries gage was reduicing down to 5 amp, the lights were flashing exterior + the dash board. After a scan at Dealer, It appear that my air pump causing this, so I did change the air pump in december 2007. 18 months after (03/2008) same trouble, I did change the pump a second time, 2 weeks after same trouble, Dealer says Buick Rainier has 2 air pump under the hood, nothing to do with the air compressor in the back for the suspension, and the second one is defective also, it's about 600$ each time - Is someone has a solution for me or did someone experimented this trouble ?
  • adf2adf2 Posts: 7
    I just bought a 2004 Rainier which has the much-read-about Speedo problem. Sometimes the speedo needle sits below zero at start-up, which always means it won't move at all when driving. Other times it is perfectly normal. Is it a sensor? Is it a cluster? Can it be corrected easily?

    Help!
  • medgarmedgar Posts: 1
    Our 04 Ranier started having electrical issues about 2 months ago. We had left it parked for 6 days at the airport. Started it up and none of the gauges were functioning. They may operate each time for a day, but then may go several days without working. About 3 weeks ago while driving about 15 mph, the accelerator failed to respond and the tach was locked in at 1000 rpm. After pulling over and restarting, all was well. In the past 10 days, the speedometer and tach have started failing also. Just last night, nothing was working and then it came on while driving. It did that several times.

    I've checked fused and wire bundle connections but have not been able to find any problem.
  • adf2adf2 Posts: 7
    Medgar,

    My problem was solved by having the garage replace a stepper motor. Now I get smooth speedo needle movement, rather than the eratic, twitchy movements I was getting.

    Your problem sounds more serious than a simple stepper motor change. I wonder if the whole cluster is in need of changing.
  • thedrakethedrake Posts: 14
    I also had the problem with flickering headlights on my '04 Rainier. The problem started about 6 months after I got it. I had the truck in the shop 3X for service of this problem, and even had copies of this thread documenting other owners flickering lights but the dealer denied their was a problem. When I bought a new battery after about 3 yrs, that seemed to help, but only temporary, the flickering returned. I returned the Rainier back to GM after my 48 month lease was up.

    PS. I also hated the automatic climate controls, especially on the windshield defrost setting. It was impossible to adjust the temp, either too hot or too cold.
  • lizsheplizshep Posts: 1
    Hello,
    Im having a problem with my 05' Rainier.
    The Gas Gauge seems to malfunction. When I fill up the tank to full it will read that it is empty and will continue to fluctuate up and down. This happened a month after I bought it from the dealer and now I am stationed overseas and cant ship my car to my station until this problem is fixed. Anyone else have this problem and know how much it cost them??
    Thanks.
  • I have had problems with my speedometer racing ahead and freezing at over 100 mph. I have to start the ignition and turn it off several times to get it to go back to 0. This week it is dead, will not move off below 0 mph. I have also had instances when the radio will not function. When the motor is turned off and started, it may began to work normally again. I am very sorry I bought this vehicle. GracemontGirl
  • bob192bob192 Posts: 19
    I had the speedo(instrument cluster) replaced on my 2004 Ranier. They charge
    $700 plus a $900 core charge for the old one. Fortunately, I had purchased an aftermarket warranty on this car, so I had to pay only a $100 deductible. Its ridiculous that GM does'nt give any better warranty coverage than 36 months, This was an expensive car. I believe perhaps mid thirties when new. I'm pretty much done with GM and Detroit too. My wifes Subaru had the same aftermarket warranty. We've had it for over five years now and have had zero claims. nothing but normal wear items. It was way cheaper and older when purchased too.
  • When my low-beams are on for about 20 min. they shut off, then y have to wait awhile and the will work again and not for long... High beams work fine
  • anetcolanetcol Posts: 1
    my buick is doing the same thing where did you get your extended warranty i had one and cancelled it becasue it wouldnt cover anything
  • crlabcrlab Posts: 2
    My wife's Buick Ranier has problems with the speedometer and oil pressure gauge. THis developed years ago and the dealer was never able to resolve this. She is now looking for a new car and refuses to consider any of the GM cars. Really sad to hear this was such a chronic problem. Sad way for such a historically strong company to die.
  • bob192bob192 Posts: 19
    My warranty was bought from the car dealer. It was from a company called Zurich. I have no complaints about them. My Buick was hit while parked and totaled by the insurance company, this year. I'm glad they survived, for the sake of the workers, but I wont buy GM again. My Subaru Outback gets very good marks on reliability and quality as well as good mpg and all important in my region all wheel drive. it as built in the state of Indiana.
  • Good thing I researched this. When I first bought this car, I had problems with the speedometer. Fortunately, I had an extended warranty and I finally got it fixed. A month later, and now all of the gauges have gone wacko all of a sudden. So, I am taking it back tomorrow to see what the problem is. And hopefully, my warranty will cover it!!

    Will keep you posted on the outcome. I planned to refinance it so that it would be paid off faster. Best believe I will be trading it in....
  • No speedometer probs yet. Have a problem with dead battery. Runs down after 1 day if left undriven. Something draining it.Short? Battery bounces right back once I get it restarted. It might be the air shock system?
    Any help or advice would be welcome

    Seaclusion
  • Took it in today, they could not diagnose the problem, so they removed the battery and recharged it, and it worked fine. So,,, I foresee that this is going to be a recurring issue. Definitely confirmed my decision to trade it in for a Honda Accord once it's paid off. Good riddance haha.
  • Not sure what that could be, that sounds odd. It's ironic because my battery died this morning, and the AAA man ran a test, bad battery, needed replaced. Once he replaced it, my speedomoter and gauges are working properly. SN: Oh yes after getting the speedo fixed for the 2nd time they went haywire again, the next day. I let it sit for about 3 days because it was my intent to take it to the dealer again, but when I went to start it, no action. Must have been divine intervention lol.

    The AAA man also suspected the alternator was bad (but after testing it, it was fine).

    I would suggest going to get your batter, starter, and your alternator tested, that could be the root of the problem.
  • Hello, my issue is my 2004 Buick Rainier CXL has just recently shut off on me. For many weeks it has driven good but out of no where it would shut off on me. When it shuts off, my dash board computer says Service Break System and my sensor break lights on my dash turn on. It has been an issue for the last couple of weeks until it recently just shut off completley. Now, it wont turn back on. Everytime I turn the key to start it, it keeps beeping and the same message reads, Service Break System on my dashboard. I was told it could be the relay fuse and I put a new one in but it didnt work. I need HELP PLEASE!!!!
  • One day last week my low beams stopped working. I thought I needed a new bulb. So I bought 2 new bulbs and found that there was nothing wrong with the bulbs. I then got the OM meter and I tested every fuse in that thing. They wre all good.So I turned to switches. Maybe it was a bad headlamp switch, or dimer switch. I thought I found the problem. Well when I went to get this switch ( I can't think of the name of it, but it's on the left side of the steering, it allows you to turn your headlights off..) the dealer said it could be that sensor that is in the middle of your dashboard. A light sensor. Well now I am back to square one. What the hell can the problem be ?There is so much electronics in this vehicle that it's almost impossible to find what is wrong. Can you help ?
  • I would love to join you in that fight. I belive that they do know about this/these problems and do not want to admit it or tell anyone because they know that they'ed have to replace /or fix these problems or do a massive recall. I like my Rainier but I can't afford the dealers cost to fix it. Talk to me........

    Steve
  • I have an 04 Rainier. I bought it about a year ago. On my way home from the dealership, the speedometer quit working. It showed that I was going 100mph when I was only going 20-25. Then it dropped to 0 and didn't move again. I immediately called the dealership and talk to the tech. He said that the guy traded it in because he didn't want to pay the cost to fix it. I was shocked that they knew it was messed up and sold it anyway. He told me that it should have been fixed and to bring it in the following business day and they would check it out for me. I took it in and was told it would be $1700 for all the part and labor. They said the whole panel had to be replaced. I went straight to the salesperson and she said she would take care of it and the company would replace it at no charge. They ordered the part and when I took it back in the Manager told me that i would have to pay half. I told him I wasn't paying a dime and he could keep it. They finally fixed it at no charge but informed me that they couldn't be expected to fix everyones vehicle.
    My headlights also flicker. One night they went out completely on dim and I had to drive home bright lighting everyone. I put a new battery in and there is no change. Today my gearshifter messed up. The shifter cable broke. I'm waiting on a replacement from the auto parts store. Has anyone else had this problem?
  • cole_45cole_45 Posts: 1
    Did you ever resolve this issue? Im having a very similar problem.
  • gmcustsvcgmcustsvc Posts: 4,252
    cole_45,

    Were you planning on having the vehicle diagnosed by a GM dealership? Please keep me posted on any information.

    Thank you,
    Caron, GM Customer Service
  • beeez816beeez816 Posts: 1
    edited July 2013
    hey, i am having this exact issue with my 2004 buick rainier! what did you do to relieve the problem??? i cannot find anyone who has been able to diagnose the problem any feedbacks great thanks!
  • lcr80lcr80 Posts: 1
    04 Rainier
    1 owner (me)
    Little over 100k
    Never again will I Buy a Buick

    Bought it with 110 miles. Bought the extended warranty (ended at 100k). In November 2012 the gear shift cable broke. 7 1/2 months pregnant. Drove it to the doctor's office then stopped at a dealership to get the inspection sticker. They were unable to move it as the cable clamps broke. The clamps are made of plastic and exposed to weather without any protection. The dearlship was able to test it & guess what IT PASS!!! How does a major cable brake, prevents the vehicle from moving but still passes an inspection. BECAUSE THAT CABLE DOES NOT CAUSE THE CHECK ENGINE LIGHT TO TURN ON. Contacted GM and as everyone else on here & all other forums, after knowing your vehicle is over 100K, its oh well your problem not ours!!!
    My main concern was, what else can malfunction (& make it unsafe) and not cause the check engine light to turn on. When I called a Buick dealership, they said you have to bring it in so we can hook it up and see what is the problem. I was furious, I'm telling you what needs to be replaced (another mechanic from a Honda dealership) & NO CHECK ENGINE LIGHT IS ON!!! Finally said it would be $400. Fixed it, what else could I do with a baby on the way.
    The waterpump acting up. Changed it $500.

    NOW, fuse ING E keeps blowing.

    Driver vent blows cold air while the passanger blows hot air. And yes I have checked the temperature and also changed the mode to the dual setting.

    RMP gauge is not working properly, its unstable while driving. When I press on the gas it goes from 1.5 to 2.5 back and forth, unstable.

    Sounds like it wants to cut off (which at times it has while waiting in line at a drive thru, red light ect.)

    Has a rough kick when the ac it turned on.

    Buick I understand vehicles will not last forever. But your vehicles only last to 100K, you should inform potential clients of that defect. I WOULD NOT HAVE BOUGHT ONE, HAD I KNOWN. I also own a 06 Honda Accord (170K) which runs like new, 02 Sequoia (115K) no major issues except to replace the normal wear and tear stuff.

    Today I will be looking for another SUV, IT WILL NOT BE A BUICK. Any make but yours. I have told everyone I know to not through their money away with buying any Buick vehicle.

    YOU WILL EVENTUALLY FILE CHAPTER 11!!!! I WILL PRAY FOR NO MORE BUICK OWNERS LIKE ME!!!!

    Potential buyers: YOU HAVE BEEN WARN!!!! MANY OF US WENT WARN, BUICK IS NOT WORTH THE MONEY UNLESS YOU WANT A VEHICLE FOR LESS THAN 100K!!!! Take your money and run from ALL Buick dealerships!!!!!
  • I own a 2004 Buick Rainier. Sounds like I'm standing in an AA meeting, doesn't it? Well you're right. It's about he same thing because this vehicle makes me want to drink. I've had all the problems listed on here. Replaced the entire dash gauges, replaced both sides of the front axle - now it seems as though it's time to replace the catalytic converter. PLUS - the air is leaking out of the rear suspension. I think the only reason I still have the vehicle is because I'm hoping that one day GM is going to be forced to recall the vehicle and I will get reimbursed for all the work I've done to it. NOT! (we've all been waiting for his and it doesn't look to be happening) I will never EVER buy another Buick and maybe not even a GM. I have a 22 year old Honda that has had only a 10th of the work done to it. Including maintenance. GM, do the right thing, own up to your mistakes and at least help us fix some of these problems! PS - don't bother calling me to offer the warranty coverage. Almost all of this model are beyond the coverage and we all know you don't care anyway.
  • Wish I had checked this site a year ago. We purchased a 2006 Rainier last May. Looked great, ran well. Within 3 months it needed a headlight replaced. We thought it was standard maintenance. Three months later the headlight was out again. The AC and heat started acting erratically, AC coming out of the driver's vents while heat came out on the passenger side. A strange sound, like a pump running, was coming from the rear of the car and a clunking sound from the front suspension. We received a recall notice and took the vehicle to the designated dealership, December 2014.

    The dealership informed us the front mounts needed to be replaced, but other than that there was nothing wrong with our car and they knew of no recalls on the vehicle. The mounts were replaced but the other problems persisted. The AC/heat stopped working completely. On a Friday evening the windshield fluid sprayer started working and wouldn't turn off. We joked that the car was possessed and was going back to the dealership on Monday. The next day the car caught fire and burnt to a charred shell of metal. We were lucky to get out as we were driving on a busy interstate.

    Insurance investigators determined it was the AC switch malfunction. The dealership denies any responsibility. GM denies any responsibility, and we still owe the finance company. We're glad to be alive, but will certainly NEVER buy a GM vehicle again. Does anyone have suggestions on how to get some justice ?


  • i have a 2004 buick rainier and the dash went crazy, blinking , buzzer, and now it goes completely dead. If we pull the fuse it comes back on, any suggestions.

  • 04RainerOwnerTwo04RainerOwnerTwo MichiganPosts: 1
    I don't know if anyone else is going to see this or not, but I have a 2004 Rainer that has the same issue as all of yours. I have been doing some very extensive research on this issue. Like all of you, I checked every fuse and every circuit for excessive draw and couldn't find it at first. My search led me to the fuse panel under the passenger seat on the driver side. There is a 10 amp fuse that controls the HVAC of the vehicle. While I had my meter connected, I pulled that fuse and the current dropped. I still needed to know why this was the case. I read a couple of service bulletins put out by GM. They say that the HVAC system can run for an extended period of time after the car is turned off . Realistically, that system should only stay on for a short period of time if the car has not run in a while. To prove my point, I pulled the 10 amp fuse powering the body control module. This caused the HVAC system to shut down in a timely manner because the computer wasn't controlling it. So, basically you need to replace the body control module for between $100-$400 and get it programmed. It's your call...
Sign In or Register to comment.