Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Are you considering a vehicle subscription service or did you previously consider one and decide against it? If so, a reporter would like to talk to you. Please reach out to [email protected] by 10/30 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

MB M Class Owners Maintenance and Repair

1356714

Comments

  • rickyrxrickyrx Posts: 1
    I have noticed rust spots on my headliner above the drivers seat and continuing on a line down 1 side of the car. The only reason I noticed it, is because I have beige interior and headliner. Has anyone else seen anything like this and what did the dealer do?
  • suvlisa1suvlisa1 Posts: 1
    I have experienced many of the problems discussed here, my latest being that I have a bad catalytic converter (>$750 to fix). Has anyone had similar issues? My engine started sounding like a diesel engine (or a motor cycle). Any suggestions - I'm already considering trading it in as fast as I can. And, NO, I did not buy an extended warranty (I have about 56K miles and I hit the 4yr mark next month). Thanks.
  • mcqueen4mcqueen4 Posts: 6
    Both my next door neighbor and I have 2001 ML320's. She has had mulitple problems with hers and I have had no major problems (knock on wood). Her brake light came on this weekend and the MB dealer told her that it is common for the brake pads needing replacing due to "wear and tear". She has just under 20,000 miles on it. Is this true? She is so upset with her ML that she will never buy another MB ever again. Lithia just purchased MB of Omaha late last year and have changed most of service people. Not the same class and treatment as we used to get. It will be 2 weeks before they can even look at her truck. I am very nervous about my vehicle and resale value.
  • Brake pad life is highly dependent upon the type of driving (city vs highway) and driving style (fast starts - quick stops). It is true that Mercedes uses softer brake pads that result in less life but these softer pads offer the advantage of better braking with less fade and longer brake rotor life. My preference would be for "safer" brakes that will get you stopped faster in an emergency before a crash that brakes that would not get you stopped in time but last longer.

    I own a 2000 ML320 with 36,000 miles and have yet to replace the brake pads. I know of others who have gotten 50,000 miles before replacing brakes and I also know of some who have replaced their brake pads at 15,000 miles. It all depends on your driving style and whether the miles are mostly city or highway.

    The other thing you must consider is that you are stopping a 4,600 lb. vehicle versus most cars that weigh only 3,200 lb. Breaking more weight results in faster break pad wear.
  • mcqueen4mcqueen4 Posts: 6
    Thank you for your help. Would that be what the black dust on my front rims is from? MB of Omaha wants $360 to replace brake pads and Brake Masters only charges $160 parts and labor. Does it matter who changes them?
  • Yes, that is what the black dust is on your front rims. Actually, the same dust appears on the rear rims but since most braking is done by the front wheels on any car, the dust builds faster on the front than the rear. Most european cars use similar brake pads and that is why you see this black dust on Mercedes, BMW, Volvo and the like.

    Whether you drive a M-Class, C-Class, E-Class or S-Class, you usually can figure about $200 per axle to replace the brake pads. Usually, rotors do not have to be replaced on the first brake pad change. Was the Mercedes dealer going to replace both front and rear pads? Was "Brake Masters" going to use OEM Mercedes pads or something cheaper? I would not use anything other than OEM parts since cheaper pads won't stop the vehicle as well, may accelerate rotor wear and may squeal when stopping.

    By the way, don't complain about Mercedes brake pad replacement cost. If you owned a BMW, you need to change both the pads and rotors which usually runs around $800.
  • mcqueen4mcqueen4 Posts: 6
    Thanks once again. Brake Masters could only replace the front brake pads (Using MB part). They were told the back brake pads could only be done at a MB dealership. MB would not sell them to anyone besides a MB dearler for the next 17 months. Brake Masters told my neighbor that the roters were fine. She has 21,000 on her ML and I have 17,000 on mine. The brake light came on last weekend and Brake Masters told her that all 4 are 80% gone. She had planned on driving 500 miles this coming weekend. He told her not to take the ML, could be dangerous. The MB dealer said that the brake light come on way ahead of any danger and told her that the ML would be just fine. The first available time to bring in her ML would be May 7. Would you be concerned, I know I would. I really appreciate your opinion and help. Thank you in advance.
  • Once the brake light comes on you usually can go 2,000 to 3,000 miles before you wear the pad completely down and start damaging the rotors. They have designed the system to allow you plenty of time to schedule the vehicle for servicing. Listen to Mercedes Service on this one.

    One reason that all four(4) pads need replacing is that all Mercedes vehicles have a very advanced braking system that "reads" the braking force on each wheel and adjusts braking pressure to provide equal braking by each wheel. This provides superior braking than a vehicle without this system. The braking systems employed by Mercedes are much more technologically advanced than most other vehicles and that is another reason I would not want to use anything other than Mercedes OEM pads.

    "You can drive a car or drive a Benz ... a car for a few years ... a Benz for a lifetime." Once you have driven a Benz, it has a certain feel that makes it hard to drive anything else again.
  • hermantamhermantam Posts: 14
    Hi, I live in the Pacific Springs subdivision in West Omaha. I bought my ML320 back in August 2000. Changed my front and rear brake pads and rotors at 30K mile (7/29/02) - MB of Omaha charged me $837 (too expensive).

    I agree with you that after the change of ownership MB of Omaha's service has been going downhill...Couple weeks ago when I brought my ML for another repair (noise from center air vent) they promised me a loaner but did not give one to me...also the two-week leadtime in scheduling service is just unbelievable...

    Did you check with MB of Omaha regarding the result of the class action lawsuit?

    If you would, keep in touch regarding the ML problems and send me an e-mail at [email protected] Thanks!
  • mloser1mloser1 Posts: 1
    I had the same problem with my 2002 ML. After second trip to the dealer, they replaced the fuel injection control module. Even after replacement, the vehicle did not run properly until the wiped the program and reloaded it. That was at about 14000 mi. Now have 22K and problem seems to be reappearing.

    While I'm on the subject, the car is a $40k piece of junk. Powersteering doesn't work at low speed, unrelated to recent recall on hose. MB acknowledges the problem exists but labels it a "characteristic" of the vehicle. I believe serious design flaw in vehicle. Good thing lemon law worked. Hope to hear from MBUSA soon about repurchase of car. After the way I was treated by MBUSA (dealer was OK), I would never purchase another MB, no matter how safe, reliable, cool... I have had problems with mold in the AC unit, AC fan bearing failed, glove box door replaced, windshield seal failed, driver seat creaks around base(no solution), windshield fluid reservoir cracked, oil pan seal failed, used Teleaid once to find a toys r us for XMAS shopping while out of town - wound up in an industrial park. All total 18 days in shop, not including the A service.
  • djdragandjdragan Posts: 3
    i am taking it in to the dealer for the 1st time on monday, anyone have the same problems?

    thx

    My ML350 when stopped at a red light keeps wanting to go forward from time to time even though I press on the brakes. It jolts forward, stops, then jolts forward again. It does this for about 10 seconds and stops. I feel that when this happens I have to press the brakes very hard in order to not hit the car in front of me while at a red light. It doesn't do this everytime, but regardless it's a huge concern that a brand new truck is doing this. I counted the # of times this happened was about 4 so far.
      
    Possible causes: Owners of Mercedes-Benz vehicles mentioned these to me:
    Someone told me this could be due to the throttle actuator which wouldn't trigger any check engine lights.
    OR
     It could be that the engine idle is not smooth and steady so far as rpms are concerned. No check engine lights came on at all when this happens.
    OR
    The engine computer is running the air/fuel mixture too lean partly due to the air in the region. The engine would then almost stall, causing the computer to dump a higher than usual amount of fuel in to prevent it from dying. This resulted in the "jolt" at the traffic light.

    Problem #2
    Dates of occurences:
    4-26-03
    5-7-03

    My ML350 was stopped at a red light. The light turned green so I took my foot off of the brakes and pressed the accelerator pedal. While still pressing on the accelerator pedal the car didn't move forward but instead it started to shake just a little bit and stalled for about 4 seconds. I seriously thought the engine was going to shut down and cars behind me were beeping their horns since I wasn't moving forward at all. After about 4 seconds of the car being stalled this stopped and I kept on driving home. No check engine lights came on at all when this happened. Also, another huge concern of mine since this is a brand new truck.

    Possible causes:
    The engine computer is running the air/fuel mixture too lean partly due to the air in the region. The engine would then almost stall, causing the computer to dump a higher than usual amount of fuel in to prevent it from dying. This resulted in the "jolt" at the traffic light.
  • chumsaechumsae Posts: 61
    Twice in the last two months the radio volume
    shot to near maximum volume. Both times on the
    AM band. I've heard that there is a cicuit that
    detects increased or decreased cabin noise, and
    thus makes automatic compensating volume adjustments. In both instances there was no change in cabin noise.

    Secondly, also twice in two months, I started the car and the radio wants my PIN code, like it lost
    power or something.

    I'll be bringing it in under warrantee, but just wanted to know if others have seen either of these problems.

    What a great car for the money - in spite of a short list of design shortcomings and minor problems, this has been one nice utility vehicle!
  • karld1karld1 Posts: 22
    Few questions on my Dad's 2001 ML430.
    My Dad owns one of them and with over 30K he already had a few warranty repairs (nothing major) he really enjoys the car but we have a few questions.
    1. What do you think about keeping the engine oil to 10-13K miles between oil changes, what oil is MB dealer using? is it really Mobil1?
    I have had used Mobil1 and Amsoil oils and I know that with about 5K miles those overall great oils have to be changed.
    What do you do?

    2. Tranny fluid
    Tranny is sealed so fluid can't never be changed!?!?!
    Sounds liks a non-sense, do you ML owners really belive it?
    Do you really thing that your car will be OK at 150K miles after never changing the fluid in your tranny?
    If not, did any of you changed your tranny fluid yet. If you did, what brand (Mobil 1 ATF?) and how did you do it?
    (Dealer, independent shop)

    3. Do you recommend buying extended warranty for another 5 years up to 100K miles?

    Personaly knowing ML series from Edmunds forum and my Dad's case I would not buy but lease it for 3 years.

    Help greatly apreciated.
  • doseidosei Posts: 11
    I was wondering if anyone is experiencing this problem. I have a 2002 ML500, and I get an occasional shrieking noise, seemingly from behind the steering wheel. I am waiting for my Autobahn dealer service shop to call me back to report the problem.
  • akin67akin67 Posts: 62
    I have a 2000 ML430 that I just took in for service. The dealer told me I need new front brakes & rotors. I only have 23,000 miles on it. They quoted me $572 to replace front brakes & rotors. So far the brake lights have not gone off and the breaks work fine without a squeek.

    Since they are telling me that I need both the brakes and rotors should I just keep driving until the brake light goes on? Whats the worst that can happen? I'll need new rotors :).

    I had also had to replace my rear brakes at 11,000 miles. Never heard of having to replace the rear brakes before the fronts.

    Aziz
  • roberto11roberto11 Posts: 4
    We have recently experienced the same shrieking noise as noted in message #123 by dosei with our 1999 ML320. It reminds me of the old "emergency broadcast" sirens that used to be played occasionally on the radio.

    The noise is very intermittent and does not stop when the vehicle is turned off. It started about two weeks ago and has occured randomly about 4 times since then.

    If anyone has any information regarding this problem please post the details.

    Thanks!
  • jckalachejckalache Posts: 6
    Unfortunately, the noise you're hearing is very typical of M class SUVs. I own a 1999 ml320 and I've taken it to the dealer at least 20 times for squeaks and rattles. The dissapointing thing is that I recentley drove a 2003 ML350 and it has similar rattles. I've personally asked to see a regional manager to go over these issues and was promised that all can be fixed. 3 years later sad to say I've totally given up hope.
  • jckalachejckalache Posts: 6
    Sorry to say I've had the problem too and yes 1998-2001 ml320 are full of problems.
  • jckalachejckalache Posts: 6
    Hi all,

    I just finished reading all 125 messages and I have to admit I am kinda of relieved. I thought that my 1999 ml320 was one of few plagued with problems but now it looks like 90% of the drivers are experiencing the same. Now, the reason I paid $45k for a Mercedes is to bypass all that headache and in retrospect I should've like some of you recommended, paid half for a Kia or Civic but I was fooled into the stylish look of MLs (which is still one the best looking SUVs). Personally, I believe Mercedes is misleading people using false advertising, claiming in one commercial that finally this is an SUV that drives like a Mercedes. My experience was so bad that 6 months after purchasing my car I asked to meet with a regional manager with the hope to get rid of this car and get my money back but instead I was promised that all these problems would be fixed. None of them has been fixed, in fact on several occasions I've taken the car back 3 or 4 times to fix the same problem and now I've given up.
    I plan to park my car in front of MB and contact my local newspaper and tv station to let the future buyers know what a "crappy" deal they're getting and I urge you to do the same. In fact if many of you are interested we should set a date and do it simultaneously. The resale value of these cars speaks for itself. Most of us are stuck with them unless we're willing to swallow our pride and admit a $25k loss.
  • roberto11roberto11 Posts: 4
    Has anyone been able to find out the cause (and fix) for this problem?
  • jckalachejckalache Posts: 6
    I've had MB look at the dashboard at least 6 times. At one point they removed the windshield and decided to weld the A frame thinking that that would fix the problem. It didn't and as a result the car started leaking water on both the driver and passenger sides. Eventually, they called for MB quality experts who ended up taking many pieces apart and found that the AC cooling insulation inside the dash is loose. The noise is kinda of gone but let me tell you for every piece they took out or messed with they introduced 10 new rattles. My point is be careful with MB technicians trying to fix one problem only to introduce many more. Again, I am sorry to say ml320 quality is very poor and MB technicians can't really help, at least in my case it's been a reoccuring issue.
  • email77email77 Posts: 27
    Hi
    Is it sound like a very high pitch noise, sound like coming from a fan. my ml320 1998. starting to do this some time last winter. it only happened in the very cold day. is not the belt. the noise is only hear inside. if you try re start the engine the noise will go away.
    Any one know how to fix it please. I don't trust MB dealer, they keep the car inside the garage so the car is warm. than tell you that is no noise at all. so you look like a ????.
    by the way the noise goes away after 10-15 mins.
  • jasijasi Posts: 2
    Recently got some bad gas. Had water in it. What needs to be done to fix this right?

    The place I purchased the gas at states I was the only one who has this problem. I always purchase my gas there. Purchased fuel on one day, had 'B' service done on the car. No problems. Gassed up the next day and with in a short time the check engine light came on.

    Thanking you in advance,
  • email77email77 Posts: 27
    Well
    What I would do is pump out the wate/gas tank. refill a tank of gas/gas.
    By the way how do you tell that is a water in your gas?
  • email77email77 Posts: 27
    Well I have just been told this noise is coming from a fuse box it had a fan inside. this fan make a high pitch noise. any one know how to fix it?
  • My 2002 ML500 has had excessive vibration - replaced all 4 tires around 25,000 miles due to severe wear; no improvement, in fact, vibration now occurs at lower speeds. Had front end checked, tires re-balanced. Just took care of repair for safety recall on power steering hose clamp. My imagination, or perhaps vibration has decreased... is there any possble connection?
  • roberto11roberto11 Posts: 4
  • roberto11roberto11 Posts: 4
    I just dropped off my 1999 ML320 at the dealer today to have recall service on the power steering hose clamp and to have the shrieking noise in the dashboard fixed. The dealer knew immediately that it was an "aspirator motor" and said I should have the vehicle back by tomorrow.
  • ew6ew6 Posts: 1
    Hi, I have a 2000 ML430, and have had all the same problems as you. I am disgusted with MB and this car. My service advisor actually told me one day to get rid of this vehicle. (Off the record, of course.) He said he is tired of making excuses for a "failed product." You mentioned a possible repurchase of your car through the lemon laws, and I was wondering if you wouldn't mind explaining in more detail, as I feel like I have been royally screwed by MB with this truck, and don't know of any recourse I can take. Thanks.
  • Karen_SKaren_S Posts: 5,092
  • she1122she1122 Posts: 33
  • she1122she1122 Posts: 33
    I see from a prior post that someone is asking about early replacement rotors. I have a 2000 ML430 and a friend, who is a brake mechanic, commented that the back rotors of my vehicle look dangerously worn. The ML has 34000 miles on it and the brakes were inspected at 23000 miles. I had them take the brakes apart as I was worried due to all the screeching noises they made. A Mercedes tech mentioned that the brakes have been upgraded in the newer ML's. Does anyone know if this is a warranty issue and the brakes can be replaced? My friend commented that the rotors looked like a safety hazard.
  • bczechbczech Posts: 2
    I had the same problem with my 2002. It was the fan for the fuse box. At least that's what they told me and I haven't heard it since.
  • batuceperbatuceper Posts: 4
    I have a 2000 ML320 which will run out of the MB warranty later this year.

    Can anyone with experience of 3rd party extended warranties give me advice as to which are the reputable companies from whom to purchase extended warranties?

    I am located in Dallas, TX

    Many thanks
    Steve
  • Karen_SKaren_S Posts: 5,092
    Take a look thru the FWI board for discussions concerning various warranty companies. And you might want to pose your question in this discussion:

    Extended Warranties
  • I've had the ML320 for four years now, and it has been giving me some engine problems lately. Although the vehicle starts up, the initial few minutes of drive is VERY jerky, and it will not rev up to more than 3000RPM, or it will knock, with severe backfiring. After the engine reaches optimum temperature, high RPM is not a problem, but pedal-to-the-metal, it can't crank out more than 140km/h. I've taken this baby up to 200km/h without a hitch, but not now. Also, the engine sounds like it's driven by chains or something, as it gives a funny motorbike-like sound. The dealer hasn't a clue. Any feedback, especially successfully solved similar situations, would be greatly appreciated. Thank you.
  • bkbroilerbkbroiler Posts: 2
    I too just had a problem with water in the gas. My 2000 ML320 started to run very roughly and I lost a lot of power. I was in the middle of no where (no cell phone service) and was barely able to limp to a diner which was about 10 miles from the gas station. They had to tow my ML to the nearest dealer which was 80 miles away. At that point I didn't know it was the gas. But they said there was water in the gas and it caused over $2000 in damage. This just happened and they are still working on it. They have to replace the fuel pump, fuel filter, fuel injectors, spark plags and drain and clean the fuel tank and fuel lines. It's still under warrenty but of course this is not covered. My insuarance company may cover this (still trying to find out), but if not then I need to try and go after the gas station (mom-and-pop stiation in little podunk town). When you add in the towning and tax they estimate the total bill will be close to $3000.

    Ouch, all because of some water in the gas!
  • kiiwiikiiwii Posts: 318
    The problem you described sounds like a bad thermo sensor in the engine. The computer is giving bad mixture of air/fuel. My colleague and I had experienced the same symptoms on our cars (not MB). The problems were caused by the thermo sensors.
  • twinmom2twinmom2 Posts: 1
    We've had very few problems with our SUV, other than the gas cap cover not closing, power steering clamp going out twice (and then we received the recall notice!), the glove box door becoming loose and the heated seats not working. Okay, I'm being facetious but really nothing major like engine problems. The heated seats being the most serious since it never worked well and we recently asked the dealer to have it fixed since we're still under warranty. It's been nothing but a nightmare and a comedy of errors. First of all, they had to remove the whole bottom seats and replace the leather since the warming unit is one piece. When they replaced the bottom seat of the driver's side (they forgot to order 2!) they never mentioned it was different color from my current interior (hence, the back of the seat and the bottom were 2 different colors!) I had to bring it to their attention and then they of course agreed with me. Again it's taken them 3 months to order this part and now they have to order it again since it's the wrong color. Two weeks later, our Service Rep calls and informs us they have discontinued my original upholstery color and that the dark gray they installed is the current color. They have offered to replace all the seats, the middle compartment and headrest but will not replace the sides unless I really insist and said they would work with me. They've had my car now for 2 weeks and still have a backorder piece, in the meantime they've given me a loaner.

    For those of you wondering, you can tell the color difference since the steering wheel is black and the side panels are black.

    We really need a bigger SUV with a third row. So here is my question to you all: What would you do in my place? Ask them to buy my car for high blue book since we really need a third row? I'm not sure I want another ML but I feel as though I'm stuck with another MB.

    Appreciate any advice.
  • jasijasi Posts: 2
    The fuel pump/filter and 3 injectors had to be replaced on my '02 ML 320. The gas retailer's insurance paid for the repairs and rental car (I was going on a trip: they provided me a '03 Chev. TrailBlazer. You don't know what you have until you drive something else.

    A tip for all: Pay with credit card or get 'cash receipt' and put your odometer mileage on the slip. You can verify (hopefully will be creditable) how many miles since you fueled up there. I always use the same gas station unless on a trip.
  • bkbroilerbkbroiler Posts: 2
    Actually my insurance company covered the $3000 bill I got for getting bad gas (looks like water contamination). They are going to go after the station but they say it will be difficult unless they find a pattern (others with the same problems from the same day). Otherwise the station can claim that it could have been vandalism - i.e. someone poured water into my tank when I went in and got some groceries from the convenience store.
  • Greetings,

    Does anyone know where to buy OEM brakes pads for
    2000 ML320? What's the brand Mercedes use as their OEM pads for ML320? Galfer USA or Textar? (Jurid or Pagid?)Please post the websites ASAP. Thanks!

    Paul
  • Best place for any Mercedes parts is www.mercedesshop.com. Great Service .... Great Prices
  • MY 1999 ML430 is in the shop having a new transmission installed!! The cost is over $5K. The vehicle has only 116K miles on it (and you can't service the tranny by the way). The regional rep for MBUSA won't offer goodwill stating excessive mileage!! EXCESSIVE MILES FOR A MERCEDES?? ARE YOU KIDDING?? WE ARE BEING TRICKED!! THIS IS NOT YOUR DADDY'S MB!! POOR QUALITY AT A HIGH PRICE!! THERE HAVE BEEN OTHER PROBLEMS I'VE HAD TO FIX AS WELL. I PLAN TO TAKE THIS MESSAGE TO THE PEOPLE BY USING MY ML 430 AS A BILLBOARD EXPRESSING HOW I FEEL. IF OTHERS DO THE SAME MAYBE MB WILL GET THE MESSAGE. BUYER BEWARE. RONERON1
  • We just got a 2000 ML320 and I almost hit a car yesterday because when I press the brake pedal it travels 2 inches before it engages. Our other cars engage with maybe a 1/2" of travel and I can't seem to get use to our mercedes.

    I went to 2 Mercedes dealers and they said this is just the way the brakes are designed on an ML. They also said there is no way to adjust this travel distance.

    Is this true?
  • kiiwiikiiwii Posts: 318
    Yes, it's normal. It took me quite sometime to get used to.
  • My wife's 2002 ML-320 (delivered April 02 and now with 20,000 miles) continues to have two problems that will not go away and in-spite of multi week long stays in the MB shop cannot be fixed.
     
    The first is an intermittent accelerator hesitation problem...from a standing stop you will step on the gas on nothing happens. No revs, no movement of the vehicle...nothing. Then after two-three seconds off it goes like nothing was wrong. It has happened when the vehicle is hot or cold, and there does seem to be a common weather factor...it seems to always happen when it is 80 degrees or above. We do live in an area that is also very humid most of the time (South Texas). How often does it happen? One or twice per week...sometimes four of five times per day.
     
    Next is a transmission problem...once again intermittent. The transmission will not up shift or it will downshift at will. Happens once or twice per month maybe. First go around the dealer replaced the control module but it still happens.
     
    We are wits end...not only are these two problems a reoccurring pain but that are both a real safety issue.
     
    I have read of others with the hesitation problem...how about the transmission problem?

    Thanks!
     
    Jeff
     
    McAllen, Texas
  • Have there been any service or technical bulletins issued for tranmissions on a 2002 ML-320?
     
    Thanks!

     
    Jeff
     
    McAllen, Texas
  • Have there been any service or technical bulletins issued for accelerator hesitation on a 2002 ML-320?
     
    Thanks!

    Jeff
     
    McAllen, Texas
Sign In or Register to comment.