Are you currently in the market shopping for a new vehicle? A reporter would like to speak with you; please reach out to [email protected] by 10/21 for more details.

Dodge Dakota 4x4 Problems

woodsenwoodsen Member Posts: 1
I reecently installed some additional driving lights on my 2002 V8 dodge dakota and had to remove my console front trim in order to mount a switch to control the lights. i have removed this front panel numerous times working with my radio, so i am familiar with how i need to disconnect all the electrical wires from the AC unit, the airbag switch, the headlight switch ect. after i mounted my switch i contiued to re-connect all the connectors listed above, including the four wheel drive switch. after re-connecting everything i turned the ignition on and started it up and the "Service 4X4" light came on.

Now i am not able to change from 2wd to 4wd or anything. the LED that usually indicates weither it is in 4wd or 2wd is not on in either position. but with the driving lights on the backlight on the switch itself is ilumnated, but it will not change to 4wd...

Anyone have any ideas???
«13

Comments

  • crazyclydecrazyclyde Member Posts: 4
    I have a 1987 Dakota 4x4, auto, v-6, carb. and cannot get
    it out of 4-wheel drive without stopping, killing the
    engine and waiting several seconds. Some one said it might
    be the vacuum actuator on the front differential. Another
    guy said it was the vacuum switch on the front differential. I'm still trying to find out if I can fix it
    myself. [email protected]
  • nmacha1nmacha1 Member Posts: 9
    i have the same problem,i got in a wreck and it fried the ecu for the 4x4 thats mounted to the steering colum. its a 552.38 dollar fix for that. it took 3 transmission ppl to figure it out. but it acted the same way. all backlights work but the transfer case or even the lights on the switch dont.
  • rich28rich28 Member Posts: 23
    I have a 2001 Quad Cab 4x4. The truck will not go into 4-high or 4-low, and the LED is not lit in either position including 2WD.

    Any ideas?
  • nmacha1nmacha1 Member Posts: 9
    i would first check the switch for power out of it and if so then its the ecu thats mounted to the steering wheel. mine was about 525 dollars for just the part plus 100 labor. i had mine diagnosed for 150 to make sure it was that part. there are alot of dakotas around here and they said that mine was the first they have seen do that. it mihgt be a problem with the part itself. how many miles are on your truck?
  • rich28rich28 Member Posts: 23
    Approx. 81,000 miles. So the ecu is mounted to the steering wheel...where exactly is it? And that controls my 2WD/4WD switch that's on the face of my dash? I'm not being smart, I just don't know much about auto-mechanics, that's why I came here.

    Thanks for your help!
  • nmacha1nmacha1 Member Posts: 9
    dont worry about it i am the same way. io can work on old cars but not these new ones. all the mechanic told me was it was mounted to the colum. the power goes to the switch then to the ecu and then the ecu tells the switch what light to put on. mine i got a new switch first and that didnt fix it and we had power leaving the switch and going into the ecu but lot leaving it. id shop around for the new part. labor should not take more then 30min to change out.
  • rich28rich28 Member Posts: 23
    Thanks! This will help me point the mechanic in the right direction. So far, this board hasn't let me down as I have had many problems with my truck. I love the truck, but not sure how many more problems I can endure. But then again, I might have them all fixed by now!

    I'll post the resolution. Thanks again!
  • geobcongeobcon Member Posts: 11
    I asked the dealer to give my drive train a maintenance procedure prior to the expiration of the 100,000 mile warranty expiration.
    They found that the front wheel bearing was on the verge of failing. They told me that it was not considered part of the drive train. In reviewing the warranty, the following is stated:
    Front wheel drive specifically states, “front wheel bearings”.
    Rear wheel drive states, “drive shaft assemblies”.
    Four wheel drive states, “drive shaft assemblies (front and rear)”.
    Is not an “assembly”, a complete shaft, along with bearings?
    Having both front and rear drive when in a 4x4 mode and a front wheel drive specifically states wheel bearings, then why are the bearings not covered under the warranty?

    The dealer stated that the wheel bearing was not covered. I contacted Daimler Chrysler Customer Service and was told that the interpretation of the warranty is up to the dealer. This is like the fox watching the chicken coop.
    Has any one had similar experiences? and, is there any way of contacting any one technical within Daimler Chrysler's higher eschelon that has access to the group that wrote the warranty?
    Your comments would be appreciated/

    Thanks,

    GEOBCON
  • nmacha1nmacha1 Member Posts: 9
    im not to sure about the fact that they get to decide what the warrenty states. anyother place unless its specific then its on the dealership. did you call the dodge line and get all your recalls looked at. i know that they have had 3 or 4 done on most dakotas. also you can try speaking with the owner of the dealership and talk to him about whats going on. and if you have to go above him. the squeeky wheel gets the oil and its the same way with cust services.
  • bpeeblesbpeebles Member Posts: 4,085
    The wheel-bearings are unquestionably part of the drivetrain. It sounds to me as if you are gettin the run-around. The dealership DOES NOT PAY for factory warantee work (Damlier-Chrysler does)...However, each dealership gets "rated" on how much they spend on warantee work. If they spend too much out of the factory coffers, they get a bad grade.

    This factory-dealership arrangement often makes the dealerships look like the bad guy. In reality, if DC "approved" replacement of your wheelbearing, then the dealership would GALDLY do it. (it is guaranteed pay for them at that point)

    The last time Chrysler had the 70,000 mile warantee...they nearly lost the company. The only reason they offer 100,000 now is because the competetion offers it. The vehicles are not any better or worse than they were before.

    DC, GM and Ford all offered 100,000 mile warantees to improve sales and make the bottom-line look better in the short-term. .... this was very shortsighted on their part. Over the next several years as the vehicles get older and start to need repairs... they will ALL be in a bind. Time for them to pay the piper!
  • geobcongeobcon Member Posts: 11
    Thanks for the response. I received an e-mail reply from "Senior Staff Representative" at the Chrysler Group Customer Assistance Center which in as many words told me that because "the wheel bearing" was not specifically listed in the covered component under the listing for the 4x4, it was not covered.. For lack of a nicer expression, "BULL-DO-DO". I even had one customer service rep tell me that the bearing was part of the suspension system and not on the drive train. I wonder where they get these people.
    At any rate, I had to accept their definition and was able to use a courtesy rntal car and get a senior citizen discount which saved me about $100.00. So much for Daimler Chrysler service.
    Merry Christmas.
    GEOBCON
  • geobcongeobcon Member Posts: 11
    Would any one know how to obtain a picture of the front drive shaft assembly for the subject for a 4.7L 2002 dakota 4x4?

    Thanks,

    geobcon
  • bpeeblesbpeebles Member Posts: 4,085
    The front driveshaft(s) are well-explained in the factory service manual. There is an entire chaptor about it.

    As I write this, I am looking at my 2000 Factory service manual. There are exploded views of the C/V joints on the driveshafts. There are about 30 other diagrams explaining other parts. (like how to dis-assemble the C/V joints and inspect the balls.)

    There is another chaptor describing the "C205F" front axle assembly. This chaptor goes into detail about the guts of the differential.

    You could order your very own factory service manual for your 2003 Dakota from any Dodge dealership. (and perhaps even online from Dodge)

    I got the factory service manual as part of my "barganing" when I orderd up my truck from the factory. The salesman are eager to 'close a deal' by agreeing to throw in the factory service manual.

    I have a factory service manual for every automobile I ever owned. I find them to be very helpful. They describe every screw, wire, electric plug and compoenent in detail. There is a description of how every component works. These books pay for themselves very quickly since I can now diagnose and repair most problems myself.
  • geobcongeobcon Member Posts: 11
    bpeebles.
    Thanks for the response. Does your manual show the wheel bearings as part of the front drive shaft assembly? I'm having a bone of contention with Daimler-Chrysler and the dealer regarding my 100,000 mile warranty on the drive train. I had the front wheel bearing replaced and they told me it wasn't covered in the warranty because it wasn't specifically stated other than "the front drive assembly". My 2002 Dakota is a 4x4. The warranty states specifically for a "front wheel drive" that the "wheel bearing" is covered. Not so on a 4x4. It doesn't call for a wheel bearing other than "the front drive assembly". If your manual shows a wheel bearing on the "the front drive assembly", could you give me the chapter and verse? If it does, I'd like to get back to the dealer and recoup some of my costs.

    Thanks in advance.

    GEOBCON
  • bpeeblesbpeebles Member Posts: 4,085
    The 2000 Dakota factory shop manual does not show the front bearings under the chapter about the front driveshafts. Instead, the front bearings are discussed in the chapter related to the front suspension.This is because for the 4X4, the front bearings are bolted to the steering knuckle.

    There is nothing specifically called "the front drive assembly". That is just an arbatrary name that can cover whatever they want (or dont want) to cover.

    Dont forget... those 100,000 mile warantees are only offered so they can SELL the vehicles - not to actually cover or protect the buyer. They are purposfully written to be ambiguous about what they cover.
  • cwebb0455cwebb0455 Member Posts: 1
    i recently bought an 04 dakota 4x4 and have NO clue how to use the 4x4 option. i know i have to put the drive in neutral then turn the switch to either high or low 4, but can i do this while driving or do i have to be stopped?
  • nmacha1nmacha1 Member Posts: 9
    well is it manual or auto? i have an manual and 4wd high can be done rolling in gear under 55 mph and 4wd low is done in neutral at dead stop or barely moving . when done with it you should put it in reverse and go back the length of the truck.
  • radneydakotaradneydakota Member Posts: 2
    ok so basicly i need some cheap mudders dotn care what kind but i need to knwo what the biggist size tire is that will fit with out rubbin so ether 32 or 33 id perfer 33 but i have a feelin it will rubb and one knwo the answer for me
  • radneydakotaradneydakota Member Posts: 2
    any one know? what the max size is for stalk
  • bpeeblesbpeebles Member Posts: 4,085
    I dont know the answer to your question about max tire size... but I do know that if you change from stock size, you may need to reporgram the onboard computer to compensate.
    Otherwise your speedometer will be incorrect and your ABS brakes may misbehave.
  • dustykdustyk Member Posts: 2,926
    The maximum manufacturer's recommended tire size for '97 -'04 Dakota is:

    15 inch = P235/75R15 XL

    16 inch = P265/70R16 (8" wide wheel only)

    17 inch = P255/55R17 (with R/T package only)

    Regards,
    Dusty
  • 440jeep440jeep Member Posts: 12
    am looking for a good 4x4 trans for a 318 to go mud slinging with any suggestions? needs to be good with daily driver HWY gear.
  • salvatorpsalvatorp Member Posts: 2
    I have the same problem that someone else has posted.
    My 01 dodge dakota began shifting into 4 wheel drive when I go around sharp corners and especially city driving. I took it to the dealer and they replaced the transfer case shift motor and charged me $747 dollars. A week later it was doing it again but by the time I got it back to the dealer it stoped doing it and they said it was fine. I know this problem is going to come back. Years ago I did have the recall done for the transfer switch programming. Any help would be appreciated.
  • salvatorpsalvatorp Member Posts: 2
  • dustykdustyk Member Posts: 2,926
    Just a suspicion, but this could be a Transfer Case Control Module (TCCM) issue.

    If the wiring is good and you've got a solid electrical ground to the transfer case and the transmission, the TCCM is about the only thing left.

    Good luck,
    Dusty
  • mtbiker_14mtbiker_14 Member Posts: 7
    I have a 2000 Dakota, V8, 4wd, manual, with only 48,000 miles on it. I was out in some mud tonight, and needed 4 low to creep down a hill. It went in, but when I shifted out of 1st, it kicked into neutral. Once I stopped, I tried again, and everytime I tried goiing through a couple gears, it pops into neutral. 4hi is fine, but when I push it into 4lo it doesn't seem like it goes in all the way. And then it pops out easily. Anyone have any ideas on what's goin on? Or what it may be? I'm gonna look at the transfer case fluid in the morning, but I have no idea what else to look for. Winter is coming, and I'l like to get this fixed ASAP!
  • bpeeblesbpeebles Member Posts: 4,085
    After all these years - you are the very 1st person that seems to have the same package on their Dak that I orderd from the factory. (2000, 4.7L Semi-Hemi, Manual xmission) I orderd mine in September of 1999 and it arrived at the dealership about 3 weeks later. The window-sticker says "This truck was built for Bruce A. Peebles" -- cool!

    I would suggest that you look at the ADJUSTMENT of the 4x4 linkage. It sure sounds as if the xfer-case is not fully going into 4Lo. This is often caused by the linkage between the lever and the xfer-case needing to be adjusted.

    I am curious... you say that "Winter is coming, and I'l like to get this fixed ASAP!".... do you *really* use 4lo that often? The "lo" setting on the Dak xfer case is EXTREMELY low. I find that when in "lo", 5th gear on the xmission is about the same a 2nd when in "hi". Cocenquently, I use 4lo about 1 time a winter. (and the winters here in Vermont are serious.)
  • mtbiker_14mtbiker_14 Member Posts: 7
    Pretty much, that's the most bad [non-permissible content removed] Dakota model ever made.

    I live in Eastern Oregon, so winters get pretty bad, and I am out in the mountains a lot. So I do use it fairly often. Although with my canopy on, I'm very pleased with it's performance in snow. I'll take a look at that linkage, and give an update as to how it goes. Thanks.
  • bpeeblesbpeebles Member Posts: 4,085
    Oregon -- wow, you may have me beat in the way of snow. 8-)

    When I orderd my Dak, I poured thru every option and specifically chose options which would give me the very best snow-traction. In addition to what I mentioned above in the way of powertrain..... I also opted for the "trac-loc" rear end and "tire-n-handling package". (31x10.5R15 tires -- that is 31inch tires!!)

    I am impressed that chryslers "trac-loc" limited slip differential with its cone-shaped clutches can easilly make both rear-wheels spin on dry pavement. I have to be careful when the gas-tank is low on fuel because the rear end can easilly slide out from under me in first gear with too much throttle.

    With this setup, I have TRUE 3 wheel drive when in 4hi/lo. (Both rear and one front must slip for me to lose traction)

    Without "trac-loc" rear-end, I would have 2-wheel drive when locked in 4Hi/lo. (One front and one rear can spin to lose traction)

    I would expect that you have the "trac-loc" too.... as I recall it was MANDITORY to get "trac"loc" when the 4.7L was coupled to the 5speed manual. (The ordering-computer automaticly added the "trac-lock" when that combo was selected.)
  • mtbiker_14mtbiker_14 Member Posts: 7
    I bought my dakota used about 12 months ago, and it only had 30,000 miles on it. I don't know who owned it before the dealer got it, but they kept it in great condition, and they must have wanted the same package as you did. Because it sounds like about everything is the same. Have you had any problems with your brakes or front drive axle?
  • bpeeblesbpeebles Member Posts: 4,085
    The front brakes are [email protected] I have replaced them several times including calipers and rotors. Currently running BENDIX rotors and NAPA CERAMIX pads. These have lasted longer than anything else I have tried.

    My rear brakes are still factory with 80K miles on the odometer. (I do take them apart occasionally to clean/adjust)

    Check out this photo of the last brakes/rotors which I took off my Dak.

    While we are at it... here is photo of my running boards.

    My Homemade intake and modified AC system (gets real cold now!)

    As for front axle... mine has been troublefree. In fact, in all my years of following Dakotas, I have never EVER heard about any issues with front axle in the 2000+ Dak. (Independant Front Suspension design)

    I am curious--- why are you asking about the front axle?

    I run RedLine lubes in all gearcases. (front/rear diff., xfer, xmission and powerSteering)
  • ronslakie1ronslakie1 Member Posts: 57
    Concerning the brakes I guess this is a real crap shoot. I have a 2K Dak, CC with the 5 speed and a 4.7, 4x4, which has 78K miles. I have the original brakes front and rear and have never had any brake problems. From the looks of them I'd say I have another 30K miles left on them. I have had the A/C condenser replaced and the door lock switch on the passenger side replaced. Also like bpeebles I have replaced the front and rear differential fluid, the transfer case and manual transmission fluid with Redline products and I'm glad I did.

    Ron
  • bpeeblesbpeebles Member Posts: 4,085
    Just to be clear about why many of us chose to run RedLine lubes in all the gearcases.....

    I realized an immedeate 2-4 MPG increase on the highway. (went from ~18 to ~21MPG) The reason for this increas is 2-fold.
    1) Group5 synthetic lube is thinner that dyno-oil so there is less wasted power due to "gear churn".
    2)More slippery lube wastes less power due to lowered friction.

    The protection that group5 synthetic lubes offer is the very best available. When the pinion-seal on my rear diff blew out and lost most of the fluid, I was in the middle of a 4-hour trip with a sofa in the back running at 65MPH. There was NO DAMAGE AT ALL to the differential gears.... All I had to do was replace the seal and re-fill with RedLine again.
  • simplesimon3simplesimon3 Member Posts: 2
    I have a 04 dakota 4.7v8 that doesn't seem to stay fully engaged in 4x4. When I select 4h or 4L on the dash it shifts into gear fine sometimes with a clunk. But when I romp on it in 4x4 it makes a clunking sound like two gears grinding. Has anyone had this problem and could someone tell me if it could be the transfer case shift motor?

    thanks

    prs
  • mtbiker_14mtbiker_14 Member Posts: 7
    I had a brake line break, and they seem to grab, especially when it's wet out. And I had something go wrong with the DS drive axle around 40K miles. It was making a clunking sound when I was going over 55 and grease was goin everywhere. But I took it to Les Schwabs and they were able to fix it. The only other problem I've had was with my rear DS door lock. It stuck half way, so i just took the plastic teeth that move the lock up and down off of the electric assembly. For now it's a manual lock.
  • simplesimon3simplesimon3 Member Posts: 2
    I have a 04 dakota 4.7v8 that doesn't seem to stay fully engaged in 4x4.
    When I select 4h or 4L on the dash it shifts into gear fine
    sometimes with a clunk.
    But when I romp on it in 4x4 it makes a clunking sound
    like two gears grinding.
    Has anyone had this problem and
    could someone tell me if it
    could be the transfer case shift motor, or the chain?

    thanks
  • osato638osato638 Member Posts: 2
    I bought a 98 dakota sport yesterday, it has 240000 km on it a 3 inch body lift and its 4x4. The 4x4 is not engagaing when shifted into 4 hi, it is a standard and has floor shift 4x4. The truck makes an unbelievably loud grinding sound like two gears slightly missing when you give it gas in 4x4. The light is on in the dash indicating it is engaged but the sound leads me to believe otherwise. I am wondering if it is due to the body lift or maybe linkage. This is my first dodge experience and the truck is being repaired for my better half. Any info greatly appreciated.
  • bpeeblesbpeebles Member Posts: 4,085
    This could be a mis-adjusted linkage or worse.... I beleive each of the wheels also has a vacuum-powered enguagement.

    You really need to ascertain if it is the xfer case which is not fully enguaging.... or the front wheels.
  • osato638osato638 Member Posts: 2
    i lifted the truck, all 4 wheels spin when the 4x4 is engaged. The wheels spin smoothly at idle speed but when the truck is accelerated there is a loud banging and grinding sound, the wheels remain spinning. The sound definately seems to come from transfer case area, truck does the same in 4 lo as well. Thank you for replying.
  • njdevil2njdevil2 Member Posts: 1
    I bought my truck used , its an 04 Dakota Club Cab 4.7 V8 and just recently when i went to use my 4wd i noticed that the indicator light for 2 wheel turned off as normal and the one for 4 wheel hi just went to a solid orange light right away instead of flashing between the orange and green and then going to a solid green as it did the first time i had used it. Any ideas of why this would happen , or how it can be resolved?? the 4 wheel still seems to work which is leaving me confused.

    Thanks All
    Steve
  • snowman102185snowman102185 Member Posts: 2
    Don't really have a good word to describe it, but when I put my 2001 Dakota into 4wd and crank the wheels it doesn't want to go, like something is holding it up, give it some gas and it jerks forward a little bit then locks up again. It doesn't seem to matter which direction I turn the wheels. The shop said it was probably in the transfer case but I want to hear if there are any little tricks that you guys have found out about these to try.
  • bpeeblesbpeebles Member Posts: 4,085
    That is TOTALLY NORMAL for a 4-wheel-drive vehicle. While locked into 4WD, you should NEVER try to turn the steering wheel very much.

    The phyisics behind it is that when locked into 4WD, all the wheels are essentually LOCKED TOGETHER. When you try to turn sharply, the OUTSIDE wheels need to spin faster than the INSIDE wheels to keep up... this causes the driveline to "wrap up" and you feel that walking sensation. (as if the front wheels are trying to take steps) There is a HUGE amount of torque built up in the driveline when the wheels are locked together but need to spin at different speeds.... SOMTHING will eventually snap.

    That is why the owners manual says to NOT USE 4WD on dry pavement. You are lucky you have not ripped a driveshaft out from under your truck!!

    If your "shop" does not understand this phenomen about a 4WD... run away from them fast!

    4WD is only really useful in a STRAIGHT LINE and can actually cause you to slide off the road in the snow if you are not prepared for the effects of the wheels being locked together around a corner. Also, NEVER use 4WD above 40 MPH... you can get killed if you do not undersand the physics of a 4WD system at those speeds.
  • markr1695markr1695 Member Posts: 3
    I love everthing about my 2005 Dakota except the gas mileage (around 17.5 combined). Would manual lockouts on the front hubs help? If so where can you get them?
  • bpeeblesbpeebles Member Posts: 4,085
    That would be a lot of $$ and time for little return.

    I was able to push my Dakota from about 18MPG to over 21MPG by simply changing all gearcase fluids from dino-oil to synthetic Red Line lubes.

    This included changing the following fluids.
    *)Front Differential
    *)Rear Differential
    *)Xfer Case
    *)Manual Xmission
    *)Power Steering

    Since Red Line lubricants are true Polyol Ester synthetic fluids, they are far superiour to most other so-called synthetics. (and also more expensive due to the cost of Polyol Ester basestock)

    There are several reasons for the increase of MPG.... including
    1)Less Friction
    2)Less gear-churn reduces wasted power (thinner oil still provides better protection!)

    A bonus is that I will NEVER EVER have to change these fluids again because of the superiour protection provided by the Red Line lubricants.
  • markr1695markr1695 Member Posts: 3
    Thanx a bunch for your quick response. Did you have change seals as well?
  • bpeeblesbpeebles Member Posts: 4,085
    There was just ONE seal that started to leak after running RedLine for over a year. The rear differential lost all of its fluid on a 6 hour roadtrip with a sofa in the the bed of the truck.

    The ability of the RedLine differential lube to protect WITHOUT fluid saved my gears. All I did was install new seal and refill with RedLine Gear Oil. If this leak had occoured while running dino-lube, I may not have been so lucky.

    BTW: The RedLine Gear Oil CONTAINS the special additive for Limited Slip Differential (LSD). There is no need to add anything but the RedLine.
  • markr1695markr1695 Member Posts: 3
    Awsome!! Thanx a bunch!!
  • mtbiker_14mtbiker_14 Member Posts: 7
    I was driving an icy road tonight, and started sliding backwards down it, even in 4wd. There was a 90 degree turn at the bottom of the hill and I would have went through a fence and down a bank into a creek if I hadn't stopped. So I gunned it and cranked the wheels. I was able to get sideways and stop in the ditch. But when I started driving again, there was a buzzing coming from the engine and steam coming out of the hood. I got stopped at a flat spot and found fluid all over inside my engine compartment. Also, the buzzing seemed to be coming from my power steering pump. When I took off the lid of the power steering reservoir there was a noticeable suction, and there was barely any fluid left (I just filled it before christmas). I also found that the plastic guard (that has a hole for the oil filter) between the front bumper and the skid plate was cracked in 2 places and pushed up about 3 inches.

    I'm supposed to leave for college 5 hours away on Monday afternoon. I highly doubt this is gonna be a quick fix, especially in a small town. Any ideas as to exactly what the problem is, or ways to temporarily fix it? Also, how necessary is that plastic piece behind the bumper? Should I have it replaced or just pulled the rest of the way off?
  • bpeeblesbpeebles Member Posts: 4,085
    From your description, it sounds as if some of the power-steering plumbing may have been damaged when you went off the road. If that is the case, you may be able to find a shop that can make hydrolic fittings in-house while you wait.

    Also, you may wish to scrutinenize for any other damage underneath the vehicle.
  • bdoucetbdoucet Member Posts: 5
    I have a 02 Quad Cab Dakota V6, pretty happy with the truck. Unfortunately had to do front brakes, front wheel brgs, CV shafts and only have 130 000 kms. When i replaced the CV on the drivers side I noticed the it seemed to have a lot of play on the splined shaft that goes into the diff. as compared to the pass. side. Recently I have heard a clunking sound coming from that area. had the truck up on jack stands tonite and put it in 4wd to listen and look and it seems to be coming from that area. I guess there is a chance that the CV is faulty (it was new, not re-man) does anyone have any ideas or experience with this problem?
    Cheers,
Sign In or Register to comment.