Are you currently struggling to find an affordable car that you want? A reporter would like to talk to you about your experience with car shopping; please reach out to [email protected] for more information.

Saturn S-Series Maintenance and Repair

edwardsfamilyedwardsfamily Member Posts: 6
Do I need to do anything other than disconnect the battery to disable the airbags on this car so I can replace the ignition lock?

Thanks
«1345

Comments

  • thomas4g63thomas4g63 Member Posts: 2
    i know the neutral rev lmiter is at 4 grand but everthing is plugged in and no fuses are blown
    i also replaced the throttle position sensor but it still throws a code for it
    please help
  • carman26carman26 Member Posts: 2
    The horn on my 1996 Saturn SC1 sedan started going off one day incessantly. After touching the horn button it stopped. I visited several mechanics, who said that I need a new horn.

    I bought a new horn (the one with the two mounting sites). However, my Saturn horn has a three-wire relay cap. I cut that off (per seller at AutoZone) and have tried "wrapping" each wire on one mount while the other is attached to a cable that is attached to the grounded horn. Nothing works.

    QUESTION: WHAT AM I SUPPOSED TO DO!?!?!? How can I get this work!?!? PLEASE HELP ASAP!!!!
  • minicoopersminicoopers Member Posts: 26
    Yes.
    Pull the SIR fuse and disconnect the SIR power plugs for the bags under the dash.
  • minicoopersminicoopers Member Posts: 26
    Since your old horn works incessantly, I'm betting it's not the problem. My money is on the horn switch inside the steering wheel or the horn relay.
  • minicoopersminicoopers Member Posts: 26
    1995 SL2
    188k miles
    A/C works fine, good pressures
    Blower motor good (bench tested)
    Blower resistors good (bench tested)
    Blower relay good (bench tested)
    Blower switch good (bench tested)
    Alternator output checked
    Battery checked
    All fuses good

    Problem:
    Turn on A/C and blower runs fine for about 5 minutes then it slows down and sometimes stops. Same results on any blower speed. Blower light dims as blower speed decreases.
    Solutions anyone?
  • sattechsattech Member Posts: 32
    Take the negative cable off,take the air bag fuse out. Check your key first, worn key's will cause problems. Compair your key with another.
  • sattechsattech Member Posts: 32
    Connect a DVOM to Ground and check the following terminals of the blower switch for voltage with the switch in each position.
    Speed Terminal
    LO E
    MED D
    MED2 B
    HI A
    Is there voltage at all terminals ?
  • sattechsattech Member Posts: 32
    Back in 1996 Saturn had a problem with the relay in the horn. They had a Bulletin in 1996 for the repair. And on some occasion's the horn buttons get stuck (in the air bag) and causing the horn to stay on
  • sattechsattech Member Posts: 32
    I can help but I need your CODES
    Do you have a E11 IN ENGINE CONTROLS ?
    That will tell you, you have a transmission code set.

    For starts right down your codes (engine & trans) and clear them. Drive the vehical till your code comes back and check to see what reset.
  • boilerman2boilerman2 Member Posts: 3
    My 98 SL1 With 195,000 miles is having EGR probs. I keep getting codes (P0405 Exhaust Gas Recirculation Sensor A Circuit Low) and (P1404 Exhaust Gas Recirculation (EGR) Valve Pintel Stuck Open) I have taken my valve off numerous times and cleaned the carbon build up from it and made sure the pintel works freely. I even changed the coolant temp sensor. Can anyone please tell me if i need to repalce the valve or is there something else i can do to correct this ongoing problem?...
  • sattechsattech Member Posts: 32
    Are you having a Drivability problem ? If so what speed ? You incountering a Starting problem ? You have a scan tool to view data stream in reference to EGR operation.

    What you can try to do is remove the EGR valve from the vehical look into the ports that EGR controls and make sure that you dont have a blockage it one port. One thing to try is with the valve removed start the vehical. Caution you need to keep you hand on the Key to shut the car off cause it will rev to the rev limiter. CHECK YOUR OIL LEVEL FIRST !

    With the valve removed start the vehical you will here exhaust leaking and if so shut down the vehical. You know the port is open but how much ?

    Make further inspection check the electrical connector and then what I recommend you to do after that is get a new valve from Saturn
  • boilerman2boilerman2 Member Posts: 3
    Thank You
    I will try the things you suggest and see how i make out before purchasing a new valve from saturn being they are pretty darn expensive. not having a starting problem, but sometimes a driveability prob at different speeds either going up hills or initialy starting out...seems to lose power and sort of bog down on me.
  • twoplankr22twoplankr22 Member Posts: 15
    if the horn was going off, it works fine. i just had the same problem, it was with the wiring b etween the button on the steering wheel and the fuse in the engine compartment. rather than take the entire dash apart and replace a mile of wiring i just ran a new hot wire from a 15 amp fuse in the car with a push button switch on the dash inline through the firewall and hooked up that wire to the hot end of the horn. ground the horn to itself.
  • twoplankr22twoplankr22 Member Posts: 15
    anyone know how to remove the ignition? key broke off inside and anyone can start it with a knife now.
  • sattechsattech Member Posts: 32
    What: Year, Make, Model do you have?
    There is a repair that can be done but you need to go to Saturn. Tell them you need a new key cut and a Ignition lock cylinder coded.

    NOTE: You will need to have your Driver's License (FOR THEFT REASONS) and your vehicle identification number, Registration card. They will need to go into there system to get your key code for your Vehicle so the new key will be the same. And with a new key cut if you have a second key put the two together and see if your second looks the same or worn. If the second key is worn REPLACE it.

    For the repair you need to keep in mind if your not sure how to do it's best to go to the Dealer. Why brake more that what’s broken. Ignition lock cylinders are not and easy repair.
    Again what Year, Make, Model do you have ?
  • twoplankr22twoplankr22 Member Posts: 15
    it's a 96 satur sc2 DOHC. i bought a cheap stock GM replacement cylinder, it's about the same size, but i dont want to spend a whole ton of time taking the stering coloum assembly apart just to get to an impass. the root of the problem is that about 2/3 of the ket is broken off IN the keyhole, if ther is an easy way to get that out id appreciate that info as well. thanks
  • twoplankr22twoplankr22 Member Posts: 15
    i need to replace o2 sensor 2 in bank 1 (bank 1 sensor 2). Anyone know which one that is?
  • sattechsattech Member Posts: 32
    Help me help you- what do you own ?
  • sattechsattech Member Posts: 32
    To all that post messages:

    First thing you need to do is always post your current vehicals informatiom for every responce. It's most helpfull. I don't know what you own.

    YEAR/MAKE/MODEL

    ENGINE APPLICATION

    THANK YOU
  • twoplankr22twoplankr22 Member Posts: 15
    1996 saturn sc2 DOCH 1.9l
    -thanks
  • sattechsattech Member Posts: 32
    Thank you
    OK now you do have two (o2 oxygen )sensors.

    The Primary oxygen (O2) sensor is located in the exhaust manifold just off the head and that is a 1 wire sensor.

    The Secondary oxygen (O2) sensor is located down by the exhaust system converter and that is a 3 wire sensor.
  • leodogleodog Member Posts: 7
    Saturn SL2 may be multible problems. The engine revs really high and stalls when you put it in gear. When you do get it going it sounds like it is in 2nd gear. Suspect it is the trans. control, but don't know where it is located. Sattech Help Me. Thanks
  • sattechsattech Member Posts: 32
    Hello: leodog
    Your SL2 what year is it ?
    Engine revs high, all Saturn's came with Tachometer's what RPM is it going to ?
    Is it hitting the rev limiter ?
    Is your (SES) light on ? Service engine soon
    Note: If the engine isn't running correctly the trans will not perform properly.
    I believe you can go to your aera parts store and ask them they will pull codes for you. Wright them down.
  • leodogleodog Member Posts: 7
    Thanks. This car is my sister in laws and I haven't got much more info. The car is a 1997. It didn't sound like it was reving high enough to be hitting a limiter. I have a scanner but haven't got there yet. Where is the trans control unit on the car? I need to drive it too. I was wanting to disconnect the tcu just to see if it changes anything.

    Thanks
  • sattechsattech Member Posts: 32
    OK
    NO S-SERIES Saturn's had a Transmission Control Unit. That was all controlled by the PCM. Powertrain Control Module. Before doing anything pull your codes first(Engine and Transmission) write them down. Compair your notes and see what reset.
  • leodogleodog Member Posts: 7
    thanks again sattech - I'll let you know when I do
  • tenpinarmtenpinarm Member Posts: 8
    trying to bleed brakes after changing both front calipers, only the left caliper bleeds.the right acts like nothing is going thru (air or fluid). Is there a special procedure involved?
    Doug
  • sattechsattech Member Posts: 32
    Hello; TENPINARM
    My question to you is:
    Do you have ABS or NOT ?
    But here are the bleeding procedure's for both systems.

    With out ABS:
    Front Right,Rear Left,Front Left,Rear Right

    And with ABS:
    Right Rear,Left Rear,Right Front,Left Front
  • tenpinarmtenpinarm Member Posts: 8
    I appreciate the fast reply and I just found a pinhole leak in the left rear brake line. Murphy's hanging around here too much.
  • kaylenekaylene Member Posts: 2
    I need help! I have a 1995 SL2 Saturn. It is stuck in park. Sometimes I it'll come out of park and that is if i let it run a while. Or like now I can't even get it out of gear. Not sure if this is a major problem. Don't want to spend a ton of money fixing a 1995. Thanks for your help!
  • sattechsattech Member Posts: 32
    Hello: kaylene
    You have two simple test's that you can perform and both are easy.

    Step 1 push your brake pedal down and see if someone can tell you if your brake lights came on. Not to worry about burnt out bulbs.
    YES go to step 2
    NO possible brake switch.

    Only if lights came on in step 1 go to step 2.

    Step 2 get into your car (key on engine off) and turn every thing off. Windows up will help you cause you need to listen to a noise. DON’T TOUCH THE SHIFTER OK.
    Now push your brake pedal down gently and listen for a clicking noise. Stop, let go, and push the pedal again
    Did you here a clicking noise ?
  • kaylenekaylene Member Posts: 2
    Thanks for the quick response, and I will try this tonight, but what if I do or do not hear a clicking noise?
  • sattechsattech Member Posts: 32
    Hello: kaylene
    If you don't
    you will need a (DVOM) Digital Volt Ohm Meter. And you need to remove the console.
    You will have a (BTSI)Brake Transaxel Shift Interlock control problem.
  • leodogleodog Member Posts: 7
    sattech : there were 10 codes according to the owner. The one that kept coming up, after being cleared, is P1650. Driver 2 imput voltage high. Thanks for your help.
  • boatmoterboatmoter Member Posts: 2
    need purge valve location for 1993 SL2, pic. of location if possible,thank you..
  • boatmoterboatmoter Member Posts: 2
  • sattechsattech Member Posts: 32
    Hello: boatmoter
    EVAP Canister Purge Solenoid
    Location is in back of the engine block look for the starter. It's behind the housing of the starter. You will see a black/plastic line coming down from the intake that is the vacuum hose for the EVAP Canister Purge Solenoid/Valve. You will need a 10MM socket to remove it. Take note of the lines to the valve before you remove them. Don’t cross them when reinstalling the new Solenoid/Valve.
  • leodogleodog Member Posts: 7
    Sattech : can you tell me what to do now. Thanks
  • sattechsattech Member Posts: 32
    Hello: leodog
    P1650 Quad Driver B Circuit
    The computer performs a system check every time you key on. So what you need to do is key on but don’t start the vehicle. The (PCM) Powertrain Control Module command’s a bulb check.
    Look at your indicator lights in the cluster when you do this to see if all of the bulb’s are working ( low fuel, ses light, temp, ..). Not back lighting.

    Check cooling fan control with AC operation turned on. Is fan on

    Check the fuse in the (UHJB) Under hood junction block for Maxi fuse. See if it’s blown
    There is a lot of criteria associated with this failure. If you cant find your problem here you will need to take it to the Dealer
  • burnattburnatt Member Posts: 3
    Fuse problem? Looked at scheme and dont know which one. Help.
  • sattechsattech Member Posts: 32
    Hello: burnatt
    Look in your (IPJB) Interment Panel Junction Block.
    Location is down by the passengers left foot.
    Pull the panel off then you will see the (IPJB). Now on the panel you pulled off look at the back side of it and you will see all the information you need. You will be looking for the lighter fuse. 20 amp fuse.
  • burnattburnatt Member Posts: 3
    Thanks. In other words this fuse is not in the fuse box under the hood?
  • sattechsattech Member Posts: 32
    Hello: burnatt
    Yes that is correct. You have 2 fuse boxes a (UHJB)&(IPJB).
    Under Hood Junction Block
    Instrument Panel Junction Block
  • helpbingohelpbingo Member Posts: 10
    1996 Saturn 1.9L
    On acceleration from low rpm to higher rpm the engine hesitates (coughs).

    When the throttle is held steady there is no noticeable problem, but once you release the throttle and begin to accelerate you get a hesitation.

    I have a cruise control that it will not stay on because of the hesitation. The cruise control shuts off after you release the throttle.

    I have a new ignition, new air cleaner, new spark plugs, new engine temperature sensor, new map sensor, new throttle position sensor, new spark plug wires.

    Help
  • sattechsattech Member Posts: 32
    Hello: Helpbingo
    Is your check engine light on ?
    If so you need to go to your area parts store to have your codes checked. 1996 Vehicles and on have OBD2 “ On Board Diagnoses”. That will capture any misfires you may have going on with your vehicle. Wright down all information before clearing.
  • helpbingohelpbingo Member Posts: 10
    I have no faults on the OBD2. The only fault I had was when I took the sensor plug out and ran it to see if there was a difference and there was none. Plugged it back in and cleared the fault.

    I have an OBD2 scan tool by AUTOTERRA for Palm OS.

    I took the EGR VALVE off today and it was clean at the pinnacle and around the port on both the cylinder head side and the valve side.

    I did spray it with brake cleaner and scrubbed with a tooth brush. All the came off was a little bit of black. The pinnacle moved freely before and after treatment.
    Reinstalled it and torqued the bolt and nut. Started it up and it ran. I am going to work soon and report on any change if any.

    The EGR has 100,000+ Kms on it.
  • helpbingohelpbingo Member Posts: 10
    There was no difference in performance after cleaning the EGR Valve.
  • sattechsattech Member Posts: 32
    Hello: helpbingo
    If your sure that the EGR valve is fine, unplug the valve and drive the vehicle. The engine light will come on but you understand why. See if it still hesitates. Driving under a load your testing the performance of the secondary ignition.

    If it still does.
    Start at the plugs look at them and see what color they are, lightly pepper looking is fine but black is not. Check your fireing order over. Plug gap .040. One other thing you can do is remove all spark plug wires from the coils and put them out of the way. Look at the coil towers and have someone crank the engine over. See if they arck together 4-1,2-3. If not you may have a bad coil.
  • helpbingohelpbingo Member Posts: 10
    Hello sattech

    I unplugged the EGR and drove the car with no change. I got the engine light on and reset it.

    I checked the spark plugs and they are white. They are bosch copper plus gapped at .050.

    I have Nology capacitor discharge plug wires, AEM cold air intake, a ceramic coated exhaust, and a flow thru cat and muffler, as well as a Complete MSD Ignition.

    I am not comfortable with shorting the coils.

    But I have run on the stock ignition and have had the same problem.

    I have changed the stock coils on the same stock ignition module and had the same problem.

    I have changed the stock ignition module and run the stock coils and and MSD coils and had the same problem.

    I have changed spark pug wires and had the same problem.
  • helpbingohelpbingo Member Posts: 10
    Hi sattech,

    One other thing I have noticed is that the hesitation always starts after the temperature gauge gets to normal operating temperature.
Sign In or Register to comment.