Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Chevrolet TrailBlazer Engine and Performance Problems

03 trailblazer started with loud engine roar after thermostat replacement , no other signs or dash codes.Noise starts at 25 mph and on highway constant .Any ideas ?Similar problems, answers!
«1

Comments

  • burdawgburdawg Posts: 1,524
    Sounds like the fan clutch has failed or is not connected right. It's viscous on the TB and needs the control line connected.
  • Mine made a similar noise. Turned out to be the pulley on the A/C compressor. Does it change pitch when you turn the A/C on, then thats it. I changed the fan clutch and the idle pulley before I found the right problem. New compressor is $600 new and $200 used at the junkyard. Good Luck
  • Could this be related to the thermostat replacement that was done?And where is the control line located ?
  • burdawgburdawg Posts: 1,524
    Hard for me to say if it's related or not. Depends on what was removed to get at the thermostat.
    If memory serves, the control cable for the fan clutch runs horizontal along the drivers side of the rear of the radiator, along a plastic boss that supports the whole assembly. If you can see it (I don't recall how much is visible) then maybe you can verify if it's connected.
  • burdawgburdawg Posts: 1,524
    Minor update. The wiring runs at about a 45 angle from the top right of the shroud (assuming your standing in front of the car looking down at the top of the radiator/shroud) between the fan and the radiator. It runs in kind of a conduit. The top connector is on the top right of the shroud from the same view.
  • Thanks for the updated info I checked connection and it is secure,I guess its time to visit the dealer. Thermostat at 55 K $297 ,strange sound at 56 K priceless!!!
  • Second thought,what could happen if I wait for 500 more miles before taking it in ?The fan clutch won't seize or could it. Thanks
  • Hi, I've been reading through your forums looking for a solution to my big problem - our 2002 Trailblazer with 85,000 miles and regular maintenance basically blew up last week with no warning from the gauges. The dealer took apart the engine (I had found the cylinder recall online), but says a blown head gasket caused the problem. We already had the head gasket replaced at 36,000 miles, that time with bells and lights and everything flashing and dinging...this time, NO warning. Any ideas? We already have calls into GMC and are talking with someone who is nice so far...this is going to be over $6000 - Merry Christmas
  • dpratldpratl Posts: 2
    pickup41 -

    Any update on your TB. I'm having the same problem as you. I recently had the thermostat replaced and noticed a roar from the engine as well. I hear and feel the roar when I accelerate hard, like when I'm merging onto the expressway.

    Prior to having the thermostat repalced I had no problems (105k miles).

    Looks like a trip back to the dealer.
  • johnny83johnny83 Posts: 2
    I have an 05 tb with the I6. When I turn on the air or heat it surges almost like it is idled too low. The mechanic said it sounded like the compressor trying to lock up but I was woundering if it could be a idle sensor or something?
  • Can someone tell me if the 2002 trailblazer 6 cylinder clutch fan has one with no electrical connections. I seem to be finding clutch fans on the net with the electrical connections attached. Hubby says the clutch fan runs off the motor with no electrical wires. Does anyone know what the part number would be. I'm confused and looking for this clutch fan.
  • burdawgburdawg Posts: 1,524
    The fan clutch on the I6 engine is electrically controlled, so they will all have a connection. This is done to more tightly control the operation of the large cooling fan and reduce the amount of drag put on the engine by the fan when it's not needed. The end result is better fuel mileage which is of course mandated by the federal government.
  • When the new one arrived, it is stiff when trying to turn it, just like the one one the truck. Is is suppose to be stiff (not turn freely).
    Thanks,
  • burdawgburdawg Posts: 1,524
    Yes.
  • Got it in within a half hour. Bought one off ebay new for $120.00 with life time warranty.
  • i have a 2003 TB. there is knocking in my engine that gets louder as i press the gas pedal. i still have oil pressure but this noise persist as if i might need a new motor. some other problems that i have been having is my speed meter works when it wants to sometimes i slow down and it does not drop to zero it will drop to about 25 or 30mph. i also can turned the key to crank it and it won't crank it will just start malfunctioning. guages start to jump and my locks start to loc and unlock can anyone tell me any solutions to the problems i have with my 2003 trailblazer. also when i turn my air on the truck dies as if it was not idle up enough.
  • welleswelles Posts: 1
    How do you change spark plugs on a 2005 trailblazer?
  • rpowersrpowers Posts: 24
    I have a 2005 TB with 21000 miles on it. When started in the mornings it seems to have an engine miss for a mile or two - almost like an old carborated engine with a choke sticking. I also don't feel all the power everyone talks about with this in-line six engine. It feels pretty peppy first thing in the morning - but most times it is a slug. Does anyone else have this experience?
  • glo4glo4 Posts: 1
    I have a 2003 TB EXT V8 that is in for a tune up, and changing fluids for 4 wheel drive and transmission. The shop is telling me a couple things I feel the need to check out. I understand that the fluids are pretty expensive. OK But the original quote for everything was around $600. Then the shop called and said that all the wires are breaking as they are taking caps off to get to the plugs. Add another $200 for new wires. Now they are saying that the 8th spark plug is stuck, giving it the weekend to soak and will try again Monday. My vehicle has 122K miles and has been very well taken care of (I thought). Can someone confirm that this sounds right. At least the original $600. I was figuring a tune-up would cost around $200. It's at the dealership that I bought it at and they are the only ones to ever do any work on it. (Oh, and he showed me the broken wires, they were broken about 6-8 inches up from the cap - is that right?) Need some advice anyone!
  • doub05doub05 Posts: 1
    I have a 2002 lt ext v6. The problem I'm having is, when I turn a corner or come to a stop for a while(traffic light), the vehicle acts as if it is going to shut off. It loses a lot of power. I took it in to be serviced and they said it was the fuel pump. Well that has been replaced 3 times already. Anyone have any Idea what the problem could be?
  • clickytbclickytb Posts: 1
    i have a 2005 trailblazer bought new from dealership and since jan. 2009 have had the vehicle a total of approximately 15 days in working condition. the service engine light came on and noticed a stalling feeling, felt like hydroplane. the next noise sounded like the engine was falling out. i have had total of 3 FULL set of lifters, and head gaskets, spark plugs with wires changed and a host of other problems fixed. presently at 4200 dollars spent and just yesterday began making a loud "clicking" noise under hood and the service engine light on. i am fuming. i have been a loyal GM buyer. GM is the ONLY vehicle i have ever owned but after this vehicle, and the company keeps letting me foot the bill, i vow to never own another GM product!! you would think in this day and time that the auto industry would stand behind their products. perhaps that is why they are in the shape they are. anyone else having the degree of aggravation that i am?
  • akhenatenakhenaten Posts: 4
    We have a 2007 TB that is dangerous to drive. It sits in the garage now for months while we pay $400 a month on a lease that expires the end of 2010. We have 30 or 40 pages of problems we faxed to a lemon law attorney in Garden City Mi at the Consumer Legal Services. We have gone thru the legal channels GM demands to get this resolved. The cost to GM at this point must be astronomical with all the maintenance costs, monitors , replacements, conversations and files in Texas...big, big joke. They refuse to replace the vehicle or terminate the lease...we were open to any offer. THEY DON"T CARE. They know the trans has been bad since 1982, the instrument cluster fails, the car accelerates and brakes on its own, the doors lock and you can't exit,etc. etc. Read these posts. THEY DON"T CARE. We will never, never, never own another GM product.
  • burdawgburdawg Posts: 1,524
    Do they actually have a diagnoses for what is wrong with it? Sounds like they're just tossing parts at it to try and find the issue......
  • ticadooticadoo Posts: 40
    Help! The engine in my 2003 Chevrolet Trailblazer has started knocking! I only have 74,000 miles on it. What could it be? Any one else have these problems? :lemon:
  • burdawgburdawg Posts: 1,524
    Can you describe the knock? Does it occur all the time, just when the engine is cold, or under certain conditions? Is it actually a knock, or more like a ticking noise?
  • Not the same problems but GMs overall plan might have something to do with it. I have a 2005 TB 4WD and it was getting 10 to 11 mpg city most of its life except for maybe the first 6 months from a new purchase. I took it back to the dealer many times and they kept saying that that is what these trucks get for mpg. I tried many things like HHO add on kits and fuel additives. Nothing worked. I started looking into basic stuff like fluid levels on the differentials and transfer case and found that my transfer case was operating with about 1/2 quart of fluid. The manual and the dealer state that this would not need servicing or checking until 50K. At $13 a quart from the dealer (only place to get it) I added a little over 1 1/2 quarts. It was an amazing difference in performance including MPG. I am now getting closer to 15 to 16 mpg in the city. So much for suggested OEM maintenance. I feel that GM and other auto manufactures do these things intentionally to get consumers to buy new vehicles fare before it is necessary. The business model for (planned obsolescence) needs to change here the US or we will all soon be in tank. Based on the recent events it looks like many of us are already in the tank due to greed such as this.
  • Not sure but I have found that GM has a plan that is all about them. I have a 2005 TB 4WD and it was getting 10 to 11 mpg city most of its life except for maybe the first 6 months from a new purchase. I took it back to the dealer many times and they kept saying that that is what these trucks get for mpg. I tried many things like HHO add on kits and fuel additives. Nothing worked. I started looking into basic stuff like fluid levels on the differentials and transfer case and found that my transfer case was operating with about 1/2 quart of fluid. The manual and the dealer state that this would not need servicing or checking until 50K. At $13 a quart from the dealer (only place to get it) I added a little over 1 1/2 quarts. It was an amazing difference in performance including MPG. I am now getting closer to 15 to 16 mpg in the city. So much for suggested OEM maintenance. I feel that GM and other auto manufactures do these things intentionally to get consumers to buy new vehicles fare before it is necessary. The business model for (planned obsolescence) needs to change here the US or we will all soon be in tank. Based on the recent events it looks like many of us are already in the tank due to greed such as this.
  • juan12juan12 Posts: 1
    Ok where do I start!!! First of all when I am driving and come to a stop or going up a hill my truck acts like it wants to cut off so I took it to dealer and he said it was the FAN CLUTCH got that fixed $600.00. After a month started back doing the same thing! Now on my dashboard the airbag light is on and all the right side lights are not working ( back head light, back light by the license plate, radio, and air condition lights) and the back wiper blade is going by itself and don't be turned on that is wild and crazy I hate to pull up in a parking space and look back and the wiper blade is really going and the truck is turned off :( . I had the spark plugs changed last year thinking that was the problem why when I'm driving the truck sound like it is tuned up real loud and changing gear like a 18 wheeler. I know three more TB owners and they TB sounds the same way lord that is a killer on gas. I need some help or is it a recall on TB
  • I too have had the ticking noise. Does anyone else have this problem. Has anyone figured out what causes it?
  • Here are the problems I have.
    Ticking noise, second row seat/passenger side window will not work, i was told by onstar that I am having a control sensor problem(i believe that is what she called it), when you take off it sounds like a jet taking off(is this natural?), .
  • I too had the fan clutch replaced...the "jet noise" and ticking stopped for a while..and is back again. This truck is possessed and nothing but junk. I've had so many problems with it and it just turned 80,000 miles. The driver's side turn signal/brake will not work when it rains; if I am using the CD player and put down the sun visor..the CD player stopps working; even with the wipers off...the come on by themselves...the A/C and heat works when/where it wants; the service engine light will not go off.....and the gas mileage is HORRIBLE. I can't afford another truck now...so I guess I'm stuck...
  • burdawgburdawg Posts: 1,524
    Ticking noise - If it's the same problem we had a long time ago it was eliminated when the PCM was updated with new firmware, I believe it had something to do with altering the VVT until the engine was warmed up. We also had a loud "ratchet" type noise coming from under the dash, it was the mode door actuator and was repaired under warranty.
    Window not working - shouldn't be that hard to diagnose/repair.
    Loud noise when "taking off" - could be fan clutch, if it's not working right the fan will be on full force and will be noisy. It's another known potential problem area.
  • my Trailblazer EXT tramssion won't shift into 3rd gear. any suggestion besides the expensive one?
  • :mad: my key wont turn off and key is stuck and at the same time my gear shifter wont lock and moves freely!!!!!!!!!!!! are these related are just a strike of luck????? and what would cause all of this???????? :( :( :(
  • I have a 2002 ltz 12000 miles my problem has been going on for a bit i lose power while driving and even when just at idle i have had it checked with no help from anyone and alot of money i was able to let it warm up for 30 mins or so and would not have a problem now its losing power while im driving.
    Please help with any info
  • me too at 164,500 miles...they say it is the clutch pistons 4 3rd and 4th gears....($3,000.00 parts and labor 4 a re-built transmission), I hope it is fixed, I have the V-8 and love my TB...it has been a workhorse for me...
  • jmes_rodjmes_rod Posts: 3
    hi to all... anyone knows how to fix P1174 code?.. i already make a tune-up complete i already remove the injectors and clean it by lunch machine and i already check the intake manifold for some leaking air... the problem is same.. im thinking now to remove the catalyst... any suggestion..... thanks
  • dustinbdustinb Posts: 2
    I have had a similar problem with my 2005 chevy trailblazer. I have had it in to the shop for the last 1 1/2 months to the chevrolet dealership three times the dealership went as far as to replace the throttle body system ,gas pedal(that also includes throttlr position sensor) cam shaft position sensor, cam shaft actuator solenoid, along with standard services and there seems to be no end in sight. This seems to be an ongoing problem since I have spoken to several other owners who are having the same problems.No one in general motors has thusfar had an answer to this situation and my repair costs are upwards of $ 1000. I have been a chevrolet man for as long as i can remember and this has been a major upset. Good luck with your situation. :mad:
  • dustinbdustinb Posts: 2
    I have had this same problem I have gone as far as to have the gas pedal(which includes the throttle position sensor) cam shaft actuator solenoid, cam shaft position sensor, throttle body plennum(i hope that is spelled right) and no resolve to this situation. I have had my trailblazer to the dealership three times and in the shop for over a month. Unfortunately this may only be the beggining of your troubles. No one i have spoken to has a fix for this problem. Good luck. :mad:
  • gmcustsvcgmcustsvc Posts: 4,252
    Hello Dustinb,
    I am from GM Customer Service. I apologize that you are experiencing and issue with your vehicle. Can you please email me more information about your situation so I can look into it further? You can find my email when you click on my name. Thank you,
    Mariah GM Customer Service
  • jmes_rodjmes_rod Posts: 3
    hi.... can you tell us what is the code.. thanks.
  • I have a TB that recently started to display the above light. It came on the day after I replaced my battery. The light shuts off when my car shuts off and sometimes takes up to 2 hours to come back on; other times it is immediately. I have avoided highway driving even though I haven't had it actually reduce speed yet. I haven't driven over 55mph since it started last Friday. I took it to Autozone but it wasn't registering any code. I took it over to the Chevy Dealership and they told me that they have had a 2003 TB in with the same problem and they can't get a code either. They recommended a list of repairs; almost $2000 worth of parts but they don't know which one will work. I am not about to start replacing parts that may or may not be the problem. I've seen so many different reasons for the light to come on I don't even know where to begin. Any suggestions?
  • burdawgburdawg Posts: 1,524
    Are you saying that the "reduced engine power" light comes on but it runs otherwise normally? My experience is that reduced engine power means you're only able to crawl off to the side of the road and stop.
  • Yes. So far I haven't seen anything abnormal. It still runs. I can still get up to 60mph although I haven't tried going faster than that. But the light is coming on sooner each time I stop and start the car. Seeing that most people have not been able to drive their cars, it raised an eyebrow for me too. Plus not being able to get a DTC on it.
  • jagtxjagtx Posts: 2
    Replaced a bad alternator last week. Now it starts and charges fine but the idle goes crazy when I turn the A/C on. It dies when I come to stops and sometimes speeds up when I take my foot off the gas going over 35mph. I've been driving it around without A/C on and have only noticed a couple of minor surges when parking. Does anyone know which fuses I should check or any other causes of this issue?
  • willsey03willsey03 Posts: 3
    I have a 2002 Trailblazer that the REP warning light started coming on and I never lost engine power either. I have it in the shop at this posting and they told my wife last night that the clutch fan was going out and there was some kind of emmissions leak that they were looking at. Would that cause the REP to stay on?
  • willsey03willsey03 Posts: 3
    Well I picked up my vehicle with a new fan clutch and water pump. A bargain at $1,200.00 :surprise:
    Anyway, they also mentioned I need brake pads and I have leak in the rear Pinion gasket :confuse:
  • I have been told these are issues also with the REP light. The problem with mine is that it still isn't picking up a code so they can't even begin to speculate what part(s) it could be. I replaced the water pump about 5 or 6 months ago and the serpentine belt/ battery the week before the light came on. I spoke with a mechanic that told me it could be anything from the spark plugs to something major. Hopefully you won't have any more problems. I am still waiting for my car to actual do something that will produce an answer. Its still running fine but the light is coming on more frequently.
  • lizc7lizc7 Posts: 1
    Is anyone experiencing problems with their trailblazer going in reverse while in drive? It is the second time it has happened with mine and it is usually after stopping on a hill, then pressing the gas to go forward. Instead of moving forward, it starts to go in reverse. The only way to drive forward is to put the car in park (in traffic), turn it off and restart it. Mechanics have no idea what the problem could be, does anyone?
  • seemenow1seemenow1 Posts: 1
    I took my 2004 TB to the dealership to get a electronic diagnostic test that cost me $95.00 only to find out that my power-train control module had some sort of internal fault. Can anyone tell me if this power-train control module be reset or re programmed
Sign In or Register to comment.