Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Buick Rendezvous Service Traction system and Anti-Lock warning

thomas001thomas001 Posts: 2
edited June 2015 in Buick
My Service Traction system and anti-lock warning light has come on. What is the problem and how do I fix the problem?

See Also: Buick Rendezvous FIX Trac Off ABS warning light DTC sensor hub wheel bearing repair GM

Comments

  • ray80ray80 Posts: 1,655
    Could be a number of things, I would suggest going through the 'Maintenance and Repair ' topic for recent posts, also check the Pontiac Aztek forums. It may be a wheel sensor or corrosion in connetor or broken wire or EBCM.
  • I also have a rendevous,and the best advise I can give you is TRADE IT!We have had nothing but problems from this vehicle.bcm twice,computer,wheel barings,gas tank,and now the traction control . What a piece of junk! 2002 vehicle an my 1993 chevy truck runs circles around it.Whats going on at gm?I'm very disappointed in this vehicle to say the least!
  • I have a 2002 Rendezvous, when I step on the brakes, It pulsates, feels like the ABS are working on snow, but this happens on dry pavement. the brake peddle pulsates as if the vehicle was going to slide, and the same noise. All the tires are good. Also on acceleration sometimes get the same sound and the TC symbol would appear. The TC symbol would sometimes come on even when the vehicle is not moving. The tires are fairly new and the brakes are good. This happens only intermittently, not every time. Please help !!!

    Sensors? How can I test to know which one is causing it?
  • ray80ray80 Posts: 1,655
    As far as I know, there is not way to test the sensors to see if they are bad. I believe you would need to go to GM dealer to have their scanner point to which one may be bad (The scanners at parts places I think would only suggest sensor may be bad, but won't point out which one). Also fairly often it is a woring issue to the sensor as opposed to sensor itself.
  • Hi ray80,

    Thanks for you help.

    Also fairly often it is a woring issue to the sensor as opposed to sensor itself.
    What do you mean by woring issue.
  • ray80ray80 Posts: 1,655
    Wiring issue, darn typos :)
  • steverstever Posts: 52,457
    For future reference, after posting, you may edit your post for 30 minutes. But we're all pretty fluent in chat typo around here. :shades:
  • Someone told me that the sensors are magnetic and that it can attract dust from the brake pads. which can cause a false reading.

    What is your opinion ?
  • leta789leta789 Posts: 1
    My Service Traction System light is continuously coming on. When I go to brake or turn the wheel going around curves or downhill there is a very nasty grinding noise. I've replaced brakes and rotors still the same thing I'm lost. I don't know what to do?
  • pondfishrpondfishr Posts: 2
    My son's 2003 rendezvous has the same "similar" problem. When you turn the wheel to the right and apply the brake the pedal jumps and after a few times the ABS disables and the AWD light comes on too. They have had two wheel sensors replaced on the right front wheel and it still does it. It seems to be getting worse. Once the ABS and AWD lights come on it drives ok. Is this dangerous?

    My Son, Daughter in Law and 2 Grandchildren are in this vehicle??? Also they have replaced the intake manifold gasket, head gasket, and water pump. GM engineering at its best.......
  • ray80ray80 Posts: 1,655
    For the grinding noise it is likely a wheel bearing. For the service traction,ABS,AWD lights it may be a wheel speed sensor (also part of wheel bearing/hub assembly), or fairly often (more so if it created by certain driving condition like going around corner) it may be problem with connection to sensor. It may be corroded or loose and I believe I've heard of a newer version of wireing that may be a bit longer so its not stretched when turning.
  • ray80ray80 Posts: 1,655
    See my prior post for possible corrections to the problem.

    'Is this dangerous?'

    No more so then the thousands of other vehicles that are on the road without ABS or AWD. The lights just let you know you are among them without the added features.
  • pondfishrpondfishr Posts: 2
    Do you know what you need to disassemble and where on the wheel you need to look to see if the sensor connection is loose or a bad cable? Thank you for the help!!
  • Mine was result of bad hub bearing on left front side - it was worn so bad the sensor could not pick up signal. By the way Bucik had recall for bad bearings, guess they never told me and you. Now i just replace rt one, thank goodness i have extended warranty = $400, twice $800.

    good luck
  • I have had the same problems with my 03 CX. I have had bearings and sensors replaced on both sides to no avail. My mechanic eventually took the whole front end apart and found some frays in the wiring harness that goes all the way across the front suspension. He said the way it was placed would not protect it from normal road wear. Replaced this entire harness -- PROBLEM FIXED!!!

    I am so happy, no more grinding, no more lights. After 2 years, we are finally fixed. No other problems with this car. I bought it new in 2002.
  • annie41annie41 Posts: 1
    edited December 2010
    I am having the same pulsations and grindings, and am beginning to think it is my driving ability and not the car, since my '01 Honda Accord had the same problems... ;) Really, though, I don't want to have any problems, of course, since I am taking a 1200-mile trip with it in 6 days. I didn't know if it was worth it to take it to the dealer where I bought it from??? What do you think? GM/American cars are new to me.
    So, not sure what is going on. All I know is the "Service traction System" light comes on when it grinds, usually when I turn, or abruptly stop. TEWALKER, your advice seems pretty solid and the most clear. So, I will go into the dealer, if need be, with this information. Thank you!!
  • I have had a similar problem for four years. I have had the brakes replaced twice. Sensors...tires...everything imaginable. My "service traction system" light has come on for two years now. After 6 trips to the GM certified dealer with no warranty, I am told all I need is a $1300 brake computer. No thanks.
  • gmcustsvcgmcustsvc Posts: 4,252
    jonesl11,
    I apologize for your inconvenience. What is the name of the dealer you had the brakes and such replaced at? Can you please email me your VIN and current mileage.
    Christina
    GM Customer Service
  • thomas001,
    I have a 2004 Rendezvous and my car has been indicating "service traction system" light after a loud and continuous grinding sound of ABS braking. I have had the brakes changed but to no avail. After reading the forum, I'm not sure where to go with this. I hope that Buick will realize it is a problem that must be recalled. Other than that, it has been a dependable car.
  • I have a 2002 Rendezvous and have spend $2,000 on trying to fix this problem with everything from redoing the wiring, buying new tires, replacing the battery, days after days in mechanics shops. What is the answer?? I am going to go back to my mechanic with this blog, but is there a definitive answer or solution? :sick:
  • ray80ray80 Posts: 1,655
    Hhmm appears I haven't mentioned here (plenty of other places though). If the speed sensors have been checked/replaced and wiring/connections checked out to be ok it may be an issue with the C 305 connector. google 'gm c305' to find thus and other issues that can be caused.
  • lmhall99lmhall99 Posts: 1
    In the past year I have replaced the bearings, hubs, brakes and wiring harness in my 2003 Rendevous. Now, 6 months after the new wiring harness I am driving along 2 hours after an oil change and the Service Traction Sytem lights all come on...really?!?! What else can I replace? The car? Help!
  • edgolfnut61edgolfnut61 Posts: 1
    edited August 2011
    Service traction control light on.I had the speed sensor replaced came back about 2 weeks later.GM dropped the ball on this vehicle what a piece of crap is there any way to disable the traction control and ABS system.I,m still paying for this vehicle,I bought this used in 2009.What a mistake.I will get it fixed and trade it in at either a foreign car dealership Like Honda Toyota or Nissan.GM should have recalled the bearing as well as the sensor.President Obama should have never bailed out GM,Should have let them fail for making such a bad and problematic vehicle

    Ed
  • juguejugue Posts: 2
    I am having the same problem. My dashboard is lit up like the 4th of July. The traction Control and Anti Lock lights just started a couple months ago but the grinding is terrible. Sometimes I don't think the brakes are going to work they pulsate and grind so bad. Always had the rattling noise in left side of wheel which on this forum I am finding is the bearings. This forum has helped a lot. My step mom has the same car hers is a little newer then mine and she has all the problems I do, but mine is worse. She only has like 40k miles on her car I have like 220k miles. Is Gm going to do anything about this? People on this forum are right GM should of stepped up to the plate and recalled this problem as other reputable auto makers do when there are problems. I love my Buick Rendavous and runs like a champ otherwise, but now it really makes me not want to buy another Buick if they are not going to fix problems they make. Is there any hope for having them fix this problem?
  • juguejugue Posts: 2
    Did the dealer do anything to help? I have same problem. Also another problem that is pretty scary is I always smell gas out side the car and inside the car. There was a hose leaking which was fixed and not leaking anymore so I dont know why I am always smelling gas sometimes really strong.
  • gmcustsvcgmcustsvc Posts: 4,252
    jugue,

    I apologize for the problems you are experiencing with your vehicle. Were you planning on having the vehicle diagnosed by a GM dealership? Please keep us posted.

    Thank you,
    Caron, GM Customer Service
  • Have an 03CX also, that had same problem. Bought (2) replacement harnesses at Discount Auto for $20 ea. and spliced them in past the damaged wires. Problem solved, have been using car for over a yr with more than 20K miles and it is still fine. Dealership isn't the answer, just think about the symptoms and you'll come up with logical cause like I did.
  • It's not the sensors, it's the wiring harness to the sensor on each side. Buy replacement harnesses ($20 ea) and splice them into the main harness. The harness (only two wires) runs along the lower control arm up into the engine compartment. Replacement harness usually comes with all needed parts. Just unplug original at sensor and plug in replacement. Keep removing old and installing new at each clip point on lower control arm. When you've reached the engine compartment cut old harness and electrically splice in the new arness. Wrap with good quality electrical tape and you're done. Remember to do both front wheels. Alot easier if you remove front wheel and the plastic inner wheel liner. Advance Auto Parts & Amazon sells these replacement harnesses. If you don't have a store near you (like I do), you can buy online. Part is: Dorman 970-040 ABS Sensor Harness.
  • First, I want to thank everyone who has already posted on this subject. I drive a 2004 Buick Rendezvous with about 120K miles. It has relatively new brake rotors/pads etc. within the last year. New tires within the last year. And now...in the last week we have gone from 'sliding on snow' in southern Texas to my dashboard lit with lights. I spent most of last weekend at the mechanic. They resurfaced the rotors (under warranty) and flushed the brake system. And after all was said and done, I was told that they could find nothing wrong - to come back when there were error lights. Well, three days later I have error lights! It looks like the greatest success in resolving this has been to replace the sensor wiring. Is that a good place to begin? I can't do this work myself, will a place like Goodyear/Firestone splice the harness together or will I need to find a less conventional mechanic? I'd like to fix the problem as inexpensively as possible - is GM doing anything about this problem?
  • yes replace the harness I replaced both sides and now she runs like a new car.
    Buick wanted to charge me 1000.00 to replace the hub bearing and sensor.
    Replace the harness for 32.00 for both.
    Thanks to all who wrote about this and did the work before I did.

    Shannon
  • sarahlynnsarahlynn Posts: 1
    edited March 2013
    I read on a different post that the wiring harness to the sensor is actually too short and thats why it breaks. I also read that buick made longer wiring for this and I wanted to ask you if you know if this is true and if there is a part number for this longer wiring harness that you know about. I am having the same issue with my 2004 buick rendezvous but the wirirng is broke right at the sensor
  • I am also having a problem with the ABS on my 2003 CX. I replaced on hub in Oct. 2012 and that seem to help for a while and now the problem is back. I am the original owner and only have 102000 miles. Have been thinking about getting a new Buick enclave or encore but have a little concerns. How easy is it to replace wiring harness? Is this something I could try to see if it helps with problem or should I pay someone to do it?
  • I was having the same problem with my 03 Park Ave. While replacing my brake pads I decided to check the connections and wiring to the sensors. What I found was that the righr sensor wire had come loose from the bracket and was laying on the transaxle. the transaxle had worn the insulation off the wire and caused it to to ground out. I put the wire back in the bracket and took a 100 mile drive and the lights never came on. They would usually come on as soon as I started backing out of the driveway. I would make sure that the wires are not laying on the transaxles before I took it in for service.
  • Im having the exact same issues, i have a 2003 cx and everytime i push my brakes it lights up traction active then all the lights come on including anti-lock, abs, i have to stop the car cut it off then turn it back on for it to clear off... this is the first buick i owned an i will not buy another one!! dont get me wrong i love my car but this is such a headache an i still make payments on it...but no warranty PLEASE GM DO SOMETHING about THIS!!
  • robsoilmanrobsoilman Posts: 1
    I have the same problem with the Service Traction system and ABS and Track off instrument warning messages. I also lost the light on the odometer PRNDL instrument panel a couple week earlier; likely unrelated. Anyone have any new ideas for 2002 Buick Rendezvous CX AWD? It has 248,000 miles on it and runs very well. Oh one other thing is a squeaking noise at low speed from the right front when applying the brake. This noise has been going on for several months and I am taking it in today for a complete brake job. Thanks
  • aheliasonaheliason Posts: 1
    Mine is a 2003 Rendezvous. The light comes on right after starting the car. The trans fluid is full. There is a wire to a device on the center rear transaxle housing that has been taped prior to my ownership. Could this be my culprit ? If so, how is that sensor repaired?
  • I am having the same problem with my 2004 Buick Rendezvous - just started recently. ABS light comes on, Service Traction System comes on,and Traction light comes on. I can feel a pulsation in the brakes, and get the grinding noise. This is intermittent - sometimes I get the full monte, sometimes just one light and a pulsing, sometimes also the grinding noise. One trip I can get everything, the very next trip NOTHING. My wife thinks the car is failing. I spent $100 to have someone hook it up to sensors, says it is wheel bearing (really the sensor on the wheel bearings) and want $700. I am wondering why Buick doesnt step up and fix this if it is this much of a problem.

    Considering a new vehicle - I like my Rendezvous but if I am just heading into continual repair bills its not worth it. Has anyone had this problem actually fixed and not reoccur?
  • Jimmymore103Jimmymore103 Posts: 1
    edited August 2019
    Massive thank you to the individual that listed the dorman harness. I've spent nearly 3k having a Buick dealer try and fix the abs system on my mother's Buick rendezvous. New hubs, new pads and rotors, flushed the brake fluid and new abs pump. After all that they handed my mother her keys back and said it wasnt fixable and she's better off buying a new vehicle. Ended up giving up on it and she drove around with it pulsating for a year and eventually the abs system stoped working entirely. Fast forward 8 years and for under $40 I was able to replace the faulty passenger side harness and now the abs system works flawlessly. She absolutely loves this vehicle even with the major issues i.e. gasoline leaking, abs system, engine leaking oil, and rough shifting yet it's still going strong with over 250k miles. I really wish Buick would've listed a technician service bulletin going over the issue with the harness and this would've been fixed YEARS ago.
  • Although this thread is over 10 years old, it is still relevant today. Kudos to the driver who came up with the spliced wiring harness solution. I have the same problem Antilock and AWM lights came on together. I looked at pictures of the $20 (now $30) harness, and I thought "One connector,2-18Gage wires". So why not just buy 18AWG Duplex Marine Boat Cable and splice it at BOTH ends with water-proof or submersible splices? Cheapest price I found is Pacer brand from Pacer Group website - (Minimum sale 25 feet @ $11.25 total) price of 8 splices is insignificant and available at Lowes, Menards,Home Depot,etc.
    The whole job will cost you about $15 and 30-60 minutes of your time. Re-use standoffs from old cable. Leave standoff in place and pull old cable through and thread new cable through standoff loop.
    Invest in a code scanner that also has ABS/SRS functions. I just bought an MDLINK MX+ Bluetooth unit and I can use my laptop as a monitor (Other ones are stand - alone or smart phone linked)
    I hope I helped someone save a boatload of money cutting out mechanics' fees and auto parts retail markup.
Sign In or Register to comment.