Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Windstar Electrical Problems

1246718

Comments

  • Try spraying wd40 into the door latches. I have suffered this for years and thought about shooting the dang gadget that goes ding ding ding. I heard about the wd40 trick on this board and gave it a try. I sprayed liberally into the from left and right doors including the sliding. That was probably a month ago and so far there is no more overhead lights coming on and ding ding ding. I hope this helps you.
  • Before you try to exorcise your wife, I think you should stay away from Motorcraft parts. I have had bad luck with Motocraft and now use OEM instead where available.This happened for my van and my wife's Escape. Changed my brake pads, battery, alternator, starter and more to OEM parts.
  • hi i purchased a 99 ford windstar and so far i have put at least 300.00 into repairing it. I had to fix something in the engine that the place i brought it to said it was something electrical at the front of the engine. I went to Pep Boys and they told me not to use my ciggarette lighter. There is one in the dash right below the cd player and there is one right at the foot of the passenger side front seat. Now I plug my Radar Detector into the one thats at the foot and it turns on but when i plug my GPS in instead it doesnt want to work. The one under my cd player just doesnt work at all in general. I have checked fuses and they are all good. But im wondering if there is something that I am missing. If anyone has any suggestions on how to get both ciggarette lighters working please let me know. It would be greatly appreciated.
  • First, I'm glad I read this! I'm going to fix my brake-light situation in the morning now!

    Second, my dashlights all flicker on and off, randomly. It doesn't seem to matter if it's raining or sunny, hot or cold out..

    Any ideas? It's been driving me nuts for about 3 years now..
  • whenry2whenry2 Posts: 1
    my 2003 ford windstar alway had its problems like windows not working door ajar lights, brake lights, tire lights.... then yesterday the radio stopped and the brake lights went on the windows wouldnt work then it wouldnt start when i try to start it the hazards come on the headlights flash all sorts of crazy stuff any advise?
  • I have a 2002 windstar and I am having a very similar issue. What was the resolution to your issue? Thanks in advance.
  • I have a 2001 windstar and out of the blue it would start but not go in gear

    also when the key was in, no key left in chime, no lights on chime, no brake lights, no hazard lights, no headlights

    when running - sometimes no brake lights, no fuel guage
    when shut off - the headlights would stay on and brake lights - if they worked

    dealer was great!! saved a tow by starting, turning key back 1 click, shifting to neutral, restarting in neutral, then drive

    then they found short in wiring harness directly under air filter - $100
    there was no power to fuse 11, fuse 16 and 5 on same circuit

    I had to reply because this forum sure helps when you get stumped

    good luck
  • tim4746tim4746 Posts: 2
    Thank-you in advance. Our 2000 Windstar's battery slowly drains when vehicle off. Something electrical is draing the battery. While driving sometimes the dome lights will automatically come on, the radio skips between stations and between the radio and cd player. This skipping around occurs especially after the turning signal is turned on or the power windows are used or after hitting a bump in the road. The running lights stay on at times when the vehicle is off and we have to restart and turn off the vehicle to get them to turn off. The past several months we've been disconnecting the battery whenever the vehicle is off to avoid having to jump our van each morning. (We have replaced the battery as well) Any help would be appreciated for our frustration. Our mechanic suggested we take it to a dealer. Is that our only option? Thank-you
  • pjmackpjmack Posts: 1
    HI... I am having a different problem, but read in the owners manual that fuse #6 is a pull fuse, used to save the energy of the battery if you are going to have the car sit for a long time. But, when you pull that fuse out, you have to reset your radio and entertainment system. Check online w/Ford for the owners manual, and read how to reset the system. GOOD LUCK
  • snooopy1snooopy1 Posts: 1
    i bought a used 2001 windstar sport & within a month the alternator pooched, i replaced it, if your having starting/battery issues it may be a short but in my case i found the culprit after testing the battery-tho old was still charging tho "undercharged"--Answer; brakelights remained on unbeknownsed to me tell i saw it one morning , now i lift my brakepeddle after turning off vehicle! sidenote; all weird-- none-starting noises, things not working correctly are signs of a weak or Deminished battery period "MOST" anyhow gl all :)
  • crissyhcrissyh Posts: 1
    I have a 2003 Ford Windstar. We bought it used in 2005. Shortly after we got it the window motor died. We had it replaced and it lasted about one year and now needs to be replaced again. The rear window also does not work on the same side of the van. The interior lights seem to have a mind of their own sometimes flickering on and off. The front heat stopped working this past winter(only blowing out cold air) although we still have rear heat. But I noticed today that the front air seems to be working fine but the rear air is not very cold. It almost seems like it is just blowing from the vent. And the first time I drive the van in the morning (mainly when it's colder outside) it bounces at the first red light I come to until I give it some gas.
  • fixeddailyfixeddaily Posts: 11
    Hello. I bought a 2002 Windstar SEL last summer, and everything worked except the driver window. Within two months, the heater, rear window and rear right blinker went out. Also, the check engine light is stuck on, and sometimes when idling the RPMs jump from 600 to 1500 and it almost dies on me. I managed to fix the rear right blinker. Then I had the heater checked out, and the mechanic said it could be an actuator (spelling?) or a problem on the heater box itself. He said I should be prepared to pay dearly if they rip everything apart...expensive to replace the box and many hours of labor. Any ideas on how to begin fixing all these problems? Or, has anyone else had these problems and have some advice (like sell the van..haha)? Now I believe the old joke of FORD being an acronym for Fixed Or Repaired Daily. :sick: :lemon:
  • fixeddailyfixeddaily Posts: 11
    Me again. I forgot to mention that you can hear a clicking inside the dashboard, and it may be that the door on the heater box is stuck and allows outside air only. The heat in the rear works, just not up front. Also, the A/C works up front and it blows air, just not hot, so it's not the blower motor.
  • I just fixed my heater this morning.It blew hot air only. The clicking noise under the dash is the Heater control box that regulates the temp. It is a little white box attached to the black heater housing with 3 small screws, it has one electical plug. it is located right behind the ash tray.a gear gets inside and i just got one at a salvage yard. really an easy fix. I had the same problem with electrical and it was because when I had new brake put in the Mechanic disconnected the battery and never told me. My check engine light would come on and the interior lights would flash on and off and the idle speed would go from 600 to 1500. You just have to reset.the computer. Look in you manual and it will tell you how to do it. Do it exactly as it says in the manual. I did Mine over 1 1/2 years ago and it has been fine every since I reset it. If you can,t find it in the manual post again and I will try to help.
  • gee7879gee7879 Posts: 1
    I just wanted to let you know that i just had similar issues with my 99 windstar, It ended up being a bad connection on the fuse box inside by the drivers feet, the whole wire loom connection became unattcahed to its proper socket, I advise checking all these, mine was a on the top right hand corner of the fuse box if you are looking straight at it, iI had to remove the fuse box to discover this, took about 10 minutes to take apart and fix, I have no clue how it became dislodged, but it did.
    I hope this helps best regards.
  • tomt4tomt4 Posts: 2
    I have a 2002 Windstar with 100,000 miles. Last week my car was dead but I have a new battery. The garage I took it to said that the drivers side sliding door was not disengaging the switch, that when the door was slammed hard, the battery did not go dead. They replaced the switch, claimed there was no more drain on the battery, we took it home around 5pm, next day went to start the car around 10am and the battery was dead again. Anyone having this problem?
  • tomt4tomt4 Posts: 2
    Did you ever find out what was wrong. I'm having the same problem and no one seems to be able to find the problem.
  • Can you tell me your issues? I just had the dash go completely dead, turned the car off and all the lights came on, the radio wouldn't go off and the fan stayed running. Then, when trying to re start, I didn't even get a click. Right now I am confused with the battery disconnected.
  • What ended up being your problem? I just had my dash go dead so I got out and turned the car off. Then the headlights went on, the blower wouldnt stop, and the radio would not shut off- and to top it off - the engine wont even turn over now. Please help.
  • fixeddailyfixeddaily Posts: 11
    So did you buy the whole white box from the salvage yard, or just a gear?

    Also, the guy who sold me the van didn't have the owner's manual? could you tell me how to reset the computer, or direct me to a website?

    Thanks for your help.
Sign In or Register to comment.