Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mitsubishi Eclipse Engine Problems

Hi,

I have a 2001 Eclipse. Recently, I had the car winterized and my mechanic found rust in the coolant fluid. I had this performed in January also so it seems that between January and October there has been something rusting in the car engine.
My mechanic is concerned. Note that this is a 2001 with only 52,000 miles.

Anyone seen anything similiar with their vehicle?
What was rusting in the engine?

It a month, my mechanic is going to check the fluid again.
«13

Comments

  • I have a 1997 Customized spyder with a 2.4L and I am looking for a polished stainless steel high performance header and down pipe with no success. The question is will a 2005 2.4L exhaust manifold fit the 97?
  • draga1draga1 Posts: 1
    some guys that are "technicians" pulled out one of the oxygen senasor of car but they got all bend and they screw the pipe hole treads where the sensor goes to. they told me that it might had been already damaged but i do not think so. so now i have to put the old sensor in that pipe hole so that the engine will not get to loud. and since then the thermostat has been going up to more half way. and the panel gets too hot, also. so i am wordering how i can fix it because i dont really have that much time to work on it. but eventually i will. i also wonder if the car can burn out like that. so i hope some one answers my questions as soon as possible. thanks
  • hey when i crank my 98 eclipse rs it runs like crap dont idle right, trys to die, and burns alot of gas.... it will be running fine then just dies all of a sudden...and when u try too crank it back you have too let it jus turn over a while till it cranks like its flooded or something.... i changed the tps senser and the idle air control valve and it helped none.... any ideas?
  • oldfarmer50oldfarmer50 Posts: 6,552
    "...any ideas..."

    I had an Oldsmobile that did that. Needed a new computer. $150 Don't know if that's your problem but my mechanic said the way they diagnosed it was to lightly tap the module while the engine was running. If it stalled and was hard to start back up that was the computer.

    2009 PT Cruiser, 2008 Eclipse, 1995 Mark VIII, 1988 GMC Van

  • i changed the engine in my 96 mitsubishi and now it won"t start there is no juice to any of the sensers. they tell me i have to disarm the anti theft system or it won't start can some one tell me how to do this it must be in the drivers door . because when you turn the key the security light comes on on the dash.
  • I just recently got the car and it blows out blue smoke which is obviously oil, the car has been pretty well maintained and my dad doesnt think the rings should be going at 133xxx miles, he thinks it may be that the valves need to be adjusted.
    Does anyone know anything about that?
  • oldfarmer50oldfarmer50 Posts: 6,552
    Try changing the PCV valve.

    2009 PT Cruiser, 2008 Eclipse, 1995 Mark VIII, 1988 GMC Van

  • i have a mitsubishi eclipse gsx 1992. the engine makes a very loud knocking sound and on a pressure gage the psi is only running at 95. i don't know what it should run at or wat a low count means. i have over 20 grand in this engine. 25psi of boost. bored out with bigger pistens 2.5 over. racing cams light weaght flywheel stage 3 race clutch ect ect. got ne info please let me know.
  • I have a 1995 mitsubishi eclipse RS 4 cyl. Just today it started dying when i stop at a stoplight, and i gotta push the gas pedal to start it back up. it wont hold an idle. The plugs/wires are new. any suggestions or ideas?

    thanks in advance
  • I am the original owner of a '03 Mitsubishi Eclipse GT with a little over 36K miles. I have done regular maintanence on it yet it blew a rod on the number 3 cylinder. I think there is a serious possibility that there is a manufacture's defect involved. Since when does any car with only 36,000 miles on it blow a rod??? Can anyone out there shed some light on this problem? Thanks in advance.
  • oldfarmer50oldfarmer50 Posts: 6,552
    "...Since when does any car with only 36000 miles blow a rod..."

    I had a Toyota that blew the head gasket twice at that milage. Is there any warranty left? After my Toyota blew the second time I went to the dealer who told me they would have fixed it free even though it was past warranty.

    You could try the place you got it from for a fix.

    2009 PT Cruiser, 2008 Eclipse, 1995 Mark VIII, 1988 GMC Van

  • does a 1994 or 1991 motor fit in a 1995 eclipse
  • HI,
    I am facing a problem lately with my Mits Eclipse GT 2000 with the first start up in morning. When the engine is first started up in morning, it creates a very unique sound(something like a pain in stomach of the engine). This sound is only heard when car is put into Direct gear drive. Till the car is in parking mode, the sound is not there. Also, this sound is not heard on rest of the day. It only comes when the car is cold at start and also goes off once I drive the car for 5-10 miles. I guess the problem, is only until the car gets heated up.
    Can someone putin some thoughts.?
    Thanks!
  • Help!!! I have a 1995 mitsibishi eclipse GSX turbo car. the car runs at idle but will not go over 25 M.P.H. when attempting to drive!! When I give it the gas the turbo boosts up real high & the engine just bogs down. I just had engine work done & no one knows what the problem is!! Any help or Ideas from anyone would be great!! Thanks a bunch! :confuse:
  • I had a mitsu mighty max truck with a similar problem, the catalytic converter was plugged up. Just an idea. You could undo the clamps after your down pipe or whatever the stock piece is called and try it I guess.
  • can noone help me out here?? i might have spun the bearing out but idk i dont' wana get into tearing the whole engine down n it just b a little problem with the heads or sompthing.
  • i have trouble with a code anyone with de manual knows whats the problem.

    thanks.
  • 98 eclipse convt idles great in driveway for hours drive it down the street[1mile] dies and wont restart for 1/2 hour then same issue ,full tank of gas and dry gas , 4cyl and 70000 miles just started ran great up to a week ago
  • I have a 1992 eagle talon with a 2.0L, 4 cylinder turbo mits motor and parts have been replaced on it. They were a MPI control relay and injector resistor module and they have been replaced 2x so I have been told. Now the issue is why can't I find these parts online and why do they keep breaking?

    Any ideas, please? :confuse:
  • My friend has a 1996 Eclipse and is not sure where and how to add windshield washer fluid to the resevoir. Can u advise?
  • it should be under the spare tire in the trunk and the fill should be in the drain rail where the trunk comes down on
  • broke_dadbroke_dad Posts: 10
    An old "trick" dealers use on cars that have this kind of problem is to put in a 100% synthetic oil like Syntec. That kind of oil will still burn but it will have zero blue smoke. Just an idea if you are thinking about trading the car in or just don't want the smoke. Sometimes a quart of oil every month or so is better than the huge expense of fixing the rings.
  • i have a problem with my 95 eclpise rs. its a 2.0L DOHC non turbo. when i start the car its like it hesitates and does not want to go, and sometimes even wants to back fire. but once it gets a little warmed up it will drive pretty good. and just recently i was drivin it around and it started to die almost everytime i came to a stop. sometimes it would keep runnin and sometimes it wouldnt. it does have over 180XXX miles on it, and i will be rebuilding the motor soon, but i know this is not a motor problem.
  • broke_dadbroke_dad Posts: 10
    If you are sure it's not an engine problem check the oxygen sensor on the exhaust. It can affect the fuel/air mixture especially when the engine is cold. A new one normally costs around $20 at an auto store. If you don't do the labor yourself expect to pay for an hour wherever you have it done. Hope that helps.
  • thanks, would that help with the car shutting off when im coming to a stop also?
  • broke_dadbroke_dad Posts: 10
    It was the one thing I could think of non-engine related that might account for a backfire. A backfire is the cause of incorrect air/fuel mixture or timing. Also try some injector cleaner for a couple tanks of gas. Having the injectors pressure cleaned by an auto shop would run around $110 so it's best to try that first.

    Check the condition and tension of your belts. Most modern cars have only one or two belts these days that run everything. A timing check isn't that costly. If your timing is off it can cause stalling at low rpms.

    Hope the suggestions help you find the problem and fix it for the least amount of money.

    BD
    ">
  • thanks. i will check and doo all those, hopefully this weekend if i have time! i will kepp posted though.
  • My daughter has the same car and I have gone all over it trying to find the miss and sometimes won't idle problem. Most of the time it will not throw a check engine code to find the problem. I have changed the EGR valve, Idle Air Control Valve, Vacuum hoses and spark plug wires only to still have a intermittent problem.
    At times it will idle poorly but when you hit the gas it revs up fine and if you push the pedal to the floor to pass someone it will miss very bad and then the bad idle begins. The problem appears to be electrical because at one stall time it had no spark. If you find the solution please post it.
  • broke_dadbroke_dad Posts: 10
    WOW .. you've done alot of stuff. Hasn't anyone suggested the ignition control module ? Sounds like that would be the first thing to look into with that kind of problem.

    BD
«13
Sign In or Register to comment.