Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Gauges

We just bought a used 2005 Jeep Grand Cherokee with 33,000 miles on it. We drove it before we bought it and everything was fine. On the way home, the check engine light came on. We took it to the dealer since it is still under warranty and they said the code showed it was a random misfire and that the plugs needed to be changed. I took it to another place to have them changed and they said it cleared the code. Well I drove it all day today and everything was fine but once I got home the check engine light is back on again. Any one know what might be the problem or of any TSB's for this? I am going to take it back to the mechanic for diagnosics again in the morning.
«134567

Comments

  • jophezjophez Posts: 3
    I have a 2000 cherokee limited and while I was driving the battery guage shot up to the max. My radio started flashing and everytime I turned on the heater the electrical system would seem to turn off completly then turn right back on. This all happened while I was driving. I noticed as the RPM's went higher the battery gauge would also go up. PLEASE HELP!!!
  • yerpyerp Posts: 2
    Hi all,

    Just wondering if anyone has experienced and/or resolved this issue with the WK. For the last 6 months or so, my local dealership and I have been trying to resolved why my indicator lights, along with my needles blink out and lose power for about 2-3 seconds, then all blink back 'on' then go off one by one until everything looks normal again.

    It used to do this about once every 1-2 weeks and the dealership has replaced the junction block, the front control module, the power distribution center module, and just recently replaced the entire instrument cluster. It still happens, just not as severly.

    It's something that's gotten quite frustrating, not only for me but also the dealership as I'm sure they are sick of seeing me

    Hopefully someone has found a solution?

    Thanks
  • You are not alone my friend!! My wife's 05 Jeep Laredo is doing the same thing. Any day now we are going to drive this jeep straight through the dealership window. It will be going back for the 6th time (or is it 7 times now?...I lost track!) in the last 3 months for this gauge issue. The dealership has no clue what's wrong with it. The last thing that they replaced was the entire instrument cluster also. I forget the other things that were replaced and it STILL DOES IT!

    Maybe we could share dealership names and then they can exchange info with each other to fix this for good. I'm in Niagara Falls, NY. My email address is Chade4u@hotmail.com.

    Please write to me so we can get our dealerships to fix these pieces of crap. :mad:
  • I recently bought a new-used JGC. I was on a dirt road and my service 4x4 light came on. Since then, my miles per gallon has decreased from 16.6 to 14.3. I took it in this last weekend and the dealership couldn't find anything wrong with it.
    Any ideas?
  • I was wondering if anyone out there may have had the same problem as I do? I have a 2000 JGCL and the check engine light keeps coming on I have had it back to the dealer going on 15 times and so far we have replaced the following
    Transmisson Cylinod
    02 Sensors
    Computer
    overdrive senser
    Ignition Switch
    and Valve Boby
    I have only paid for 3 of the times it was in and finally told them no more. but tonight the light came back on again so I am lost for words

    Any ideas of what it could possible be?
  • shootshoot Posts: 4
    I BOUGHT A 2005 GRAND CHEROKEE/HEMI IN APRIL OF 2005 AND THE MOMENT I DROVE IT OF THE LOT THE ENGINE LIGHT CAME ON - AND NOW THE SERVICE 4WD LIGHT COMES ON EVERY SO OFTEN - THEY REMOVED THE MANIFOLD, FLASHED THE COMPUTER SYSTEM, REPLACED THE SOLENOID - I'VE TAKEN MY JEEP IN SO MANY TIMES AND PAID FOR SO MANY RENTALS AND SERVICE CANNOT FIND THE PROBLEM - I JUST GOT OFF THE PHONE WITH THE GENERAL MANAGER OF THE DEALERSHIP AND HE PROMISED THEY WILL LOOK AT IT AGAIN AND BRING IN THE OUTSIDE EXPERTS - LET YOU KNOW WHAT HAPPENS - HOPE THEY DON'T JUST REMOVE THE LIGHT BULB :mad:
  • My brother's friend told me that JGC are always having problems with a wiring harness...If my light comes on again, I'm telling them to look at that. As he said, it's something that hasn't caused enough issues to have it recalled.
  • shootshoot Posts: 4
    I'LL MENTION THE WIRING HARNESS POSSIBLILITY TO THE SERVICE GUYS AT DAVID ELLIS JEEP AND LET YOU KNOW THE OUTCOME :)
  • Would be interested if you find an answer for this problem. Changed the battery, cleaned the battery cables, alternator is fine, not sure what the problem could be. :confuse:
  • Hey, the alternator isn't fine. Jeep's regulator is inside the alternator. The alternator will give a reading of being fine because the voltage coming from it is fine. But the amps being pushed are not fine. That is the mistake everyone is making, because they only test the alternator and forget Jeep has an interal regulator in the alternator. Once we changed the alternator haven't had any problems.

    Change the alternator and I guarantee she will purr like a kitten. :)
  • Check the alternator. It will register the voltage just fine but jeep has the regulator built into the alternator. Check the regulator connections. Guarantee you the AMP will be low. Once we changed alternators we haven't had any issues. :)
  • blkjewelz,
    Did you have the same problem that we have with the gauge cluster?

    The dealer just changed the ignition switch last week. So far it hasn't done it yet. Jeep is giving us an extended warranty for all of our troubles. That's the least they can do at this point. We did turn in the paperwork to New York's attorney general for the Lemon Law just to be on the safe side.
    :mad:
  • Ok here is the most recent update since the light came on this last time 2/15 they told me to drive it while the contact this traveling tech Guru to see if he will come out and look at my JGC. I get a call yesterday and they said he is going to look over the codes and see if he can figure it out as to why but he was leaning to having them take the remote start out out wire the vehicle back to Factory specs while they test it! Remote start installed through them by an outside guy of theres over a year ago.

    We have already had it disconnected while we drove it and the light still came on.

    I will keep you guy posted as to the outcome of my problem Maybe I will also have to mention the wiring harness and see what they say :mad:
  • Have a 96 grand cherokee and the interior lights flicker on and off and the doors lock and lock at the same time. This occurs more so when the temperature is cold. Any ideas?????
  • tidestertidester Posts: 10,109
    You may also want to check out Jeep Grand Cherokee Electrical Problems.

    tidester, host
    SUVs and Smart Shopper
  • I have a 2001 Jeep Grand Cherokee Laredo that constantly reads "Low Coolant" on the display, although there is plenty of fluid in the radiator The dashboard temperature gauge reads normal while the jeep runs idle and the cabin heats up pretty well, but the gauge quickly bottoms out once I hit normal road speed and the cabin becomes an icebox. I have to stop every 30 minutes on long road trips just to thaw out because there is no heat unless I'm sitting still at idle.
    Any ideas?
  • johnk123johnk123 Posts: 1
    My 2000 Grand Cherokee is experiencing the same problem. Has anyone a solution?

    Thanks
  • jeepny4ujeepny4u Posts: 3
    our dealer has replaced our ignition switch and it seems to have fixed it.....finally.
  • bobbyorrbobbyorr Posts: 1
    Please help !! Overhead reading lamps flash on when turn signals are engaged. Can someone help me troubleshoot? Thanks
  • haglejshaglejs Posts: 1
    I have had the same problem with my 2000 Cherokee Sport 2WD. It only has 55k miles. I have had the problem for several years and spent $thousands on it. Light usually comes on after a hot start. Neither jeep dealers nor other shops have been able to fix the problem as it usually comes back after a couple of months. Car drives perfectly otherwise. I do not want to spend any more $$ on this. My question - 1) Is there any way for me to turn the light off once it goes on? Mechanic/Jeep Dealer charges $100 just to turn it off. 2) Is it easy to disable the bulb in the dashboard and to turn it off that way? Thanks!
  • shootshoot Posts: 4
    The last time I sent my jeep in for the "engine light" I was told the light came on because they had put in the wrong type of oil. Oil? OK. So I take it in on Tuesday - they changed the oil the filter and the light has not come on for two days now. The longest ever. So maybe talk with your mechanics and make sure they are not substituing the oil.
  • tuggajbtuggajb Posts: 646
    get obd 2 reader hook up to readout plug read codes erace codes light off. cost about 70.00 bucks for reader then is yours
  • jerry50jerry50 Posts: 6
    Had same problem with mh 02 GC check engine light coming on and on and on. Dealer did the "smoke test" on the fuel system and found an o-ring at fuel inlet area had small rip, allowing smoke to escape, causing sensor to read low pressure which triggered the check engine light. hope this helps because it worked for me
  • srushiasrushia Posts: 6
    Some days no problem, other days this happens. Engine skips a beat, but otherwise runs fine, ABS & Brake light come on, speedometer pegs from end to end, odometer lights fade in & out, radio buzzes, and battery gauge fluctuates between 9-14v. This continues until I shut it off & then on. Also, sometimes when I try to start it, nothing hapens but a low clicking sound, I wait a minute & it starts fine. Battery was replaced 6 months ago. Dealer suggests it is a bad alternator, but could not guarantee it would fix it. Any suggestions?
  • tuggajbtuggajb Posts: 646
    there is a temp sencer under the bat i would remove the bat and mahe sure that the sencer is not unhooked the sencer controles how much the bat charges check this first

    if just clicks when try to start but starts right up when jumped bat is low take to auto zone they can check cargin system on car
    good luck
  • srushiasrushia Posts: 6
    Thank you, I'll check the sensor. I've also read in this forum it could be the regulator/alternator, ignition switch, or ABS module. Once I narrow it down I'll post up what fixed it. But I'm open to more suggestions.
  • isomanisoman Posts: 11
    2000 Jeep 4.7L engine. Would not start. Started after 4 tries. Drove with no problem. Next day started ok but engine light on for about 30 seconds Diagnostic code showed code for camshift sensor. Took to dealer who did complete diagnostic check and replaced camshaft sensor. Insured me that this was the problem and that car would not start if it put out a bad signal. Can someone tell if the car would not start if the sensor itself was sending a bad signal or would something that the sensor was sensing as bad have to occur.
  • Along with my overheating problems, at about the same time the "airbag" dash light came on. At first it went off and on sporadically, then just stayed on. We have not hit anything, or touched anything (that we know of). Any way to shut the annoying thing off? Should I be concerned that it's on?
«134567
Sign In or Register to comment.