Automatic Suzuki Grand Vitara Stalls when it is put into- D, R,N. Battery was disconnected for 15min

Daisy2381Daisy2381 MinnesotaMember Posts: 5
edited April 2019 in Suzuki
I disconnected my battery trying to get my cruise control to work. Now my car stalls right away when I put my automatic it stalls- Drive, Reverse, Neutral. The battery was disconnected for 15min to try to get cruise control to work on advice but now I'm having this problem. This was never an issue before. I tried to reset the computer by disconnecting the battery again for 15 min then turn the ignition to on position but not starting it I let that be for 30 secs and then shut it off for a while then started the car. it did it again. I then turned it worked some but stalled on occasion. in between, it would work then stall. the odd thing is the cruise control worked. then I shut the car off the check engine light came on the car did the stalling thing cruise stopped working. please help! I have no clue what to do. Just bought the car. A code did show up after the battery was disconnected but doesn't make sense. I looked it up doesn't really go with my problems-P0031. Any ideas? any advice? Automatic Suzuki Grand Vitara Stalls when it is put into- D, R, N. The battery was disconnected for 15min

Best Answers

Answers

  • Daisy2381Daisy2381 MinnesotaMember Posts: 5
    Ok, Thank you so much! I will definitely, take your advice. Tomorrow when it’s daylight I will give it a try. Thanks again!
  • Daisy2381Daisy2381 MinnesotaMember Posts: 5
    edited April 2019
    So I'm still having a problem with my vehicle. It did come out of it for a while. It drove fine for like a 1- 1/2 days then day 2. That morning the battery was completely dead. Nothing was left on or open. I charged the battery for almost a full day. Then went to pick up my daughter and the car died. When I put it in the park, I had to hold my foot on the accelerator and on the brake to rev the engine enough and basically sit there for 5 minutes to get the car to at least jump enough into drive. Then I had to push my foot on the accelerator and a little on the brake and never stop completely or it would stall. It ran fine all the way into town with no problems. I dropped it off at the mechanic he said that the battery life for this car is like a month even with new battery versus any other car a year. It didn't do it for him he drove it. Any ideas? I'm already $400 in and need ideas. I can't get rid of the car because I just got it. It ran fine before I disconnected the battery for 15 minutes over last week. I ordered the memory saver but not here yet. Please help!
Sign In or Register to comment.