Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Cadillac Escalade Maintenance and Repair

1356

Comments

  • My 2003 ESV has developed an issue with wildly fluctuating voltmeter readings - usually start out at 14v, but drops to 9v or below after 30-35 minutes. I've had it checked while it read 9v and all was on-spec at 13.8v. No dimming of headlights, no other symptoms, just a screwy reading on the voltmeter. Caddy dealership says they can try replacing "instrument cluster" at a hefty price. Does not appear to be battery, alternator of regulator problem. Anyone with any similar experience or advice?
  • HI,I have a 2003 Escalade, no problems until yesturday when the truck would not start. Checked the starter, checked the battery, seemed to be ok. Please email me back, to let me know what was the problem with yours.
    Thank You,
    Al
  • vajohnvajohn Posts: 8
    Hi Al,
    Sorry to hear that. I drove over 1500 miles over the holidays and the voltmeter gave all kinds of readings from normal to zero to pegged out. Only conclusion is that the meter is shot, but replacing it means the whole panel. Guess I'll ignore it. I do see some starting problems mentioned previously in this forum, but have not had any issue along that line. Hope you find your problem. happy New Year.
  • vajohnvajohn Posts: 8
    Also, car should have come with wireless headsets which can tune in the audio.
  • Has anyone experienced a whining/whistling noise from the engine at high RPMS (>3000rpm) I took it into my dealership and they said "it could be normal" For some reason I don't believe them.
  • ahoronahoron Posts: 30
    Very common on the gm products from full size vans suvs and pickups. Time for a fuel pump!
  • 2002 escalade has no park brakes, pedal goes to floor and veh. will still roll. have a 99 vette, had same problem, found rear disc brakes have park brake shoes inside of disc rotor and hav to remove rotor and caliper to adjust park brake shoes, is the escalade the same system/procedure?
  • Update- problem has expanded to the oil pressure gage as well. Non-Caddy mechanic says it is a computer programming issue. Guess I'll see what GM says.
  • paulclgpaulclg Posts: 1
    Same problem
    2003 Escalade
    All power but will not turn over
    Did you find FIX?
  • hosiefahosiefa Posts: 3
    I have a 2003 Escalade with 87,000 miles. Twice now the engine has shut down (not off but down)the message center displays that the stabilitrac system has been disengaged and the engine power has been reduced. Anyone having this same problem now or in the past. and What is the solution. Thanks
  • hosiefahosiefa Posts: 3
    I have a 03 Esc with about 87,000 miles, just couple of days ago it started showing "reduced engine power" then stability track disabled" ...the engines goes down (but still runing) but with much reduced power and some times will shut off completely. I need help, can someone give some advice
  • awf_axisawf_axis Posts: 136
    I would say the obvious thing would be to take it to the dealer so they can read the trouble codes, but I'm sure your avoiding the steep charges for service.

    You might try and borrow or buy a code reader. This would be the best way to find the problem. The thing is called an OBD II interface, which you can buy at most auto-parts stores, or on-line. Plan on spending a few hundred.

    Dave
  • hosiefahosiefa Posts: 3
    Thanks Dave for the advice. Actaully I think I have found a solution to the probelm( fingers crossed). I read on the the Yukon forum that the problem is cuased by loose or corroded ground cables. I had a guy check all the ground cables and since then (24hrs now) no sign of the same problem. Before the cables where check I can not drive for more than 10 to 20 mins before the msg comes on. Hope it never comes back.
  • nvbankernvbanker Posts: 7,285
    It didn't come with an owners maual because we bought it privately.

    I have an extra owner's manual for an 04, that I'd be happy to give you. E-mail me with your address, and I'll ship it to you.
  • texsal94texsal94 Posts: 3
    I have an '02 Escalade as well, and it started having a "whining" noise about 3-4 years ago. I replaced the Power Steering fluid, but that has not helped. My co-worker has an '02 Tahoe and my Dad has an '05 Avalanche and they both have the same noise. The dealership claims everything is functioning normally and there's no discernible cause. I wish I had a suggestion, but I just opt to turn up the radio/music to drown it out.
  • texsal94texsal94 Posts: 3
    I have an '02 Escalade and I experience the same thing. It only happens intermittently, but I agree with the feeling...it feels like it transmission has "slipped" and takes a few seconds to "catch". Of course, the dealership "could not replicate the problem". It hasn't happened in awhile, but it does happen more frequently when I drive on the highway for a long time and have to come to a full stop.
  • texsal94texsal94 Posts: 3
    I have an '02 Escalade with 110k miles. This problem started, however, back when I only had 50k miles (and under warranty). After stopping, I accelerate and hear a very LOUD "flapping" or "ratcheting" sound from the engine/transmission. It sounds like the flapping noise from a diesel semi-truck. I have brought it in at least 6-8 TIMES to the dealership. Everytime I get it back, they claim they "could not replicate the problem". I feel like they did hear it, but was a major problem they didn't want to deal with since it was still under warranty. Now, I'm left with the same embarrassing problem and no warranty. Anyone have any suggestions? BTW, I owned a 1988 Oldsmobile Cutlass Calais that made the SAME noise..it was transmission-related.
  • nvbankernvbanker Posts: 7,285
    It's probably a CV joint somewhere, going out. I have found the best way to get a mechanic to "replicate" the problem, is to make them take a drive with me and demonstrate it. Once they admit they hear it, they seem to be able to deal with it. Sometimes, I take the Service Manager with me..... It sure helps.
  • mil6753mil6753 Posts: 61
    Is there a free website where you can see Escalade TSB's?
  • jdodrilljdodrill Posts: 1
    I have a 1999 Cadillac Escalade with DTC Error Code P0452. This is described as Evaporative Emission System Pressure Sensor/Switch Low Input. How do I "fix" the problem. I recently had the fuel pump replaced, before the "check engine" light came on. On a recent trip when I opened the gas cap to fill, it appeared to be under a vacuum. I saw where someone recommended to replace the gas cap, what other items should I check and how?
  • steverstever Posts: 52,462
    The Edmunds Maintenance Guide has summary TSB info (sometimes the NHTSA has full text, but not too often).

    If you find one in the summary list you want to read, sometimes the service writers will copy them for you to take home.
  • bfanbfan Posts: 3
    Just bought 05 ext which has about 1000k left on original gm warranty. Has anyone had problems that are common on any 05's that I should look for. Rides real nice on michelin LX tires so far only foglamps allowing water in.
  • MY VEHICLE HAS HAD THE SAME CLUNK TYPE NOISE.EXCEPT NOW I ALSO HAVE A NOISE THAT SOUNDS LIKE A WHISTLING OR RATHER A ROARING/HUMMING NOISE THAT I HAVE HEARD FOR ABOUT 3 MONTHS.NOW MY SERVICE STABILITY LIGHT,ABS LIGHT AND TRACTION CONTROL LUGHT ARE ON AND IT FEELS LIKE MY BREAKS LOCK UP EVERY TIME I DRIVE IT. NEEDELESS TO SAY IT IS PARKED .HAS ANYONE HAD THIS PROBLEM AND IF SO PLEASE TELL A LADY WHO FEELS LOST WITHOUT HER ESCALADE WHAT TO DO.ESPECIALLY SINCE MY HATING [non-permissible content removed] HUSBAND WONT.
  • YES I HAVE THE SAME NOISE IT IS LIKE A HUMMING/WHISTLING NOISE .NOT QUITE SURE WHERE IT IS COMING FROM.BUT NOW MY SERVICE STABILITY LIGHT IS ON, AS WELL AS THE TRACTION CONTROL LIGHT AND THE ABS LIGHT AND WHEN I DRIVE MY BREAKS LOCK UP OR AT LEAST IT FEELS LIKE I AM PRESSING THE BREAKS WHEN I AM NOT,I AM ACYUALLY TRYING TO ACCELERATE
  • WHAT I THOUGHT I WAS EXPERIENCING WAS MY BRAKES LOCKING UP. I HAD THE SAME WHISTLING/HUMMING NOISE FOR A COUPLE OF MONTHS.THEN ONE DAY MY SERVICE STABILITY LIGHT , ABS LIGHT AND MY TRACTION CONTROL LIGHT CAME ON AND EVERYTIME I TRIED TO EXCELLERATE IT FELT AS THOUGH MY BRAKES WOULD LOCK UP.
  • Thet forgot to tell me that the truck bed cover panels are NOT watertight. Water gets inside whenever I wash it. Cadillac says this is how it's designed and that if stuff in the truck bed gets wet, tough. Amazing. BE WARNED
  • I have an early 2007 escalade and had to recently get new key fobs. When they were re-programmed the flash to pass would not work during the day when the headlight switch was set to off or auto. Cadillac says that the new ones are like this and that is the way it should have been. I know of no other cars that operate like this
  • awf_axisawf_axis Posts: 136
    This was necessary because of the nature of HID headlights. Rather than use a halogen high-beam, the system retracts a shutter over the lens of the low beam pattern.

    Since HID's take a few seconds to ignite and come to full brightness, it isn't feasible. Secondly, repeated ignition shortens the bulb's life quickly. You don't want to be changing these bulbs out much.. $$$.

    I believe that BMW solved this problem by keeping the HID's lit all the time (angel eyes), and the flash-to-pass feature is simply the shutter opening and closing.

    Dave
  • Thanks for your message. The flash to pass worked fine with the switch in the auto position during the day for the first year we had the vehicle. It only changed after they reprogrammed the new key fobs. It also worked properly on the 2003 and 2004 Escalade with bi xenon lights.
  • Hey guys im new to this board. I was having a low beam light issue. it used to come on some times but now not at all. i put in new bulbs but still does not work...HELP!! I have to drive with the high beams on. Im thinking it couldnt be the sensor because the lights dim on the radio and console . i have a 2002 ext . Also can any one tell me where the fuel filter is located. thx...last but not least i started my truck by remote before but cant seem to do it again . it is a factory alarm and i got it by luck a few times ...Pls help thx
  • Hey I have a 2000 cadillac escalade and it does the same thing. Did you happen to fix yours already. I hit the gas and it doesn't move i even changed the catalytic converters thinking it was clogged. Can anyone help me?
  • My 2000 escalade is acting up. I press the accelerator and the damn thing does not move. I changed the plugs, cables, filters, and anything you name i have changed. I even changed the catalytic converters. Can anyone help me?
  • My wife drives a 2002 5.3L 2WD Escalade and mine is a 2005 6.0L AWD Escalade ESV Platinum. Both vehicles have been great but they have a common cosmetic problem. All four headlight assemblies have a hazy buildup inside the lenses. Anyone have a "cleaning" method?
  • We are thinking about buying FULLY loaded (22" Chrome) 2008 ESV for $63K with an MSRP at $71,000 in Houston area. Is that a better price? Would greatly appreciate if anyone can share their experience of ESV for 2007 and/or 2008 model(s).
    Thanks. :)
    Highpoint7
  • I am having the same problems you had, service stability light/traction control light staying on. Dealer states they can't diagnose because of the accessories i.e. tv/auto start, although I have had them installed since 2003 w/no problems! Can you tell me what you did to fix your problem, don't want to have to pull everything out for them to figure it out :mad: ?....thanks!
  • I am setting my 2000 Escalade to tow behind my RV and I am having a problem with the aftermarket brake controller (Roadmaster EvenBrake) the transmitter has to be connected to the cold side of the brake light switch which in the Escalade is almost impossible to access, I was wondering if anyone new which wires under the dash come from that switch that activates the brake lights or another way other than running a wire from the rear bulb to the drivers area. Thank you for any help you may render
  • owned car 6 months runs great for 2or 3 weeks then it will start missing or even die while going down road no lights come on. Had grounds under hood checked plus changed fuel filter. Looking for a bad ground am I on the right track
  • I just recently noticed that if I put my foot into it from a stop or slight roll the vehicle feels like a Drag Boat launching out of the water, the steering wheel turns back and forth and the vehicle just feels "squirly" any sugestions.
  • I experienced the same symptoms with a Nissan Armada. My home dealer tried everything (almost) but did not fix. I took it to another dealer who changed the fuel pump....problem solved.
  • some times when the vehicle goes over a bump or while turning the instrument gauges and stability codes and alarms go off and if I tap on the steering column or under the dash it will reset. has any one had this problem?
  • I have only heard of this problem with the
    Escalade and not from other luxury lines...I realize that no car/suv is perfect but for 60k and up GM needs to come through for it's buyers. I wanted an 08 Escalade, but the more I research the more afraid I am to get one.
  • it sounds like that car was in an accident prior to you buying it, you should have done a vin # background check on that car.
  • For one the Xenon lamps from GM are superb and I'm shocked. You should have never have asked them to adjust them. GM uses good HID, they are very bright and if people flash you...flash them back.When they see your highbeams come on then they will know that your lights are just bright like all 07 Escalades are.
  • That is right, other people will have to deal with the lights.
  • Is the whole truck shaking or just the mirrors? Because I know that there is a mirror issue that they are addrssing rigght now.
  • Does anyone know the correct tire pressure to use? The are after market so the info in the door does not help. Also, Pirelli Tire Manufacturer could not tell me. They told me there were too many variables to advise me. What other info could I have given them other that an 2007 Escalate with 22" aftermarket Perille Scorpion's on it?
  • hey guys im new to the escalade scene. my question is for all of you who have escalades when if at all did you start having problems mileage wise 100,000? 150,000? and also how long do these run efficiently? thanks
  • vajohnvajohn Posts: 8
    85,000 on my 2003. Replaced the instrument gage cluster a while back and the radio und er warranty (cosmetics on the knob. Yes they switched out the entire radio due to a paint defect on the knob). No real issues with the power train. My mechanic says these should run 200,000 easy.
  • I have a 2003 at 145,000 still runs like a dream, only the radio sometimes won't come on, the seat heater on the driver side doesn't soon work and also some cosmetic things like the lettering on the cd player, radio and controls on the door panels
    oh and there sounds like more air coming from the sunroof when closed
    I'm am very pleased with it and will trade for an 08' very soon :)
  • bfanbfan Posts: 3
    I have a 2005 escalade ext and have had problems with fog light lenses leaking water and have had drivers exterior mirrror replaced when the motor began skipping when it was closing, GM fixed it free of charge but fog lights fixed twice now out of warranty and I have to pay $150 to put in new fog light. Have 102K on truck. Lovin it still.
Sign In or Register to comment.