Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

How has COVID-19 impacted your car shopping? Click here to help us help drivers like you with a 5-min questionnaire.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Hyundai Santa Fe Climate Control Questions and Problems

econn1econn1 Posts: 2
I just had my 2003 Santa Fe serviced and the climate control got set to Celsius. I looked in the manual and I only have information for the manual controls, not the automatic. Cna anybody tell me how to set it to Fahrenheit? Thanks.
«13

Comments

  • ejdiffejdiff Posts: 2
    My 2005 sante fe it seems the condensation from the a/c is not draining. I can hear water that has collected when making sharp turns and it drips by our feet in both the driver and passenger seats. anyone experience the same problem? is there a simple solution?
  • ommfommf Posts: 1
    This past month I had to replace my a/c compressor on the 2002 Santa Fe. Within a week the same part broke down and had it replaced. The service manager said it was a fluke that the same part would break down. My question, any other santa fe owners having the same problem. also is there a recall on this part
  • ON MONDAY, 9/11, I WILL BE TAKING MY 2003 SANTA FE TO THE DEALER FOR THE 4TH TIME IN 2 1/2 MONTHS WITH AIR PROBLEMS. THE FIRST 2 TIMES, THE EVAPORATOR HAD TO BE REPLACED. THE LAST TIME IT WAS A LEAK DUE TO THE "o" RING IN SOME VALVE. ANYONE ELSE HAVING ON-GOING PROBLEMS WITH THE AIR CONDITIONING?
  • ON FRIDAY, 9/25 MY 2003 SANTA FE IS HEADED TO THE DEALER FOR THE 5TH TIME FOR THE A/C! ON THE 4TH VISIT, THEY REPLACED A HOSE ASSEMBLY. YESTERDAY IT COOLED OFF, BUT NOT AS COLD AS IT SHOULD BE, ONLY AFTER I WAS ON THE HIGHWAY. BEFORE THAT, IN CITY TRAFFIC, IT WAS BARELY EVEN COOL. I'M FRUSTRATED, AND EVEN THO I LEFT A MESSAGE FOR THE SERVICE MANAGER EARLY IN THE AFTERNOON TODAY, HE DID NOT CALL BACK. WONDER WHY? WELL, I'M SURE I WILL TALK TO HIM TOMORROW. ANY INPUT?
  • tidestertidester Posts: 10,059
    I recommend turning off your CAPS LOCK. People tend to ignore messages typed in ALL CAPS.

    tidester, host
  • iluvmysephia1iluvmysephia1 Alamogordo, NMPosts: 7,615
    I haven't seen an all caps message for a while. That is nasty!

    Please type in a mixture of lower and upper case(mixed case for lack of a better term)so we all can have a fighting chance of reading your message.

    2011 Kia Soul Sport 5-speed

  • My 2001 cools when I'm on the road but it blows warm air when I stop in traffic. It goes to cool again when I resume highway driving. It has been to 2 dealers and they cannot find a problem. My warrantee is about to run out. Any suggestions
  • Sorry, Tidester, thanks for the recommendation. I had no intention of being loud or offensive, was just easier to type all caps. After testing at the dealership today, freon was determined to be low, so it was maxed out and a dye was put in, too. I have to take it back next Wednesday and hopefully, they will find the leak, solve the problem and relieve my frustration.
  • Sounds similar to my problem, but not the same. Each time, the problem started with cooling to be insufficient, maybe on the way home from work. The next morning would not be bad because I leave home about 6 AM and the outside air was relatively cool. But, if I drove for lunch, or on the way home, cooling stopped altogether. Sorry, I don't know what to suggest. Don't stop trying to find the answer. Maybe someone can help before your warranty runs out. Will post to let you know what the outcome of mine is on Wednesday. Good luck!
  • tidestertidester Posts: 10,059
    they will find the leak, solve the problem and relieve my frustration.

    Good luck! I hope it works. Be sure to report back here when you find out.

    tidester, host
  • Hey, I just got finished working on my 02. The AC says it was on, but was not sending 12v to engage the clutch. Freon levels were good, a little low, but not low enough to trigger the low preasure shut off. After some investigation I found that the AC relay was not engaging. There was power to the relay and voltage on the main bus, but the relay was worn out. A $3 replacement from the parts house and we have AC again.
  • Hopefully my Santa Fe has been to the dealership for the last time with the air conditioning issue! It's my understanding, that it has been determined that the evaporator used originally in the Santa Fe has had a number of failures, and a different brand has been installed. It was still working on Thursday (last time it was driven), 8 days after being in the shop. Will let you know if this new evaporator doesn't hold up.
  • We have had nothing AC problems with our 2002 Sante Fe. Infact it is at the dealer right now and they continue to "troubleshoot." I am happy I bought the extended warranty. The problem always starts the same...it starts making a howling noise and within days starts blowing hot hair. They have replaced the evaporator twice and several hoses. After reading some of the prior posts, I wonder if they replaced the evaporator(s) with one of the older brands. Thank you for the posts as it will assist me with dealing the company.
  • I thought that Hyundai changed the AC system in 2002?
    I have a 2001 LX and the AC is barely adequate at best. I had it go south on me twice in all this time and each time my dealer has replaced what was needed and at no charge to me. Well we go in once more this Friday and from the sounds of it the compressor is going bad. Nasty sounds and it all started with a loud hiss and then warm air.
    I have an extended Hyundai warrantee which expires this coming January. I cannot say enough good things about the service I get from my Hyundai dealer in Cocoa Florida.
    Next year we will be replacing our 2001 with a 2008.
    Have to pay off my new Chevy HHR first.

    Best,
    Rich R
  • I have 2002 Sante Fe with the exact same issue. If I stop or idle the AC blows hot. Then a couple of miles down the road it works again. I have already taken it in and was told a hose was leaking. This was replaced and the problem is still happening. I have not made any headway on this but I will let you know if I do.
  • somedai1somedai1 Posts: 416
    if it only gets hot at idle or stop - it may be a problem with the fan - does this car have 2 cooling fans?
  • sanibelsanibel Posts: 9
    I just had my 2003 Santa Fe in the shop for the 10th time week before last with the air problem again. All weekend the air didn't work. I took it to the dealership Monday afternoon (they provided a rental-wow!). They drove it Tuesday and left in running idle in the shop for over half an hour and said there was nothing wrong with it - it worked just fine. I'm in Florida and I definitely know when my air is working and when it isn't. They said they did nothing to it. If that's true, then it repaired itself! Well, I've had it back for over a week and it's fine now. My concern now is how all the times it has been in shop is going to affect trade-in value or my trying to sell it, especially since car fax reports are available showing the problems I've had. Will keep you posted.
  • bj02176bj02176 Posts: 115
    2007 2.7 awd, ac is not that great, but okay, have to say it's one of less cooling units that I have had
    Not as good as a Fusion or Escape
    Not as good as a Honda Accord.
    Not as good as a Forester
    Not as good as a Camry
  • nifty56nifty56 Posts: 279
    Weak A/C seems to a common problem with most new vehicles. I have a 2005 Mazda 3 with weak A/C. On the highway it is great, but stop and go it sucks especially after the car has been sitting in the sun for a long time, interior heat soaked. With the Mazda it has something to do with the Compressor not cycling often enough and long enough. With short cycling you can feel the air from the vents go from cold to warm. It cycles on for 15 seconds and off for 45 seconds. Mazdas specs is a vent temp of 51F, anything over that then there is a problem. Now tell me if that temp is cold enough to cool down a car? Mazda set the bar high because they know the A/C sucks. When having the A/C checked by the dealer ask them for a vent temp reading or you can do it yourself by buying a digital thermometer from Wal Mart. At a Mazda3 forum there is a poll and 75% of owners think there A/C sucks. There is a mod on the forum which makes the compressor stay on longer in turn creating cooler air longer. My next vehicle will be tested on a hot, humid sunny day to test the A/Cs ability to cool the interior. Not cold no buy....just a note Mazda and maybe other manufactures set the compressor to cycle short to give better gas mileage to meet their miles per gallon requirements.
  • gizzer777gizzer777 Posts: 335
    While not as good as most vehicle's I have owned , the AC in my 3,3 Santa Fe SE is adequate...been in the mid 90's and it is comfortable (we only have 19% humidity which could be a factor)...Good thing the fan is quiet since I have to run it a little higher than my other autos.
  • mpuzachmpuzach Posts: 635
    I've driven long distances in temps over 100 degrees in my 2007 Limited (3.3 liter) and the A/C has performed very well.
  • somedai1somedai1 Posts: 416
    yeah- to me it seems the a/c is ok - maybe the dual climate function is not top of the line but as far as keeping it comfortable when it's hot - i set it to my preffered temperature and put it on auto and have no worries!
  • bloodclawbloodclaw Posts: 8
    I have had no problems , I live in New Mexico 98' to 100' 10% humidity. after a few minutes I have to turn down the fan speed , it get to cold.
  • I've had my SF Limited for 2 weeks now and am confused by how the 2-zone AC controls switch back and forth.
    I've read the manual several times and it should be as simple as turning off the Auto AC button. Then the air coming out the vents should be fresh air.
    Well, actually if you are in AC mode and you turn it off, everything is off, even the fan. Then I touch the fan speed button, the fan comes on but AC (cold air)comes out the vents. I also hear the compressor cycle.
    I've gotten the system to work right just once. The screen showed the two temperatures that moved simultaneously, which vents were being used, and the fan speed. Then it got warmer outside and AC was needed, and switched over to Auto. A little later in the same ride is when I realized I couldn't go back to just outside air.

    Anyone else have this kind of difficulty??
  • nifty56nifty56 Posts: 279
    Glad to hear the A/C is ok for most drivers, will wait till the temps and humidity here gets a lot higher to check it out..
  • jcwsbltdjcwsbltd Posts: 167
    I've had similar problems trying to figure out the different configurations. I can see how the mode button works to operate the face vents,floor vents,defog windshield - I think with dual control ("Auto" off) you have to have the A/C button on as well, then set the temps. for each side.

    I've turned Auto off and the fans blow but no A/C seems to be on, unless I push the A/C button in and it lights up. Everything stops(fans, A/C) if I push "Off".

    I also noticed that the fan speeds are much higher with "auto" setting with the recirc. on than regular dual or A/C mode. It must have a booster for the fan in "Auto" recirc. mode.

    I posted elsewhere asking if anyone else experienced a lag of about 8 seconds or so, when first starting up with the Auto Climate control on. I noticed it doesn't start blowing immediately, even though the engine is running - does yours do that too?.
  • lv2drvlv2drv Posts: 132
    My problem with this system is that if it's about 60 degrees out, and I don't want anything on, their is still a cool breeze coming out of the vents. I realize this is the fan blowing the cool fresh air, but it's too cold. If I push the "off" button, nothing happens. The fan still runs. I also looked in the manual and could find nothing that would help me.
  • mpuzachmpuzach Posts: 635
    I can't tell from your post exactly what you're trying to do. Here are a few tips:

    When you select "Auto", the system will automatically control temperature (whether heating or cooling is needed), fan speed, fresh air intake vs. recirculation, and choice of output vents.

    If you just want fresh air (without A/C), turn off the A/C button and manually select a fan speed and choice of vents (using "Mode" buttons).

    If you want A/C but want to choose your own fan speed and/or output vents, just make sure the A/C button is on and manually adjust the fan "<" and ">" buttons and "Mode" buttons to your liking.

    That's pretty much it. If the system is in the "Auto" mode, it will come out of "Auto" the moment you adjust fan speed or mode or the moment you turn off A/C.
  • mpuzachmpuzach Posts: 635
    What if you just turn up the temperature setting?
  • dougmickdougmick Posts: 1
    Hi,

    I've been a long-time reader of this forum....very helpful!!
    This is my first post.

    I concur that the A/C system is pretty simple & agree with your summary. What bothers me, in AUTO mode only, is that (at least on my '07) the A/C button never lights up, even when I know that the A/C is running. The button will light up when I take the system out of AUTO.

    Is this how it is designed or do I have a problem?
  • mpuzachmpuzach Posts: 635
    I just checked mine and it works the same way yours does. I suppose in a way it makes sense since under certain conditions (e.g. when it's cold outside) the unit will be heating rather than cooling when in the AUTO mode. Regardless, it looks like they're functioning normally.
  • jcwsbltdjcwsbltd Posts: 167
    Do you also have a lag time between starting the engine and the Auto A/C coming on fully, or does yours come on immedately? It may sound like a dumb question, but I don't have anything with which to compare normal functioning ! mine seems to come on gradually to full speed.

    I also agree about the A/C switch not lighting up in "Auto" mode, but you can feel the cold air OK.

    There is also no way of knowing whether the cabin is reaching the set temperature, either. I will try with a separate thermometer and see if it is accurate.
  • rick2456rick2456 Posts: 320
    That is unusual. I live in Atlanta and am hot natured, but the AC puts out great. One of the best features in my opinion. Far better than my Freestyle and as good as my GMC Envoy did.
  • rick2456rick2456 Posts: 320
    That is why I didn't get the limited model SF. The climate control AC is a royal pain in the butt. Trying to get the AC to put out cold air buy adjusting the temperature setting is redundant to me. I prefer the simple manual color coded adjustment. You just dial what you want instead of trying to adjust the temperature selector to get the system to put out what you want. Climate control (via selecting the temp) is a major step back in my opinion. Though, I do admit having seperate controls (manual) for the passenger and driver is nice.
  • davesuvdavesuv Posts: 149
    I can see everyone has their own likes and dislikes about climate control systems. I really like the climate control in my Limited. I can set the temperature and forget it. It does a wonderful job of keeping the vehicle (at least my half of the vehicle - my wife usually keeps her side cooler) at that temperature.

    I also experience a short delay before the system comes on when starting up. It almost seems like the system is doing a check of outside and inside temperatures before blowing inside the car. I also notice that the front windshield vents will blow for a short while after starting up. This is very helpful in colder weather. This is the best climate control system I've ever owned.

    2007 Santa Fe AWD Limited with Premium and Touring packages
    Dark Cherry Red with beige leather interior
  • I think I'm being fed alot of b.s. at the moment. I bought a 2003 Sante Fe 4wd on 9/25/06. The milage was 42,500. The truck is still under warranty until 60k miles (has 55,200k). However, this is the first time I have gotten to use my A/C and it doesn't work!

    I was told by the service shop @ the dealership, "it appears you had leaves and other natural debris stuck in between the A/C condensor. The leaves have now rotted and caused a hole in the A/C condensor. This is not covered under the warranty because this is due to leaves not manufacter defect. Repair comes to $850."

    My question is: I have only had this vehicle a short while, it stays in a carport, I don't go running off street with the truck. Are you telling me after the dealer did all the inspections on it prior to selling it to me, that leaves came in between my A/C, rotted within 8mths and it's my fault? I believe this is manufacter defect & not my fault. Any takers on this problem??
  • mpuzachmpuzach Posts: 635
    To rick2456 - I've gotta disagree with you on this. What could be easier than dialing in the temperature that you want to maintain? I just set mine at 70 degrees and leave it alone. It's no different than what we do at home.
  • mpuzachmpuzach Posts: 635
    Have the dealer show you the leaves. (I'm betting that they can't. In that case, how do they justify their comments?) If that doesn't work, try another dealer.
  • thanks for everyones input to their trial&error. It has helped and I think I've got it.
    If it's in Auto mode you get it's light. But turning the whole system off and then touching the fan >> button seems to start the ac. But neither Auto or AC buttons are lit.

    I think turning off the Auto, then making sure the AC button is off by cycling it seems to get me to just fresh air.

    Isn't just leaving the Auto on all the time running the compressor all the time? Even if it's 70 outside and the cabin is set for 75, the sensors are going to see that if the cabin goes to 77, the AC will be turned on to try to correct it? Same for heating....won't the compressor go into reverse-cycle mode?
    I'm not nitpicking. This is my first Auto climate control vehicle. There's a lot to figuring out what all the new toys are doing!!
  • pelican19pelican19 Posts: 323
    The AC button is for continuous duty. It will only come on in auto mode when you select Lo as your temp. setting.(Below 63 degrees)
  • I don't know if my automatic climate control is acting up or not. On several occasions now I have been driving down the road with the windows open and the climate control system shut off when I suddenly notice cold air coming out of the vents. It seems the automatic climate control is a bit more automatic than I would expect and is turning itself on??? Am I missing something? Anyone else seeing this. This is after its been at the dealership twice for a total of three weeks to repair the air conditioning (a coolant leak they had trouble finding). I don't know if this was doing this before since the air didn't work.

    On separate notes, my map lights have been upgraded, finally.

    But, as someone who actually takes advantage of a lot of mp3 music on CDs, I'm not real satisfied with Hyundai's single disc base cd/mp3 player (pre-xm). Mp3 sound quality on this unit is drastically degraded. I've had it replaced by the dealership once because of the levels of distortion coming out of the unit... still the same problem. I've even tried different recording techniques offered by users of these forums... still the same problem. It appears to be a problem isolated to this specific type of unit as other hyundai mp3 players work fine. But the other Santa Fe's on the lot with this particular unit all had the same problem.

    The dealership has thrown up its hands and said that since the Hyundai Corporation has not yet identified a problem with this unit, there's nothing that can be done.

    Needless to say... I'm not pleased.

    07 Santa Fe Limited
  • One other gripe about the audio issue... I asked the dealership if I could pay the difference and upgrade to the newer, base xm version of the same player. The loaner I was using while the air was being fixed had this unit and it worked great with mp3's. The dealership told me that this could not be done because the newer version has an external amp while the one I have has an internal amp? Anybody know if this is actually the case or am I getting the run-around?
  • pelican19pelican19 Posts: 323
    Look under your front passenger seat. Your getting the run around...
  • gizzer777gizzer777 Posts: 335
    I also have the XM base radio...ask the dealer to show it to you (the supposed amp)! I believe it is the infiniti that has external amps (infinity is in the LTD SF...therin probably lies the issue since the base unit sounds just fine! Still want the jack though for my GPS, which also plays MP3 from an SD card...(Nuvi 350).

    I do not take long trips so the XM is a waste for me. They just keep on sending me reminders...I hate recurring revenue models anyway!

    On the auto climate control issue. I had it in another car and will not ever buy another with it. I find just setting a comfortable spot on the temp and fan dials just fine. I am a computer consultant so this will sound strange. TOO many computers in cars these days...too much to go wrong!
  • somedai1somedai1 Posts: 416
    yeah - the a/c function is kind of dumb- it is fairly automatic when you set the temp to what you want with the dials
  • rick2456rick2456 Posts: 320
    The idiotic climate control was the main reason I didn't get the Limited. To me, this is a step backward in technology.
  • kdahlquistkdahlquist Posts: 130
    Different strokes for different folks. I love auto climate control. I had a 96 Mercury Sable with auto climate Control, and later a 2002 Yukon Denali with auto climate control. Then my wife got the Denali and I started driving a Pontiac Vibe that had standard manual heat/AC controls. I hated it. I was always fiddling with the controls on the Vibe, turning the temp and fan up or down. Auto climate control works like the thermostat in your home -- just set a temp that's comfortable and forget. The system turns the heat and/or AC on and off and adjusts the fan periodically to maintain the temp. When I went shopping for a vehicle to replace the Vibe, auto climate control was on my "must have" list, so I opted for the Santa Fe Limited, and I'm very pleased with it. The system works perfectly in my Limited.
  • mpuzachmpuzach Posts: 635
    "Idiotic"? Hmmmm......I certainly don't share your opinion. It took me about 2 minutes with the owner's manual to fully understand my Limited's climate controls. The system works very well and the controls make perfect sense to me.
  • gizzer777gizzer777 Posts: 335
    I agree, They are not idiotic...Also agree that different strokes for different folks. Personally I chose the GS without the auto climate since I did not like it before in a different vehicle (If I could have gotten the GLS with a 3.3L V6 -no timing belt) that would have been my choice.. Auto climate control is very simple to operate as well! I did want the heated seats but my dealer did not have the vehicle with the exact items I wanted so I compromised...Packaging accessories does not do the consumer any favors but makes the auto companies more $$...oh well, we saved a bunch with the SF over the other competitors...I am still quite happy with the vehicle and the dealer!

    What I do not like is the xtra $$ it will take to repair the electronics when the warranty is over and if it breaks!

    WHAT I DO LIKE ARE THE FAN CONTROLS and vents (and placement On the Pillar too!) FOR THE 3RD ROW SEATING THAT HELPS CIRCULATE THE AIR IN OUR DESERT 100 DEGREE DAYS in NEVADA. The SF's have a substantial cabin!

    When it gets that hot...the auto system goes to high or the manual system is set by the driver to high! ONE nice feature I miss is the different temps for the driver and passenger...I personally like that idea
Sign In or Register to comment.