Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Are you considering a vehicle subscription service or did you previously consider one and decide against it? If so, a reporter would like to talk to you. Please reach out to [email protected] by 10/30 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Kia Sportage battery and electrical Problems

mlgarbinskymlgarbinsky Posts: 3
edited June 2015 in Kia
i have a 99 kia sportage. my problem is sometimes when i go to start my car i turn the key and it goes to start a little then the whole battery goes completely dead! its a new battery. and we have done battery/alternator tests i don't know whats the matter any help would be appreciated.

Comments

  • Hello mlgarbinsky,

    Interesting. This just happened to me today! I have a 99 as well just getting ready to turn 100K. I turned the key and nothing happened. I turned it again and it started. I drove about 5 miles then the engine light came on so I came home and parked it. I turned the key a few minutes later and it would not start and will not start. All dash lights are on however the starter will not engage and I hear no click. Battery is fine. I am going to check the starter later if the weather improves. I need help too:~(. Thank you in advance.

    JKstorm
  • Problem solved. I tested the wire that engages the starter solenoid which is built into the starter. This wire has a simple push in connector. I put a 12 volt test light on it and the light glowed when I turned the key. I cleaned the contact on the starter with fine sand paper and cleaned both the push in connector as well as the contact on the starter with contact cleaner and have not had a problem since. In my opinion this connector should have been designed a little more weather proof since it is low on the engine and un-protected.

    JKstorm
  • orzechtorzecht Posts: 1
    I have a 2000 sportage Kia and recently changed the battery. Now the alarm goes off when I open it and does not go off when I put the key in the ignition. Is there a relay or reset procedure that I can do to silence the alarm?
  • kia6kia6 Posts: 1
    The radio does not get electrical power. Where and what should I be looking for to fix the problem? The fuse is good in the fuse box. Is there a reset breaker some where for the radio? Any help to fix the problem would be appreciated.
  • lmp4lmp4 Posts: 188
    ... the alarm goes off when I open it and does not go off when I put the key in the ignition..
    ..I guess that means the alarm starts sounding when opening a door and keeps sounding even when the key is inserted in the ignition...Is your car equipped with a remote door lock? That complaint comes rather frequently but I do not remember someone coming with his solution once found out; ...
    check with www.kiatechinfo.com and look for information about ETAC module..however I did not find a reset procedure..
    anyway come back with your solution once the problem is resolved...
  • sensor
  • sensors on wrecked kia
  • hey i have the same problem with power to the whole dash. did you find out what was wrong
  • Hi,

    my KIA Sportage 4X4, build 2000 has an issue with the alarm system. The alarm goes on after having locked the car which can be instantly or after some time. Any thought how to fix it or at least disable the system because right now I cannot lock my car because it bothers everybody.

    Thx

    Frank
  • arifiarifi Posts: 1
    i have KIA CLARUS 2000 SLX. i have a lot of problem even there trained technicians are unable to solve.
    when i am starting it will start with huge sound and the niddle will be at around 2.
    the spares parts are not available we have to search too much even with their appointed dealers...
  • gallego8gallego8 Posts: 1
    HI maybe this helps. I did not know my 2000 kia had an alarm, it must be a factory anti theft device, I realized it started after locking my car through the passenger door instead of the drivers side first. try this:
    1 after driving your car while park, leave the front passenger and driver's door open
    2 shut the ignition off
    3 with the ignition off, shut the passenger door
    4 start the car with the drivers door open
    5 close the drivers side door while the car is running
    6 shut the ignition off with the two doors closed
    7 exit car as normally would do
    8 lock car using master lock on drivers side
    CG
  • I have a 99' Sportage 2WD 4-cyl. Currently, after a series of other repairs, it has finally been narrowed to no power reaching the fuel injectors. My mechanic is saying that now he needs to figure out if it is a short or the computer. He has had my car disassembled for over a month, so now I want to see if I can do it myself. Please help. (Also, it has been doing the random alarm stuff I have read in previous posts. Initially, I thought it was a faulty alarm because it would go off when I unlocked the doors as oppose to locking the vehicle.)
  • I have had my battery changed 3 separate times and the car keeps ruining them. I took the car to the shop and had the battery and alternator tested. Both test good at the time if testing. I recently fixed a bad headlight ground and was assured by the garage that it is not the cause of the issue. Please help me!!! What other reason could cause the battery to go dead all the time?
  • Some time when I turn key . nothing happens. Then after Sometime 3 trys it will finally start right up. Then If driving and i Turn car off and try to start it takes several times of turning key before anything happens. It like a relay or something is not allowing any power to starter. have replaced battery, alternator. and am wondering if there is some sort of relay between my key ignition and starter that may need replaced.. Help.
  • Had same issue with a 1997 Sportage. I believe they had to replace the ground cable on my battery. Grounding problems seem to be a common Sportage fault.
  • Having had my 2001 sportage for a little over a month now, I had similar problems.

    1) Check your "back gate open" lock. make sure it is turned all the way to the left. I know that the back gate open dash light may not be on, but this seems to be weird in mine.

    2) When I th9ought the battery was dead, I went to jump it. no sooner than I connected the negative cable when the alarm went off, and the car started fine. I also noticed that the check engine light, which has been on since I bought the car, is now off. May come on again later. It did this when I had the alternator checked.

    3) I am taking it to a mechanic today. I'm thinking that it has something to do with a sensor. i wish I woulda read more about the sportage before I bought it.

    I'll let you know what they think, though honestly, based on what I'm reading, this car is full of boogers and spooks. No one seems to really know what the answer ever is...

    I'll keep you posted!
  • My 2008 sportage is certifiably insane. Upon removing the key, it will occasionally spaz out, with windows going up and down, locks flipping, lights flashing.

    The day I brought it home, the battery died. It goes dead at least once a week. After 3 batteries, I don't think that's the problem.

    Tonight I drove it home, had dinner, went to put it in the garage, and the battery was dead. In less than an hour. 30 seconds on the charger and it started.

    I have despaired of the dealership fixing it. They can not find a problem. The next time they say "you must have left the lights on" someone is going to loose a tooth.

    This thing is, in fact, a piece of garbage. I don't want to trade it in because I'd feel guilty pawning it off on some other unsuspecting fool. It is pathetically underpowered, gets terrible mileage, and is generally a crap chunk.

    On the other hand, my 1999 Sephia, although almost completely rusted away (I think the seat belts are the only thing holding it together) runs beautifully. I let it sit for a year (whilst swearing at this Sportage). One day, in too much of a hurry to again recharge the Sportage, I got into the Sephia, tapped the key, and away we went!.

    How a car company can make something as reliable as a Sephia and then produce something like the Sportage escapes me. They stopped making the Sephia, but push the Sportage. I thought only American car companies were that stupid.

    BruceR
  • immelimmel Posts: 2
    Darn. I have a 2001 and mine does the same thing. I was not given a keyfob when i bought the car from a private owner. Car is in emmaculate condition, just no keyfob. I tried your combination of things you published here, but it didn't work. I then tried a combination of things and still nothing works. :( I'll keep searching.
  • immelimmel Posts: 2
    Did you ever find what to do on this issue? I have a 2001 and mine is doing the same thing. I too cannot lock it so I don't bother everyone. :(

    Thank you in advance

    Kathy
  • I have a 2001 Kia Sportage, It will not start. I replaced the ignition switch as other had a short in it and had to keep jiggling the key or lift up on it when trying to start my Kia. . Right before the switch totally quit working when doing this My starter made a slow noise like it was trying to engage. Noise lasted about 3=4 seconds.Then would not turn over.no noise at all. Removed the starter had it tested and found starter was bad.Replaced it with new. My dilema is all my power works when I turn key on (windows, fan blower, wipers, lights ect. But starter will not turn over. I don't get a click or any sound when I turn the key. Starter has power to it.. Is there a relay or something that may have shorted out? My battery has good amperage. All fuses good. need help. Thanks
  • lfodlfod Posts: 1
    I need to replace the negative battery cable in my Kia. Obviously, the battery end is easy to find--but where the heck does it connect to the frame (or block)? I'd prefer to remove the old cable, and install the new one in the same place, but I can't trace the cable all the way to the end, and haven't been able to ID the connection point.
  • ronsdawkinsronsdawkins Posts: 3
    edited July 2012
    I have replace the fuel pump, filter, and crankshaft position sensor.. and the relay for the fuel pump. The darn thing seems to delay on starting i have to turn it over several times and then eventually she will start, then she runs like a new car.. no skipping or stalling. I am at a complete loss... I read alot of negative things on here about the kia so I would like to say that I have really enjoyed my sportage. It has always been dependable and reliable... So any information on this would be greatly appreciated
  • well after all is said and done it turned out to be the ECI relay under the hood... kia runs like brand new
  • pwittpwitt Posts: 1
    I checked the fuse did not see any broken. but cant tell about the solid gray ones. did not see a eci relay just a gray main and the little ones I checked.
  • roxyhawkroxyhawk Posts: 1
    Did you ever fix this crazy alarm problem? Mine used to go off when I unlocked driver door with key, but only in very cold weather. In Texas, wasn't going off more than couple times a year for about 3 yrs. Now, it does it in spurts for a few days and its good for a few days. Lately, I've had trouble getting the key to turn a few times. Sometimes it wouldn't alarm if I opened passenger door first, but it went off when I did this last week. I've considered that making a new key might work. Leaving the key in ignition before opening door keeps it from going off when getting out of car. Rear left door won't unlock. Only drivers window goes down with main control. Other windows I have to reach over to use. I was told at dealer that window problem might be master control needs replaced and very expensive. I'm a night person, and alarm going off when I go to the store is waking people.
  • I sprayed wd-40 in my the locks on the drivers side and passenges side and i did not have any more problems with mine..
    Where is sprayed is where I put the key in the door to lock and unlock it.
    Give this a try .. I hope it helps .. Please let me know if it does... It really did the trick for me. so now i do that quite often
  • I got my 2001 Kia Sportage new, in 2001 and never had any major issues other than reg maintance stuff. I can drive the car locally around town durning the day with no issues. However long distances say over 30 miles in a straight shot my car starts to lose power til it dies, like it was running on just battery power. At times I also noticed that if I go over 50 mph, it dies faster. Now, at night, with lights, I can barely drive 5-10 miles before it dies. It's even done it when I charged the battery to full. Yet, When Autozone hooked it up to there thng they use, they say the battery is fine, starter and alternator is fine. I am at a loss. I know when its about to start dying cuz the internal clock starts to dim then goes out and bomb, car dies. But durning the day then the clock starts to din a bit, it then get bright again and I have no issues. Anyone have any ideas, suggestions??? Has anyone had this happen??? :confuse: :confuse: :confuse: :sick:
  • The most intermittent problem that has yet to be solved. Car will run like a champ then all of a sudden it will lose all power...up hill, flat down hill ect. If you put the gas pedal to the floor the RPMs stay at almost zero. Max speed when it decides to do this is MAYBE 20mph....that is if it actually is still running the RPMs. MANY parts have been replaced and noting seems to work. MAF sensor was grounded, throttle position sensor was grounded, new fuel pump/filter...blah blah. Now the interesting thing is that if you put the car in neutral or just park it and turn it off...it will start right up and run perfectly fine for a little bit then will bog down and have to turn it off again. Any ideas? I have searched the internet for hours now and haven't found any help. :sick:
  • iluvmysephia1iluvmysephia1 Alamogordo, NMPosts: 7,615
    edited April 2013
    I had a 2001 Kia Sportage 4X4 and had that same problem one morning. It turned out to be the alternator. It was about a $350 repair counting the labor cost. Never had a problem with losing power like that again. Same thing as you, the radio started going out and the dash lights dimmed, then the headlights started dimming, then the SUV's accelerator just went down to the floorboard and I had to exit the highway and come to a stop without the power steering working.

    Towed it to a shop and the guy came out and said "It's the alternator. It will not be cheap, that's the trouble with these foreign cars, they get good gas mileage but their parts are expensive." He didn't have the part in stock, the SUV was fixed early the next day. I rented a 2004 Mitsubishi Lancer 4-dr. sedan and decided to trade the Sportage 4X4 in about 3 years later, when the 2008 Lancer GTS came out, it was in March of 2007.

    We had a 5-speed standard tranny in our '01 Kia Sportage 4X4 and the SUV's locking hubs worked like a champ for us. Got of unstuck in the ice and snow about 4 times while we had the nice looking little SUV.

    But that's what yours sounds like to me - the alternator.

    2011 Kia Soul Sport 5-speed

  • misled023misled023 Posts: 2
    It was the alternator and it was replaced by myself and all is well now. :) :)
  • iluvmysephia1iluvmysephia1 Alamogordo, NMPosts: 7,615
    good for you for doing the work yourself! Glad you're all fixed up.

    2011 Kia Soul Sport 5-speed

  • I had similar issue on my dodge , the computer was the issue, in hot weather the computer would get bad voltage readings and shut down to protect itself. you can get a used one to replace it but may have to go to dealer to get vin number changed on it soyou can get smog done
  • I have a 2001 Kia sportage. I love it. It's been the best car I've ever owned. However, I have had an issue with it for almost a year now. I will be driving the car and the AC, wipers, and power windows will click off, stay off for a time, click back on, stay on for a bit, click back off. There have been times when it would NOT do this for weeks/months at a time and work normally, then it would start doing it again. Started doing it again the last time someone had to jump start my battery (left a switch on and ran the battery down). I've had several people check it out, had auto zone run the tester on it, checked the wiring and all electrical connections and repaired anything that looked suspicious, replaced the battery, checked the fuses, etc... What's left?
  • I have just replaced the starter on my 2001 KIA sportage bit I forgot which bolts on front of the solenoid does the positive cable goes to somebody help please
  • bigkizbigkiz Posts: 1
    ive got a short through the BTN1 relay, because when the relay is in there is a spark through the terminal and when I take the relay out there is no spark What could it be
  • Hi all i have ashort somewhere when i take the relay for the radio and central locking out there is not short at the negitive ternamal when i tape the negitive ternamanel at the battery with the negitive connetor when i put it back in there is a short there its is draining the battery big time
  • son has 2002 kia sportage, bought a year and half ago. so far put on 2 new b atteries, starter, and 2 alternators...keeps going b ad.. heard clicking under dash, next to fuse box in black box... could that be it? frustrated widow here,
  • hey i have the same problem with power to the whole dash. did you find out what was wrong

    I had the same problem and it turned out to be a bad contact in my ignition. I had to jiggle the key and turn the car on and off till it would start. Check your valve cover bolts to I was getting oil in my spark plug holes and found all the bolts on my covers were loose.
  • Please help my Computer box was replaced and everything else went on except my engine . My car has been standing for 2 months now
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,490
    It needs to go back to the place that replaced the ECM. If you mess with it on your own, or have someone else look at it, the first shop is off the hook.

    There's no easy online answer to problems like this. It requires a methodical diagnostic from a well-qualified electronics specialist.

    Here's a list from the International Automotive Technicians Network

    See if there is someone on that list that works near you. They are trained to fix problems like this.
  • orzecht said:
    I have a 2000 sportage Kia and recently changed the battery. Now the alarm goes off when I open it and does not go off when I put the key in the ignition. Is there a relay or reset procedure that I can do to silence the alarm?

  • Disconnected the battery for 5 minutes. That will reset the computer. This will fix your problem 
  • soul0123soul0123 Posts: 3
    Hi I'm new here so I have a 2002 Kia sportage that is having some charging problems. Bought a new battery and found it was the alternator. I've changed the alternator about 3 times now and it goes for a little bit before it dies. I have cleaned all the grounds and the battery connectors. Now I'm at a lost 
  • THallieTHallie LiberiaPosts: 1
    Hi
    I got my 2004 Kia Sportage and never had any major issues other than reg maintenance stuff. I can drive the car locally around town during the day with no issues. But something strange is happening this few days, the car starts good, drive it around and soddenly goes off which will take about an hour before starting and sometimes start immediately but with heavy/tick smock, can`t accelerate. Sometimes i will drive for 2-3 days without going off. i have tried all no good result. I NEED YOUR HELP
Sign In or Register to comment.