Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

2012 Chevrolet Equinox

I just bought my nox a few weeks ago. Got a LT1 4 cyl and FWD. Now im wondering if I should have went with the 6 and AWD.

The mileage is not to bad. Getting 27-28 on the highway at 68 mph. Did get 29 plus at 55mph. City is about 22-23. Takes getting use to not gunning the car on take off from a stop.

Just the get up and go power is not what I felt on the test drive.I plan on a vacation into the mountains and thinking this is not going to make it up the hills.
Anybody else drive thru the mountains with the 4 cyl?
Anybody tow with this yet?How was it handling?

Thinking about doing my own oil changes.I will see the cost difference before I decide on that.

Love the ride and comfort.I heater is a bit noisy. But I can live with that.

I will check back and add to this as I drive it more.
«1345

Comments

  • cmhj2000cmhj2000 Se, Pa.Posts: 381
    Granted we've only had our 12 Nox LS FWD 4 cyl for a few weeks, but so far it's everything we thought.

    Wife really likes it. Easier for her to drive and park than she originally thought. Dealer let us have one for an extended test drive one day. So we went around town, out on the turnpike for a bit, thru shopping centers etc. By the time we got back to the dealer some 70 miles and 3 hours later she said, "Sold".
  • Does anyone have positive or negative input regarding the 2012 or 2011 equinox 6 cyl. SUV?
  • rhouser2rhouser2 Posts: 114
    we have been cross shopping the 2012 2LT equinox and the 2012 SLE 2 terrain. if you get the equiped the same the terrain is about $400 higher. am i missing something that is standard on the terrain , but not available on the equinox? could someone clear this up for me as i see no reason to spend $400 more just for the GMC logo. thanks
  • indrgbindrgb Posts: 115
    We've had our 2012 2LT V6 for about 6 weeks. So far we like it a lot. The only thing that doesn't seem right is when you put it in reverse when it's overnight cold, it kind of jerks into gear. Only going into reverse and only once when the engine is cold. We dropped it off at the dealer one night and they checked it the following morning. They said it did not jerk for them. Why am I not surprised. I can see this being a lingering issue, but what do you do except take it back again until it does it. Otherwise this Equinox is a ton better than the old one. It has more power than the old one and gets about the same mileage.
  • jonoxjonox Posts: 100
    Very important to warm up aluminum engines before driving, this may also solve your "jerk" issue.
  • The 6 Cylinder is teamed up with a 6 Speed Transmission that has been in production since 2006. This combination is very reliable, especially since the same transmission was designed to be used in the much larger/heavier Chevy Traverse. When the transmission oil is cold, it is much more viscous, which makes oil flow to the Rev Clutch more difficult. The "jerk" you feel is from clutch timing not being sequenced to the engine power. This cold shift is a "low energy" event in the transmission, and is not damaging. As the oil warms, oil flow is much more predictable for the transmission software, so you should have smoother shifts warm. The transmission software will also try to "adapt" to these events, and smooth them out over time. You should only be alarmed if you are getting "jerk" consistently when the transmission is warm.
  • tomsfiretrucktomsfiretruck Posts: 6
    edited March 2012
    So far so good. Transmission a little sluggish. Need that extra pedal push.
    Gas mileage was as advertised, but now I see it slipping a little bit.
    Dash average showing 24, but actual calculation is 22.9.
    Waiting for a long Interstate drive to see how close we come to the advertised mileage.
    Driver side door seems to be noisey. you can really hear the other cars passing by.
    Still getting used to the front end styling. Loose my point of reference.
    Backing up is an issue with the rear window viewing. Need to look all around to make sure not going to hit something or someone.

    Having said all this, quite sure we made the right decision to purchase this car.

    Tom in Temple, TX
  • torgy2torgy2 Posts: 2
    We have only 6600 miles on our 2012 Equinox. Took in to the dealership to fix what we thought was an engine miss. ( at 1500 rpm with trans in park a real noticeable miss) It was diagnosed as a sever engine vibration. The dealership contacted GM tech support and was advised to R&R the harmonic balancer. This did not fix the problem and we got the car back untill GM comes up with a fix. We also found out that 4 other 2012 Equinox at another local dealership had the same problem one had tobe bought back by the dealer. Our service tech said it sounds like it might be a "fleet wide problem"

    Any one else having these problems? It seems to be only in the 6 cylinder.
  • grampsiegrampsie Posts: 1
    I, Live in West Virginia and have a 2012 LS AWD 4 Cyl . It does find. I came up mountain at Mount Ary on I-77 with cruse set at 75 mph. Stayed at 75 in 5th gear.
  • In order for you to be getting that good of mileage you must have the eco button on, turn it off for the mountians and I think you will be fine. You also could switch to manual shifting, with the buttons on the stick, takes some getting use to. Anyway, I love mine!
  • skyetxskyetx Posts: 2
    Just brought the New LT2 home April 13,2012 and kept in nice cozy garage. I happen to see a spiderweb across my tailpipe.
    I bent down to brush it away and noticed RUST ALL OVER the arms fixed to the exhaust on both sides of muffler. Even the screws used to attach the arms of tailpipes to muffler are rusted--screwhead and all. I have photos and will be contacting the dealer and Chevy.
    Am i just being uninformed or lacking knowledge but this Cannot be Normal!
    I know eventually metal does rust-especially the undercarriage of a vehicle but REALLY...at 2 weeks old?? And i am not in an area that runs damp or salty that would promote such damage.
    Anyone else having Rusting problems with Brand New 2012 Equinox LT2?
  • torgy2torgy2 Posts: 2
    Just a little up date to our problem. After taken the car back to our dealer and having them check it out again. And comparing it to other new 6 cyl EQUINOX on the lot. They all seemed to have a engine vibration around 1500 rpm. Our service tech said it was not normal. After checking with GM was told by engineering that it was with in "Normal Parameters" and because there one only 1 complaint nothing could or would be done. So we are stuck with a saver vibration until some one else complains too.
  • indrgbindrgb Posts: 115
    If I press the accelerator while in park, I noticed my 2012 6 cyl Nox has an unbalanced feeling at around 1500 RPM. I do not notice it while driving or when it's started cold. I don't plan to take it in unless I have another problem. I suspect the dealer will tell me it's normal. I don't plan to lose any sleep over it.
  • Let me ask a question.....do you think they built it the day before you bought it?
    You need to look at the build date of the vehicle. Also, it may be a combo of rail dust and the metal rusting. But remember, rust actually protects the metal and keeps it from deteriorating faster.
    In other words, not a problem.
  • petrichorpetrichor Posts: 1
    Recently while shopping around for a new 2012 Chevy Equinox at three separate dealerships, I was shocked by the lack of product knowledge the salespeople had regarding the radio systems. I fully expected to demo the new Mylink radio which has Pandora and Stitcher but was told by each and every salesperson that the Colortouch (which does not have those features) is Mylink. One went so far as to tell me that Remote Link for Allstar is the same as Mylink!

    So which one do you have and what did you think you were buying">?
  • jpfjpf Posts: 496
    It's unbelievable that so many car/truck salespersons are so poorly trained. I have purchased GM and Chrysler products for over 20 years. Frequently, I know more about the product than the salesperson. Anytime I buy a big ticket item, I spend several hours researching the product. The knowledge I gain from this basic research frequently is more than the salesperson's knowledge. I simply do not understand why companies do not train their sales staff better.
  • salesman7salesman7 Posts: 1
    Better? I am a GM salesman. We don't get trained at all. Any training we get we have to do on our own. And when we are constantly busy with customers, have several different models of vehicles (Chevrelot, GMC, Buick, and others, plus every make and model of used vehicles on the lot) it is very difficult, if not impossible, to remember everything about every car. Try to take it easy on your salesperson. I assure you, they are trying very hard. Its not easy. Its alot easier for a consumer, interested in one or two vehicles, to do thorough research than it is for us to remember every available feature on every car.
  • I bought my 2012 6cyl Nox on June 22, 2012. Within the first 1000 miles I noticed a terrible hesitation/stall as the car would go from a dead stop to full on acceleration right around 1500 rpm.

    I found this out the hard way, almost having a wreck thinking I had all the power in the world to clear an intersection to have it hesitate and nearly stall with oncoming traffic....EEEK!

    I also noticed that it would occasionally downshift very hard at times.

    It has been in the shop for about two and a half weeks now and I am not having any of that Chevy Confidence feeling right now.

    My service advisor says that they are ripping the tranny apart to see if they can find the issue and that they are working with GM on it.

    We'll see what happens.
  • godeacsgodeacs Posts: 481
    Geez, sorry to hear that! After looking at the LS 4 cyl, I was just getting interested in the V-6 1LT version so I could tow a small camper. Now not so sure..... :confuse:

    BTW, where in Texas are you and where did you buy your Equinox?
  • I am in Corpus...and the dealer is Allen Samuels.

    I do have to say that the dealership is working diligently to try to solve the problem. They have gone so far as to get the sales department involved again in case the problem can't be fixed.

    As of tomorrow, the car will be in the shop for 3 weeks....my patience is still in abundant supply....but I am bummed.
  • I have the same v6 in my 1LT and experience the same hesitation/hard downshifts - they are probably normal. I have noticed with the 6 speed trannies for better fuel economy, they are slower to respond and help slow the car down when you let off on the accelerator - I rent a lot and feel this a lot on GMs and Fords. The accelerator is a bummer, I had to really hoof it to beat out a Scion IQ. But I can live with the hard down-shift as I do not have to brake as much as I did before. However, to answer another person's question - if I were towing, I would certainly go with a v6!
  • Maybe this is something your management may want to figure out. Customers are concerned about making the best purchase, not how hard the salesperson is working. There isn't much sympathy on either side of the auto sales business. Good luck.
  • Noticed today that the top of the cluster was extrememly hot to the touch. So hot, could not keep my hand on it. This does not seem normal to me. I have seen it mentioned one other time, but no answer. Anyone have any thoughts on this.
    Tom in Texas........
  • Hi I really want to get a Chevy Equinox but I'm not sure of the year. Or even a 2013 model. And pros or cons would be greatful
    thanks
  • Purchased a 2012 Equinox 4 cyl AWD one month ago and live on a country gravel road. Dust is coming in the rear latch and the two rear doors. Dealer fixed and said it was excessive gaps in LH RH rear doors and liftgate seals. The adjusted all door strikers inward. Well guess what - it is still doing the same thing. Has anyone else had this problem and if so how did they solve it. Have talked to 3 other equinox 2012 or 2011 owners with the same problem. Is there a solution?
  • I have the same problem with my 2011 SLT2 Terrain. At low speeds when I
    tramp on the accelerator, a real hesitation as if the engine is going to stall.
    When i ease off and accelerate slowly the car speeds up smoothly.
    Its as if the transmission gets lost between gears and the engine cuts the
    fuel off. As usual, the dealer says they can find nothing wrong.
    You would think they could reflash the computer chip and correct the problem
  • I have a 2012 Equinox LT2 and love it. I had a 2011 and had some problems so I made a deal with my dealer and got a 2012. We took a trip to Boston from Milledgeville GA and got as high as 34.1 mpg at one point, going through Virginia. We averaged 30.7 on our trip back from Boston. We average 27.5 around town and driving from Macon to Milledgeville. The best I have done on short trips is 28.3 mpg. (It's all the way you drive.) The vehicle runs great, handles great and has adequate power to pass and do anything I need. We have received many comments from strangers regarding the looks of the vehicle. We have the red color and love it. Can't think of anything negative to say.
  • I have just purchased a 2012 Equinox with a 4 cyl. When I first crank the engine it runs rough for a few minutes. I have not completed my dealership survey until I see if this problem continues. Has anyone else had this problem?
  • Good afternoon rocketbob,

    Are you noticing this issue when you are traveling at speeds below 35 miles per hour? If so, and if I understand your post correctly, I would recommend adjusting your acceleration so as to only be pushing in the gas pedal about half way rather than all the way down (per p. 9-35 in the manual). If we can check into anything further, please let us know by sending an email at [email protected] (include the last 8 of your VIN and contact information along with your inquiry).

    All the best,
    Sarah
    GM Customer Service
  • Congratulations on your Equinox, sonnyh777! We're so pleased to hear that you're enjoying it and wish you many more happy miles!

    Sarah
    GM Customer Service
  • Notice when cars are passing me on the left lane, that the traffic noise is very loud. It alsmost seems like the drivers door is not fully closed. Is there some sort of adjustment they can make to the door closure ??
    Tom in Texas
  • tomsfiretrucktomsfiretruck Posts: 6
    edited August 2012
    Noticed that the front and back seat power outlets do not function when the engine is turned off, but yet the one in the cargo area works just fine.
    Any thoughts.................Tom in Texas

    Nagging little things, for an otherwise good running/milage vehicle.
  • Congratulations on your new Equinox, smokey27, although we're sorry that you are having some concerns with the way it's idling upon start up. If you decide to have your dealership take a look into it and would like for us to follow up on that appointment, please contact us at [email protected] with more details including: your name and Edmunds username, phone and address, the last 8 of your VIN and current mileage, and the name of your involved dealership. This will allow us to set up a Service Request and contact your service department.

    Best,
    Sarah
    GM Customer Service
  • Good morning tomsfiretruck,

    Congratulations on your new Equinox! Aside from the road noise and power outlet concerns, we're glad that everything is going well. Are you planning on having your service department check into the power outlets and road noise concerns you are having? Keep us updated on what they say!

    Sarah, GM Customer Service
  • ronwelronwel Posts: 57
    I can tell you that this is not a problem as this was how the car was designed. The manual mentions this...and both my 2010 and 2012 functioned this way.
  • I just bought a new 2012 Equinox and noticed that my exterior light sensor, located on top of the dashboard, flashes red every 4- 5 seconds when the vehicle is parked and when it is dark.
    Is this normal?
  • Yes this is normal. It is part of your security when car is off & locked :)
  • We just purchased a 2012 Nox on this past Thursday evening. The Nox is the first Chevy we have ever owned. This car was purchased for my wife. My wife drove the car to work and noticed noise coming from the engine. We took Nox back to the dealer to complain about the noise and of course the dealer convinced us that it was the Nox’s engine character in other words “the norm”. We listened to one of the other Nox the rough engine noise was the same.

    My wife did have a hard time explaining the noise. However, low and behold, I sided with the dealer saying “Maybe it is the engine general performance”, because it was the same in one of the other Nox.

    It wasn’t until Saturday night when my wife return from the hospital visiting her friend she asked me to hurry out to the garage and listen to the Nox. It was than I noticed what she was talking about. There was a vibration noise that could be heard inside the car. Vibration noise is the best way that I can describe the noise. The noise was the same sound heard when something is out of line. When the engine first starts the noise isn’t there. The noise start out low and increase as the engine becomes warmer if I can use this term.

    I’m at “Awh” for a few reasons, one when we took the car back, my wife decided she didn’t want the car, because it was purchased as a brand new vehicle. When something is purchased new the expectation is, you’re not buying a problem to be return to be repaired later. If we wanted this issue we would have gone to a used car dealer. Second, the dealer was more concern about keeping the car sold and not wanting us to return the vehicle vs., finding out if we were 100% satisfied with car we purchased. The noise is annoying especially when you’re use to a vehicle that has little to no outside engine noise.

    Have anyone else experienced or is experiencing this vibration noise issue? My concern is, it this noise is happening in a brand new vehicle, what is it going to sound after a few months of driving.
  • If you bought your Nox under the promotion of returning it if you did not like it and did not take the $500 discount in lieu of the ability to return it you have some leverage on your side. However, if you have the issue now, your bumper to bumper warranty will cover whatever needs to be done; the question is did you let the service dept go out with you on a test drive to duplicate noise? If not you need to do so in order to build your case with the dealer if the dealer is not responsive then switch to a dealer who is. These are great cars and I hope you get your questions answered quickly.

    Please let me know if I can be of further help. Good luck.
  • Good afternoon junejune1,

    Congratulations on your new Equinox! However, we're very sorry to hear that you're already experiencing some concerns with vibration noises.

    I see you've consulted your dealership on this noise already and would like to offer to follow up on this with your dealership. Please email us the following information at social[email protected]: your name and Edmunds username, phone and address, the last 8 of your VIN and current mileage, and the name of your involved dealership.

    All the best,
    Sarah
    GM Customer Service
  • I'd love to say I'm happy about my 2012 2LT AWD Equinox but after 3 months of ownership imagine my shock as I was driving down the highway at 65mph only to feel the vehicle reduce power and flash warnings at me. Abruptly and after cruise cut out I could hardly reach 45-50 mph on a busy highway during my morning commute to work. My vehicle flashed the warning to "Service Stabilitrak" and that I was now "Operating On Reduced Power" with the check engine light lit. Needless to say, I drove straight to the dealership!

    After reading these forums it appears to be a reoccuring issue with many GM vehicles and I can't believe it's ongoing! Covered under warranty or not, I'm saddened to be put through a situation where I have to worry over something of this nature when driving a brand new vehicle. I'm hoping the dealership will be able to correct the cause but again I'm concerned I'll be visiting the service department repeatedly for something which appears to be a defect arising in many models of GM vehicles.

    If you are reading this and have had similar issues - have any of you found a permanent solution? I've read replacement of the throttle body helps, avoiding car washes which could douse various sensors in the underbody and even gas pedal replacement to changing fuses and replacing an onboard computer. In any case, this is not a very positive first impression of owning my first brand new Chevrolet vehicle (I almost went with a Toyota!). :sick:
  • Service Dept just called. They said they couldn't even pull up codes for the issue that I'm experiencing and he test drove it and it didn't happen to him. It never happens to them! I guess I won't put much faith in my engine when it comes to passing on the highway and considering highway is all I drive I'm a little hesitant! And now winter will be on the way...AWD and Stabilitrak is supposed to make me feel more secure! :confuse:
  • ray80ray80 Posts: 1,655
    I believe the reduced power message is to allow you to limp it back to dealer without doing any potential damage (thats a good thing). Since the dealer is going to have trouble fixing something that they can't recreate or find a code for, I would look back a post or two and open a case with GM customer service (send Sarah an email with the info she always requests). They may be able to work with dealer (and perhaps others) to find a solution.
  • We're sorry that you're having these troubles with your new Equinox, waterviolet! It looks like you're already working with your dealership on this, but if you wanted for us to check into this further we're available to do so. Please email us at [email protected] with more details (including your name and Edmunds username, phone and address, the last 8 digits of your VIN and current mileage, and the name of your involved dealership).

    Sarah, GM Customer Service
  • Thanks ray80. I didn't mean to be a Debbie Downer but it's an awfully hard pill to swallow when you purchase a new vehicle and with it having less than 4000 miles on it I'm having issues which could potentially spell disaster in the coming winter months. I will definately contact Customer Service as from what I've read of other occurances, this event is bound to happen again. :D
  • jpfjpf Posts: 496
    You may want to check out the Impala forums. This seems to be an issue with that model. There is an entire discussion dedicated to the issue under the Impala forums. Unfortunately, stability control is one of those mandatory government safety features now required on new vehicles. I purposely bought an 07 Uplander last year without the Stabilitrak to avoid this issue. Another silly government requirement that adds cost to new vehicles and additional headaches to car owners when it fails. Tires with decent tread life and driving the speed limit avoids the necessity of most stability control systems. My 2 cents worth. Good luck.
  • I have had my 2012 equinox 1lt since November 2011 and have 11800 miles on it. I was driving my car on the highway at about 65 miles an hour and almost instantly lost all power, warning lights galore were going off including the stabilitrack. This was Thursday. The dealership couldn't take my car until Tuesday. After 9 days without my car, they finally got it back to me saying they replaced parts within the high pressure fuel aystem. 5 days later it did it again. They weren't able to reproduce anything after having my car for another 5 days. They gave my car back to me. I had it for another five days and more warning lights. I am frustrated. I am scared to drive my car. I didn't invest in something to be terrified of it. I am at a loss!
  • Good morning jessicas6977,

    We're sorry that you are frustrated and frightened with your Equinox, and that it's been difficult to nail down the cause of this problem with the dealership. If we can check into this situation further with you, please contact us via email at [email protected] (include your name and Edmunds username, phone and address, the last 8 of your VIN and approximate mileage, and the name of your dealership).

    Sarah, GM Customer Service
  • This morning it happened again. This time, I drove straight to the dealer WITHOUT shutting the car off thinking it needed to be reset. This time, I went from 68mph to 60mph in a drop of the hat on the highway. I was able to keep up that speed until waiting at a stop light on an exit ramp which from that point onward I could only accelerate to 20mph. I still had all the same lights and warnings as before, Operating on Reduced Power, Service Stabilitrak and Service Engine light. This came 2 days after receiving a call about my previous service for the same issue and being advised by the awesome Customer Service Rep she was going to research it some more. She understood my reservations on passing vehicles while driving my normal highway commute - so TWO big thumbs up to Customer Service! Fortunately, there was a cancellation and the Service Department was able to take a peek at my array of lights and warnings. I'm not sure what codes they came up with but they just called to tell me they will be replacing the High Pressure Fuel Pump. I have high hopes this will help but it's still concerning on a vehicle which now has about 4500 miles on it. Crossing my fingers and hoping for the best! :confuse:
  • You are not alone! I too am a bit frustrated but overall my reservations with this vehicle is the feeling I have driving it. I lack the sense of security I once had before these issues started to arise. It's very concerning especially when my daily commute involves highway driving with no passing lane and now winter will be upon us in a flash! The reason I purchased the vehicle was to have the security and power I need! These forums have been a priceless fountain of information on this issue when it comes to the exact problems we are experiencing. For now, I will go along with the High Pressure Fuel Pump replacement the Service Dept tells me I need but I will not trust 100% this will not happen again. Various other reasons have been sighted for this issue, including the accelerator pedal, on-board computer, etc. In fact, this very thing happened to my co-working on her 2005 equinox (they replaced the computer). In any case, log everything, take pictures if you have to and talk to your Customer Service Rep. Don't back down...this is how things get corrected and we need to provide them with all the feedback we can! :D
Sign In or Register to comment.