Have you shopped for a car recently but decided to hold off on your purchase because prices were too high? A reporter would like to speak with you; please reach out to [email protected] by 9/30 for more details.

Volkswagen Jetta Engine Questions

1246

Comments

  • tdurniattdurniat Member Posts: 1
    I have a 1998 Jetta 2.0 with 63,000 milles. It starts fine, but when accelerating the engine wants to die after about 2 seconds. If I take my foot off the accelerator at that time, it will not die and I can accelerate again for about another 2 seconds. Thid repeats at about 2 seconds the entire time I am driving. As long as I stop accelerating every 2 seconds, I can eventually get it up to speed, but if I try to continue to accelerate, it will die. The error codes scanned are P0103 & P1580. Did anyone else have these problems or have any ideas what may be the cause based on these codes?
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaMember Posts: 64,482
    Code 1580 says a throttle actuator problem. There are diagnostic procedures to test this but you need a tool like a VAG-COM. Jettas seem to throw this code a lot.. Also the P103 code is the MAF circuit input, which may be related, I'm not sure. You'd need a wiring diagram to see if these two components happen to have something else in common like a relay or ground wire or whatever.

    You can always try to clean the throttle body and MAF sensor thoroughly (using the correct solvent).

    A new actuator is very pricey. You don't want to be guessing on that part.
  • bpeeblesbpeebles Member Posts: 4,085
    I have never heard of the throttle actuator going bad.... but it may be "out of sync" with the accelerator pedal. This could happen if somone mistakenly touches the accelerator pedal while starting the engine. (One should NEVER touch accelerator pedal when starting engine!!) Also, disconecting battery may lose the adaptation settings.

    There is a procedure to re-synchronize the throttle-pedal to the throttle-plate. This procdure is called "throttle adaptation" by VW. Here is a synopsys of the "throttle adaptation" procedure from the Bently manual:

    1) WITHOUT touching accelerator pedal, turn key to "run" (do not start engine)
    2)wait several seconds for onbaord diagnostics to complete.
    3) slowly press accelerator pedal to floor and HOLD for at least 5 seconds.
    4) slowly relase accelerator pedal
    5) turn key off

    The above procedure also resets an automatic xmission to the default settings.

    If the above does not help... you may wish to search the internet for "throttle adaptation" to learn more about it. Some folks have reported that they had to do other things (like disconect battery 1st, or leave key in "ON" position for 3 minutes before pressing pedal down.)
  • purdysjetta99purdysjetta99 Member Posts: 2
    is it possible to swap my 2.0 for a 1.8t motor in my 99 vw jetta?i only honda swaps not vw...thanks for all the help!!!!

    devan
  • brockm666brockm666 Member Posts: 1
    Hey, im curently having the same problems with my car. I have a 99 Jetta. (older body style) and it cuts out at 2-3 grand and maxs at 35-40mph. i changed my spark plugs, my wires, fuel filter, and nothing came out of it. a friend suggested coils like you had been suggessted. but you say it didnt help? another friend says cam sensor. did you find out what the problem was??? thankx for your time
  • iyoulowiyoulow Member Posts: 4
    Hi all. I'm having major problems. First let me say that I replaced an ignition coil a few months ago. I had a difficult time locating one. Once I changed it everything was fine. I did drive the car for more than a week with a bad coil though.

    Last Thursday on my way home from work the engine started running rough and losing power. I figured it was a coil again. The next day I swapped out each coil with a good one with no change. I then changed the plugs. It ran rougher. Then ran a little smoother. Now it is very rough. I had the codes scanned at Advance Auto Parts. I'm getting P0172 - System Too Rich (Bank 1) and all four cylinders are misfiring. They keep switching around so I know its not the ignition coils.

    I have read that the catalytic converter can be damaged when driving with a bad coil. I think the cat is bad and have ordered a universal one online. I drilled holes in the old one today hoping it would improve engine power. That was dumb. Loud but no change. I can't drive it anymore until I fix it. I can't afford to take it to a mechanic.

    Could the problem be something other than the cat? Would a bad O2 senser cause the engine to misfire. I also have the rotten egg (exhaust smell). What causes the system to be too rich? Thanks
  • bpeeblesbpeebles Member Posts: 4,085
    What causes the system to be too rich?

    MAF sensor
    O2 sensor
    leak in intake plumbing
    trubocahrger not pushing enough air thru engine
    (some others)

    Try this, UNPLUG the electrical connector from the MAF and then start engine and drive for a couple days. (This will force the computer into "limp mode" and may turn on the CEL.) If it runs better, suspect that your MAF is sending bad signals to the computer and may be bad.

    Many folks have reported that when MAF is bad, the engine will run BETTER with it disconnected thus forcing engine to run in "limp mode".
  • iyoulowiyoulow Member Posts: 4
    The MAF has been bad for a while and unplugged. The car ran fine regardless. It is definately something else. Can the O2 senser cause the power loss and the rotten egg smell?
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaMember Posts: 64,482
    yes definitely a possibility. You need to get a handle on this car I think. It seems to be running away from you. Do you know of any VW specialty shop that has a mechanic who knows how to do step by step diagnosis? I sense that you are throwing parts at the car (and I know you're trying to do the right thing here) and I'd hate to see you waste more money than it might cost to pay a clever tech to straighten this puppy out once and for all.
  • zepperszeppers Member Posts: 2
    perfectly normal for a couple seconds then falls off. Would a damaged/missing crankshaft positioning sensor allow that to happen? If I tap the accelerator irregularly it will sometimes rev up but always dies. There is a dent in the oil pan but not very large. I love this car (newly acquired). I can't help but think it's something simple (wishful?). I tried the accelerator "sync" procedure another member suggested, disconnected the battery.... It sure feels like a fuel issue. Any other ideas?
  • zepperszeppers Member Posts: 2
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaMember Posts: 64,482
    we need to get some codes to know where to start I think. A simple fuel test would be to measure fuel pressure in the injection rail, if you had that type of gauge.
  • iyoulowiyoulow Member Posts: 4
    You're correct. I just didn't want to run into a huge bill. I cut the cat out today in anticipation of the new cat being delivered Monday. Still the same issues with the engine. It is still misfiring. I still think the cat was bad but there is something else wrong as well. How do I find out if either of the O2 sensors are bad? I looked at the hose from underneath; didn't see anything obvious. If I can get the new cat installed on Monday at least I avoided having to pay someone to do that. Then I can take it in and have it looked at if no one on this board has an obvious cause for me.
  • scottie0352003scottie0352003 Member Posts: 4
    I am having some trouble. If i hook up the alternator, it will start but runs rough and if i push on the gas, it shuts off. However, if i disconnect the alt. it will run fine. I have replaced the coil, rotor,plugs, wires, distributor, starter alt ans battery. Could someone help me with this.
  • mk4wemk4we Member Posts: 2
    i have a 2001 wolfie that has 140000 miles on it i run strictly shell v-power and always couple valvoline syn power 5w 40 with a bosch 3421 filter and she still drives like new i just want to encourage people to not be cheap with preventative maintenance for example YES shell is more expensive than most BUT with a 14.5 gallon tank you look at a maximum of TWO dollars more at the pump each time multiply that by 50 and it costs 100 dollars A YEAR more to run v-power than the "best price" 91 octane which is the recommended fuel i have replaced the timing network on my car as per maintenance since i have owned it and that is the extent of the cars time spent in the shop.................just a thought if you are truly a v-dub lover its the least you can do for your car
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaMember Posts: 64,482
    02 sensor is hard to test. It has to be (well, should be) done with the car running and with a special type of voltmeter attached. Probably not something you are equipped to do.
  • bpeeblesbpeebles Member Posts: 4,085
    The O2 sensors are much easier to test with a VagCom. Just plug your laptop into your VW and run diagnostics.

    Dont forget that there are 2 types of O2 sensors. Some have a digital (on/off) type of output and other have an analog output. VW uses BOTH kinds of O2 sensors on some enginecodes.

    If you REALLY want to test out the O2 sensors, you can collect data as you drive then graph the results on the screen when you get back home.

    In the hands of a skilled user, the VagCom system can be used to efficently isolate almost any issue with your VW. I have diagnosed everything from bad MAF to burned out glowplugs and popped-off hoses. Even burned-out heated-review-mirrors can be located quickly. Faultcodes can be diagnosed and reset....etc etc.

    You can even enable/disable any of the programmable options such as auto-door locks, beep when armed...etc.
  • scottie0352003scottie0352003 Member Posts: 4
    Update, it is the voltage regualtor wire doing this to the car.
  • autowork7456autowork7456 Member Posts: 15
    I have a 2002 Jetter 1.8T. The check engine light keeps coming on. The code is P0171 running lean. One dealer had the car for three months replaced all kinds of parts. Carried to another VW dealer and they have replaced cat coverter, pulled the head and checked it (it was fine), have replaced several sensors and usually before we get home from the dealership the light is back on and with the same code. This time we drove the car for 166 miles before the light came back on, but it is back on again. I am getting really tired of it. It is getting very expensive. The car runs perfect, just the check engine light. Can you help me?
  • scottie0352003scottie0352003 Member Posts: 4
    wow, thats a lot of money to toss into it and it not fix it. Have you tried cleaning the throttle and Mass Air flow sensor. I just put 1000 into my jetta just to find out that it is the voltage regulator wire bad, and i cant find another one. Really dont want to have to go thru the dealer if i can get out of it. A nieghbor wants to trade a 2001 dodge neon for my jetta, not sure about it though.
    Your problem could also be something in the fuel system too, always check the spark plugs gap too.
  • jkartcrazyjkartcrazy Member Posts: 3
    I have read through some of the other comments and tried the "throttle adaptation" that was discussed but it didn't really fix my problem. When I hit the accelerator my car takes off like a rocket and my tires squeal (my neighbors probably think I'm crazy) The engine seems to lope and then I loose my throttle completely. The car does not totally shut off, the throttle pedal just no longer works. This happens sometimes when I first take off and sometimes when I'm driving down the highway. Lately, it is happening non stop. I took the car into the dealer and they told me it was the MAF and oxygen sensors. The MAF has been replaced as well as both oxygen sensors and nothing has changed. The dealer also said the battery was bad so I replaced that also. I tried the "Throttle adaptation" that someone here described and it seemed to help the idle (the idle goes up and down erratically when I start the car). Does any one have any suggestions? I was going to go out and try checking on the vacuum hoses. Any input is appreciated. Also, I took the car over to Auto Zone on Friday and the following codes P1116 (Oxygen sensor heater circuit, open, P1118 Oxygen sensor heater circuit, open, P1542 Throttle actuator sensor,range or performance problem, P1545 Throttle valve actuator malfunction. Thanks to any input!!!
  • bpeeblesbpeebles Member Posts: 4,085
    Since "Throttle adaptation" did not seem to correct your problem. There is really only a couple possibilities left, (not the MAF nor O2 sensor that your dealership suggests)

    The P1542 Throttle actuator sensor,range or performance problem, P1545 Throttle valve actuator malfunction. are the clues.

    EIther the potentiometer in the throttle-pedal assembly or the throttle-valve actuator itself is your problem.

    If you are on a tight budget, any scrapyard should have both of these components.

    Personally, I would remove and throroughly clean both of these components and then do another "Throttle adaptation" BEFORE spending any money.
  • scottie0352003scottie0352003 Member Posts: 4
    jkartcrazy, thanks for the advice, i will try this again. And the other problem is the voltage regualtor wire, it went bad and i cant seem to find the little wire anywhere.

    Will let ya know how the cleaning goes.
  • disappointed7disappointed7 Member Posts: 1
    For my 2000 Jetta, not VR6 but 2.0, catalytic converter was recalled and replaced by VW- I hope you didn't pay for replacement! Check into it!
  • bpeeblesbpeebles Member Posts: 4,085
    Lets not forget.... on a 2000, - recall or not - ALL the emmissions-equipment is coverd for 10-years/ 100,000 miles by federal law.

    The catalytic converter is part of the emmissions system and is thus covered by this federal law.

    so... when we say "check into it"...we really mean READ YOUR FEDERAL EMMISSISSONS WARANTEE!!
  • native_qtnative_qt Member Posts: 1
    I was wondering if anybody knew the price range to get new turbo in my 2001 VW Jetta. The turbo that is in there right now is going out and is making a really nasty noise when the turbo should be kicking in. I received an estimate and they told me it would be about $1,000 to have it fixed. I was wondering how hard of a procedure is this to do and why does it cost so much? I know nothing about cars and I already had to spend about $2,800 to get it fixed because my timing belt went out and messed up all the valves... I am so disappointed. :sick:
  • bpeeblesbpeebles Member Posts: 4,085
    This is what I suspect happened... when the TimingBelt broke, the pistons crashed into the valves and some debris from this collission got into the exhaust thus damaging the turbocharger.

    If you continue to drive it, and the turbocharger decides to self-distruct... then pieces from it could get sucked into the engine thus damaging the engine again. (It is a visious circle)

    Here are several online websites that specialize in Volkswagen parts.

    http://www.worldimpex.com/
    http://www.1stvwparts.com/
    http://www.germanautoparts.com/
  • jeffyscottjeffyscott Member Posts: 3,855
    I know nothing about cars and I already had to spend about $2,800 to get it fixed because my timing belt went out and messed up all the valves.

    You don't need to know all that much to avoid problems like this. You really just need to follow the maintenance schedule. It is in the owners manual, if you don't have one you can also find the schedule on vw.com. That schedule would include replacing the timing belt, had you done that you'd have saved at least $2000.
  • jkartcrazyjkartcrazy Member Posts: 3
    bpebbles, thank you for your input. I had all of my codes erased(which had not been done since the MAF and O2 sensors were replaced. I did the throttle adaptation but it didn't last very long (5 min) and it now only threw two codes, the P1542 and the P1545. I have taken out the throttle pedal assembley and cleanrd the potentiometer and will be getting that back in the car this morning. One other question however dawned on me as I've been reading. I have also replaced the battery recently. Could that be messing up my throttle control module? I have read that it the ECM needs to be reset to it's basic codes after a battery replacement? If so, how do I get the basic codes and do they come with a Scan Tool if I purchase one at Autozone or other auto parts store? Thanks for any input!!
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaMember Posts: 64,482
    that's not a bad price to replace a turbo. Even if you took it off yourself and shipped it out for a rebuild, that would cost maybe $350. Not sure about labor rates to R&R this. I would think an independent shop might be able to do it somewhat cheaper.

    Sounds like you need to step up the maintenance on this car. I hope you are using synthetic oil on that particular engine.
  • bpeeblesbpeebles Member Posts: 4,085
    I beleive that performing the "throttle adaptation" procedure is considerd the same thing as reseting the "basic settings" ....at least as far as the throttle-settings go.

    Given the 2 codes you have been seeing (P1542 and the P1545) If you have tried all the easy fixes by cleaning the throttle poteometer and the throttle-plate actuator.... Perhaps you might consider that one of these 2 components is truly defective.

    BTW: Here are more details about the various "Adaptations" you can perform with VW
    http://p086.ezboard.com/frevotechnikfrm13.showMessage?topicID=5.topic
  • jettajakejettajake Member Posts: 2
    my 1998 TDI is running slower than normal and when i start the car up it revs up the engine. does anyone know what the problem is or if there is anything i can do? the car has 140,000 miles on it
  • jpedd43jpedd43 Member Posts: 3
    Ive got an 01 Jetta 2.0 that quit running on me. Had it to a dealer, and they told me that I needed to put a new engine in it. Had another shop look at it, and mechanic determined that the head was warped. He had it machined and put it back to gether and its running, but not very well. Was getting random misfire codes so I changed the plugs and wires. Still not running well. Now its showing a PO 606 code. Can anyone give me info on Trouble Code po 606. Would it keep the car from running? Do these computers go out often. How can I fixt it?
  • jeffyscottjeffyscott Member Posts: 3,855
    I am no expert, but I thought machining a head is generally not a good idea, because shaving off some of the head changes the amount of space in the cylinder thus changing the compression.
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaMember Posts: 64,482
    01 07 24

    Feb. 23, 2007

    2010582

    01 07 24, dated Feb. 23, 2007 supersedes Technical Bulletin Group 01 number 04-18 dated Aug. 26, 2004

    Vehicle Information

    Condition

    DTC P0604 (16988), P0605 (16989), P0606 (16990) Stored in DTC Memory

    Technical Background



    The above DTCs may also be stored due to a low battery condition.

    Production Solution

    N/A information only

    Service
    ^ Do not automatically replace the ECM for this condition. First, perform the following:

    ^ Verify that battery voltage and condition are OK (charge and load test as necessary).

    If battery voltage is low:
    ^ Correct reason for low battery voltage



    With battery fully charged:
    ^ Clear any stored DTC.

    ^ Perform throttle adaptation procedure (see Repair Group 24, ECM to throttle valve control module, adaptation.

    ^ Test drive vehicle for approximately one half hour.

    If MIL does not illuminate and DTC does not return:

    Low battery voltage has most likely caused the DTC to be stored.
    ^ Procedure is complete.

    If MIL illuminates and DTC is stored again, perform the following:
    ^ Replace ECM (see appropriate Repair Group).
  • jkartcrazyjkartcrazy Member Posts: 3
    Thanks for feed back. I was able to find a re-manufactured throttle body on-line for a little over $200 and had it installed last week. This seems to have fixed the problem. Car is now running great so it was the throttle body gone bad.
  • bpeeblesbpeebles Member Posts: 4,085
    I am glad to hear that you have got your problem straightened-away. VWs are great cars with superb engineering... but along with that comes complex systems that may be difficult to troubleshoot.

    The main thing to remember is that a "troublecode" is just an indicator about a problem... NOT always the problem. Replacing parts is a last resort. (unless you are a paid mechanic and want to sell parts - LOL)
  • curtisrose420curtisrose420 Member Posts: 3
    Ok so my car started to go from being in drive to neutral ( my stick is still in neutral) then after that all my gears on my dash lit p d n 1 2 3 all lit up so I put my car into park ( my stick) so i thought and turned the car off well now on my dash its saying im in drive but my sticks in park so it wont start now. Its an automatic. What do I do?
  • kfeigumkfeigum Member Posts: 3
    Help! My car speeds up and slows down all by its self. I can hold the accelerater steady and it will buck sometimes dying when at a stop light. The CEL, EPC and ASR lights come on and off randomly (mostly on) it has thrown me P1142 and P0101 codes. I have already replaced the MAF, I replaced the coil pack and spark plug wires, and battery 6-7 months ago am just trying to get the lights off now so I can trade this lemon in.
  • ryederryeder Member Posts: 2
    I have been reading many of the post that are dealing with the same issue I am trying correct. 01 Wolf 1.8 Turbo. Once engine is warmed up, engine loses power. I have replace plugs, and replaced the filters. One thing I did notice was when the plugs were set at the correct gap, they fouled up. Widening the gap helped, but engine still lost power. What, if anything has WV offered in the way of tech help seeing that this seems to be a fairly common problem? I also changed the computer (used), and the engine failed to start, so I reinstalled the original. Does the install of a replacement computer require re-programing, and would the anti-theft device programmed into the radio cause any untrue sensor readings? Someone mentioned this to me as a possibility. Anyone want to buy a Jetta? :sick:
  • kfeigumkfeigum Member Posts: 3
    I changed the O2 sensor Pre Catalytic and now its just giving me a P1128 code. HELP
  • tradrockrattradrockrat Member Posts: 2
    Hey all -

    The car has serious lack of power - replaced spark plugs, wires, air and fuel filter cause it was time anyway - no help. Before going and replacing cat converter I decided to get the codes - engine light was blinking.

    Checked trouble codes and got multiple misfire readings - 0300 / 0301-02-04

    Any idea what to check next?

    Thanks
  • bpeeblesbpeebles Member Posts: 4,085
    If you replaced the plugs and wires and still get misfires... perhaps the ignitor coil is suspect.

    This is easy to check. With engine idling, use spray-bottle of water to lightly spritz the ignition components and coil. If the engine stumbles at all, you have found your problem.

    Also make CERTAIN that when you routed the ignition-wires that they NEVER touch each other nor any metal. (the wire-spreaders are there for a reason.)
  • tradrockrattradrockrat Member Posts: 2
    No luck. Do these 2.0's have a history of head gasket issues? I'm asking cause I replaced the coil and the problem persists, but this time it ran OK when started, but got very bad once warmed up.
  • gramm6654gramm6654 Member Posts: 3
    Hey there, I have a 2002 2.0 Jetta - 46k. I was told by the dealership that it needs a new Alternator and they want $700. Seems a bit steep to me. I'm not that educated on repairs, and from what I hear VW's require a specialst to work on them? Can any place repair the alternator, or do I have to go to a VW specialist?

    Appreciate any guidance you can give, $700 is a big hit to the budget right now that I can't afford.
  • asifgrkhanasifgrkhan Member Posts: 13
    Hi,

    I have a 2000 Jetta 2.0L Automatic in Honolulu, HI. The odo reads 77k and I purchased the car at 60k.

    1. I know that for this model year, VW recommended 40k between timing belt changes and dont have any records whether the previous owner did so.
    My question is 'how much does it cost - including labor' and are there any pointers to any shops in Honolulu avoiding the delaership.


    2. For the past couple of months, there has been a rattling sound coming from the silencer/muffler - almost like a couple of nuts are loose in the area. This usually occurs when stepping on the gas and is more pronounced during a cold start.
    Does this call for a catalytic converter change? Any ideas on the cost (incl installation of this) would be very helpful.


    3. In Honolulu - which is mostly stop-go traffic with verly little highway Is this what is expected?

    Mahalo and Thanks in advance,
    Asif
  • ldruthldruth Member Posts: 2
    My car starts fine, idles fine. But, when I put it into gear it takes off without touching the gas pedal. Disconnected the MAF connector as someone on here suggested and it works fine, other then it idles a little rough. Would cleaning the MAF help or do I need to just replace it. Also, My engine light came on, is there a way to make it go off, besides disconnecting the battery?
  • ldruthldruth Member Posts: 2
    My car starts fine, idles fine. But, when I put it into gear it takes off without touching the gas pedal. Disconnected the Throttle Postion Sensor connector and the problem is gone, other then it idles to low. Also, My engine light came on, is there a way to make it go off, besides disconnecting the battery? Manual says I have to reset my "basic setting" with a VAG1551 Scan Tool. Where do I get one?
  • jeffyscottjeffyscott Member Posts: 3,855
    On #2, did you check if maybe it is just a loose heat shield?
  • 600kgolfgt600kgolfgt Member Posts: 690
    1) If there is no record of the timing belt being changed - assume it hasn't been changed. I would purchase a timing belt kit from germanautoparts.com and have a private mechanic perform the installation. It will save you hundreds $$$ over what the dealer will charge you. Here's the link for the timing belt kit for your 2000 MkIV Jetta:

    http://germanautoparts.com/Volkswagen/Jetta/Engine/290/6

    The price for the kit w/o thermostat is $119. The price with the thermostat is $159 (I would get the kit with the thermostat). Prices do not include shipping. I would call or e-mail germanautoparts.com for exact shipping charges.

    I've been using them for years (as a long time VW owner), and they're well known in VW enthusiast circles (known as the GAP). They usually ship your order the following day.

    The normal timing belt change interval is 60,000 miles - due to the fact that the factory waterpump is made of plastic and won't last beyond 60,000 miles. The germanautoparts.com timing belt kits include the new and improved metal waterpump which will extend your timing belt change interval to 90,000 miles. The belts (timing belt and serpentine belt) are new and improved designs that will last 90,000 miles.

    I performed a search for private VW mechanics in your area, and the following one has had good reviews:

    Tai Vw & Audi
    (808) 623-4282
    651 Kilani Ave, Wahiawa, HI 96786
    Cross Streets: Between Westervelt St and Mango St

    2) That rattling sound is more than likely the lower heat shield on the catalytic converter. I would ask the mechanic on his opinion as to whether the heat shield is worth saving, removing or replacing.

    3) Since you do a lot of stop and go driving, I would take the car on a good weekend highway run every once in a while. Short of that, given the added heat of stop-and-go driving, I would have the timing belt service done every 75,000 - 80,000 miles.

    Hope this helps...

    Mahalo...
Sign In or Register to comment.