Are you currently in the market shopping for a new vehicle? A reporter would like to speak with you; please reach out to [email protected] by 10/21 for more details.

Dodge Durango 5.7 Hemi Engine Failure

2456789

Comments

  • zan1zan1 Member Posts: 1
    Had same thing happen 80,000 miles motor blown mechanic says he has no idea of cuase all fluilds where good and had been serviced reg. would be greatful for any info as far seeing this prob addressed by dodge. [email protected]
  • tidestertidester Member Posts: 10,059
    Please don't include your email address in posting to our Forums. Thanks! :)

    tidester, host
    SUVs and Smart Shopper
  • louguzmankylouguzmanky Member Posts: 1
    So many similar stories in this forum. I have a 04 Durango with 5.7 Hemi. It is clean and very well maintained...I love driving this SUV! I never had an issue with my Durango, had dealer perform all scheduled maintenance as suggested in the manual. One morning I turn on my Durango and thump, thump, thump...engine dead. I don't understand or accept that an engine that was simply humming in harmony one day can die the next with no warning. I'll keep calling Chrysler knowing that I will never hear "we'll send you a new/reman engine"

    The dealer is asking approximately 7,000 for a replacement engine. I live in Kentucky, outside of Louisville. Does anyone know of engine suppliers that may come in less than what I have been hearing? Any help is greatly appreciated.

    Thanks
    Lost without my Durango =(
  • smleistsmleist Member Posts: 2
    Looks like i'm stuck with a $10,000 lawn ornament. I can't afford to have the engine replaced. Luckily I wasn't driving when mine went. Maybe that is why I don't have a big hole in the engine. I am still able to start it, but it makes a very loud and fast ticking noise. Won't be driving it, that's for sure. What sucks the worst, is that i'm still paying almost $300 a month in payments for a vehicle I may never drive again. I can't let my credit take a hit on this, because I will need to get another vehicle eventually. My 3 kids are hoping for a recall as well, so that they don't have to be dropped off at the day-care at 5:30 in the morning anymore. Keep me posted on what comes down the pike. smleist at hotmail dot com
  • tidestertidester Member Posts: 10,059
    Please don't include your email address in messages posted to our Forums. Thanks.

    tidester, host
    SUVs and Smart Shopper
  • mepoillionflmepoillionfl Member Posts: 5
    I had the Dodge put mine in. I really didn't have the money to do so, but I figured that if I am spending $7000 on a new engine I wanted a warranty. So now my Durango has an engine with a warranty.
  • jkthorpejkthorpe Member Posts: 1
    Hello Airborne,

    I have a 06 Jeep Grand Cherokee with the 5.7L Hemi and I am on my 4th engine. Each time it has been replaced I have asked for the accompanying tech form for the engine and each time I have been told that they do not exist. Also I have never been told what happened to the engine. I got 30K miles out of the original, 2K out of the second and 6K out of the third. I have also requested a call from the Chrysler Regional Manager but again nothing. I would be interested to hear the results of your tear-down if you have the time.

    Best regards,

    Ken
  • mechanicskidmechanicskid Member Posts: 1
    After reading most of the posts in this forum I am not feeling good! After driving around all day, no issues, I went out to start my truck and it fired then stalled. On re-start it cranked until i opened the throttle then it started rough and would not idle. I was able to get it to the dealer by maintaining rpm with my foot on the brake. It felt like restricted fuel flow or a plugged exhaust at first, no loud bangs or rods through the block. The dealer finally called me and told me #7 had a dead miss, ignition checked good, may be a bad valve spring or rocker arm assembly.
    With everything I have read here it should be an interesting discussion on Monday. The truck has 145,000, excellent condition and maintenance, no heavy use unless pulling a horse trailer for 4H counts has heavy use. Like many others no warning at all, just stalled at startup.
  • autorecyclerautorecycler Member Posts: 5
    I have a 2006 jeep commander with 77k oil changed every 4k with mobil1 at 100.00 per oil change my wife came out of the store started it BOOM 0 comp #1 cly smashed spark plugs dents in the piston. the only good news I am a ex mech of 25 years I can fix it myself for a fraction of the cost when I have the time. the BAD news is for dodge is I have been in business for myself for 18 months and doing well was looking at a 2010 ram with a hemi for a company truck and a challenger for my daughter when she turns 16 you just lost $60,000.00 in car sales I will do like the rest of the americans get smart and buy a nissian or honda
  • vadacvadac Member Posts: 1
    I had been having problems with my Durango starting, the check engine light came on, took it to the Dealership to have it checked. They said they couldn't find anything wrong with it. It had 120K miles on it, they said to do a tune up. We keep up with the maintenance like clock work, it is paid for and I want to keep it a few more years before jumping in to another note. The dealership quoted me $650 parts and labor to change the plugs and wiring harness. We purchased the plugs and wires at Oreilly for under $100, and spent the afternoon changing them ourselves. The light went off and it ran fine for 3 days, the light came back on and then I had to start accelerating it to get it to catch. It would try to turn over, but wouldn't start unless I gave it the gas. It got worse so I took it in and told the dealership what was wrong. They called me 2 days later and said the Auto Light Platinum plugs I put in it were gaped at .056 and I needed .040 and that Auto light plugs won't run in a Dodge, I needed any other brand but Auto Light, WTH???? Oreilly and Auto Zone both recommend the Auto Light Platinum on their web sites. I called 2 Oreilly stores and they both recommended them also.
    After hearing all of this, I am really scared now. I can't afford to replace my engine. I am going to the dealership on Monday, we will see what happens from here.
  • regina9524regina9524 Member Posts: 4
    i also had a problem with the engine with the rod going through the engine
    i was told to call national highway safty comm there is over 56 complaints so please call they are the ones to do there re-calls this is the first step so please call
  • deanosdeanos Member Posts: 1
    Oh my just when I thought I was alone w/ this problem! I purchased a New (w/ 26 miles on it)'04 Durango w/ Hemi engine in Jan '05. For almost 2 yrs. I took it to dealership several times for same problem...ONLY when it rains, the car would just start shaking & vibrating like it didn't want to go. Each time I take it there, couldn't find anything after rainy weather has stopped. Decided to drop by 1 day as it was raining & while it was doing this shaking in mid-summer. Code problem showed up as a Misfire on #4. They weren't certain if needed to replace coil pack, wire, or if maybe leaking in to car looking as if an electrical problem. One morning in Oct '09 went out to crank it & just started shakiing & sounded like a vaccuum sucking up trash(really loud noises). Quickly shut it off. Had it towed in to the dealership. The following day they called & said engine was done & $7,000 estimate to replace. I was very ANGRY about this b/c by then it was no longer under warranty & couldn't pay anythiing towards repair. Engine failure w/o any kind of warning except for the same problem I kept telling them about. I got it fixed but this forum shows that Chrysler really do need to recall & give replacement $$ for repairs for these Durangos. That's fine that they fixed the problem when the new '05's came out but how many '04's did they sell w/ this problem? And what do the owners of these '04's do once it happens to them.
  • evw1959evw1959 Member Posts: 11
    I dont know if the rain had anything to do with the engine failure but I had a similar problem before my o4 engine totally crapped out without warning. I noticed that after rains when i opened the two back doors water would come running out of them. Apparently the 04s had a common problem where the channels around the sun roof and doors would become clogged with debris. In my case it was mostly some fluffy stuff that came from the tree over my driveway. Anyway, when the channels become clogged the water would flow into the doors and, more importantly, into the fuse box located under the drivers side dashboard. Since your still driving your durango [and i would get rid of it if i was you] you might want to have your mechanic check it occassionally to make sure that you no longer have this issue. The water wont typically pool in the fuse compartment but it will get real damp in there and can screw things up. Someone wrote an article about it a while back in a trade magazine and thats how my mechanic figured out what that problem was.
  • autorecyclerautorecycler Member Posts: 5
    I have a update I took apart my 5.7 hemi 1# cly intake valve seat came unglued or whatever dropped under the valve, then the valve hung open the piston hit the valve
    ENGINE damage. Like I said I am a EX master tech its just trying to find the time to work on it in this texas heat. Now that the left head is off I can see the piston has been beat to the ring looks like the head has been beat with a hammer. the cly does not have any damage I am going to pull the engine out put in on a engine stand replace 1# piston and rod and both heads, I can get by with just the left head but with my luck the right side will come unglued and BOOM again I hope I can get another 77k on my repair est cost 2 heads, 1 piston and rod, gaskets around
    1300.00 with of course free labor (THE problem valve seat comes undone)
  • hemichichemichic Member Posts: 2
    Wow I am glad I am not alone with this problem. My durango started missing when it was raining. I just figured something was getting wet and blew it off. About a month after that started happening it would keep turning over before it started. Well I had a 94 jeep grand cherokee with a v8 that did the same thing and I never had any other problems with it so I blew that off too. Well I drove it Friday to work and it ran fine. I parked it friday evening and didn't try to start it again to sunday night. Now it is knocking bad in the top of the engine. My husband is going to see about the damage tomorrow. Our whole family are die hard mopar people, but this really sucks and dodge should back their products.
  • drrighteousdrrighteous Member Posts: 49
    WOW, is all I can say.
    LAST WEEK it happened to our Durango. At 132K miles, with meticulous maintenance, it slung a rod through the side of the block without warning as my wife was driving home.
    The other weirdness is common to this one too. The rough idle when it rains.
    We would get a cylinder misfire code, chalked it up to maybe needing ignition wires. But it ran great otherwise. A few days before the engine blew, it wouldn't start. If you turned the key it would try to turn, but wouldn't. Check battery, connections, all were fine. But then it started fine. No problems for several days until it finally failed.

    Needless to say I'm SICK over this. We still owe money on this vehicle. We went all out and purchased this because we wanted a NICE new vehicle for a change.
    This isn't a Kia. This is a $40K American Made vehicle.
    I'm BEYOND pissed off about this. We cannot afford the $3000-$4000 it will take to fix this.
    I'm going to the NHTSA site right now and fill out a complaint!
  • hemichichemichic Member Posts: 2
    Update on my durango! My husband started taking it apart today and come to find out it has slung a rod threw the side of the oil pan and cracked the block. I am pissed. I called chrysler today and they told me they have never heard of other people having this problem, so I asked what could have caused this problem and they said a number of things. I said name one and I quote " we cant do to legal matters". I was so pissed and went on to tell them that chrysler should back there products better than that. I told them that I had found numerous people on the net that was having the same exact problem and they said that you can't believe what you see on the net. They also told me that because I had bought the vehicle used that I didn't know how it had been up kept by the previous owner. I told them I have had the vehicle for three years and If it had something to do with the previous owner I thought something would have went wrong before now. My husband is a mechanic so he is going to break it down and see what caused the problem. I really think I am going to put a used motor back in my out of an 05. I don't want another 04 hemi. Everyone that has had this problem needs to complain to chrysler and post what they say. The number is 1-800-247-9753
  • evw1959evw1959 Member Posts: 11
    Hemichic - chrysler reps are either liars, stupid, or both. They tried pulling the same used vehicle purchase with me until I told them my durango was considered "used" because the dealerhad taken title to it when it was in the Houston Auto Show and it had a grand total of 24 miles on it. How they can say that they've never heard of this problem without breaking down laughing is amazing. I got an email back from them saying they were sorry that I had a bad experience with their vehicle & they would pass my comments on to their public relations office. I wrote back that as soon as the next weather forecast called for snowballs in hell I would run out and buy another chrysler dodge product. I haven't heard anything back since.
  • drrighteousdrrighteous Member Posts: 49
    From my research about this issues, it appears it effects 2004 models. The later hemis are not effected. Obviously this is a KNOWN ISSUE they corrected in the next model year.

    I know guys with Hemi Chargers and trucks that seriously abuse the them racing them using Nitrous. That puts tremendous stress on an engine and they are not having problems. This is why I had such confidence when I purchased our 04 Durango. I wanted something that I would have years of trouble free service out of. We have owned it less than 2 years, this happens. Somebody pass the Tums.
    We are currently hunting a used engine but specifically a 2005 model.
  • mepoillionflmepoillionfl Member Posts: 5
    You may want to re-consider your 2005 engine search. My Durango is a 2005 and the engine totally blew coming down a dangerous mountain in Tennessee. As I have told the story on here before, when the engine died we didn't have power steering or anything. I had a mechanic that told me about the problems with these engines so yes they know. He was the one that told me to go to this website. We need to take this to the public, because Chrysler sure isn't doing anything.

    I didn't have the money to get it fixed. So I borrowed it and had a new engine put in so that I had a warranty on it. I am a Realtor and need my car to make a living.
  • drrighteousdrrighteous Member Posts: 49
    edited September 2010
    Ahh, at this point we might even sell it once we get it fixed. We really don't need it anymore. My wife is driving 60 miles round trip to work and back and needs something much more fuel efficient.

    OH< here is something for those hoping for a class action law suit;
    Chrysler isn't liable.
    The current Chrysler ISN'T THE SAME COMPANY that built your Durango.
    That is part of the bankruptcy provision.
  • steverstever Guest Posts: 52,457
    It's my understanding that the new Chrysler assumed the warranty obligations of the old Chrysler.

    nclc.org
  • drrighteousdrrighteous Member Posts: 49
    Well, the options were not numerous.
    A brand new engine from Chrysler $3500+ whatever labor to install it. :mad:
    A used but "tests good" low mileage engine $1650+ labor. :(
    Do nothing. :sick:

    We opted for the 2nd option. Also I am getting the blow engine back so I will be able to find out what killed it. I suspect failed valve train parts but we will see.
    Turns out my inlaws offered to loan us the money to get it fixed because it is "their little girl's car"
    What ever. In the hole already, just dig it deeper. :cry:
    A mechanic that is a family friends is doing the work.
    We expect to get it back probably in another week.
    There is a Dodge board I'm a long time member of I have a related thread going.
    I will post photos of the carnage for those keeping track.
  • mqtmqt Member Posts: 2
    I had the same issue with my 2004 Durango on Sunday. While taking off from a stop light - normal acceleration - when I got to 30 MPH the vehicle started to shake and a loud thumping from the front end. I pulled over thinking I blew a tire at first, but the thumping continued after I stopped.

    I limped it the 1/2 mile back home and left it sit. I started it up later in the day. It was barly idle, with the tell tale ticking sound so many others are mentioning. I could also hear like it was puffing air but there was nothing visable. I shut it off and checked the dip stick - coolent in the oil. I also removed the oil cap and had exhaust come billowing out.

    I had it towed to the dealer, they said the engine needs to be replaced. He said about $8000 for a new motor, $4000 - $5000 for a used motor, installed. The one that got me was when he said the motor would come with a 100,000 mile warranty (I wish my current one had that).

    This vehicle has 79,000 on it. Other than the engine, the vehicle is in great shape. I have had no problems with it. I had all service work done at a dodge dealership - until chrysler decided to close all of them in the county. I couldn't justify the 30 miles one way to get my oil changed.

    It is sitting at the dealer right now - I am waiting for the service manager to return from training to see if chrysler will do anything about it.
  • usscout5usscout5 Member Posts: 3
    had the same exact issue in april at 71k. the piston broke apart and smashed everything. After arguing with dodge and had extended warrenty take over they put a new engine in it ran 5 1/2 months and 6078 miles until the exact same thing happened. The reason so the engine builder says is that dodge used the old intake that would have had metal fragments in it from the first blown engine so now i am fihing with dodge and tryin to get them to replace the engine since the warrenty ran out 78 miles ago.
  • dead_durango1dead_durango1 Member Posts: 1
    I have a 2004 Dodge Durango with a blown engine. My 5.7 Hemi has approximately 96,000 miles on it. My vehicle's engine has been properly maintained for the four years I've owned it. I've kept the oil changed every 3,000 miles, have run only high octane fuel in it, and put less than 10,000 miles a year on it. My 17 year old daughter was allowed to drive it to her dental appointment which is thirty miles from our hometown. However, she was not able to get out of the driveway. She called and told me the engine was "banging," and I don't mean slang for awesome. So, she took her old Maxima with over 200,000 miles to her dental appointment, and when I got home, I found out what she was talking about. The engine had thrown a rod. I called Chrysler to ask if there is a recall on the vehicle since after researching my problem on the internet I found that my engine failure is not an isolated incident. I understand completely that I have no warranty on the vehicle, but at such a low amount of miles, I assumed that Dodge had realized with so many reported and repeated problems for this engine that they have an obvious mechanical or engineering defect that needs to be corrected. Unfortunately, Chrysler does not agree. After talking to several agents at Chrysler, I was assigned a case manager who had come to the conclusion that I was on my own, but they wanted to offer me four complimentary oil changes! I did not make that up. Four oil changes for my blown engine. I've babied this vehicle; most of the miles on my Durango have been highway miles. I"ve only hauled a trailer a handful of times. This vehicle should not be worn out. I still have two years to pay on it. As a poor school teacher who relied on this vehicle for transporting his family safely, I am severely disappointed with Chrysler's choice to ignore so many people who have experienced this very same problem of counting on Chrysler to protect our families with a reliable vehicle built to safely carry our families in traffic and through all types of weather. What if the rod would have been thrown as my daughter was driving through the curvy interstate filled full of 18 wheelers? Is it going to take a death for them due to their engine incompetence to respond? What will it take for Chrysler to admit they sold an inferior product? I have five other vehicles, and they all have over 100,000 miles on them. I buy vehicles to keep and to last. I made a mistake trusting Chrysler. I did the same with a 1998 Buick Regal; I won't buy another Buick, and now I won't buy another Chrysler.
  • autorecyclerautorecycler Member Posts: 5
    Thank you all for all the information on the 5.7 hemi's I got lucky replaced left head #1 piston and nec gasket's about 700.00 and 4 sunday's I was able to flush out the intake manifold it had the valve seat fragments if it was'nt for that tip I would have blown the engine again thank you again,
  • danbarniedanbarnie Member Posts: 1
    My son bought a 2004 2500 with a 5.7
    changed oil every 3000. Has less than 100,000 engine blew. dodge
    wants 8000 plus. sounds like there a lot of unhappy people.
    .
    I will never buy a dodge again.
  • awblackhawk1awblackhawk1 Member Posts: 4
    :sick: I have a 2004 durango with 5.7 hemi . Never a problum, A couple of days ago while riding around in the neighborhood at 20 miles per hour or less it began shacking, vibrating, and knocking as I have never herd. I did make it home, and shut it off. It would not start and the lights on the dash were acting really funny and things were buzzing.Really strange things. I checked the battery , it was shorted out, I got a new one and things started working again, but when i started the engine its got a very loud knock on the left bank under the valve cover with every rotation of the engine. WHAT THE . I think it may be a bad valve spring or something to do with a valve. Any ideas thanks
    .
  • drrighteousdrrighteous Member Posts: 49
    The issue with the hemis is the harden valve seats coming out of the aluminum heads. If you don't know aluminum heads have to have a hardened steel valve seat pressed into them. This is because aluminum will quickly deteriorate and does not make a suitable exhaust seat, steel must be used. Steel and aluminum expand at different rates. Also because of different types and quality of gasoline the hot exhaust valve can instantly "spot weld" itself to the steel seat and in some cases yank it out. This is a big problem because of unleaded gasoline. The led protected the engine from this kind of damage (thanks EPA) This has always been a downside to pressed in exhaust seats and the machining and material selection is super critical. Looks like this issue is known, since it happens to must people when their vehicle is out of warranty, they chose to pretend it does not exist. The newer Hemi have better quality than the 03, 04s do. This isn't an issue with them. Looks like the early Hemi vehicle adopters are the Ginnie pigs.
  • mqtmqt Member Posts: 2
    To follow up on my engine failure. . .

    After waiting for the dealer for 1 week they told me because the vehicle was out of warranty there was nothing they could do for me, and they suggested opening a case with Chrysler. On Oct 18th I opened a case, giving all of the information about the failure. I also noted that the vehicle had regular maintenance at my local Chrysler dealerships until they both closed about 2 years ago. I also noted that this was the 3rd new Chrysler vehicle I had bought from the dealership. I referenced the several similar cases listed on NHTSA website and this board.

    I had to call them a couple of times but they agreed that Chrysler should do *something*. After a week they asked that I authorize the dealer to tear down the vehicle so they could determine the cause and make sure it was not abuse. After doing this I waited 2 weeks. I called the dealer asking for status. They said they were waiting a call back from the case manager at Chrysler. I called Chrysler, and they said they were waiting to get back information from the dealer. This went on for 2 weeks, until I finally facilitated a conference call between the dealer and Chrysler.

    One more week went by and the Friday before Thanksgiving my case manager at Chysler called to let me know that they had received all of the information from the dealer but because of the cost that they would need to escalate my case. I was figuring on another week, but was pleasently supprised when she called back 10 minutes later saying that it was approved.

    Chrysler footed the bill less a $500 deductable. I got a used motor with a 3 year/100,000 mile warranty. It took another 10 days but I got my vehicle back last Tuesday.

    All in all I was out a vehicle for 51 days and it cost me $500. Because I have an extra commuter vehicle I was able to wait it out with Chrysler, and was not in such a hurry to get my Durango back. This saved me about $4000. It ended up being about the happiest $500 repair bill I ever ended up paying all things considered.
  • mr_karpymr_karpy Member Posts: 1
    My 2004 just let go on Monday. Wife's car since new, all maintenance documented, but from what I see here the volume of failures is not enough for Dodge to acknowledge. Filed a report on the NHTSA but doubt it will help. Has anybody been able to find the Mopar part # for a complete OEM engine?
  • la415m3la415m3 Member Posts: 2
    My 2004 Durango with the Hemi also blew a connecting rod causing two major cracks in the block. All the oil leaked out and now it sits in my dealer needing a new engine. It has 71,000 miles and the dealer tells me the powertrain warranty wouldnt even cover it, not to mention that I am 1800 miles past 7 yr/70K warranty period. After doing some research, I discovered all these similar complaints. I filed a complaint with the NHTSA and going to make a call to the corporate offices tomorrow. My Durango was in great shape too.
  • awblackhawk1awblackhawk1 Member Posts: 4
    Well my problem was not as bad as I thought, I told the service manager where to look and was dead on it ,The number 5 cylinder broke a rocker arm , 480.00 and back on the road. I feel we got lucky. I did call corp. and told them if the engine was blown, I would expect help. The only thing that was on my side was the fact that I bought it new, and had all the service work done at the dealer. I do believe they would have helped me if it cost more or it was completely destroyed.
  • hazmat1980hazmat1980 Member Posts: 3
    2004 Dodge Durango 98,000 miles, had a ticking noise coming from the valve train and then let go completely. Working on tearing it down to see exactly where the problem is.
  • hazmat1980hazmat1980 Member Posts: 3
    Well, finally got the motor out. Found out that the ticking noise was #7 cylinder connecting rod was bent and hitting the baffle above the crankshaft. It broke, as I was driving it onto the lift, and sent the rod through the side of the block. The weird part was that when i had a stethoscope on the motor it sounded louder from the top, which is why i thought it was a valve problem. Working on filing a complaint with NHTSA now don't expect anything to come of it though. :sick: :lemon:
  • la415m3la415m3 Member Posts: 2
    I called Dodge corporate offices. They were very helpful. I had to show proof of oil changes which I did. I had to pay $1500 deductible and a new rebuild (whatever that means) will be installed in my Durango. They forgave the 1800 miles I am over the powertrain warranty. We will see how the new engine works out.
  • tcyrtcyr Member Posts: 1
    I have a 05 Dodge Durango with the 5.7 hemi and it is stalling on me, becoming more fequent. It happens when I'm at a low idle, and when I am turning Very dangerous when you are turning into uncomming traffic. It will start back up after I put it back into park and restart the egnition. I looked this up on line and found other dodge vehicles are doing the same thing and they put a factory recall on them. But when I went to the dealership they looked up my vin and said it was not part of the recall. Very unhappy, and hoping that nothing horrible happens to my family or myself..
  • bklynwenbklynwen Member Posts: 2
    Have your service station or dealer check the EGR sensor, even if no check engine lights have come on.
  • chatito01chatito01 Member Posts: 1
    I HAD THE SAME PROBLEM WITH MY 02 TOYOTA CAMRY.I CHANGED THE SPARK PLUGS AND HELP ME A LOT SO I ASUME IF I CHANGE THE FUEL INJECTORS THE PROBLEM SHOUD BE FIXED.TRY TO FIX IT ASP BECAUSE I KNOW THAT CAN BE VERY DANGEREUS.GOOD LUCK.
  • danland1danland1 Member Posts: 1
    Wow, I had no idea so many had had the same problem I indured just before Christmas leaving my son's hockey game. we weren't even out of the parking lot before we heard that horrible sound, BANG! and then that constant very loud knocking. I knew right away the engine was gone. We did't even make it to the street light to leave the lot. I manage to hup it back in the lot at a crawl and then it stalled and died. Tried starting it again but nothing. I jumped out only to notice oil spilling from the buttom. I was in tears just about. I bought this truck second hand with 57 000 miles and had all the history from it from car proof. Turns out it was a lease return where previous owner made regular oil changes and maintenance done at dealership.
    I got the engine replaced with a 2005 5.7 hemi from a pick up truck with 39 000km on it but at a hefty price of $4000 installed and 90 day warranty. So far so good.
    Turns out my blown engine when mech"s took it out of the truck had a broken piston arm. which had the piston still in the cylinder and the reminder of the broken arm still connected to the crank which caused two large holes on both sides of the block from the arm swinging like mad around the crank.
    I asked how does this happen to the mechanic who himself drives a hemi and had no idea. I seen the damage with my own eyes and could not believe the size of both holes . 3 inchs in diameter and about 2" on the other side.

    Funny how I had just gave it an oil change the week prior. Engine was very clean, not sluge what so ever. Didnt bother with Chrysler due to it being a second hand car . Too bad.

    So now I have a just about new engine with a good looking truck again. it is a 2004 but still looks great, still turns heads. :sick:
  • boonefamilyboonefamily Member Posts: 1
    We have a 2004 Dodge Durango with a Hemi engine. We have kept the maintenance up and it has about 100,000 miles. We just took a road trip last weekend without incident.

    Friday, my husband goes out, of course after cleaning the truck and making it shine, to go to the store and gets absolutely nothing except noise. No warning, no signs of a problem - absolutely nothing! The dang thing just died without warning. Our story is the same as most on this site - now we are debating whether or not to replace the engine because the exterior and interior of the truck is still in great condition. :cry:

    We are stumped! My husband found this site while searching for answers and we sure wish we had know this before making this purchase. :surprise:

    I understand that folks are thinking about a class action suit. If a suit is brought against chrysler (they don't deserve a capital letter), we are definitely in and will help lead the charge. :mad:
  • tbird37887tbird37887 Member Posts: 4
    Any help available... My girlfriend parked her 2004 Durango 5.7 Hemi Friday after work, was running perfect, no noises no engine lights running great. Went out Tuesday morning to take her to dr and soon as hit the key BAM blown motor I am guessing, afraid to let run afraid the crank or rod will let go and ruin the block but I cant even find a rebuild kit. Help 83k miles and perfect body. Any help out there or from Dodge?
  • autorecyclerautorecycler Member Posts: 5
    Sorry about the mess your in I was there last summer with the 06 hemi commander a few pages back, I repaired my hemi, the steel valve seat comes loose in the alum head gets under the valve then the piston breaks up the seat you might get lucky like me, for some reason its always the drivers side, I replaced 1# piston and rod assy, new head, gaskets and fluids about 700.00 doing the work myself becareful not to run the engine the rod could break the block and you will have to replace the engine also make sure who ever does the work to remove all the framents out of the plastic intake manifold or the same thing will happen again good luck
  • joeyghemi07joeyghemi07 Member Posts: 1
    wow. SAME THING HERE.I came home from work on a thursday friday morning went to start the truck up. nothing we thought it was a starter husband changed it cranked it up heard banging.. and that was it the rod went through the oil pan..no sure what is gonna cost for a new motor but i love the truck.
  • just_sayinjust_sayin Member Posts: 2
    I am looking at a 2004 Durango with 116,000 miles on it (for a second vehicle to tow a travel trailer). It is the limited edition with a Hemi in it. Is it worth the risk to buy this vehicle with this many miles on it? Thanks.
  • regina9524regina9524 Member Posts: 4
    i got 5,000.00 from them for my 2004 i never gave up and a chrylser dealer never put the engin in for me i went to a privet place
  • kaykaywckaykaywc Member Posts: 6
    How did you get $5000.00? Was your truck still under warranty? How many miles did it have on it? Mine was out of warranty but it still should have lasted longer than it did. I ended up getting another motor and now I'm afraid the same thing will happen.
  • regina9524regina9524 Member Posts: 4
    i have a 2004 88,000 miles out of warrenty the rod broke i belive in june and i finilly got the 5,000 from chrysler in dec if you want to talk e mail me at [email protected] and i will give you my cell number
  • jayebonde06jayebonde06 Member Posts: 1
    i had the same problem in 06. i called chrysler they did not help and had to get a new engine
Sign In or Register to comment.