Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

2012 Chevrolet Equinox

245

Comments

  • Hopefully the high pressure fuel pump replacement will do the trick, waterviolet. We're definitely available to you after the repair is completed as well to follow up on this.
    Have a great weekend, and we'll try to keep an eye out for any updates.
    Sarah, GM Customer Service
  • My car is back in the shop. This is time #4. I am getting the runaround from MJ Sullivan (Dealership) and Chevy and my District Specialist (Maria).

    Out of 45 days, my car has been in the shop for 18 of them. That is 40%!

    This time the incident happened when I was on the high way with my 8 year old god son in the back seat. My car is unsafe. And I am not getting help.
  • jessicas6977,

    If you would like to forward us either the last 8 digits of your VIN or the case number (or just contact Christina again as she should be able to locate the case if she set it up for you), we will check into the progress of the Service Request.

    Sarah, GM Customer Service
    [email protected]
  • I sent the info on Friday
  • Hey everyone,
    I got a 2012 Chevy Equinox about 6 months about and it was perfect. Now I am experiencing a rough idle. I'm sitting in the car at a traffic light and feel the car vibrating. I put my head on my window and my head is vibrating. I've taken it back to the dealer 3 times and they can't seem to find what is wrong with it. I am just frustrated right now. They have the car right now for the 4 time to see what they can do. Anyone else have this problem?
  • gmcustsvcgmcustsvc Posts: 4,252
    Good morning bryan5589,

    We're sorry that your dealership has been unable to pinpoint the rough idle concern you're having. If you would like for us to follow up on this with them for you, please contact us at [email protected] (include your name and contact information, a summary of the situation, the last 8 digits of your VIN and mileage, and the name of your dealership).

    All the best,
    Sarah
    Chevrolet Customer Service
  • I know your pain! as of today NOV 8,2012 my 2012 NOX is in for 4 issues that I have been experiencing, one being the noise coming from the engine compartment. It sounds like a pump. And like your NOX it's after the engine is hot and can beheard at idle when waiting at a stoplite or train. My dealer says that it probably is the fuel pump under the hood. The second pump in tank. Sorry I bought this vehicle. Too many issues for a new car! :mad:
  • gmcustsvcgmcustsvc Posts: 4,252
    mrdubious1,

    We're sorry to hear that these issues are taking away from your experience with your new Equinox. If you wanted for us to follow up on this visit with your dealership, please email us more information at [email protected] (include your name and contact information, a summary of the situation, the last 8 digits of your VIN and mileage, and the name of your dealership).

    Sarah, GM Customer Service
  • Check your timing chain I had similar issues. Head gasket also blew due to chain
  • equinox_atxequinox_atx Posts: 1
    edited November 2012
    I recently purchased a *brand new* 2012 Equinox LT at the end of July. Since I purchased the car, the vehicle has died (completely lost all power, including interior lights) approx. 10 times. It has happened in all of the following situations: In Drive, Reverse, Idling, Park, Full Motion (50mph), day/night, flat/incline, EcoDrive and out of EcoDrive, remote started and w/out remote start.

    The problem is so intermittent that it has happened twice in one day and also gone a month in between happening. At first, I thought maybe it was just a "tuning" issue (not knowing that this is not how these computer operated cars work this day) because most of the time it happened I had just started rolling or driving. However, when it died at night while I was going nearly 50mph, it created a dangerous, unsafe situation and I had it towed to the dealer immediately.

    The dealership I purchased it from has now had it 2.5 weeks. They tried to return it to me after one week but I insisted that they keep testing it and that the car is unsafe to drive until the issue is found and remedied. The computer does not recognize any issues. (One would think that your car dying while in drive going 50mph would be logged somewhere!) They have put nearly 700 miles on it trying to duplicate the issues and have not yet been able to. They said they "may have fixed the car without even knowing it". They also said they have not been able to research and find any similar issues with any other Equinoxes.

    Any suggestions would be greatly appreciated. Thanks!
  • gmcustsvcgmcustsvc Posts: 4,252
    Good afternoon equinox_atx,

    We're sorry that the dealership has had a hard time diagnosing what happened with your Equinox; if you want for us to check into this further, even if it's documenting your concerns until we have success getting this resolved, please email us at [email protected] (include your name and contact information, a summary of the situation, the last 8 digits of your VIN and mileage, and the name of your dealership).

    Sarah, GM Customer Service
  • I bought a 2012 Equinox 1LT FWD, 4 cylinder in August 2012 and have about 5000 miles on it. It is currently sitting at the dealer for the second time this week awaiting a new heat actuator.

    On the coldest day in the life of this vehicle, I did not have any heat. When I took it to the dealer, they told me that it worked fine for them but back flushed the heater core and returned it to me the next day. On the drive home that night, the heater faltered again and the service department at the dealership basically told me that I don't know how to work my car.

    Should this kind of thing be happening at 5000 miles? Has this problem happened to anyone else in this model/year?
  • gmcustsvcgmcustsvc Posts: 4,252
    daizygirl1,
    If you would like for us to follow up on this with your dealership, please email us at [email protected] (include your name and contact information, a summary of the situation, the last 8 digits of your VIN, and the name of your involved dealership).

    Sarah, GM Customer Service
  • Purchased a new 2012 Traverse LT in June, Experiencing Rough idle when first starting after a long sit, and engine noise when cold (sounds like a pulley).
  • gmcustsvcgmcustsvc Posts: 4,252
    Good morning alexsmith,

    Have you had this checked into by your dealership? Were they able to locate the source of the rough idle and engine noise?

    Sarah, GM Customer Service
  • Hey Folks, after a few rants and raves on the "Fight for the Recall of the Nissan Rogue" forum, we traded it in and purchase a gently used 2012 Equinox with 15,000 miles on it. I must say that we have been Asian Import owners for the better part of the last 15 years and this vehicle impressed us. Better fuel efficiency, larger cargo space, more legroom, just to mention some of the highlights I have noticed (It's my Wife's Primary Vehicle) I am in the Auto Service Field as an Independent Service Facility Manager, with a technical background, but by no means a master technician.

    I do have some questions about some of the quirks we have noticed.

    When sitting at idle in park, with the ECO enabled, the vehicle has a lower than normal idle and feels slightly rough (800rpm ECO off, 600rpm ECO on) with a surge in idle speed. Disabling the ECO function clears this up and the engine idle returns to normal with no surge or rough idle noted.

    Also, the operation of the transmission is harsher in ECO mode. We live on the top of a hill, with a significant incline to the road leading up to the house. When we come up the hill with ECO enabled, the transmission seems to hunt for the proper gear for the torque required, then abruptly drop into a gear and make the transit up the hill. With ECO disabled, the uphill transit is easier with a downshift that is substabtally smoother and no lag time for gear hunting.

    Has anyone else had these or simalar observations with the 2012 Equinox? Ours is an LS with the inline 4, FWD.

    I have noticed that GM Customer Service is Monitoring this forum. That is alot more proactive than Nissan was.

    I'm looking forward to some responses.

    Rusty
  • gmcustsvcgmcustsvc Posts: 4,252
    Congratulations on your new Equinox, Rusty! Wishing you many safe, happy miles!

    In regards to your Fuel Economy Mode questions, I found the following information in the manual for you (section begins on 9-31). I hope that it's helpful!

    "When Fuel Economy Mode is on:
    . The transmission will upshift sooner and downshift later.
    . The torque converter clutch will apply sooner and stay on longer.
    . The gas pedal will be less sensitive.
    . The vehicle's computer will more aggressively shut off fuel to the
    engine under deceleration.
    . The engine idle speed will be lower.
    . Driving performance is more conservative."

    I think some of these bullet points correlate to the questions you had had. We're available to you if you should have any further questions on vehicle function or want anything looked into further. Please contact us at [email protected] (please include your name and contact information, as well as the last 8 digits of your VIN, with your inquiry).

    Sarah, GM Customer Service
  • Sarah, thank you for the feedback. It does explain/clarify the issues. I am concerned about the idle surge. In earlier model year vehicles, idle surge is normally associated with the idle control valve sticking due to carbon buildup or restriction of the air bypass passage in the throttle body. Have there been other reports of idle surge or fluctuation as I have described? If so, would cleaning the throttle body help?

    Again, the direct feedback is very much appreciated.

    Rusty
  • gmcustsvcgmcustsvc Posts: 4,252
    We can certainly understand your concern, Rusty. Unfortunately I am quite limited in my access to technical information and while I would love to provide more information publicly I have reached the end of my resources.

    As you are well within your factory warranties, it may not be a bad idea to get the idle checked out by a technician with one of our dealers to see if it is normal or not. They would be better equipped than I to make that judgement. If you would like for us to work with you through that process, please don't hesitate to contact us via email at [email protected]

    Sarah, GM Customer Service
  • Everything you are asking is normal in ECO Mode. We have 2012 LT2 Equinox inline 2.4. ECO Mode drops idle to save gas. Car will shift faster to get you in a higher gear to save gas. We have found ECO Mode works best on the road not in town. :)
  • ronwelronwel Posts: 57
    edited November 2012
    I owned a 2010 1LT, and currently own a 2012 1LT Nox. and my father owns a 2011 1LT Nox...each one of these cars has a rough idle when the ECO is turned on. My 2010 really felt like it was going to stall several times the RPMs got so low. The engine would start to stall, then 'catch" itself and rev up again. Your RMP numbers are exactly what mine were.

    I went to my dealer and talked to several of the techs their. Each one of them laughed and said that they have heard the same complains from a lot of owners of ECO equiped cars...not just Nox owners. They all felt that GM was a bit to agressive in "fuel econnomy" in ECO mode, and bsically are starving the engine of gas.

    Since talking to the techs neither my father nor myself run our Noxs in ECO mode...and both idle quiet and smooth.
  • Bought our Equinox 6 months ago. Primary user is my wife who drives approx 30 miles to school each way. Her trip is approx. 70% highway and 30% stop and go. She is very aware of MPG and keeps good records of cost and distance. She is averaging over 30 miles per gallon for her commute. When buying the Equinox I was a bit skeptical about the claim of over 30MPG highway considering 4cyl. and size/wt. of the car. We both really enjoy the ride. It is a tight vehicle and attractive.
  • Bought 2012 Nox 4 cyl .... 2 weeks ago!.Ticking noise in engine.Sounds like a diesel. Its in right now getting a new actuator.. they say that will fix it.I had severe vibration a couple times at stop lights and they say they could not detect it..I felt it right through my seat and up my back...not a comfortable ride .I felt like I was on a tractor...I hope I dont have a lemon..G.M. does not need a bad rap right now.Problems already? I cant believe this.So I know what you mean about the VIBRATION.
  • gmcustsvcgmcustsvc Posts: 4,252
    worried8,

    Congratulations on your new Equinox! We're sorry to hear about the engine noise you're experiencing right now; it looks as though you've been working with your dealership but they are having trouble recreating the condition? If we can follow up with them for you, please contact us via email at [email protected] (include your name and contact information, a brief recap of the situation, the last 8 digits of your VIN, and the name of your dealership).

    Sarah, GM Customer Service
  • We bought the 3.0L v6 equinox 2lt on feb 28th of 2012. It has been fantastic, we now have over 14000 miles on it in 9 months and it is one of the best vehicles I have ever owned. It gets anywhere from 25 to 29 MPG on the highway even though it is only rated at 24 and it steadily gets 18 to 20 in the city even though it is rated at 17. I am a big fan of them now, I would recommend it to anyone shopping for a small suv, the handling is great, it is quiet, the touchscreen is amazing. Love it!!!!!! :) :) :)
  • Equinox purchased new earlier this year, approximately 10,000 miles on it currently. While driving home on I94 last night at 77 MPH I noticed a slight jerk. I then noticed that the service engine light was flashing, the flashing stopped and the light went off. This morning I contacted one local dealer to tell them what happened. The service rep. said - bring it in right now it may stall on you and you won't be able to restart it. Well that was great to hear after I just drove the NOX 35 miles to the next town. I contacted the local dealer where I was at in Valley City, ND. The service rep. told me the same thing, bring it down right away as it may stall.

    I did so, several hours later the service rep. called me to tell me that a P0300 engine misfire code was found in the 4th cylinder. They checked the plug and coil and claimed all appeared to be ok. They test drove my NOX and the code didn't reappear - go figure.

    I have read numerous forums and chats, while doing other research. Is this the beginning of something worse to come?
  • gmcustsvcgmcustsvc Posts: 4,252
    huntered,

    We're sorry that you're having these concerns with your new Equinox. If you would like for us to check into anything further, or to document that you're having these troubles, please contact us via email at [email protected] (include your name and contact information, the last 8 digits of your VIN, and a brief summary of the situation so far).

    Sarah, GM Customer Service
  • This is my bad experience with GM and the dealer who sold it. I bought a 2012 Chevrolet Equinox from Crossroads GM in Corinth MS. After owning it less than a year and only 20,000 miles on it the engine is going to have major work done on it. I have taken it to Crossroads GM for all its service work as scheduled. Crossroads GM told me that they would not give me a loaner vehicle until they started working on mine. I complained and after 3 days with GM customer service they got me a loan vehicle, while mine was sitting outside waiting to be serviced. It has been waiting for ten days now because other vehicles are waiting on parts for repair. I was contacted today to return loan vehicle and would not get another one until they start working on mine next week. Crossroads GM does not care if my wife has a vehicle to drive to work in, she is at work with it today. I need mine to drive to work in. I bought this vehicle through my Credit Union, so GM has been paid in full for it. They do not care about my aggravation or trouble with a new vehicle they sold me. What happens a year later? Will I have more problems with the Equinox? This is fraud and completed neglect for taking care of their customers!
  • Was all set to buy 2013 6cyl 3.6l AWD 2LT. Love the overall size and comfort. Suits me for a lot of reasons. Thought I did enough homework but after reading these forums I am terrified to buy Equinox. The comments here make the Equinox sound like an expensive piece of junk. Some have even called it 'dangerous.' Car reviewers seem to recommend it and the people I've stopped on the street who own it seem to like it a lot. But the complaints here are terrifying! Why is the car repeatedly named a top 5 pick when such serious problems are talked about here? Don't know what to believe.

    Sarah from GM -- has GM addressed what sounds like nagging issues on previous model years so that new car buyers can buy 2013 Equinox with confidence? Please respond as I am in a position where I must make a decision very soon. Thank you!
  • If you read back most of of the problems were 4 banger in from 2009 to 2011. We have 2012 Nox LT2 4 banger. No issues so far. The 3.6 v6 is new for 2013 Nox. 2012 Nox had a 3.0 v6. The 3.6 v6 is a good motor. I have rented Impalas for work. They have 3.6 in them in 2012. Have not heard of any problems with the v6s. You can not beleave everything you read. Some people paid to much for their Nox. That is not cars fault. That is were you bought it. They knocked your head off and made a big profit on you. So do not blame car and make stuff up.
  • jpfjpf Posts: 496
    They have 3.6 in them in 2012. Have not heard of any problems with the v6s.

    Check out the the Acadia and Cadillac CTS forums about this engine. Good luck.
  • Sorry you are wrong. They only had 3.0 v6 in the Nox for 2012. Do your research.
  • jpfjpf Posts: 496
    The Acadia and Cadillac CTS use GM's 3.6 liter engines. The Acadia since 2007 and the CTS even prior to 2007. The 3.6 has gone from non-direct injection to direct injection, but they have have three timing chains. There's been a problem with these timing chains as they stretch. The results are catastrophic when this happens. Check out the Acadia and CTS forums and you'll see. Also, google "GM 3.6 engine timing chain problem" and you'll get many hits. If the 3.6 is made available in the Equinox, down the road, the same problem will likely occur in the Equinox. Good luck.
  • I purchased a brand new 2012 Chevy Equinox at the end of March 2012 and it had 200 miles on it - it was driven from a neighboring city for me. I love my car and it's the first SUV I have ever owned. However, not long after purchasing I began to notice that it "jerks" really hard at least once a week. I called the dealership I purchased the vehicle from and the tech, whom has always been a great help with my other Chevys, said that his did the same thing and asked me if someone else drove it as well. I advised yes it was often driven by my fiance. He said when his wife drove his, since their driving styles were so different that it "freaked" the car out because it has an internal memory of how the car should be driven. I accepted that answer because my friend has a Lexus and was told the same thing about their vehicle a while back...so I assumed this was a new feature on new vehicles.

    Yesterday while on the interstate during 80mph (KY's speed limit is 70 so I was speeding a little) it jerked so hard I'm surprised it didn't give me whiplash! I know the other drivers had to have seen my vehicle vsibly jerk if they were looking that exact moment. I thought my car had just broke right there on the road! It drove fine afterwards, but the "jerking" is apparently getting worse.

    My Knox is scheduled to go into another shop - since I've since moved from my purchase dealer and I was told it sounds like the transmission or the transmission module.

    Has anyone else had or heard of transmission problems in these vehicles? I don't want to owe $20,000 dollars for the next few years on a car that's going to be nothing but problems!!!! :confuse:
  • gmcustsvcgmcustsvc Posts: 4,252
    deltalex,
    Is the shop you're going to be visiting one of our GM dealerships? We want to make sure everything gets resolved, so please keep us updated.

    Sarah, GM Customer Service
  • Well, we are now into the new year and so far there is no indication of further problems with Engine Operating On Reduced Power. The Fuel Pump replacement seems to be doing the trick so far. I just wanted to be sure I kept up with the feedback so others can learn from the Edmunds Forums just as I did! :)
  • I have the same issue. Every time it does it, I have look to see if I was rear ended. This is really annoying. Mine normally does it when I take my foot off the petal and pressing it again close to it shifting. This has happened in a couple of other vehicles that I have owned but never had any of them jerk this hard. There is definitely something wrong with the transmission. I am sure it will eventually break. The dealership says that it is normal but only time will tell. I will not buy another Chevy.
  • gmcustsvcgmcustsvc Posts: 4,252
    rccraig76,

    I see you've already had a dealership diagnosis that this is normal. If you wanted for us to document your concern or help you locate another dealership for a second opinion, please contact us at [email protected] (include your name and contact information, the last 8 digits of your VIN, and a brief summary of the situation so far).

    Sarah, GM Customer Service
  • alamo3alamo3 Posts: 3
    I’ve had no issues with my 2012 Equinox that I purchased one year and 15,400 miles ago. Its positives are the workmanship, the ride, and the spacious back seat. The gas mileage varies depending on how, when, and where I drive. Overall my mileage is 26.5 mpg based on total miles driven divided by gallons used. Many of these miles are in urban traffic and on interstates. My interstate speed is usually 70 mph. At 55 mph I get over 30 mpg. ECO Mode and manual shift are never used. I have been to the dealership twice to have it serviced. At the last service, I asked the mechanic about the 2.4L engine problems discussed on this forum. He told me that with synthetic oil and regular service (around 7,000 miles) I shouldn’t have any problems. So far, I haven’t.
  • lablover2lablover2 Posts: 106
    i am considering either an equinox or terrain but am very concerned with all of the problems with these vehicles, can i ask why using synthetic oil would make a difference? i see so many on the street but after reading all of the problems with them i am very afraid to buy one. surely gm has to have fixed this by now,right?
  • gmcustsvcgmcustsvc Posts: 4,252
    It's great to hear from you, alamo3! We're pleased that you're having such a great experience with your Equinox and wish you many more smooth miles ahead.

    Sarah, GM Customer Service
  • skeet7skeet7 Posts: 10
    I had the exact thing happen to me!!!! In the middle of an intersection, the car just stopped going and then allllll of a sudden, SLAMMED into gear and off I went. It happen a second time while exhilarating onto an interstate, it sput and sputtered like it was going to stop, and then just took off. I've told my husband if I am killed in this car, to do a investigation.
  • skeet7skeet7 Posts: 10
    We just purchased a 2012 Equinox in June. I was so excited and very pleased with all the options I was able to get for the price. The style looks good, and it was a more comfortable 'zip around town' than our Tahoe. I currently have 8,000 miles on the vehicle and literally CRY weekly because I'm so disappointed with this car.

    1. The seats are EXTREMELY uncomfortable for long drives, my driving leg actually goes to sleep. I've been to nerve doctors and MRI to see if I have a pinched nerve...all were negative.

    2. At 2,500 miles the dash began to rattle, it gradually got unbearable. The rattle was more on the passenger side so I dealt with it.....until we took our first trip (see #3). I now was sitting in the passenger seat and told my husband the I do not feel I can listen to this for four hours. I had to wear my earphones the whole trip!

    3. At 3,500 miles on our first "out-of-town" trip, when we reached our destination (after about 4 hours a driving) we exited the car, returned maybe 15 min later and the CAR WOULD NOT START. It made an awful sput and sputter, jerked around and finally stopped. The next try, it started and all was well until we returned home.

    -The next week, we took it to the dealer for the engine problem and the rattle. An engine coil had to be replaced (it did throw a code) and the WHOLE dash had to be removed to fix the rattle.

    -so, back on the road (only now have scratches all on both doors plastic from un-cautioned workers) . Every since the repair, the engine turns over VERY hard when starting. And, I've had the car stop immediately after starting with automatic start (not normal)

    4. About a month after this, I was entering an interstate 'on' ramp, and upon acceleration, the car (once again) sput and sputter like it was going to stop, but then kicked into gear (scared the living daylights out of me)

    5. Two weeks later, I was entering an intersection to turn left. This time upon acceleration the car decided to STALL in the middle of the intersection and the ALLLLL of a sudden it SLAMMED into gear.

    -I took the car in and of course, they could not duplicate the problem. I've informed my husband that if I'm in a wreck, a full investigation should be taken with the car.
    -At the end of the year I just wanted to get rid of it and get in something else, but the dealership has not been helpful at ALLL! Once they have your money, they could care less.

    6. GUESS WHAT HAPPENED TODAY????? THE RATTLE IS BACK!!! Lovely!! I do not have time to keep taking A BRAND NEW CAR in for repairs!!!! This car is truly a piece of crap and would NOT recommend to anyone.

    FYI: We have ALWAYS been die hard Chevy owners. My mother and step-father worked and retire with GM and are proud employees. This has soured the mouth of our WHOLE family!!

    And yes Sarah with GM customer service, I have contacted you and your 'concerned' department. Unfortunately your concern doesn't go past your post on the forum.
  • skeet7skeet7 Posts: 10
    You will continue to be in "Awh" until you get rid of the car! we are on 8,000 and I get sick to my stomach when I have to drive it because they would not work with me to get out of it!! $7,000 upside down and 4 trips the to repair shop with a rental for 5 days is NOT a NEW car experience that I ever want to have again! I struggle everyday to not go trade it in and just be upside down!
  • skeet7skeet7 Posts: 10
    Buying an Equinox would be the worst decision you EVER made. We bought a new 2012 in June, and I cry everyday a have to drive it. It's been in the shop five times, and needs to go back in for a dash rattle that they ALREADY have had to take the dash out to fix. It's unsafe, and I have been told, "SORRY" we can NOT duplicte the problem so many times I can spit.
  • skeet7skeet7 Posts: 10
    We had to same thing happen on our 2012 at 3,500 miles....They had to change an engine coil. Has NOT ran right since! Very unsafe!!
  • OK...I just purchased a 2012 LTZ 6cyl two days ago and am considering asking for my car back tomorrow! I was driving down the road today...car felt a little Jerky, then the stabilitrak light came on and the check engine light started flashing. I pulled into a parking lot...turned it off then turned it back on and everything is fine.

    I'm reading all of the posts about how everyone is afraid to drive their Equinox's and well...i am now!! With all of these posts...has anyone experienced the same issue and had a solution???

    Really looking for some good news! :lemon:
  • skeet7skeet7 Posts: 10
    I'm sorry, but I'm not the one to ask for good news. I've had this car Since June and have been completely unsatisfied. For the look and all the bells and whistles, you could not ask for a better car. I've had the whole dash removed the fix a rattle, that's still there. An engine coil replaced. Two times it stalled in the middle of heavy traffic and then decided to go. The seat is extremely uncomfortable after a 20 min. drive. The control for the radio on the steering wheel decided not to work one day, they are good now. And my USB port disconnects all the time.

    I hate to be a Debbie Downer, but the car just sucks, or at least mine does! There are tons on the rode, and many people who love theirs, maybe that will be you. I wish you the best of luck. Keep us posted on what you do.

    Curious, did you buy brand new or used? Miles?
  • gmcustsvcgmcustsvc Posts: 4,252
    ejwinters,
    We're sorry that you're experiencing these troubles on your Equinox. Have you already consulted your dealership on this?
    Sarah, GM Customer Service
  • I took it into the shop this morning. They gave me a loaner to drive while they are working on mine. It's an LT not an LTZ...the ride in the loaner is a lot smoother than mine. In mine you can feel everytime it changes a gear...up or down. So of course I called to let them know so that they will be aware of it. I'm hoping it's a bad sensor...and not the whole transmission. My dealer in NC bought it from a deal in FL who used it as a courtesy car. It only has 8800 miles on it.

    At this point I'm terrified because of a previous experience with a past car that was in the shop 9 times within the 1st month I had it!!!
Sign In or Register to comment.