Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Chevy Blazer GMC Jimmy Maintenance and Repair



  • I have a 2001 GMC Jimmy. It has always made a popping sound when I turn to the left to tightly. Recently, It has gotten worse. I was told that the front coil spring is out of position and the front end needed to be repaired. The repair will include the front end, Idler Arm, and the Pitman Arm at a cost of about $800. Has anyone had this problem - do you have any other suggestions?
  • james2006james2006 Posts: 6
    hi wanted to know if anyone can help me on this i have 95 gmc jimmy 4dr 4x4 4.3 vortec . does not want to start sometimes. seems its not getting fuel . already put in fuel injectors and fuel pump . but its makeing a lound umm noise seems lounder then should be . could it be the pump again . can anyone help me on this

  • repairdogrepairdog Posts: 948
    2wd or 4wd makes a big difference but have to assume 2wd if a coil spring cause 4wd have torsion bars. Coils have rubber insulators between them and the frame. So, depending on mileage etc could be the center steering link assembly (common) or idler, tie rod ends, hubs, or ball joints - a shop should be able to tell by inspecting and doing some pull/push on the tire/wheel at 12/6 oclock and 3-/9 oclock position, as well as listening to the hubs as they rotate. Now if actually a 4wd its the lower ball joints as #1 fault area and popping.
    Grease all front end fittings and see if it goes away or lessens - any pulling or drift in steering or during braking is also a clue. Also if caliper slide colts are not free and greased they can bind and shift/pop. Have to jack it up and inspect so if you don't trust one shop get a second estimate from a front end alignment shop (sorry but some tire giants may be alittle quick to make work/$$).
  • repairdogrepairdog Posts: 948
    CPI injection under the upper intake is a known problem leakage area and theres a CPI and nut kit (actually the 2 fuel lines) that fix internal leaking and if you smell fuel thats it so search on this and see the many posts. If you test the fuel pressure at the rail its 60 psi key on engine off and 54 running. If when off the pressure drops quickly its the CPI/nut. Pump could be running as fuel dumps in manifold so check this out so don't trash the cat convertor (excess fuel in it) or dilute the oil with gas.
  • james2006james2006 Posts: 6
    ok i was told that the timing chain could be causeing my truck not to run right is that true i am doing a fuel pressure test on thursday morning and putting a new fuel filter. then go from there .
  • jpmccrjpmccr Posts: 31
    Good point on the battery and alternator. However I thought the same thing and replaced both already thinking the problem would be solved. NOPE. :confuse:
    Did I mention that I got his one used and the folks that had it previously put a battery in it that was bigger than the tray! I liked to never got it out and when I did I almost dropped it. Luckily it landed on the plastic shroud cover (yeah right). The corner of the battery punched a hole in it! CRAP!!! :cry: Oh well. I did notice with the battery out the tray had acid on it (cleaned it up with baking soda and some water) and there was some caustic damage to a cover for the hot lead from the battery to where ever it went. If you want I could send you a picture and let me know what you think. My wife seems to think it might be the ignition cylinder. Not sure. . . :confuse:
  • I have recently replaced coil pack and fuel injectors. Now it wont start. it is firing through the coil but not the plug wires. :mad:
  • repairdogrepairdog Posts: 948
    Reread the original and now with the acid point did you pull the battery and tray out and look at the juction under it - you have to look at it and the cable - that cable is multi piece and runs to the starter so pull that out and look and use an ohm meter and flex the cables around and see it reading change - if so replace. Also easier is make sure those side terminals to the cable are clean by pulling the insulator back - it just slides back.
    Wife could be right but unless she has a really haevy key chain full of junk doubt it. When this happens is the shifter in park for sure all the way cause these do have an adjustment on the trans and if off slightly won't start so next time it won't start with the key on (engine off) and your foot on the brake move the shifter to N and then back to P and see if that allows it to start.
  • cwboatmancwboatman Posts: 4
    I've got the same problem with my Blazer. Has anyone heard of a fix. This is becoming a pain, I need to disconnect the battery at hight so the truck doesn't unlock itself. :confuse:
  • repairdogrepairdog Posts: 948
    There is an electronic module that controls the remote/FOB so would guess its defective or a wire in the door control panel has a short or the door switch - you can pull the door panel and check or just pull the fuse to the locks.
  • blaze4x4blaze4x4 Posts: 29
    About when will a radiator on a 2001, with 101,000 miles go ? And what should I expect to pay for a replacement? After idling for approximately 10 minutes yesterday with the A/C on, I traveled 20 miles then stopped for dinner. Upon returning to the vehicle, I noticed about two pints of Dex Cool under the left front cornor of the blazer. Monitoring the temp gauge (never got above 210), I had to travel another 80 miles home while running the A/C. This morning, there is a damp spot in the same location, however the level in the radiator isn't very low at all.
  • repairdogrepairdog Posts: 948
    Could be several things so it was drivers side up front.
    1. Look at the water pump it has 2 holes in the bady that drip when the seal starts to go. Look at the small bypass hose on WP too.
    2. Intake manifold gaskets all leak on the 4.3 motors by 100k so look above the water pump where the engine block and intake meet - any leaksge - usually when hot running and the reservior will slowly drop and often you hear the lifters tap on startup. Could also be leaking out the top area in the V between the intake and valve cover and then runs down - seen both before.
    3. Radiator hose leaking.
    4. Plastic tank cracked below that rad hose - just did a 98 with that. Cost is $150-200 for a new one then you install.
  • repairdogrepairdog Posts: 948
    Cap and rotor mounted correctly? All the wiring and other connectors solidly clipped on?
  • I found # 3 cylinder wire off at plug replaced and check all others. Should I replace rotor and cap?
  • cwboatmancwboatman Posts: 4
    Thanks for the tip. I'll try check the items you mentioned. Just as an FYI, The dealership said one of the relays maybe bad. I replaced all three and it did not correct the problem.
  • guestguest Posts: 770
    You never said what year and model but one of mine is an LT with 2 button memory and 8 way and that one had a short in the seat wiring and took out the remote and seat drive modules - love that quality engineering.
  • wgochwgoch Posts: 4
    Finally got a chance to work on it a bit and removed shrouds, covers etc. to expose wiring in steering column. There is a large junction box about 18" below steering wheel. Appears to be straight through and has continuity (including to the battery on the side towards the firewall. Is the switch you are talking about just under the ignition keyhole?

  • repairdogrepairdog Posts: 948
    So before you did these did it run? Basis question I should have asked. Cap and rotor at 100k or when pitted or arced inside. Same on plugs and wires. 97 had problems with the ignition module often called the switch but not the key/tumbler portion that causes most no start and stalls on 97 only. All power runs thru it and had bad/loose connections internal and most owners change and find it fixes it. Search on 97 blazer ignition switch.
  • repairdogrepairdog Posts: 948
    Yes, in the upper column so go to online lookup sites like autozone or advance (parts america) and look at the part so you will know - or go to the store and they will let you see it. Have to take the column covers off to reach.
  • james2006james2006 Posts: 6
    hey 95 gmc jimmy 4.3l vort does not want to start right seems its not getting fuel i did a fuel pressure test . with key on motor off 60psi then it drops slowly . with engine running its at 50psi and is jumping around . so not sure if its the fuel pump or the injectors and what is the cpi nut i called gmc and they did not know what i was talking about . any help . thanks
  • repairdogrepairdog Posts: 948
    Here's the info on it from an eariler post:
    Leaking CPI regulator and hoses/fuel lines (called a nut kit by GM) under the upper intake manifold. You can remove the IMTV (Intake Manifold Tuning Valve) from intake manifold. Once the IMTV unit is removed, visually inspect the inside of intake manifold. The manifold and injector unit should be very carboned up and dirty. Any clean areas indicate a fuel leak internal to the manifold plenum. Most times this is caused by the fuel pressure regulator leaking fuel from vent hole in the regulator body. Other factors may be present (such as a cracked inlet fuel line) but usually the regulator unit has failed. If no leak is detected through the IMTV hole, but a faulty unit is still suspected then you must pull the upper plenum to get a full view of the inside of the intake.

    CPI was used until 96 when the newer spider type injection was introduced that has its own problems. Good luck.
  • cwboatmancwboatman Posts: 4
    The year is a 98. From reading your comments, this issue can be caused by a number of different electrical failures. I think I've found my problem. While doing my P/D, I started with the rear door/tailgate. The reason being, thats when the problem started, I had the tailgate opened for a couple of hours, thats when I heard the silinoids engaging and disengaging by them self. When I removed the back panel I noticed the windshield wiper, water supply tub was disconnected (spraying water inside the door. There are about (5) different electrical plugs/connection controlling all the little silinoids and latches. I started isolating/disconnecting one at a time and waiting to see if the issue re-occured, which happened every 5 seconds to 1 minute in intervals. Once I disconnected the plug going to the rear door key/switch assemble, the issue stopped. It has been 12+ hour and the issue has not returned. To test my results, I plugged the key/switch back in, the issue started within 30 seconds. I disconnect key/switch connection and plugged the other 4 connection back in and it appears to be working. The only thing I loss by leaving the key/switch disconnected is the ability to lock/unlock rear door with key. I works fine with remote. Looks like I'm heading back to the parts house. :surprise:
  • Hi everybody,

    I was hoping that someone could shed some light as to diagnosing 4WD problems on my '98 Blazer LT.

    Here's the problem:

    When the 4Hi button is pressed, the light on the button flashes and I here clicking noises from the TCCM but don't here the encoder motor activating. All it does is go back to 2Hi, All the buttons light when I start the engine and the 2Hi light stays lit. I've tried changing when moving slowly, in Park and in Neutral.

    I can get into 4Lo by being in Neutral, hear clicking from the TCCM and also hear the encoder motor shift, and the 4Lo light is on. So this seems to be normal.

    If I try to shift from 4Lo to 4Hi, and again, the 4Hi light flashes but it shifts back to 2Hi.

    Off hand, I would think that the TCCM and the encoder motor are fine, but can anyone point me in another direction as to why it does'nt like 4Hi

    Thanks in advance for any help.
  • repairdogrepairdog Posts: 948
    The encoder motor is the low gear in the xfer case engaging. If you get in 4 Lo you should be able to get into 4Hi. Both need to engage the front axle coupler on the pass side and there is a sensor on the axle to send a signal to the TCCM. So, pull the battery cable off for 30 minutes and see if the TCCM reboots and all works OK.
  • cwboatmancwboatman Posts: 4
    I had the exact same problem. There is a separate electronic control module that controls the shifting between 2 & 4 wheel drive. The control module is located behind the side kick plate on the passager side under the dash board. Be sure to disconnect the positive side of the battery before connecting the new module or you will blow it. I'm not sure what the cost is now, but I paid aprox $150 at the dealer about a year ago.
  • First off, I'll thank repairdog and cwboatman for thier replies.

    I tried pulling the fuse fuse for the 4WD rather than disconnect the battery. Did'nt work so I will try the battery disconnect next. What it did do though, is when I engaged 4Lo and then pressed 4Hi, both lights stayed on and when I moved the truck, I was'nt getting any tire chirping that you would get on dry pavement in 4Lo. I did'nt want to drive at any kind of speed thinking I'm in 4Hi in case 4Lo engaged.

    But on a good note, I can hear the axle coupler that repairdog mentioned activating on the passenger side as well as the encoder motor shifting. That would indicate that mechanically, every thing seems to be O.K. (I think). Then again, the TCCM might not be sending all the signals it should be.

    Thanks again for the help :confuse:
  • repairdogrepairdog Posts: 948
    There is a sender unit on the front axle coupler that tells the TCCM its engaged or not, same on the xfer case so one of those may be sticking - ball type that as the shaft moves pushes the ball up - had the front one stick on one of mine before and its a $15 part so if in doubt change it.
  • kaphilkaphil Posts: 1
    I had this same problem and was told my the dealership it would cost 500 to fix. To it to a local shop and it turned out to be a vacum hose had a dle in it. So, check the vacum hoses before you invest any money.
  • gmc2000gmc2000 Posts: 1
    My 2000 Jimmy will not start and the key is stuck. Cannot put it in gear. The lights on the dashboard or anywhere else do not work. What's going on?? Anyone help?!
  • steverstever Posts: 52,462
    Will the key turn at all or will it just not come out of the cylinder?

    If it's not turning, sometimes you can free it by gently moving the steering wheel a few degrees left or right.

    Steve, Host
Sign In or Register to comment.