Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Chevy Blazer GMC Jimmy Maintenance and Repair

1484951535472

Comments

  • repairdogrepairdog Posts: 948
    Could be fuel pump so check the pressure - many posts on that. Could be fuel pump relay also. There is an oil pressure switch and if the relay fails and the oil pressure switch also fails it will shut off but thats not common to have both go together. Any code (SES light)?
  • I got it started today and for some reason it has a little knock and sounds like fan belt sqeaking but its not the fan belt.Any Ideas ??? Idleing real rough... Called a local parts store (Advanced Auto ) and they said cant do diagnostics without the service engine light being on.
  • mattn10mattn10 Posts: 3
    I just bought a jimmy and to get the 4wd to disengage i have to disconnect a vacum line. To get it engaged I have to reconnect it. Any Help will be greatly appreciated.

    Thanks matt
  • mbgld1mbgld1 Posts: 1
    I repaired the secondary air injection pump. I freed up the pump, replaced the relay, inserted a maxi fuse and checked the valve with a vacuum pump and lengthened the intake hose by three feet. I still get a code P0410 after a couple of days. Any ideas?
  • repairdogrepairdog Posts: 948
    Not alot of info for a majpr problem but I'll give you a few things to look at.
    1. Is the coolant dropping - has the lower intake gasket been changed - most go by 80-100k and water gets in the valley area.
    2. Last tuneup - cap,rotor, plugs, wires, feul and air filter by 100k.
    3. EGR valve clogged or stuck - black 2"x3" cylimder mounted on front of engine - remove 2 bolts clean port.
    4. Injection clogged up - run some good cleaner.
    5. Sensors - MAF in intake dirty spray clean, or othres but a code usually shows.
  • repairdogrepairdog Posts: 948
    Look under the battery tray - yea, have to pull battery and tray out and the 4wd front axle coupler is there - vac operated and it pulls a cable to the front axle. Believe you also have a vac fitting on top of the transfer case on 93 that might also be looked at if not the actuator.
  • repairdogrepairdog Posts: 948
    Lucky you - I fixed my 99 and 01 this year too.
    Once the pump runs then you have to make sure it shuts off - after a minute feel/listen to the end of the intake hose and it should be shut off - another solenoid above the pump to open/close that - then did you open (pops apart) the plastic valve in the line by the pump in the large hose - has a diaphram that can clog/burn and that has to be good. Then are the check valves on the exhaust manifolds new and the L shaped little hoses (dealer for hoses but check valves at all auto stores) - most rust out before now and cause the code due to air leaks or staying open - easist way to change those is remove the 2 small bolts on the metal pipe to exhaust and take out of Blazer - the check valve is threaded and rusts to pipe so a vise is usually required. Pass side can be reached but easy way is remove air box on drivers side. Good luck.
  • Just had the lower intake gasket changed about 12 days ago..
  • mattn10mattn10 Posts: 3
    Thanks Repairdog. I will give it a shot when I get back to the states.

    matt
  • My Blazer is stuck in 4hi and will not shift into 2hi. What should I do?
  • repairdogrepairdog Posts: 948
    Pull off the vac line that goes down to the actuator from the intake and see if the front axle coupler disengages. If so push the 2Hi button and see if it goes in. If that doesn't do it disconnect the battery for 30 min and that will reset the TCCM (4wd computer) - hope that does it. There is a sensor on the axle too that tells the TCCM the axle position.
  • I can't figure out where the knocks comeing from, it sounds down low almost under the vehichle.
  • repairdogrepairdog Posts: 948
    Hopefully not your engines rod or crank bearing - if water was getting in there for some time those can fail. If the intake was done by a shop ask them to pinpoint the noise. Sometimes when the lower intake is down the intake bolts (8 of them) are over torqued and there is a bulletin on that - distorts the block and the crank bearing fail. 96up with newer injection and intake design bolt torque is 12lbs while older style was 35lbs (95earlier).
  • mattn10mattn10 Posts: 3
    when i first start the truck when it is cold there is a knocking from the engine. any idea's would help

    Thanks MATT
  • Would you have coolent in your oil-pan if this happens???
  • i have a 98 Jimmy AC/HEAT Blower does not work. Fuses look good. When you turn on AC it has no effect on engine, no compressor. :( NEED HELP

    Thanks
  • repairdogrepairdog Posts: 948
    Actually when the lower intake leaks and it is internal it sprays into the valley area over the lifters (often a lifter tap on start is first sign) and on cam and counter rotating shaft and then evaps due to heat - never see in the oil. When you pull the intake off the valley area is orange from the Dex Cool.
  • repairdogrepairdog Posts: 948
    Does the blower work on vent? If not the motor is probably shot. If it does work then its the AC compressor rear seal probably leaked and R134 low so will not turn on, or a bad connector somewhere, or a low press switch - AC shop can tell in 5-15 min and let you know. The compressors usually fail at 80-100k but not always so if it did get a NEW one not a rebuilt - only a few dollars more and the rebuilts do not last.
  • I got the upper ball joints replaced with no problems but I cannot for the life of me get the dam lower ones out. I have it unbolted from the lower control arm and have it seperated from the lower arm as well but I cant get enought room to get it out/ put a new one in. I have turned the steering wheel every way to gain clearence, I also took the upper one back off to get some room but I just cant get it off. :( Any help would be great.

    Add: Also I have 4wd, the lower joint is just sitting there ready to be pulled out, just dont have enough room to get it out. It seems that I would have to remove the half shafts to get it out but nowhere have I read anywhere or in the manual that you have to remove them. It simply says to move the lower control arm over :mad:
  • repairdogrepairdog Posts: 948
    If the lower is similar to 98up design (all I've done) after disconnecting the upper ball joint, with the CV shaft disconnected from the hub and hub/bearings,dust shield, brakes and brackets all off, I removed the steering knuckle and lower from the vehicle then pound the lower out of the knuckle. Then bolt the new upper and lower in the control arms, install the lower into the knuckle, then jack up the lower control arm to bolt the upper onto it. Install hub/bearing, brakes etc. Hope that helps. Even the later years say don't have to remove the hubs but never done works for me that way. They are a pain.
  • I had a garage look at it yesterday and he said I had metal shavings in the oilpan ,said the moter was shot. Also said couldn't be fixed..But I have had 2 other people tell me that they rarley see 1 that cant be rebuilt...When I got it back home I checked the oil and it was full,now how could they check the oilpan without draining the oil??
  • pergo69pergo69 Posts: 1
    I have a 89 blazer that won't get gas.I know the fuel pump is not working.I was told it could be a fuse to the pump but dont see one .
  • repairdogrepairdog Posts: 948
    Would guess you have the standard magnetic plug so they just pulled that and held their finger over the drain or inserted a diff plug or added some oil back in - any charge?
    If the bearings are throwing metal shavings its rebuild time but after most intake gasket work you will see a small amount of crap in the oil from the old gasket and the scraping they had to do. Again - I did not see the actual "shavings", did you? Most engines can be rebuilt unless the block or heads are cracked then its not cost effective. You can get a complete junk yard motor with all accessories on it often for a good price - 10 year old Blazer is not actually worth much, sorry.
  • repairdogrepairdog Posts: 948
    Believe on 89 need to check the ECM B, ECM 1 and Crank fuses. There is also a relay but not sure that far back if its behind the glove box door or in the engine compartment. Also the TBI system needs a pulse to ref the fuel spray and its the ignition module in the distributer under the cap so see if you have a spark too. Post results.
  • There was no charge for anything ,when I got it home and checked the oil it was clean no shavings.And I agree not worth much but have quite abit in it. Just droped a 2000.00 transmission in it not a month ago.
  • Will an 1986 chevy blazer v6 go in my 96 blazer .It only has 56000 mls on it
  • repairdogrepairdog Posts: 948
    The older odometers had no 100k place remember so beware. It might physically but believe that 86 has a carb or TBI so diff computer and sensors. Also the fuel pressure is much lower like 12psi vs your current 60psi pump. You have a 4L60E trans now and controlled by many sensors of which on the TB now is a TPS and not on 86 - there are probably a bunch of things that will drive you crazy trying to put that 86 in a 96. Main is the computer and wrecking yards have a book to tell you. 96up had same injection but 99-01 had an added smog exhaust air pump and 02up HP changed. Many block/crank/balance shaft diffs thru the years also in older ones.
  • I posted a msg a couple of weeks ago about my Blazer stuck in 4hi and repairdog replied, thanks. I found out that it isn't in 4hi but is still in 2hi although the 4hi light is on and 2hi light is off. I had new tires put on and while they had it off the ground I started it and put it in gear and the front wheels didn't turn. I assume that means it's not in 4hi. Do you agree? You suggested looking for a vacuum leak. How do I get to the reservior in the fender well? The vacuum hose going into the fender well appears to be dry rotting. One thing I didn't mention in my first post was that the trans. takes a few seconds to catch after starting the engine. I only does this right after starting the engine, once it catches it works fine from that point on. What would cause this?
  • repairdogrepairdog Posts: 948
    That reservior is mounted in the fender and with 2 fingers and a few trys you can put a new piece of vac line on it - I've done many and takes a few trys. 5/32" small and larger is 7/32" hose. Then replace the hose to the intake and down to under the battery tray to the actuator that pulls the cable to engage the 4wd axle coupler. To get to that actuator have to remove the battery and tray. That may not be working. Also a sensor on the coupler that tells the TCCM its engaged (thats the electrical plug under the axle).
  • wbgalwbgal Posts: 9
    I just bought a 98 Jimmy 2 weeks ago and had to replace the front passenger side bearing the day I bought it. I will have to replace the drivers side bearing within days (again front) because it's bad too, you can hear it as you drive it. I accidentally ran over a good size dog today with the passenger side of the car. It still ran fine for around 15 miles from where I hit the dog to my driveway. My fiance took it another 4-5 miles down the road after we got home and again it ran fine. We parked it for a few hours before I had to use it again. It ran great on the gravel driveway but the minute I hit pavement it acted like it had a flat tire. I stopped and checked the tires, all were fine, but the wheels didn't want to turn to the right when I tried to turn around to get it home. It was like it suddenly had no power steering and made an awful squelch when I tried to turn the wheel enough to get back onto the road. It pulls really badly to the right now (which it didn't do after I hit the dog). The girl that I was riding with me said it felt like it had a tire out of balance in the back part of the Jimmy. Could I have caused a major problem when I hit the dog? And do you have any idea as to what it could possibly be? Please don't say the new bearing because I can't afford two new bearings right now. :cry:
  • Well then can you answer this for me..The place I had look at it wants $1500.00 just to drop a new engine in it ,is that a reasonable price.I can get a new engine from jasper for $1700.00..
  • guestguest Posts: 770
    Doubt the hubs went bad from the dog hit, but could be the lower ball joints or steering components - depends where the impact was - have a shop look under it or jack the front end up and turn the wheels and see where the problem is. Driveshaft U-joints are possible if you did a hard hit and a bounce over it. Also tire balance or rims/wheels as well as alignment.
  • repairdogrepairdog Posts: 948
    If thats just labor thats about 20 hours worth - seems alittle high so ask for a breakdown. A jasper motor needs all the external stuff moved over still.
  • auto9999auto9999 Posts: 86
    My dealer's service department fixed the problem. The labor and parts were $350, but I paid $100 only because the extended warranty covered it. The explanation was that the bad speed sensor of the right front bearing/hub unit kept sending the wrong speed signal and the ABS kicked in every time the vehicle comes to a stop, as it was mistaken as the speed was high and the wheels were locked.

    I told one of the service reps to inspect the vehicle thoroughly before the extended warranty expires in this October.
  • lahirilahiri Posts: 394
    Get rid of it!!! Everything on my 99 Blazer failed (I had it for 7 years/ 72000 miles - first 5 years I had the extended warranty, but last 2 were extremely horrible - I had to get the Blazer towed to dealership 9 times during these 2 years and also spent $10K on fixing). Horrible quality - no help from GM's customer service - customer service thought problems were typical of Blazer. FYI, I have traded it in recently for a 06 CR-V - the poor resale value of Blazer also hurt badly. Anyway, I'm now at a safe distance from GM products.
  • I have a 2000 Chevy Blazer with about 106,000 miles. I recently had to replace the passenger side wheel bearing - everything was OK. I was backing out of a parking lot last night and it felt like my emergency brake was on (wasn't). Did the same thing when pulling forward and turning left. This morning, the tire actually "hopped" and felt like it locked up (only turning left). Any suggestions as to what's going on here? I appreciate any help you may be able to give me.
  • SUCCESS! Well, sort of. Luck is more like it, but it's also a lesson to begin with the simplest measures before you tear the truck apart.

    Reminder: This is for a 98 Jimmy in which the A/C blows only blazing-hot air, despite the fact that the compressor is working fine. The vehicle also has automatic climate control (ability to select interior temperature).

    My blend door, or "Actuator Temp Valve" in GM-speak, was stuck on the hot side, apparently. It's possible that the blend motor gears are stripped out, too, but it seems to be working now. Here's what I did:

    1. Lower the glove box
    2. Identify the blend motor (above and behind the upper vacuum actuator). It's a black, square assembly, about 3x2". The left end attaches to the heater box.
    3. Start up your junkmobile. Turn on the heater blower so you'll know if this scientific procedure succeeds. Make sure the dash vents are on.
    4. Push the A/C button to turn the A/C on. In the time that the blend motor would likely be sliding the door from one channel to the other, take a long, flat screwdriver or equivalent prying device, wedge it beneath the blend motor (it's open around its housing except for where it plugs into the heater box), and wiggle it gently.
    If there's no immediate change, continue tapping and wiggling the blend motor while cycling the temperature knob and switching the A/C off and on.

    Mine broke free immediately. I think the blend door was simply stuck. It would probably be wise to check for this before doing anything drastic and expensive, which, on a GM, is anything.

    To see the part in question, and be in the company of others stricken by GM misery, look at this excellent blend motor thread:
    http://www.automotiveforums.com/vbulletin/t574779.html

    Remember: Brute force first, then dealership.

    Gotta Mechanic Comin'
  • I have been reading the posts here and this looks like one of the best sites around for problem solving, most of the other sites just host a forum full of complaints... anyway here is my problem. I have a 2000 Blazer 4x4, it has been sitting in my drive for about 5 months (started here and there). About a month ago I noticed that the electric Door Locks didn't work when I tried them. I now am considering putting this vehicle back on the road and I found out I have a bigger problem then the door locks.

    I started the Beast about 2 weeks ago and I noticed that a bunch of things weren't alive, this is a list of things that are not working. The 4X4 switch, Door Locks, Gas Gauge, Odometer, Speedometer, Tachometer, dash lights, internal dome light, Under hood light, Radio, headlights (there may be a couple of other things also but that is the bulk of it).

    These are the things that do work, the engine starts fine and runs fine, the AC works, the Temp / Direction thingy, Power Windows, Oil Pressure gauge, fuel pump, basically anything that keeps the engine running as well as a few of the accessories...

    Fuses seem to be good however I haven't dug into the engine compartment fuse box thoroughly. It almost seems as though the items that are run of the "in vehicle" fuse box aren't working and others are...

    The funny things is when I was testing stuff out I had a case where when I pulled back (as to turn my brights on) all the items that weren't working came back to life. After that I tested a couple of other things and I could get it all to come to life if I activated certain things such as the Brights switch, the dimmer switch (turn it all the way up), and if I turned the headlights on manually. This all worked for a bit but it no longer works so now all the stuff listed as not working will not come on regardless of what I do. There have been a couple of times where I pop the hood and the under hood light comes on but then it will go off shortly after... Any advice would be great! Thanks ahead of time!
  • repairdogrepairdog Posts: 948
    Long one.
    Light switch in dash has the auto on feature for the headlights and the delay for the dome - they go bad. Wipers and beam selection is in the multifunction switch in the column and those can have a short so have them tested. Door locks - if it sat and was damp the switch in the drivers door get crap/corrision so depress many times and see if they work otherwise if the remote does not work also there is a remote module - and batteries in the remote too. May have to test in the door at the back of the switch.
  • repairdogrepairdog Posts: 948
    Put it back in 2wd - you hit the 4wd button and that will do it.
  • I actually got time to get dirty last night and this is what I found. I pulled the engine compartment fuse box out, I think there are a total of 6 plugins in the bottom of it, all of the boxes looked good however one of the thicker gauge plugins (the ones that only have two wires) had one of the wires corroded off, completely severed and the wire was just powder... Now I have to figure out where I can get a wiring harness, it would be the one that runs from the engine fuse box through the firewall into the internal fuse box in the dash, not sure if I have to replace the whole thing or just those smaller plugs (all of the other three connections are showing signs of corrosion). I am looking on some of the parts retailer’s websites (autozone, murrys, advanced auto) and I really can't see anything that will work, would this be something I could even order through them or will I have to talk to a Junk Yard / Dealer? Thank you for your response and if you can point me to a website or retailer that I could find this at I would really appreciate it!
  • The last several times I have attempted to get gas at various stations I have had difficulties. When pumping the gas nozzle continues to shut off as if the tank were full. It takes forever to pump gas with it continually shutting off. The Check Engine light has been on for a several weeks. The fuel pump was replaced last September. Any ideas to cause, and potential solutions?
  • boba246boba246 Posts: 4
    Hi,

    Repairdog, you had sent me this answer awhile back and was wondering if you could give a little more help. How do I get to the sensor? Do I have to remove the grill? I have checked looking down the hood and can't find the sensor. Really would appreciate any help.
    Regards,
    Bob
  • jpmccrjpmccr Posts: 31
    Ok, I have the power thing worked out (Bad connection at the hot post on my battery). The shimmy has worked itself out (I think the pads had to wear themselves to the brake rotor). Now this one isn't anything major just real annoying. How do you get rid of a brakle squeal?? I know it is not the pads; they are brand new. I greased the moving parts as I always have and the slide bolts. Should I take this thing apart one more time a regrease everything or can it be brake dust build up??:confuse:
  • repairdogrepairdog Posts: 948
    Pull the grill by firmly pulling the center - about 10 metal clips will start to pull out with the whole center and lower turn signals (hood open of course). Should be in front of the radiator - note this location of the sensor was per reading and I have not had to look for mine yet.
  • repairdogrepairdog Posts: 948
    If the pads came with metal shims attached on the rear of the pads that should do it but the ones that don't require you apply a paste or spray of blue anti-squeal to the rear or piston and bracket side - not the pad side! Also make sure the metal guide inserts that the pads slide on are firmly clipped into the brakets or if they are not they will rub on the end of the rotor (outside of circle radius). If the rotors are slightly warped they may sqeek. Did you do the rears and grease the slide pins in the metal brackets - that is a big one most never pull those pins and grease them and they bind eating the inside of the rear rotors - been there.
  • jagmajjagmaj Posts: 8
    I've apparently activated the Passlock system on my 97 Blazer. When I try to start it, the lights just flash on and off and the security light blinks. I've tried the tricks of turning the ignition switch on and off for 15 minutes and even disconnecting the battery for a while, but nothing works. I did have a problem a little while back where my ignition switch would sometimes refuse to turn all the way to the off position so I couldn't get my key out, but it just seemed to clear up on its own. I'm wondering if maybe there's a problem with my ignition switch. Regardless, I need some information about how the Passlock is supposed to work, so I know what I'm dealing with before I have it towed to a dealer.
  • repairdogrepairdog Posts: 948
    Need a scan tool that can access the body control module.
    In 1996 GM introduced the GM Passlock anti theft system.
    The Passlock Anti-Theft system involves resistor codes which are generated by resistors located in the ignition key cylinder switch. 96-97 have a coded key and then the 98up use a Hall Effect Sensor in the key cylinder to send a resistor code to the Passlock module. The resistor code is activated when the ignition key is physically rotated in the ignition switch. Depending on the model of GM vehicle, the actual resistor code is only introduced to the Passlock system when the ignition switch is turned to the ignition on (run) position or only when the ignition switch is turned to the start (crank) position.
  • So how exactly do I turn it off? Does the scan tool allow me to reset the system? Also, can a worn or faulty key cause this problem?
  • I did the rears and they were a piece of cake. Not a sound. The front(Bendix)do have anti-squeal(?) clips on the ends. They sorta snap in/on. I greased the pins before putting them back in. It doesn't immediately happen. Depending on the pressure I put on the brake pedal sometimes they squeak and sometimes they don't.
Sign In or Register to comment.