-June 2024 Special Lease Deals-

2024 Chevy Blazer EV lease from Bayway Auto Group Click here

2024 Jeep Grand Cherokee lease from Mark Dodge Click here

2025 Ram 1500 Factory Order Discounts from Mark Dodge Click here
Options

Chevy Traverse Stabilitrak/Traction Control problems

1567810

Comments

  • Options
    Mr_ShiftrightMr_Shiftright Member Posts: 64,481
    Intermittent problems of this type are a big challenge for the automotive technician. Here's an overview of what's involved in trying to deal with "intermittents"

    https://www.communityautoinc.com/blog/diagnosing-intermittent-car-problems

    As you can see, it's a bit like chasing a ghost, and there's no easy way out. It's one of those rare cases where you HOPE the car will break down so that the culprit will finally reveal itself.

    The article points out a strategy which really amounts to not much more than guessing--to replace the most likely offender. In your case, that might be the throttle positioning sensor, or the wiring or connector that goes to it, or the pedal positioning sensor (under the gas pedal).

    Otherwise, the only surefire solution is to have the car break down while the technician has his equipment hooked up to it.
  • Options
    rcontrerasrcontreras Member Posts: 7
    Just changed cooler, rack & pinion, sensor on driver side rear wheel, window switch, both struts. When it rains...it pours. The speakers don't work...or rather, they work when they want to. The back up sensor sound is non existent and the "service stabilitrak" and "service airbag light" comes on when it feels like it. Catalytic converter is probably bad too since that code poppped out too. I am the original once proud owner. I wanted to pass this vehicle on to my soldier son thinking it was safe...come on...it's chevy! Hmf.
  • Options
    Mr_ShiftrightMr_Shiftright Member Posts: 64,481
    Gee, with all those multiple failures, you'd almost want to suspect a battery/charging issue, or an issue with electrical grounding, or....(gulp) an ECM issue.
  • Options
    rcontrerasrcontreras Member Posts: 7
    My ABS Lights are back too...
  • Options
    rcontrerasrcontreras Member Posts: 7
    Just applied dielectric grease to my speaker connections on all 4 doors. Works so far. Fingers crossed.
  • Options
    rcontrerasrcontreras Member Posts: 7
    ...aaaand the right side decided not to work this morning. (Sigh)
  • Options
    rcontrerasrcontreras Member Posts: 7
    Put in cataclean...check engine light went off! We'll see again.
  • Options
    rcontrerasrcontreras Member Posts: 7
    It's back on today...hahahahaha (laugh of insanity 😝)
  • Options
    rcontrerasrcontreras Member Posts: 7
    Now. I think a radiator hose popped or something..just got home.
  • Options
    Shortay42_Shortay42_ Member Posts: 1
    I have had the Service Stabilitrack, Traction Control Off and Engine Power Reduced issue going on for some time. I have had my car for six months 2 to 3 of those months the Dealership had my car for repairs. I got a remanufactured engine, new steering pump, 4 new tires, gaskets, seals and hoses replaced. Went to pick up my car after the 2 to 3 months the Dealer had it got about 4 blocks away and Service Stabilitrack, Traction Control Off and Engine Power Reduced comes on I turn around take my car right back to the Dealership they have my car an additional week. Went back to pick my car up after a week they tell me it was flooded and they restarted it several times and that everything was Okay. I had my car for about 4 days those same lights came on plus my car started smoking the dealership said they had to replace my radiator then my brakes locked when they took it on a test drive so they had to replace my master cylinder. So they had my car for another week yet again. This week I had the same problem yet again Service Stabilitrack, Traction Control Off and Engine Power Reduced while driving to work at a new job I just started, I needed my car to get to work. Called to get my car seen the gave me an appointment for two days out. Missed two days out of work at a new job. Took my car into Dealearship they told me that I have to replace Fuel Rail Pressure Sensor, Intake Gasket, and Exhaust Flex Pipe. I told them I didn't have a problem with the exhaust system until they put in my new engine and they didn't secure my exhaust properly. Needless to say they didn't want to hear that. The total to correct the problem for the Service Stabilitrack, Traction Control Off and Engine Power Reduced is going to cost $1488.00 and this fix SHOULD fix the problem. Not it WILL fix the problem. So as of today I decided to get a second opinion on the matter. It's sad when you have to get a second opinion on the ones who manufactured the car in the first place. You would figure they would know how to FIX what they made. I'm over Chevy all around the board sad to say.
  • Options
    Disappointed2010_Disappointed2010_ Member Posts: 1
    Wish I had read these reviews before I bought a used 2010 Chevrolet Traverse. Traction control light comes on and loses power. Dangerous. Chevrolet NEVER again .
  • Options
    AnotherchevyissueAnotherchevyissue Member Posts: 1
    I have a 2014 Chevy Traverse LT and Im having the same issue with the Stabilitrak /ABS and decreased power. I really cant believe how many have the same issue with the same car. We're a family of six and dont have the time to keep taking it here and there and getting raped by replacing 1 part then later another part. THIS IS A SAFETY ISSUE GM !!!!!

    IM LOOKING INTO A ATTORNEY TO HANDLE THIS FOR ME AND WILL GIVE AN UPDATE. ALSO WILL SEE ABOUT A CLASS ACTION AND SEE IF GM DOES SOMETHING.

  • Options
    berriberri Member Posts: 10,165
    How do they sell these vehicles after all these years of the same issue???
  • Options
    TmATmA Member Posts: 1
    I just ran into the same issue with my 2014 Chevy Traverse The service stability track and traction control light still comes on all time. noticed a few days ago GM issued recall only 2014's that chassis module needs to be replaced. So googled what does in car it stated electronic whenever drive suv turns completely off no matter where am have brought dealer several times for them not know what's problem bought dealership they stay said can multiple issues do time pay different is wrong was told brake sensors. After replacing those took 1 day for the truck to break down again I mean cut completely off while I am driving or at the red light warning reappear also I had to replace the sensors and alternator. It is very clear upon returning the truck that the service department is at loss. I have no choice but to pull over turn off the truck and wait sometimes takes long to turn back on and when it does engine stays on. This is very dangerous when I'm on the highway and very frustrating when your family car doesn't run properly being a mom of 7.This car is unsafe to ride. I notice there are allot people complaining about the same thing. I Spoke with the dealer and the stated that they would have to just fix different thing and see if that works neveragain chev traverse unhappy custom.
  • Options
    berriberri Member Posts: 10,165
    ...and these issues have been going on since the vehicles first started selling. Is GM engineering that incompetent that they can't resolve this ongoing problem area? Personally, I think they are very nice cars, but between Stabilitrak and A/C matters, I won't consider buying one. Too much of a risk. Just look at their reliability rating in Consumer Report.
  • Options
    thecardoc3thecardoc3 Member Posts: 5,767
    TmA said:

    I Spoke with the dealer and the stated that they would have to just fix different thing and see if that works neveragain chev traverse unhappy custom.

    There is a way to test and prove what is wrong, what needs to be considered at this moment is why the cannot not simply are not doing it. The stabilitrack system isn't a component on the vehicle, it is software running in the background on a group of systems that all have to work together. If you have a problem ocurr in any one of the systems that make up stabilitrack, it causes the system to shut down. Normal testing routine would start with pulling codes from all of the modules on the car and build a diagnostic plan from there. If you can get the codes stored in all of the modules and post them I could explain which one(s) should be dealt with first.

  • Options
    I just ran into the same issue with my 2011 Chevy Traverse The service stability track and traction control light, reduced power all of it. This has happened twice now in the last month (September 2019) while transporting 4 kids on the highway. Took it to the Chevy dealership (Bergstrom in Apppleton WI) and tried to explain issue and show YouTube videos and these forum posts. Was told that the mechanic wouldn't be able to reference them and they have a strict set of policies they need to follow to diagnose issues. Paid $117 dollars to diagnose and drive it around for 15 miles. Wasn't able to find any issues and sent on my way. The very next day (9/26) my wife had the issue again on a highway and I took it right back to the dealership. So they said it was the ECM and needed to be replaced. That came to $816.00. Sent on my way again. I have no trust in the safety of this vehicle and the dealership seemed to care less. I left feeling like I was inconveniencing them. Talked to a fellow employee that owned a GMC Arcadia who had the same exact issue. He had the Throttle Body replaced but traded it in the next week with safety concerns. Please stay away from GMC vehicles. Learn from the issues in this forum.
  • Options
    ErnieHErnieH Member Posts: 2
    I am also the owner of a 2013 traverse and I am having the same issue with the stability control warning and reduction of power. I agree with other members as to how dangerous and unsafe this is. My wife was at side of freeway this morning due to this issue. I have already cleaned the throttle body and the problem went away for a couple of weeks, now it came back. What is the answer to this issue??
  • Options
    ErnieHErnieH Member Posts: 2
    How do I send my VIN via private message and to whom??
  • Options
    GabdelohGabdeloh Member Posts: 2
    edited November 2019
    I bought a traverse 2013 six years ago, now out of warranty. Mileage about 82000 km. I took it to my dealer to change all the four tires. After changing the tire, the car show traction control off and service stabilitrack swerve left or write without me turning the steering. So scary on highway. My initial guess is that it had something to do with the tire my dealers changed. I took it back to the dealer and they changed steering sensor. I did not drive 3 minutes before the problem re-occurred. Had I known this is a peculiar problem with traverse, there is no way I would have purchased the car. Anyone with similar experience and how it was resolved. Thanks.
  • Options
    GabdelohGabdeloh Member Posts: 2
    edited November 2019
    Problem is now resolved. It was due to issue with wheel alignment
  • Options
    MfoistMfoist Member Posts: 1
    I am having this same problem on my 2012 Traverse. The other day it happened and the car even went into "Limp In Mode". I drove it straight to the dealership and the car had no error codes by the time they checked it. How is this even possible. The car is also downshifting hard around 30 mph when costing to a stop and vibrates around 40 when accelerating. Does anyone have a suggestion on this? The dealership has no ideas how to fix things without an error code.
  • Options
    StarfireStarfire Member Posts: 1
    edited November 2019
    2016 Traverse, 51k miles. Same issue as the others. ABS light comes on and the car shudders over about 1.5k RPM. Was originally told it was a cruise control issue, so we just don't use cruise. It's only happened 2-3 times in the few months we had the car and only lasted a few seconds, each time. Now we're several states from home with kids and the thing just started, again. Shutting the car off didn't clear it. So I guess we're stranded.
  • Options
    EpefemanEpefeman Member Posts: 3
    Looks like I need to pile on here with yet another Service Stabilitrak error message. In my case, it does NOT have give a check engine light. I own a 2017 and it looks like Chevy still doesn't have it figured out. My problem wont allow the vehicle to go above 45 MPH and shakes erratically if accelerator is pressed. No error codes are being generated so I'm sure its gonna be difficult for the dealership to diagnose. I've had the vehicle for about and year and had this problem surfaced about 2 months after purchase (I purchased used w/ 28K Miles on it). It went away until I hit about 50K and now its lock it and wont go away. It my wife's vehicle and she will no longer drive it in this condition. Just too dangerous. Any suggestions??
  • Options
    thecardoc3thecardoc3 Member Posts: 5,767
    edited December 2019
    You have to start by trying to pull codes from all of the modules in the car, not just the engine controller. Post every code found and what module generated it.
  • Options
    EpefemanEpefeman Member Posts: 3
    edited December 2019
    I wasn’t aware there were multiple places to pull codes. I’m taking it to the dealership today and will see what they say. Wish me luck and thanks for replying.
  • Options
    EpefemanEpefeman Member Posts: 3
    UPDATE: 2 local parts dealers could not pull any codes. They both said nothing was available. The dealership managed to pull code C0710, which called out 'Steering Angle Sensor' being shorted to ground. They replaced the sensor and the vehicle has been working fine for a few days now. Not sure why the local dealers could not pull any codes. Perhaps the dealership has a more comprehensive scanning tool or they pull from multiple modules as indicated by 'thecardoc3' as noted above. Kinda sucks that it cost so much to replace a 65 dollar part, but I guess I'm also paying for the expertise of the OEM. Eitherway, glad its working. Thanks for all the help.
  • Options
    Jason_70Jason_70 Member Posts: 1
    2014 Traverse 70k miles with Stabilitrak and ABS failures. Reduced speed, firing on fewer cylinders, etc. My vehicles symptoms are par for the course from all the reading I've done. I have already sent an email to socialmedia@gm.com for guidance with this problem. Yes, it is a big safety issue, and my wife commutes in it. Really icy here in MI.

    Why has a recall not been issued? Consumers should not be paying for repairs on crucial electrical safety systems that should be able to span a reasonable vehicle life.
  • Options
    TexRedTexRed Member Posts: 1
    IT'S THE FUSE BOX! I just had it replaced this morning. Although time will tell, so far so good, and my A/C is working again. Skip all of the other potential fixes, because I tried them all, and get your fuse box replaced. It will save you time and money.
  • Options
    SMF90SMF90 Member Posts: 1
    edited January 2020
    This is, an older post. But I’m having 100% the same issue. It unfortunately doesn’t just affect the Traverse, it affects the Equinox as well.

    I can do 70-72 and it does just fine on a normal day with dry roads. But the second it’s showy/ icy and you can’t go over 35/40 and everything just turns for the worst. I used to love Chevy’s. However, after this I feel just as screwed over as when ford put the 5.4 Triton Motors in their trucks.

    Thank god for having an uncle that’s a certified mechanic, as it’s only going to cost me $170 to fix chevy’s mistake and not $500+ like it would cost me at the dealership 🙄
  • Options
    Ml80Ml80 Member Posts: 2
    I have a 2012 Chevy traverse. I keep having the service stabilitrak, traction control off problem. Today it also said reduced engine power. Wtf chevy if you read everyone's comments it is clear this needs to be a recall. I have had several things replaced according to the codes it throws. Nothing works. Also mine had an airbag recall and they supposedly fixed it but the light stayed on and then they told me I needed to pay to replace the airbag. I am a die hard Chevy girl but maybe not anymore. You are putting my family in danger.
  • Options
    Ml80Ml80 Member Posts: 2
    edited February 2020

    I have a 2014 Chevy Traverse LT and Im having the same issue with the Stabilitrak /ABS and decreased power. I really cant believe how many have the same issue with the same car. We're a family of six and dont have the time to keep taking it here and there and getting raped by replacing 1 part then later another part. THIS IS A SAFETY ISSUE GM !!!!!

    IM LOOKING INTO A ATTORNEY TO HANDLE THIS FOR ME AND WILL GIVE AN UPDATE. ALSO WILL SEE ABOUT A CLASS ACTION AND SEE IF GM DOES SOMETHING.

    Let me know if you get anywhere this. I have same issue and 1000's in repairs.
  • Options
    MadChevyOwnerMadChevyOwner Member Posts: 1
    edited March 2020
    I have a 2012 Chevy traverse and I’m pissed tf off! Service Stabilitrak, traction control off, and reduced engine power errors keep coming on. I have been doing research for about a month and a half, which is when this foolery started, and I have found absolutely nothing that could help. I have watched YouTube videos and guess what, still nothing. I was told that the cam shift sensor is what comes up. I tried to get my car diagnosed and fixed prior to my warranty expiring and was told that the s*£t wouldn’t be covered, so I wasted my f’n money on that when it should have been saved for whatever tf this issue is. Chevy dealers all over, if you are reading this please recall these vehicles and fix them no matter the mileage because this is completely unfair to all of us. I am a single mother of 2, which isn’t anyone’s issue but mine, but I purchased this supposed reliable vehicle and it’s a s?!t show at this point. The car fax didn’t mention any of these issues either, in case anyone was wondering. Again Mr and Mrs Chevy, do what’s right because I don’t have the money to fix several issues on this car, I don’t want to do a voluntary repossession because I am rebuilding my credit, my kids have to go to school, and most importantly my job requires me to drive 95% of the day. This all means I need a good working vehicle. If a class action suit is what needs to happen to make you all do something about the issue I will speak to the appropriate people to get it started because 7 years and 10 pages of the same exact complaint makes no sense to me at all. You all are continuously advertising new traverses and other vehicles with this issue as opposed to fixing the damn issue
  • Options
    Chevy_Owner1Chevy_Owner1 Member Posts: 1
    I had this issue with my 2014 Traverse for months. Changed the throttle body which did no good. Swapped out the fuse box under the hood and it appears to have resolved the issue. No codes for several weeks. Both are relatively easy to change on your own if you have basic knowledge. Repairs cost me $440.00 for both the fuse box and the throttle body. Obviously only needed the fuse box at $265.00 but didnt know that at the time. I had the same code issues stabilitrak/traction control/ reduced engine power/ABS codes...all of them.
  • Options
    Clinton2070Clinton2070 Member Posts: 1
    So my wife is on her second Traverse. (I wanted a different vehicle). We got rid of the first one because the Dealership couldn’t fix the stabilitrak/traction control plague. We now have a 2014 model and here I sit on the road, 4 hours from home and the plague hits this car. And it just left the shop after having their $1,500, 90k mike service package performed. We’ll see what happens. On a side note, my ‘05 F150 with 200k miles on is still going. Only replaceD the alternator and a radiator. I honestly think it doesn’t even have any oil in it, and it’s STILL going.
    Keep y’all posted.
  • Options
    Zach_Keene23Zach_Keene23 Member Posts: 1
    My 2014 traverse has the same issue the stablitrack and abs and traction control lights come on and it loses power ajd cruise control wont work. They flash on and off on oocassion then the next time i drive its fine. The truck feels unstable and it feels Like it slips gears when the lights are flashing.
  • Options
    meechigana2meechigana2 Member Posts: 3

    I had this issue with my 2014 Traverse for months. Changed the throttle body which did no good. Swapped out the fuse box under the hood and it appears to have resolved the issue. No codes for several weeks. Both are relatively easy to change on your own if you have basic knowledge. Repairs cost me $440.00 for both the fuse box and the throttle body. Obviously only needed the fuse box at $265.00 but didnt know that at the time. I had the same code issues stabilitrak/traction control/ reduced engine power/ABS codes...all of them.

    You replaced the fuse box itself and all the fuses?

    I’ve had engine light issues on my 2012 traverse since it was about two years old and the dealer could never replicate it. A little over a year ago it was bad and I found a dealer about an hour away with an experience 30+ years mechanic who was able to fix it, at least for while. I never had the reduced power until today and it happened right after I filled up my gas tank. It felt like the car wouldn’t shift out of first, allowing me to go up to 20 mph and then after driving a little but it let me get up to 40. I needed to get home as I wasn’t going to be stranded during the current situation. After backing in the driveway I turned off the car. When I went to turn it on it struggled to turnover but did start and the same traction control off, reduced power, service stabilitrak, and engine light came on. I’m ready to set this car ablaze but it only has 98,000 miles and I like it besides the fact that I no longer feel safe driving it with my family or alone and am done with GM cars.

    So,the question is do I try to find a mechanic to try the fuse box or some cheaper option and try to trade it in. Any suggestions of more problem free suvs?
  • Options
    thecardoc3thecardoc3 Member Posts: 5,767

    You replaced the fuse box itself and all the fuses?

    What works for one car has no real promise of working for another. Lucky guesses can work, but a qualified technician can test and prove what is going on,


    I’ve had engine light issues on my 2012 traverse since it was about two years old and the dealer could never replicate it. A little over a year ago it was bad and I found a dealer about an hour away with an experience 30+ years mechanic who was able to fix it, at least for while.

    An important step in diagnostics is to know about what has been done previously but "forget that you know it" while actually testing. That applies to now as well. Someone needs to test and prove what is happening right now and with an experienced technician as long as the problem is present that is what they have learned how to do.


    I never had the reduced power until today and it happened right after I filled up my gas tank. It felt like the car wouldn’t shift out of first, allowing me to go up to 20 mph and then after driving a little but it let me get up to 40. I needed to get home as I wasn’t going to be stranded during the current situation. After backing in the driveway I turned off the car. When I went to turn it on it struggled to turnover but did start and the same traction control off, reduced power, service stabilitrak, and engine light came on. I’m ready to set this car ablaze but it only has 98,000 miles and I like it besides the fact that I no longer feel safe driving it with my family or alone and am done with GM cars.

    OK that's a good description and a tech should be able to analyze this and get you an answer. It's a shame that tech is so far away but you should be getting hold of him/her and allow him to deal with this for you.


    So,the question is do I try to find a mechanic to try the fuse box or some cheaper option and try to trade it in. Any suggestions of more problem free suvs?

    Do not just throw a fuse block at this, that is more likely to be a waste of money than successful.

  • Options
    ChinrichChinrich Member Posts: 4
    I have a 2010 chevy traverse that started with the stabilitrak & traction problem yesterday. My car wont start. This is one of the many problems i have had. Did not know it was a common problem!!! Will be getting rid of it. POS!
  • Options
    ChinrichChinrich Member Posts: 4
    Ml80 said:

    I have a 2014 Chevy Traverse LT and Im having the same issue with the Stabilitrak /ABS and decreased power. I really cant believe how many have the same issue with the same car. We're a family of six and dont have the time to keep taking it here and there and getting raped by replacing 1 part then later another part. THIS IS A SAFETY ISSUE GM !!!!!

    IM LOOKING INTO A ATTORNEY TO HANDLE THIS FOR ME AND WILL GIVE AN UPDATE. ALSO WILL SEE ABOUT A CLASS ACTION AND SEE IF GM DOES SOMETHING.

    Let me know if you get anywhere this. I have same issue and 1000's in repairs.
    I also am interested in a lawsuit. Having same problems with my traverse. Thanks
  • Options
    ChinrichChinrich Member Posts: 4
    Ml80 said:

    I have a 2014 Chevy Traverse LT and Im having the same issue with the Stabilitrak /ABS and decreased power. I really cant believe how many have the same issue with the same car. We're a family of six and dont have the time to keep taking it here and there and getting raped by replacing 1 part then later another part. THIS IS A SAFETY ISSUE GM !!!!!

    IM LOOKING INTO A ATTORNEY TO HANDLE THIS FOR ME AND WILL GIVE AN UPDATE. ALSO WILL SEE ABOUT A CLASS ACTION AND SEE IF GM DOES SOMETHING.

    Let me know if you get anywhere this. I have same issue and 1000's in repairs.
    Im also interested in a lawsuit. Im having same problems with my chevy traverse among other things. Thanks.
  • Options
    ChinrichChinrich Member Posts: 4
    Still dont have my traverse back. Theyve tried battery& fuse box now saying they need to take vehicle to chevy dealer. Will be contacting an attorney. This is [non-permissible content removed] & u need to be held accountable!!
  • Options
    DannyG_562DannyG_562 Member Posts: 1
    My wife had the same situation happen this morning with 3 kids in the vehicle. She was on the way to work when the warning lights flashed for a second then the vehicle began to shake and lose power while on a busy road. She was barely able to get off the road. She called me crying and scared to death.but not with confidence after reading all the posts here. I have already contacted GM via the email address I read here to discuss the options. I think enough is enough and GM needs to back their product before someone gets seriously injured or even killed. I'm in the public safety business so I know many legal representatives that would love to jump on board if GM doesn't want to do the right thing with this issue. If the 2012 Traverse had a recall and now MANY 2011 have the same issue obviously the manufacture is not doing its job in providing a safe vehicle for the roads.
  • Options
    CanSum1PleaseHELPCanSum1PleaseHELP Member Posts: 1
    edited November 2020
    Omg their are so many people with this same problem and I too have 2011 chevy traverse 98000miles and stabilitrack check engine reduced speed i Just paid 5000 cash im so very upset idk wtd im single mom with no experience with cars its so DANGEROUS WHY WOULDNT CHEVY RECALL THIS THIS IS ABSOLUTELY DEPRESSING AND AFTER ALL THE MONEY SPENT THE LIGHTS ARE STILL ONE IS THERE ANYONE OUT THERE THAT HAD THIS HAPPEN AND HAD A 100% FIX AND WHAT IT TOOK PLEASE LMK ON HERE OR TEXT ( Impermissible content removed )
  • Options
    oldmcdfarmoldmcdfarm Member Posts: 1
    I have a 2010 Traverse. The first time this happened, I had just pulled into Kohls. When I came out, it was fine. It has been about 2 weeks. Just did it again. Drove home at 10 mph. Was going 50 when it abruptly slowed me ddown. Guess I will go to the dealer Monday.
  • Options
    NykkyBNykkyB Member Posts: 1
    gmcustsvc said:

    @sassyshamrock said:

    Had a near death experience because of the "Service Stabilitrak/Reduced Engine Power" last night. I have a 2011 Traverse and with no warning the Service Stabilitrak appeared on my dash and I lost power. Going from 45mph to under 20mph in a matter of seconds in heavy traffic. With all the posting on the various blogs of countless ppl having this experiencing this and no recall. I am extremely disappointed with Chevy/GM, what is it going to take a death in order for them to get in front of the problem and alert the public and do the right thing and recall the part???

    Hello sassyshamrock,

    We truly apologize that you recently experienced this issue with your Traverse. We would like the opportunity to further investigate this matter, and work towards seeking a possible resolution. If you would like our assistance, please PM us your full contact information, VIN, mileage, and the name of your dealership.

    Thank you,

    Amber N.

    GM Customer Care

    GM Customer service there should be a recall on these treaverse. What will it take for someone to lose there life.
  • Options
    Canuck2050Canuck2050 Member Posts: 1

    Hey all just had these same issues with our 2015 Traverse. After replacing the left front speed sensor and cleaning the throttle body as some have suggested in various videos and post. I was still getting ABS warning lights and traction control stability messages. I took a closer look at the rear of the hub where the CV axle attaches to the bearing and found a piece of metal stuck to the magnetic ring which was providing a faulty sensor reading. Problem solved. So please before taking it to the dealership$$$$% just double check that the sensor is clean as well as the hub assbly from any debris.

    All the best!

  • Options
    Tm180Tm180 Member Posts: 1

    SOLVED MY SERVICE TRACTION/STABILITRAC ISSUE. I recently purchased a used 2014 Traverse LTZ. Shortly after, I started receiving most of the "service"stabilitrac/traction control issues, including cruise control off and limited acceleration. Could reach 70 mph, but very slowly. Too fast and shuddering occurred. Long story shortened..... replaced wheel speed sensors, had brake position sensor "relearned", checked numerous other posted fixes. No luck. Daughter and her boyfriend following behind noticed brake lights on, intermittently. Called me on cell about if I was riding the pedal, nope. Left foot lift up on brake pedal, brake lights go off. Next 150 miles holding pedal up... not a single "service" stabilitrac/traction control issue at all. Investigation of brake pedal showed friction wear on the metal stud (that the sensor slides on). Also some wear (free play/slop) in the brake pedal assembly. This caused the pedal to not fully return to up position Temporary fix is heat shrink tubing shim around top fork of brake position sensor. Until I can replace worn brake pedal assembly.

  • Options

    My 2013 Chevy Traverse with 115K miles is also experiencing a complete breakdown. It started with the ignition switch, brake position sensor and now traction control and Stabilitrac issue. VERY DANGEROUS when your driving on the freeway and your car completely dies due to loss of power with your family in the car. If this is a know issue how do you communicate the exact fix to the dealer/mechanic. I've spent thousands on this car and i do not feel safe driving with my family in it. Does anyone know how to contact GM for correct fix? I really just want to trade this in and get a car i can rely on. I dont know if dealers would take it as is. Any guidance would be greatly appreciated.

  • Options
    kwms428kwms428 Member Posts: 1
    edited November 2021
    Just purchased a used 2013 traverse with 99k miles and already regretting the purchase! 2 days after driving it off the lot the ding ding ding occurred and the service stabilitrak/park assist off/traction control off came on along with the engine light and reduced power. A nice gentleman who happened to be a mechanic and knowledgable of Chevys told me it was probably the wheel sensors. The only code that showed up was for the neutral safety switch, which everyone is saying "shouldn't impact loss of speed." He cleared the code so I could drive it to the dealership. They gave me the run around about how they couldn't pull any codes or replicate the problem and "couldn't find anything wrong with it" they brushed it off as a fluke or maybe water getting on a sensor. They told me to turn the car off and wait 10 minutes and restart the car if it happens again....which tells me they're aware of the problem even though they played dumb. SO basically now I am terrified to drive this vehicle since we don't know if/when the issue will reoccur and when it does I'll need it towed 45 mins away to the dealer we purchased it from in order for it to be resolved. I'm furious! I wish I found this forum before we purchased the car.
Sign In or Register to comment.