Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Are you under 40 and think that you might not be able to afford a brand new vehicle when you purchase your next car? If so, a reporter would like to talk to you. Please reach out to [email protected] by 12/16 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Kia Sorento Maintenance and Repair

1353638404143

Comments

  • That was really a nice offer and I really appreciate it. I just got news that my 93 year old father passed away so I am headed to the US on Saturday. I will purchase one while I am there.

    It was a real considerate offer to make to someone you don't know and I want to thank you very much for it!

    Scott.
  • nyeenyee Posts: 2
    I'm looking to change my spark plugs on my own, but cannot seem to find it within my engine. Does anyone know where it's located? I looked in my owners manual and it doesn't say either.
  • paopao Posts: 1,867
    changing plugs in the sorie isnt for the backyard mechanic IMHO...its a couple hour job at the dealer....and you have to take some of the engine/cam covers off, replace gaskets etc I beleive.....its a three to four job at the dealer.....expect $300-$500 depending on your dealer for this one....
  • hello i have a 2004 kia sorento and i noticed the floodlight on the bottom under the bumper. i took apart the clip on the wire and i am not able to remove the plastic assembly to get to the light. i can see it under the car and get to it but i dont know if it turns or unhooks somehow. any help would be appreciated.
  • paopao Posts: 1,867
    the light assembly doesnt come off...the the bulb socket should twist out of the assembly from the rear.....assume you mean the fog light...
  • I recently took my 2003 Sorento in to the dealer for a couple of things. When I got it home I noticed the headlights will not turn on without the key being in the on position. The parking lights will come on but not the headlights. I took it back and the dealer told me that was how it was supposed to work. I find this suspect as it wasn't that way before they worked on it. Is this true or am I being taken for a ride?
  • This is how it is supposed to work. I actually always leave my headlights on. When you turn the car off the headlights go out, but the park lights stay on. When you remove the key from the ignition, the park lights go out. That's how it's always been. I have an '06 Sorrento that was purchased new.
  • thanks Jimmy. .. So you can't even turn the lights on manually? It sure seems to me that I usta could. But I have been known to be mistaken before. I also leave my lights on all the time, I think its the safe way to do it.

    Tami
  • I tried to put a Sony stereo in my '08 Sorento yesterday. It powered up, the SWI-PS worked from the steering wheel, but there was no sound. I talked to crutchfield tech support. they had me hooking up two of the other amp and ant wires. Still no sound. As I had spliced the new set in, I was able to re-connect the old set. No Sound. It was late/cold. I took all the new wiring out and re-connected the old set. Works fine. I think I must have had a bad connection somewhere. Does anyone know exactly what power leads need to be connected where?
  • Hi. I just had my daytime running light module relaced to correct tail lights not working. (106000K so no warranty left) I also have my shifter lights not working, but the KIA dealer where I live says their are no lights on the shifter and to ignore the problem. I know their are lights under the P/N/D buttons etc. Why they would say their are no lights is beyond me.
    My problem is how to fix the lights. They will turn on if I hit the top of the shifter cover 5 or 6 times, but they do not stay on when I shut the car off and back on again. The back of the shifter dust cover is broken off and I can feel down inside with 2 fingers the light wire under the light assembly, but it feels tight. I cannot figure out how to get the shifter cover off to see if the connector I cannot reach is tight or not.
    Any help would be appreciated.
    Dave
  • hi

    i have the same problem with my auto sorento. what was the out come with yours
  • I am very happy with my diesel manual sorento. However, it has begun to hesitate occasionally when the accelerator is depressed. It feels just like it is running out of fuel and then it takes off normally. This is NOT turbo lag. I have asked my dealer about it. He says others have reported the same problem but they cannot isolate a cause either on the diagnostic computer or otherwise. It is a sporadic problem. It is scary when it cuts out just when you need the power! I wonder how many others have this problem and has anyone found a solution???
  • my kia sorrento is stuck in 4wd low; any ideas about how to get it out before going to the dealer and looking like a fool?????
  • ado1ado1 Posts: 4
    Hi, I had the same problem on my 03 sorento just before i boarded a ferry to go on holiday.
    I managed to get it out by going into reverse and Driving back and forth a few times.
    Luckily it worked or i would have missed my holiday.

    Good Luck.
    Adrian
  • Once again having continued problems with my 05 kia sorento. Tried to get rid of it last year but due to only being offered 3k for it I decided to keep it thru this winter. Not sure right choice but anyway. can anyone tell me if there is a place to buy kia parts cheap instead of thru dealor. dont want new expensive parts on a car that is worth nothing. My wiper arms do not sit on the windshield. Last year had it fix but only after it blew the motor that was already replaced twice. now they are telliing me i need new wiper arms. someone mentioned going to a junk yard which i will try but if unsuccessful i was hoping to find other places to try and also wondering if ANYONE else had this isssue and if it is the wiper arms itself or another problems. i have been dealing and paying for this issue for 2 yrs. also just had all belts replace and now they are telling me the belts are junk (at another mechanic i trust obviously not a kia dealor) and i need to replace them (not the timing belt). they squelled ever since they were put on about 3 months ago. any help extremely thankful. renee
  • paopao Posts: 1,867
    is it the arms or the wipers themselves....as far as the belts....why is the mechanic telling you they are junk.....frayed, cracked, manufacturer????? as far as they are squealing....that is a tension adjustment.....has nothing to do with the belts themselves.....do a google for kia parts....many online auto parts dealers are much cheaper....try rockauto .com
  • It is the wiper arms. not sitting flat on windshield.
    as for belts, I asked specifically what was wrong with them frayed,etc they told me they are just cheap parts and they are going to squeal (bought at advanced auto but kia put them on). Just doesnt sound right but I dont know enough about cars. All I know is ever since they were put on they squealled. thanks for suggestion for rockauto.com!!
    god knows I put enough money into this vehicle already.
    thanks again
  • would they not see that the tensioner was bad when they put the belts on?? Or should I say is that a part needed or just something they need to adjust? thanks again
  • paopao Posts: 1,867
    they may have the belts too tight as well..the tensioner is just another pulley/flywheel that can be adjusted to tighten the belts....most belts squeal because they are slipping...not because they are cheap....if you bought the belts from an national auto parts store....they are fine......I replaced mine with NAPA belts....beleive I paid 20-30 a piece for them...had Kia do the work...and havent had any problems with mine at all.....

    as far as wiper arms....so the blade itself doesnt make contact with the windshield.....uuuuummm should be some sort of adjustment...not sure......will have to look at mine.....unless the motor was installed incorrectly ....or the arm is simply bend....there shouldnt be a problem...
  • I've got about 37000 miles...occasionally a burnt out bulb....changed oil regularly...sometimes by myself...suspect I need new disc pads....car jerks a little when stopping....should I do the 30,000 checkup and hope for the best moneywise from the dealer or can I replace them myself? Do I void all warranties if I do that?
  • paopao Posts: 1,867
    what I have found...you will not void the warranty...but the service department may demand to see all receipts and description of services, parts used...oil etc etc....Ive simply let the dealer do most of my work...as mine is reasonable...and I have neither the time or tools to do most maintenance
  • paopao Posts: 1,867
    EX model..with 114K on it...no major issues with the vehicle...other than the intense scheduled maintenace requirements...and short interval between major services..all services done to include timing belt etc......only part to go bad so far was an O2 sensor..and he infamous coolant reservoir bottle

    engine hesitants under heavy acceleration....comes from the drives side of the engine..almost like a misfire...but its a loud thump instead.....once the sorie is up to speed, it doesnt thump.....again....but when going from a complete stop...or when trying to pass...the engine hesitates........coil...bad plug, valve issue??? any suggestions......I have no check engine light either....
  • DenDen Posts: 1
    My Sorento is just four years old with under 33,000 miles. It has seen light duty and no off road miles because the engine light is a continual bother. I don't think that I've driven 1,000 miles without the check engine light warning me about something. There have been times when I've been on the road and I've ignored the light when it has come on, but I've kept my eye on the temp gauge to watch for any overheating.
    None of these warnings have been about anything, "important." That is to say, no hose, nor belt nor anything other than bothersome DEQ equipment failure which leads to hours of diagnosis by the shop. All of this has been handled under the warranty, but no transportation has been provided for me except when the shop forgot to reinstall my oil dipstick, after an oil and filter change, and they delivered it to my address. I would not purchase another Sorento and wished I'd gotten a Honda or Subaru in the first place.
    Anyone else having "check engine light fever?" :(
    DEN
  • paopao Posts: 1,867
    for the light to be on that frequently, there has to be a systemic problem with the emissions system.....you state hours of diagnosis..what kind of codes are being shown with the light...what is being replaced or fixed.......my 03 had only thrown two check engine lights...one for a bad O2 sensor..and one when the tech failed to connect my MAF cable after the changeout of the coolant reservoir....
  • Was your '05 subject to that injection head recall of a year ago? That defect was causing the warning light to go on and in some cases causes serious engine damage.
  • My 2004 Sorento with 92K miles Battery and Brake warning lights come on at idle and go off during acceleration and cruise. They do this simultaneously. I have a new battery and it seems to be holding a charge from the alternator. What's going on here?
  • About three mounths agao my battery when dead in my sorento, never thought much of it at the time, just jump started it and had no problem for about two mounths. Then it was dead again one moring, and when i went to jump it the car started to crank over as soon as i attached the jumpers. It did this without and keys in it. I disconnect the negative battery terminal and charged the battery, as soon as i attached the battery it started cranking on its own again. I let it set for two days, and hooked the battery back up and everything worked fine. This morning the battery was dead again, so i put the jumpers on to get it started and it took a charge and started properly. I let the car run for awhile too completly charge the battery, and it started starting itself while already running. Any ideas!
  • I just put a post up asking for help on my 03 that s try's to start itself in the driveway with no key in it.
  • I have an 03,
    Headlights keep going out
    Taillight go out
    Shifter light is off and on
    Driving lights at least three times

    Now the car is trying to start itself with no key in it, just starts cranking over all by itself in the driveway
  • I bought a used 2008 Sorento in Dec. 2008 (14,000 miles on it) and about 4 weeks ago had a fuse blow (out went radio, clock, keyless entry, back window wiper, dome light). After finally going around and around with the service dept. on the phone, they told me which fuse to check. Yay. I seriously did NOT want to drive the 2.5 hours to the dealership just for them to change a fuse.

    When I changed the Audio fuse (labeled as needing a 30 amp) I noticed it had a 25 amp in it. I hoped that was the problem. Two weeks to the day went by and the new 30 amp fuse I put in blew again. I replaced it this morning. Jammed out on the ride to work.

    When I came outside at 5-o-clock to go home, my keyless entry wouldn't work. It had blown again, ALREADY!

    Anyone know of something that could be causing this particular fuse to keep blowing repeatedly?! I really dread taking a whole day off work to go and sit in the dealership 2.5 hours away while they trace back thru the entire electrical system. And then they can't guarantee they won't need the car overnight.

    Can you turn off the dome light in the LX? If so, I'll try turning that & the radio off, replacing the fuse again and see how long it lasts. I read on here people were having bulb problems. Does that include interior lights? Think shutting the door is jarring a wire somewhere and causing a blowout?

    I'd just like to try everything before taking it back to the dealer. Lastly, can I take it to a different dealership than the one I bought it at? There is one a little closer (a little over an hour).

    Thanks for all the help. For the most part, I love the car! Just want it to work right! :(
  • I've had no problem taking my Sorento to a closer dealership.

    Did you find the schematic on the fuse box lid? It should tell you if the right size fuse is being used. It almost sounds like you might want to try a 35 or 40.

    I've had my 2005 since new & not too many problems. It saved mine & my friends' lives when a guy hit us at 35 MPH with a new Grand Caravan. Only the wheel, bumper & quarter panel on the exterior were damaged. My boyfriend has one too & I won't let him sell it to get something with better mileage after going through that.

    Good Luck to you.
  • Do you know why in the maintenance section of the KIA Sorento owners manual page 7-5, it says to replace the timming belt at 60 months or 60,000 miles but then it has footnote that says "For California, this maintenance is recommended but not required."
  • paopao Posts: 1,867
    the state of CA took a class action suit to KIA challenging the need to replace it at that interval and won...I beleive....

    the scheduled maintenance and KIA and Hyundia is outrageous IMHO and is a reason I will never buy another......deviate just a little or fail to document all the maintenance properly, be prepared for warranty claim denial.......just the transmission and differential fluid change intervals alone are ridiculous......not to mention the timing belt and spark plug change outs.....and this engine isnt the most mechanic friendly to work with either....also be careful as to how the dealership defines you maintenance schedule as to whether its severe or normal....most like to define it as severe..since the scheduled maintenance required is much more frequent

    my other vehicles are GM and dont require any major maintenance until the 100K mark......happy with all three of them....04 wiht 138K, 06 with 37K and 09 with 10K on it.....my 03 Sorento has 116k on it
  • kiakellykiakelly Posts: 3
    Why does my 04 KIA Sorento stalls when driving between 60 and 70km?
    My 04 KIA Sorento has been great until now. Has been in to dealership 6 times in 2 months for same problem. Mileage now over 100 000K but they have kindly extended the warranty for this issue. Problem started 2 months ago where around 60km it felt like the transmission would slip/RPMs ran high for a couple seconds before changing gears. This has been intermittent, happens couple times a week, otherwise ran great. Now it will completely stall and cut power, again at random, last time the engine light stayed on for 4 days, then turned off on its own. Dealership says they can not find anything wrong. Very scary feeling driving home on the highways with 3 little kids in the back to have car lose power and die on you in the fark and scared someone is going to run into you.

    Please only serious responses, I only have a month extended warranty with the dealership to resolve this problem and I do not have very much money right now to start taking it to other mechanics for second and third opinions. Thanks.
  • alexisbalexisb Posts: 2
    My '03 has approx. 758000 miles on it and today I felt a slight change in the way it drive. I noticed that whenever i pressed the gas, or even floored it, the RPM wouldn't go higher than 3,000. I let my engine cool down and tired it a few hours later, i floored it and it slowly creeped up to 4,000 rpms, i hit 60 mph before it cleared 4,000rpms even. then when i let go of the gas, the pointer dropped down all the way to 1,000 then creep up to 2,000, without me pressing anything. It also feels like my car is struggling to pull itself, as if it's gotten heavier...someone who knows about cars said it could be the mass air flow sensor...i'm not sure though, anyone else have this issue?

    Also, I am the second owner, does the warranty carry over to me?

    Thanks! :blush:
  • tidestertidester Posts: 10,059
    My '03 has approx. 758000 miles on it...

    I don't think any warranty covers that much mileage but I'm pretty sure you put an extra 0 onto that! :)

    A defective MAF sensor would produce the symptoms you described.

    tidester, host
    SUVs and Smart Shopper
  • alexisbalexisb Posts: 2
    Whoops, indeed i did, sorry 'bout that, haha. :P
    Yeah I'm going to take it to a shop today to get it checked out, hopefully it just got disconnected or something...i'll updated later, thanks!
  • kbeyerkbeyer Posts: 1
    I have had this exact same problem on my Grand Prix, but have never experienced it with my Sorrento. The problem with the Grand Prix turned out to be the Crank Position Sensor. The car would just die whilst driving right after a quick jump in RPM like you described. It wouldn't start again for like 5-10 minutes, but after that wait it would fire right up and run fine for another day or so until it happened again. It's a cheap part, but depending on where it's located may make it an expensive repair (mine wasn't under warranty).

    Anyway, hope this helps. I know it wasn't a Kia, but the problem was so similar I had to respond.

    Good luck!

    Kevin.
  • kiakellykiakelly Posts: 3
    Thanks. The dealership extended my warranty for 1 month and they replaced the crank shaft sensor and so far seems to be OK. It makes me feel better to know this resolved your issue. These forums have been very helpful.
  • arosen1arosen1 Posts: 2
    Mine is doing the EXACT same thing! It's a 2003, and will also cut out at lower speeds as well. Very hopeful someone can shed some light.
  • kiakellykiakelly Posts: 3
    It has been over a week with me driving every day with no issues since replacing the crank shaft sensor. While they were in there, I also had the timing belt tuned up as I saved a lot of money on labour with the sensor being replaced under an extended warranty so not sure if that helped with the resolution as well. Just very happy everything seems to be working well again. As I said before, I have always loved this vehicle, just not the service provided by KIA.
  • I have an 03 Sorento (actually, I have two identical 03 Sorentos) and basically, pretty satisfied. My question here is about the radiator fan on one, which sometimes continues to run for ever after the engine is shut off,. I udnerstand that if the engine is really hot, this fan may continue to run for 10 minutes or so after the car is shut down when it is working right, but, apparently, the relay or whatever is stuck because some times the fan runs a long time, engine very hot or not. It may happen 1x month, but, if I don't notice it and go into work, battery will be dead when I come out. I can stop it/reset it by pulling out one of the fuses under the hood, but sometimes I don't notice it...anybody got any ideas what is happening and what I could do? I'm afraid I'll be out of work soon and don't have a lot of money to spend at the dealer but am pretty handy. Thoughts anyone?
  • Hi there, i have an 03 Sorento as well an dthis has happened a couple of times to us as well. but it was in the late spring last year and found it weird. a short time later i was getting electrical problems and finally had the tail light stop working totally. I checked the fuses in the cab of my Sorento and then checked the fuses under the hood and found that the the tail light or parking light fuse was not there and in its place found a rubber fuse that said do not use. I found it weird and replaced anyways with a real fuse as indicated. all the electrical troubles we had during this time has stopped completely for some reason and believe the computor was trying to keep the lights going even without the fuse in and bypassed it or something. But 6 or so months later there has been no signs of an electrical problem and the rad fan has never continued after the motor has been shut off. you can check it if you wish and i know it sounds stupid and that it can not be real but since i have replace that one fuse it seams to have calmed or stopped ll my electrical issues I was having with my vehicle. Let me know how it goes for you.
  • mike954mike954 Posts: 2
    I also have a KIA Sorento that caused me some anxious moments. Its a 2005 and twice after driving at highway speeds then slowing down it would not speed up and shift to appropriate gear going uphill but rather stayed at about 40 - 45 mph. No engine light came on. Took it to dealer and they adjusted throttle sensor.

    I also filled out report with National Highway Transportation Safety Administration - Office of Defects Investigation in case other people were having the same problem.
  • militarymilitary Posts: 1
    I recently replaced my tires with used ones. All four of them where the same size. They were different manufactures, the two in the front were Goodyear and the two in the rear were BF Goodrich. In about a week, I noticed a strange noise coming from under my front end. When I took it to the dealer, I was told that the front differential had burned out because my tires where more than a half inches in circumferences of each other. Therefore, the warranty was voided. Is that normal for a warranty to be voided for that reason
  • paopao Posts: 1,867
    you should always match the tire size and tread life, if you have a TOD AWD Sorie....believe the owners manual also states the same...if in fact your dif is blown...and you have TOD...be prepared for an expensive repair bill the dif alone is almost $3.5K, then labor

    though you bought the same size tires....they were apparently different in tread remaining....thus the difference in diameter of the tires..leading to the dif failure...the warranty isnt voided....they simply arent honoring it due to the failure being caused by dif tire diameters.....you may in for a battle to convince them otherwise....goodluck!!!
  • kiabustedkiabusted Posts: 1
    my 4 wheel drive does the same thing and will not change into overdrive what do i do?
  • ado1ado1 Posts: 4
    my sorento was stuck in 4wd low and would not go back to normal 4wd.How i resolved the problem was by going back in reverse and dack in to drive and go foward a litle, i had to do this a few times and it came back to normal.
    Hope this is of some help.
    Adrian.
  • raptorageraptorage Posts: 1
    I have a leak in my rack and pinion seal that is seaping through my tie rod boot. Is it possible to just replace the seal, or do I have to replace the entire rack?
  • I had this happen while mine was still under warranty and the dealer replaced the rack!
Sign In or Register to comment.