Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Chevrolet Avalanche Transmission Problems

KCRamKCRam Mt. Arlington NJPosts: 3,516
The new place to talk about your Av's automatic.
«134

Comments

  • Does anyone keep having to replace the electric switching solenoid in their tranny? I am at 100,000 and this is my 3rd one! Any insight?
  • chadxchadx Posts: 153
    I've been having a problem with what I'm guessing is some type of trasfer case control/solenoid. Could you describe the symptom so I can tell if it's the same thing? I haven't brought mine in for servicing yet. But basically, sometimes when I start it, the 4x4 selector light shows the red dot in the neutral position rather than the amber 2x4 light. Also the dash flashes "service 4x4". Other times, when I start it, it goes to Auto4x4 rather than staying in 2x4. Other times I can't shift from one mode to another. Usually, I can get it to reset by shutting off the truck and restarting. Rarely, I have to also play with the buttons and/or shift into neutral while doing so. Sound like the same thing? Mine is a 2003 with 60k miles. The problems started around 55k. Thanks.
  • gilberb0gilberb0 Posts: 1
    To All,

    I have a 2004 and have had this issue numerous times. My brother is a Service Manager and he hate's when I call! LOL
    but he finally fixed it! After many encoder modules he found a update on the 2002 and did it to mine. It is a sensor that works with the encoder! Knock on wood it has worked well for several months now! Good Luck! :)
  • My 07 Avalanche transmission, bumps from a dead stop, and bumps several times going up to 10 mph or so, also seems to bump as if I accelerate fairly hard. Kind of like running over boards in the road. The dealer claimed they could not duplicate the problem, but anyone who drives or rides in the truck can definitely feel it. Any ideas? Thanks
  • tomainetomaine Posts: 1
    I purchased a used 2002 Avalache and it did not come with the owners manual. Does anyone know how I can get one?
    Thanks,
    Thomas
  • njbjjnjbjj Posts: 1
    I've been having recurring problems with my transmission leaking fluid...been taking it for service every year...getting gaskets replaced, etc. Been having this problem occur since it was purchased in 2004. They say they can't seem to find the actual cause of the leak...they just do some "bandaid" job of repair, a temp fix...as soon as I start driving it again, the leak eventually starts up again...any clues for a final solution...my driveway is starting to look like a Dalmation with all the fluid leak spots!
  • alc1588alc1588 Posts: 2
    I have experienced the same problems with my 07 Avanlanche also. My dealer says that it is normal and says he did not feel anything wrong, as if I was crazy. I know slipping when I feel it. Have you had any luck with your problem? I am about to just leave there until they find out what the problem is before my warrenty runs out!
  • transmission under lite load or steady speed between 45-60 vibration in rumble strips in road. Dealer found water in oil coming from radiator trans cooler. Truck has 60,000 miles. GM will pay half of cost to repair. Cost to repair before GM $3000.00. This vehicle has seen the shop 5 times since new March 2005 problems getting worst. :lemon: :lemon: :lemon: :mad:
  • I had the exact same problem with mine slipping. I have 8k miles on my 07 and was going to wait until my next oil change to have the dealer look at it. But the other day it wouldn't shift from 3-4. They are replacing the transmission right now. I baby my truck probably more then anyone and haven't towed anything with it. So there was for sure something wrong with the transmission from the factory.
  • My 06 same problem, my service guys told me it was due to putting 22" wheels & tires have to much bite as to the traction. The computer needs some wheel spin in order to controll the torque. They say because there is no wheel spin, it gives full torque which causes the wheel hop. They said I could a high performance forward sprag gear (called a 29 element sprag gear) in the tranny to be able to handle larger tire & wheel combo. It doesn't do it with the factory 17's only the 22's. The other thing they told me was to come to a complete full stop before shifting from reverse to drive & to lightly accelorate before mashing the pedal, but who the hell does that??
  • I also have and 07 AV that is having transmission problems. I have had to the dealership four times, each time the response is the same "It is within factory specs." Yesterday a GM rep drove the truck and said it was functioning according to gm specs. The tranny is designed to return to a zero pressure mode before allowing engagement. (drive,stop,reverse,stop,drive.) I have experienced anywhere from a slight hesitation to lengthy upon acceleration. I have also had the same experience setting at a light then accelerating with hesitation occuring. Now you know why GM offers the 100k drive train warranty. I would be interested in hearing other excuses offered by GM thanks
  • I just had my transmission go out completly on my 07 avalanche with 9000 miles. I just got off the phone with my dealer and he advised me that my transmission was shot and they were replacing the whole trans.. I had similar experiences as other. Sometimes when pulling from a parking spot I would feel like I hit a rock or something and would look and there was nothing there. It finally went out as I was pulling away from a redlight at low speed and kaboom, it was loud, I thought I got rearended. The trans then began slipping until I got home about 2 miles from where I was. Now I will have to wait a few days for a new transmission to be installed.
  • chadxchadx Posts: 153
    Update to my issue:
    "I've been having a problem with what I'm guessing is some type of trasfer case control/solenoid...basically, sometimes when I start it, the 4x4 selector light shows the red dot in the neutral position rather than the amber 2x4 light. Also the dash flashes "service 4x4". Other times, when I start it, it goes to Auto4x4 rather than staying in 2x4. Other times I can't shift from one mode to another. Usually, I can get it to reset by shutting off the truck and restarting. Rarely, I have to also play with the buttons and/or shift into neutral while doing so. Sound like the same thing? Mine is a 2003 with 60k miles. The problems started around 55k."

    Issue has been fixed. I had it fixed under extended warranty. It was the transfer case module that had gone wacky. It's been about 6 months and 8k miles since the fix (with plenting of shifting to Auto4x4 and high and low 4x4 now that it's winter in the mountains) and have had no problems.
  • WHEN is this going to be offered on the Avalanche? What year? WHAT are they waiting for? The new Tundra and 09' F-150 (due out early fall) have these.
  • I have had problems since I bought my AV. Blown transmission at 15,000 miles. Trips to the dealer several times before w/ complaints of slipping transmission and banging into gear. Many other problems as well. Starter doesn't disengage after ignition. Dealer says GM says I have to live with it. Dealing with Chevy to get a new truck. I have lost 14 days with my truck. Dealer very arrogant. Where is the service? brendanfay2001
  • I have an 07 Avalance I bought with 9400 miles on it. Between the RPM rage of 1300 and 1600 it shutters or rumbles. I had it to 2 different GM dealers and when they drive it they say something is wrong. So they contact GM and then they come back and say its normal. I have owned all types of cars threw the years and never had one act like this. I dont feel the people they have working at the dealerships know what to do to fix it so they say it's not abnormal.

    I am very unhappy with the dealership and GM customer complaint. What really upsets me is you buy a vehical close to home and then get this type of service. Also, when you call GM customer complain you have to speak to someone that cant speak english and you have no idea what they are saying. I have 6 Lemons to put on my Avalanche and going to leave them on and drive through the dealership and my home town.
  • patty_mcpatty_mc Posts: 1
    Have a 2004 Avalanche. Recently the transmission went out. Specifically the D(drive) gear went,I can still go from 1st thru 4th and then to the D(drive). AMCO offered to replace the transmission for $2300. The computer at the dealership said that transmission had nothing wrong with it.

    My question is, is there really anything wrong with the transmission or has GM rigged it so their transmissions check out o.k.? Obviously there is something wrong, any advice would be appreciated.
  • 2 years ago i bought a 05 chevy ava the first thing i did was put some 22'' rims on it ,and by the second week i started noticing this strange hesitation. i was at the stop sign waiting for the green light and when it was time to go, i put my foot on the accelarator then the engine reved up but it took a couple seconds too take off i heard a loud clank then it finally moved .now ive taken it back to the dealer and all they gave was bull and they were only going to take care of it untill it was broken down. Now its done this to me 4 times since the only sense i can make out of it is that the transmission is going out.can anybody tell if this has happen to you i appreciate it. :confuse:
  • hp995hp995 Posts: 2
    I purchased a new Avalanche in '05. The first problem I had was in the steering.
    The dealer replaced the steering arm in '06 under warranty. Last year '07, I was on a trip out west pulling a small 10' trailer and the trans. went out. It was 2000mi out of warranty, $2500 to fix it. This winter the tailgate handle broke inside, dealer wants over $300 for a new one, NOT ! I'll use a screwdriver ! Last week I took a trip to Canada pulling a 20' boat and the rear universal joint went out - $200 more. The rear end still makes a noise (clunk)when it's put in gear or sometimes when you take off from a stop. I was told by a friend that the rear universal was under recall, but I can't find anything about it it. I have been a Chevy guy all my life, I have '99 dully FWD pickup, '99 Tahoe (best car I ever had) and the Avalanche. I think I am changing to a Ford guy after this one!
    I like the Avalanche allot but it seems to be cheap made. Almost afraid to take it anywhere.
  • We had a '07 Avalanche. The transmission lost 2nd and 4th gear; the truck had about 30,000 miles at the time. Dealer wanted to replace the transmission, but GM insisted that they rebuild/repair it - which they finished after about 10 days. They paid for a rental.

    Other than that, the vehicle was a good one; not a lemon. Made two trips half-way across the US, and one trip to Georgia. We traded it in April 2008 for a '08 Malibu, mainly because at that time gas was predicted to hit $4 per gallon (which it eventually did.) Because of it's (less than good) milleage, I anticipted the re-sale value of the Avalanche dropping like a stone - and it did; thankfully it dropped after we traded it. I digress. The dealer described the tranny going out as a "freak" manufacturing flaw.

    Regards,

    Misha
  • I have a 2004 ave that has had 3 switching devices since i bought it 3 years ago. Its in the shop today getting the 3rd unit installed. This will be the last unit i pay for since i plan on getting rid of this lemon as soon as possible. The sad thing is that I don't go off road, not a heavy driver, and still the problem has happened for the 3rd time. The truck has 80k miles on it, which I had only driven 28k since buying the truck. There have been other issues as well, but the switch selector is the biggest problem. Time to go back to Ford, I guess.
  • hp995hp995 Posts: 2
    My 2005 is messing up on the 4WD switches now. Keeps saying (service 4WD) and somtimes the indicator lights don't work, but it works fine. Had my garage check it and change all the oils. He said there was nothing wrong with it. Is this the same switches as yours chadx ?
    Wife just told me today, it will not take gas correct when she hits the gas.
    What a piece of #$%& !! :lemon:
  • Jamm3rJamm3r Posts: 1
    Hi,

    My 07 Avalanche with 12,800 miles just blew the transmission and the dealer trying to say that they won't cover the warranty due to my 22" rims. Any advice on how to fight this would be appreciated.
  • jhinscjhinsc Posts: 399
    You will have to prove that your aftermarket rims didn't cause the transmission problem. One easy way to do it is to compare the overall height and dimension of aftermarket rim and tire to a Chev 20" rim and tire. If they are the same, your rims didn't cause the problem. If it's taller and/or wider, or perhaps shorter, it threw off the gear ratio putting more stress on the transmission. Good luck.
  • Tranny just went on my 07 with 20 k on it. It has been in the shop for over a week now, good thing I did not need a rental because they said they do not offer that anymore. Lost reverse. They are in the process of rebuilding it. Sure is taking a while. Funny thing is I do not tow or abuse the truck. I traded in an 04 for this one.
  • I purchased my Avalance in Feb 08 it is an 07 so it was a slightly used purchase. However being that it was fairly new, I figured it would be a good buy. NOT...this car is Junk! It looks nice, but from day one the brakes were squeeky but new, the battery was constantly dieing out on me, finally had AAA replace my battery. The air noise comming through the windows is annonying and now yesterday..less than one year after purchasing my vehicle..my Transmission went out I think..I really dont know what happened I was at a red light and when it turned green I stepped on the gas and the car jumped and made a loud noise. As I stepped on the gas again and nothing it would go nowhere! People behind me were furious as I was holding up traffic on a busy street. Tripple AAA had to tow it home..Monday I have to take it where I bought it or a Chevy Dealer? I'm not even sure where to take it?

    Thank God I purchased the extended Warranty for 60 thousand miles! But people used to tell me when I drove my Ford - Chevys the Vehicle! And I say now..I'd rather push a Ford than Drive a Chevy I'm so sick of this big expensive unreliable hunk of junk. In Comparrison to my 2002 F150 Supercrew which I bought brand new..and put 120 thousand miles on it and only changed the Oils, brakes, and had the fuel injection cleaned. It never stranded me and took me all over the US faithfully..it was a quiet ride and even when I turned it in was running smoothe as could be? Why I traded it? I dont know..I wish I could go back but since I cannot does anyone have any advice for me? Turns out my Avalanche will reverse and run in 3,2,1st but does not move in D-drive. Really really strange..I've had cars with Transmission problems but this gave no warnings...before-hand?
  • romeo046romeo046 Posts: 1
    I have a 04 ava trans went out 2yrs ago. ITS in shop now for 2nd trans. Bought it in 04 with 800 mi. got the extended warr. cost me only 50 bucks but here we go again warr. ended 4-19-09 I have less than 60,000 mi. and 17in. rims I DONT KNOW WHAT TO THINK!!!! :confuse:
  • You need a transfer case motor which is about $500. because the same thing happen to my 05 avalanche and it only had 26,000 miles on it.
  • I have an '03 Z71 with 86k miles on it. Transmission kicks going into 2nd gear from first. but the thing is, it only does every once in a while. Local reapir shop that specializes in 4x4's said its a common thing with the avalanche, and its something electronic. I've reading several places that electrical issues were prevalent with the first gen '02s and they fixed most of them but maybe someone else is having the same problems? it's not really a problem yet but i'm a little wary since boating season is just around the corner and towing doesnt help a vehicle thats struggling already. any advice is appreciated
  • wmpanaceawmpanacea Posts: 1
    I have tge exact same problem. What did you do?
  • Two weeks ago I lost the transmission on my 04 Avalanche. I thought that someone hit me from behind. Anyway I knew that the transmission was finished and I'm not a mechanic. I called a local Chevy dealer in my town and described the situation, 04 avalanche with 46000 miles on the odometer. They told me sorry, it was my problem and not theirs. Took it to a local transmission shop with a good reputation and paid for a rebuild, 1800 bucks worth. Decided to call Chevy complaint line and give them a piece of my mind and was told that they probably would have covered at least a portion of the cost but since they did'nt do the work I was out of luck. Actually, they are out of luck, I have owned 7 Chevy's in my life and will not buy another. I think that their customer service stinks and that type of attitude is why GM is in the situation that it is in. Otherwise I have loved the vehicle but will not do business with a company that refuses to stand behind their product or long time customers.
  • mav007mav007 Posts: 4
    i have a 04 avalanche z71 yesterday on a take off pulling approx 3500lbs i heard a loud pop and noticed i was not accelerating i have no drive and no #3 i have #2 #1 and reverse fluid is fine and no burt smell is it the whole transmission that is shot or is it a module sensor type problem thanks
  • mav007. I went to the gm site. There is a comment section there and I explained my problem (similar to yours) I received a reply within 3 days from GM asking me to call them. Long story short they agreed to reimburse me 1/2 half of the cost to repair. total transmission rebuild 1800, they paid 900. I thought that was fair. Hope this helps
  • belriabelria Posts: 3
    My husband and I are ready to upgrade. We found a 2002 AV with 81,555 miles for 10k. the blue book on it in excellent condition is 12,535. I have researced this rig thoroughly and am concerned about transmission problems. Especially since they are one of the most expensive things to fix. We cannot go wrong in buying a newer vehicle. We are a young couple living off one income and do not want to screw this up or drive it for a year and have it break down and not be able to fix it. Should we take it to a mechanic first or take the dealer's word for it? Will it break down on me and my spouse leaving us @*$( out of luck? :confuse:
  • Belria, I purchased a 2004 Avalanche two years ago with 29000 miles and the transmission went out on me last summer. (see previous posts) I was completly upset over the entire matter. The cost to replace the transmission was 1800.00 and the vehicle was out of warranty. I wrote a letter to GM explaining the issue and kept it professional. GM agreed to pay 1/2 the cost of the repair even though they did not do the repair work. It is my understanding that most of these transmissions that do fail, do so before they reach 75000 miles, but I would still have the transmission checked by a mechanic before you buy or at least get a warranty in writing. My truck now has 52000 miles and I have had no other problems. Good luck.
  • mav007mav007 Posts: 4
    where can i locate a new/rebuilt transmission for a 2004 Z -71 5.3 w/o getting ripped off mine is totally out of service thanks mav
  • belriabelria Posts: 3
    Everything I have read about the transmission problems on avalanches seems to happen to on models 2004 and newer. Does anyone know anything about the older models. We're still looking at that 2002 model. I found out it was a company rig for the first 72,000 miles and am hoping they took good care of it maintenance wise. The dealership says it has no current transmission problems and there is nothing on the car fax indication anything is wrong with it.
  • belriabelria Posts: 3
    I would say craig's list or find a truck that doesn't run but has a good transmission still. Wrecked ones could still have good parts.
  • i just bught a 2003 av... my very first piece of chevy ever, any way i have noticed that when ever the truck is put into drivethere is a hiccup or pause if you will that unless i give the tranny anywhere from 1 to 7 seconds to engauge it usually leads to a good jolt to which the transmission then runs completely fine. is there anyone who has had this problem or can lead to any insight into my issue?
  • mav007mav007 Posts: 4
    i purchased a 2004 in feb 2008 with 80,250 miles the trans went out with 132000k mi
    you never know run a car fax and ask the dealership to run the v i n for any service work....a service history i wish u well mavrick
  • west8west8 Posts: 4
    I was reading about you guys solenoid problems and want to know if my problem is the same thing. My 04 Avalanche does not want to stay in 2x4 it will bump into neutral so I have had to keep it in auto 4wheel, any suggestions what may be causing this.
  • Hunterman4- I had the same exact problem happen to me this afternoon with my Avvy. I jumped online and starting looking to see if there were any posts regarding tranny problems and I stumbled upon yours and mav007's posts, so I called the GM customer service hotline and explained to them the problem and they are going to review my "case" with the tech tomorrow. I was just wondering if you still had the phone number that they asked you to call.
  • Sorry, but I don't have it any more. I believe that it was to GM corporate offices. I was very impressed when I called the number that they gave me and an actual human answered the phone. As I stated in my post, I thought that GM was very fair in the way that they treated me. I explained to them that regardless of warranty coverage, a transmission should not fail with only 46000 miles on the vehicle. They agreed with me. Good luck to you.
  • 51yrsgm51yrsgm Posts: 2
    If you sold 03 AV cowboycadillac...I think I now own it! Kick seems to be getting worse (does it most every time now) Anyone else haveing this problem? Is 12 MPG rolling down hill on interstate really what I can expect out of this truck?...If so...It's GONE! WHAT A PIECE OF JUNK!!!!!
  • My 2004 Chevy avalanche z66 was working great today. after driving all day I went to go to the store and the transmiton went to drive on the column but did not engage to move.I checked the fluid that was full and I shut the truck off for 30 minutes then got in and tried again the truck went into gear and drop 100 yards and then stopped driving. I did this again waited 30 minutes started the truck, it went right into gear then drove 1/4 mile and then stopped driving again...could this be an electronic sensor problem ? or do you have any idea what this might be?

    Thanks,
    OTG
  • smfd730smfd730 Posts: 1
    otownglazier.. My 04 avalanche is doing the exact thing that you said was happening to yours.... perhaps u could give me an idea on what it is?? thanks
  • cesarhcesarh Posts: 1
    Did you find out what the problem was...tjis just happen to me and i hate to overpay if it is something electronic or so?
  • kato677kato677 Posts: 2
    To anyone who settled w/ GM for Avalanche Transmission Problems,

    PLEASE let me know what settlement you received & if you had to sign any paperwork which said you could not file any complaints against GM w/ your Attorney General's Office and/or pursue GM for any remaining or future repair costs. In addition, what did GM conclude about your claim and what was your initial problem & onset of said problem.

    Thank you!
  • kato677kato677 Posts: 2
    It seems you have had some success w/ GM. I noticed you haven't been on the forum in a while, so my hope is you have this set to e-mail you if someone responds. I just posted a message on the board regarding specifics on problems, settlements and communications w/ GM. If you could provide me with additional information on your settlement, I would be very greatful.
Sign In or Register to comment.