Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Have you recently bought/leased a new car online and requested a home delivery due to coronavirus? A reporter would like to speak to you; please reach out to [email protected] by 4/5 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Chevy Silverado and GMC Sierra Starting Problems

13468911

Comments

  • Thanks we have been trying to clean it the worst is the check engine light has not come on so there are no codes. The truck does have over 150,000 but that is not a true read being that the instrument cluster is bad. When the truck is cold or its raining the odometer does not work sometimes ten or fifteen minutes late it will start working and this is not the first instrument cluster this is the second one. All I know is I put gas in it and thats when the truck started acting up. i try not to buy off brand gas either I have noticed it gets better milage with some gas then others as well as it just runs better. Thanks again for all info
  • have a 2000 GMC Sierra with 5.3 eng. Now has a issue with starting when eng is warm. won't start on 1st try, but usually does on 2nd. Idle is rough for a few seconds also. Never an issue at cold start. Fuel tank sensor / pump replaced 1 yr ago as was filter. Becoming more of an issue and need resolved..
  • Seems like full battery. left me stranded in the woods. four hours later when we got it home still on the trailer it started right up. drove it for two days and now will not start again. for no apparent reason. Just had the oxygen sensors replaced a few months ago. they said the tranny sensor will need replaced soon. could this affect the starting of the truck?
  • Strange now I went home after about 10 hours of sitting the damn truck started? anyone know whats up with that?
  • I have a 1996 GMC K1500 with 86k, 5.7 fuel injected Vin engine code "R"
    4 weeks ago at 20 MPH it simply shut down, not a cough, sputter, skip it just quit.
    Prior to the shut down i did notice a slightly longer cranking time before it fired up. Typically 2 -3 seconds extended to maybe twice that before it fired up. It ran OK once started
    Had a guy plug in a Snap on computer, OOPS no codes battery dead lost the RAM in the computer.

    under the hood we go look for the big 3 fuel, spark and air. Got em all?

    Three different spark testers say the plugs are getting juice.
    Good visual spark on external plug test

    Fuel test ga reports 62 PSI at the fuel rail test tap.
    I am guessing air is a given??????
    Noid light looks like Christmas on all 8 injector ports, signal confirmed

    We tried new plugs, new cap, new rotor, ignition control module tested OK 2 times.
    Throttle body sensor reports the proper voltage @ .88 VDC and rising voltage on acceleration of the throttle.

    Tried starting fluid in the throttle body not even a cough.
    Tried one half ounce of raw fuel down the hatch not a cough, sputter hop skip or jump?????

    Completely confused anyone have a suggestion short of replacing the VCM.
    thanks
    copdaddy
  • 2005 Silverado, 190,000. Ignition problem for at least 2 years. Turn the key to start... all the lights flash normally, as I go over center to the start position everything dies... no lights, no sounds, no starter noise.... NO Start!!! The vehicle has never left me stranded. It usually takes 10-20 attempts then it will turn over. Everything will run normal for a while then it will do it again. It doesn't matter if the engine is hot or cold. This morning it took about 60 turns of the ignition to get it to turn over. ANY IDEAS? The dealer had it for 3 days once with all kinds of wires attached... the truck started every time for them. Thank you in advance.
  • obyoneobyone Posts: 7,841
    Have you tried using another key to start the truck?
  • I haven't... but I will...
  • I have a 2001 GMC 2500HD with the 8.2 liter engine. I had problems with it cutting out while driving. It would crank over but not start. After waiting a few minutes it would start. No OBD codes registered. I took it to the dealer and they fixed it. The problem was the crankshaft position sensor. $370. If I had know what the problem was I could have fixed it my self. The computer needs to know the position of the crankshaft so that it can fire the spark plugs and turn on the fuel injectors. Good Luck. Bob
  • i have a problem starting my truck if won't start and the thing of it is i just put a new starter,battery , and alt. on it and i drove it for about a week and now i do have juice to the starter and the starter will turn over with me jumping the starter over but when i turn the key nothing happens but i can hear the relays kicking in & out .....what could this be ?
  • did you ever find anything out on your truck? I am having the same problem on my 03 sierra. they are telling me it could be the wire itself between the ign. to the fuse or from the fuse to the starter. i need to ohm it out. let me know if you found anything.
  • jhop2jhop2 Posts: 1
    i had a problem like this happen turned out to be timing belt never heard a thing when it went just shut down hope it helps.
  • bhavlobhavlo Posts: 1
    I have been having a problem with my truck starting the first time in the morning. It doesn't happen all the time but when it does it is extremely hard to start. I had the Chevy garage check it out but as luck would have it there were no codes in the computer and it started very easy for them over a couple days.

    One suggestion they made was to replace the crank shaft sensor. As soon as I put the new sensor in, it wouldn't start, so I know the new sensor didn't fix it. I put the old sensor back in and returned the new one because it was about $70. It still has the problem, when it happens the only thing I have found that helps it is to splash a little gas in down the throttle body and it fires right away.

    I would really appreciate any thoughts?
  • Vehicle has 300,000 miles. Vehicle starts then dies right away when cold/ when hot it stalls but does not die. But problem only occurs when starting once going runs fine. Also smells like fuel when under heavy acceleration. Truck has new plugs/ wires/ injectors/ egr valve/ idle air control valve/ maf sensor. I have done exstensive testing to this truck, I have checked for vaccum leaks/ intake leaks/ fuel pressure testing/ testing and monitoring of all sensors. Truck has had all new 02 sensors and brand new fuel pump. Now i know these trucks are notorious for fuel pumps im on the 5th one. I have heard rumors of the fuel pressure regulator or torque converter, however in my opinion if it was the torque converter i think that it would affect the way the truck shifted. If anyone has had this problem or has any new ideas im open to suggestions, other then buying a new truck lol. Any ideas would be much appreciated
  • Had the same problem. used starting fluid then ran great once started. I did the checking of fuel pressure and regulator,all that checked out.Found out many GM vehicles suffer this problem. It is caused by dirty or clogged fuel injectors. Dont waste your money having them flushed at shop it dont work .
    Found out the hard way. $100. dollars later. You have to replace the fuel injectors, but they dont come separate they come as a assembly of 8 injectors hooked to a module. You have to remove the upper intake to get to them. But i would remove the upper and lower intake if you go this far. Because of a another gm problem. The lower intake gasket has plastic seals at the ends for the water passages. These will crack and fail in time. Replace the lower intake gasket with one that uses metal at the water passages. Trust me.
  • I have the same problem with my truck. I wiggle the key, I put in Neutral and I put it back in park and after several attempts it will finally turnover. If you have a fix please let me know. Thank You
  • I have a 2003 silverado with cranking issues. I turn the key over and nothing. I sit there and wiggle the key, put it neutral then back in park, and sometimes rock the truck and put it back in park and finally about doing this for a few minutes it will crank. It is now getting to the point to where I have to do this everytime I crank the truck. Any suggestions would be greatly appreciated. Thank You
  • ruskieruskie Posts: 1
    Hi I have a 2011 Sierra and I would like to know more about this ignition problem. Currently I have no problems but would like to know the signs. I have had this truck for 2 months and have rust on the front bumper, and door seals, and rust specks on the sides of the doors. Spoke with a dealer and they will replace the bumper, I have watched this web page and have notice that other people having the same problem. I feel this is a poor quality workmanship
  • I have a brand new Silverado (sticker price in excess of $40K!) that has ongoing, intermittent starting issues. Turn the key. Nothing. Plenty of power, all accessories work, but zippo when I hit the key. Truck's been towed to the dealer who couldn't find anything wrong with it, but replaced the battery anyway (seemingly to passify me), but the problem has continued. Truck will eventually start after some period of time (no guess as to how much time has to pass -- it's a crap shoot). I've been lucky that the four times the truck has stranded me I wasn't in unsafe circumstances. It'll be fine for a while, then, with no warning and for no apparent reason, it's dead again. It's REALLY frustrating to have paid all this money for a vehicle that I don't know will start or not. I get that there are no guarantees in life, but one would expect a brand new vehicle to be more reliable than this (I purchased a brand-new vehicle for peace of mind, which I am not getting. Guess that's an option that didn't come factory-installed in this truck). I am terribly disappointed with the vehicle and the dealer's lack of desire to make it right. I've seen other posts from people who seem to having similar experiences. Has anyone been lucky enough to figure out the problem? Any help is appreciated.
  • have same truck & same issues. please tell me you found out and fixed the problem so you could let me know what to do. I've replaced battery, alternator, fuel pump & filter. But not the ignition module or switch yet, which could be next. Rarely, after wiggling the the steering column the gauges would turn on, hear fuel pump & it starts; any suggestions?
  • I might have an idea for you I have a 2008 Chevy Silverado doing kinda the same thing. It is probably a short in one of the ignition wires in the column.
  • I have a 2008 Silverado, Mine is doing the same thing. So far I can tell you its not the alternator, starter, any of the connections or the battery. But what i can tell you is that its probably a wire inside the steering column. I haven't checked mine and found out it to be the problem but I am pretty sure it is.
    let me know how yours goes.
  • I have a 2008 silerado as well that has the exact same issue. I have had it towed three times now to the dealership (Third time today) and they still have no idea what is wrong with it. First they said it was the starter relay loose but I know its not that. Then they said it could be the encryption in the keys. Its not that. I have absolutely no faith in this truck and the wartantee is up in 5 months. If anybody has a resolution to this I would love to hear it. I do not know what Chevy will do with this one as it is happenening every month now. I have been lucky that the three time this has happened I have been locally in town but I live in Alaska and if I am out fishing somewhere in the middle of nowhere once it gets nice out, no cell phone reception and come back to a truck that won't start again I will be in for a bad day.

    Thanks
  • I figured it out! I have been having the same problem for about a month now. It was a real crap shoot on whether or not my truck would start. It came to a head yesterday because it was happening more and more often til yesterday when I could not get it to start at all. I have done almost everything on this blog that has been suggested and none of the suggestions worked. One blog spoke of an electronic neutral safety switch on the left side of the transmission. I unhooked the two wiring couplings from the neutral safety switch and it still acted that same way. I took the neutral sfety switch off of the tranny and hooked the wiring back up. I rotated where the shifter changes the gears to where i thought neutral and park was at and wala, it started. I went to the parts store and bought a new neutral safety switch and replaced it. After approximately 30 minutes labor (easy) and $40 for the part, Im back in business. It has started fine every since.
  • I have a 2008 Silverado Max that has 24,000 miles on it. I have had there times now in the past three months where I go to turn the car on and the lights come on and all instrumentation is fine but the truck does not turn over at all. I have had the truck towed to the dealership three times now. The third time this happened was just yesterday. I spoke with teh service rep at the delaership and we went through what they had thought it was wrong the past two times, key loosing its encryption to computer (Not the issue) They thought the starter relay was loose. (Not the issue) right now I have absolutely no faith in this truck and I live in Alaska so if I am out in the middle of nowhere fishing or something with no cell phone signal I am in a bad situation. I only have 5 months on the warrantee and the chevy service guy already stated they "Seem to have an issue dianosing the issue." Does anybody know what I can work with Chevy on if they can not resolve this issue. If they can't fix it do they need to replace due to warrantee and what type of documentation should I be sending to Chevy now. They have no idea why the truck would eventually start working and work for about a month until it decides to not run again.

    Thanks,
  • Found It, Fixed it! Called the ignition switch-a wiring harness within steering column/lower dash. Bought brand new w/lifetime warranty @ O'reilys for 139. Couple hrs labor. Starts like new every time. BEST instructions for removal w/pics & step by step @ www.sparkys-answers.com/2008/12/1996-chevrolet-1500-truck-ignition.html. No sign in, they forget to mention an E4 & E5 star socket needed. Also, clean & tighten the ground wire for fuel pump located under truck, next to gas tank, on TOP side of frame. Heavy corrosion/dirt and loose will affect starting. Easy to check and has happened before.
  • gmcustsvcgmcustsvc Posts: 4,252
    kip1975,
    Can you please email me your complete contact information including a good number to reach you, VIN, current mileage, and involved dealer? I would like to assist you with this.
    Christina
    GM Customer Service
  • I have a 2009 2500 chevy with low miles on it. The last time i was using it, i parked it outside and shut it off. after about 20 minutes i came out to put it inside and it wouldn't start at all. It makes clicking noises. I ended up jumping it to see if that would work, and it started right off. Ever since then it has run fine, until this morning i had the same problem. I haven't jumped it yet, but have tried tapping the starter and the gas tank to see if that helped, which it didn't. Any ideas?
  • Nevermind!!! I drove this truck (2003 GMC Sierra) only a few times since I replaced the neutral safety switch and it did fine . Now it wont crank at all. Doing the same thing. Turn the key and nothing. Battery is fully charged. NOTHING! I am at my wits end with this truck. Has anyone figured it out yet?
  • gmcustsvcgmcustsvc Posts: 4,252
    aknapp2005,
    Taking your vehicle to a dealer is always a good step when trying to diagnosis your vehicle. Please feel free to email me if you have any questions, comments, or concerns.
    Christina
    GM Customer Service
  • We have a 2003 Chevy pickup that is doing the exact same thing, we have tested the battery, changed the ignition switch, now we are going to have to tow to a mechanic. If anyone finds a solution, PLEASE share. As for taking it to the dealership, it sounds like many of the people here that have done so have spent a lot money getting several things replaced, but are still having the same issues.
  • bigred46bigred46 Posts: 4
    Christina,
    I am having the same problem with my 08 Silverado. It wont start. This has happened to me twice now and it is currently at the dealer, but they cant find anything wrong with it . There is a problem and I want it fixed. I have only had this truck two weeks. The dealer I bought it from is going to pay to have it fixed, but they have to be able to find the problem first. The first time it happened, the engine code said to Service the Theft Deterrent System. The second time it happened, no code would come up. I have also been told from others that they beleive it has something to do with the OnStar system. Can you help me !!! Please !!!
  • gmcustsvcgmcustsvc Posts: 4,252
    I am currently assisting Christina on the forum and I am glad to here that you are working with your local dealership regarding your concern. Please feel free to keep me informed on any new developments with the fix. I can also try to assist you. In order to do so I will need your VIN as well as your name, address, and phone number. Thank you in advance.

    Tricia, GM Customer Service.
  • I have a 2005 Silverado 1500 crew cab that I bought last fall. Love the truck, but I've had four occasions where it wouldn't start - had full power, but wouldn't make a noise or turn over. Had it towed to the local mechanic, who didn't have the diagnostic equipment, but checked out battery, alternator, etc. and all checked out fine. Started on its own a few days later. Did the same thing again a few days later, but then did start later in the day so I drove it straight to the dealer, who put it on machines, but couldn't find any problem... never did it there. Brought it home and now it's done it again yesterday. Tried to start again this morning and nothing. This is really stressful... I'm a single parent and can't be stranded places! Bought a nice truck for reliability and am very stressed and worried about being left stranded again somewhere. Please help!
  • bigred46bigred46 Posts: 4
    Tricia,
    Thank you for replying. The Chevy dealer finally got the truck to not start and tracked it down to the starter. The starter armature has a bad spot in the comm, and everytime it would happen to stop in that exact spot it would not start. So, they replaced the starter and said that it is fixed. I hope it is. I dont want this happening again. For now I am good to go, but if it happens again, I will contact you with the info you need.
    Again, Thanks
    Bigred46
  • 1996 chevy 5.7 I have to turn the key on wait for the pump to cycle then bump the starter I will have to do this 5- 10 time if the truck has sat for awhile it will start with out turning the motor over completly just from bumping the starter and once going it goes great no issues ?
  • Dear GM customer service:
    I have a 2008 Silverado I purchased new with a similar no start situation now 3 times.
    Each time the truck is running fine and turned off only to find out I cannot restart the truck within the nect hour. The battery, lights, remote etc all work flawlessly and the voltage checks out fine before and during starting attempts. The 2nd time this happened I called the warrantee number and the truck was flatbedded to the Chevy dealer on a Saturday morning. After calling in all day Monday I finally just git a ride to the dealer at 5PM to learn they were just getting to it then. Since it started for them they returned it to me saying they had no error codes and it was fine and there was nothing else they could do.
    I must say I am a bit concerned that this has happened 3 times and that there appears to be no correction for the problem - it is not fun to be stranded and not know when it will happen next. I called service a couple of times now asking what to do next but have no answers at this time. Since I will be reaching the end of my warrantee period in a few months it is even more concerning.

    All of this and my contact information is traceable through the Vin ....

    2GCEK13J681319168 - 2008 Chevy , Silverado , Crew, 5.3 , LTZ

    Last call to the warantee center was on 3/27/2011 - please help.
  • gmcustsvcgmcustsvc Posts: 4,252
    jenniclark,
    Please email me with your complete contact information including a good number to reach you, VIN, current mileage, and involved dealer. I look forward to your response.
    Christina
    GM Customer Service
  • gmcustsvcgmcustsvc Posts: 4,252
    smitty477,
    I apologize I do not see your contact information connected to your VIN in our system. Can you please email me this information, including your Edmunds user name? I would like to look into this further. Have a great weekend!
    Christina
    GM Customer Service
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    edited April 2011
    To reach Christina and her colleagues, click the "gmcustsvc" link in the heading of the post, and the email address will appear in the profile.

    We ask that you avoid posting traceable information like VINs to prevent unauthorized or malicious use - vehicle identity theft is just as real as human identity theft.

    kcram - Pickups/Wagons Host
  • bbsmith7bbsmith7 Posts: 3
    Bigred46,
    I have a 98 Chevy 1500 that has had this problem for years now and i've never been correct it. I'm curious if the new starter has fixed your problem??
    Thanks!
  • Christina - Thank you for your help I will proceed as directed.

    KCram - Thank you for your attention as well, I was not aware of that.

    Ron
  • jeram69jeram69 Posts: 3
    I have a 08 gmc sierra 2500hd 6.0l crew cab runs rough when i come to a stop after driving more then 17miles or is warm, and the engine has a vibration in the morning when its cold, almost like engine mounts are broken. dealer replaced them under warranty and its still there. truck has only 25,000 miles. has any body have any problems like this, dealer said it was normal to me its not, please help me or give me some kind of help. thank you.
  • addmicaddmic Posts: 1
    the truck is a 91 gmc k1500 305 and this is a real brain teaser... here is what I have replaced; air cleaner, fuel filter, O2 sensor, throttle position sensor, egr valve, plugs, wires, distributor cap and rotor, pcv valve, grommet and hose, I have also rebuilt the TBI all new rings and gaskets. here is the problem that still remains. some times when I go to start the truck it turns over but idles rough and then dies if I don't give it gas some time even if i give it gas it still dies. the more annoying problem is after driving for awhile is will sputter and if i let off the gas and baby to throttle it will stay going and get back up to speed. at times it has stall completely when pulling out from a light. any direction would be great. also the catylitic converter is gone and the muffler is shot do to a bad back fire but I had this problem before any of that happened. PLEASE HELP I am going crazy.
  • gmcustsvcgmcustsvc Posts: 4,252
    jeram69,

    Please feel free to get a second opion from another dealership. Please keep me posted on any information you may find out, and we can go from there.

    Thank you,
    Caron, GM Customer Service
  • bigred46bigred46 Posts: 4
    smitty477,
    Yes, so far replacing the starter has worked. It has been two weeks since I had it fixed and no problems so far!!
    Regards,
  • My chevy sat for about 8 days, then finally started again. Drove it straight to the dealer. Wouldn't start for them the next morning (a miracle). They replaced the starter and battery. So far, no problems, but I hold my breath every time I turn over the key.
  • jeram69jeram69 Posts: 3
    I had selman chevrolet look at it they had it for 2.5 day, and the service manager call tech support at gm to get some info, after they drove the truck and did some reserch he said that its normal for that truck to run rough at idle. some of my friends have the 6.0l and there truck runs smoth. I just cant belive that a dealer is telling me that a engine with only 25000 miles, its normal to run like crap at times, if there is some thing you can help me with i will bee more then thank full to you.
  • gmcustsvcgmcustsvc Posts: 4,252
    jeram69,

    I would be happy to set up a case with GM Customer Assistance. To get the case set up I will need the VIN, current mileage, full name, address and best contact number for our records sent to me in an email.

    Thank you,
    Caron, GM Customer Service
Sign In or Register to comment.