Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

2010 Chevy Equinox Problems

I just purchased a 4 cylinder 2010 Chevy Equinox, and am having one major problem (I don't know if it is actually a "problem", I'll explain below), and one thing I just want people to be aware of.

The main thing is how it brakes. It seems that around 25 mph (about where it goes from 4th to 3rd gear) when slowing down it will "self-brake". It does it from this point until maybe down to 10 mph, when it switches to 1st gear. I don't actually think it is braking on its own, but it feels like it. It seems a little jittery during this time. It does it with ECO mode both on and off, but seems a little less with ECO off (maybe due to how the ECO mode cuts off fuel at certain times).

I don't know if it is the way the tranny is geared, or the engine not being broken in, or the brakes maybe being adjusted too tight, or what. It has about 400 miles on it, seems to be happening less (not as extreme but just as often), but it might just be us getting used to it. We noticed it during the test drive but seemed worse once we got the vehicle. Also remember the 4cyl. LS trim we drove on July 2nd did it some (at the time thought it was brake assist kicking in, but after reading more about what the brake assist actually is it isn't that), but don't remember details (it was a month ago!).

Anyone else notice this with their new Equinox, or just on a test drive? I haven't seen anyone else mention it on forums, or auto magazine/web site test drives talk about it. I don't even know if it is a "problem" or just how it is, possibly related to something(s) they did to get better fuel economy.

Also, know many of the 1LT trims don't come with the USB port installed (need Vehicle Interface Package). They just forgot to put it in a whole bunch of 1LTs.

Also, OnStar says the microphone is bad. Using Bluetooth it sounds like the person talking (from the car) is really far away. Dealer says it should have the part in a week.

Overall, love the vehicle. Seats are comfy and it is very quiet. Interior styling is great (hard plastic dash, but it doesn't look "cheap"). Acceleration is good, love the Vehicle Interface Package features (an option), and moonroof.
«13456747

Comments

  • vrmvrm Posts: 309
    What did the third dealer say?

    If transmission is the problem, then GM will replace the transmission free of charge. What are you worried about? You have posted a lot of messages but so far I have only counted 2 different owners (on this forum) who have complained.
  • I've noticed similar performance on mine, but I mainly notice it at higher speeds than what you describe. My previous vehicle (Mitsubishi Endeavor) acted the same way, so I'm not too worried about it. With 5 yr/100,000 mi powertrain coverage we should be pretty well protected against any major transmission problems that develop.
  • I just test drove two 4 cyl Equinox's at two dealers and noticed your issue with slowing down. But if you look at the tach, you will see RPMs bump up a bit as the transmission downshifts while slowing down, foot off the brake. I think it is a quirk of the transmission/engine combination and not a brake issue. Since I only have about 20 minutes of seat time, I may be all wet.
  • wallyuwlwallyuwl Posts: 166
    I also noticed it at higher speeds too over the past day or so. It just seems to be doing it more than I remember on the test drive (with the LS 4 cyl. a month ago or this actual vehicle before buying). I also noticed the RPM change from the beginning. I think they may have adjusted the tranny to do this to save on brakes and save gas, assuming once you take your foot off the gas you're going to slow down or stop. I think it is just something they did. I'm glad you guys noticed it too, so I know it isn't something abnormal for this vehicle, even though I don't like that they made it do this.
  • wallyuwlwallyuwl Posts: 166
    So I'm finding out more the more I check into this. It gets very jittery at about 17mph when going on a flat surface/slight decline. You can literally feel the car going back and forth from front to back. It does this in regular mode and ECO mode both, with the automatic engaged and with the sport-shift, but is most noticable in ECO mode in regular automatic mode.

    It also seems to start decelerating immediately when you take your foot off the gas, nomatter what speed you are going (to different degrees, though). In other words, it won't let you just coast like normal.

    My question: Anyone have a 4 cylinder and NOT have this jittery problem or where it slows down dramatically from 4th to 3rd and from 3rd to 2nd when in the normal automatic mode? It doesn't seem to do the slowing down thing when shifting manually with the sport-shift feature.

    Anyone else notice this HAPPENING for them?

    I'm just afraid of going to the dealer, they do a scan, and say nothing is wrong because no codes came up. But this behavior is clearly not normal, even though it appears I'm not the only one experiencing these things. I'm just wondering hope prevalent this is. You'd think it would have shown up at some point with all the magazines and web sites test driving the thing for their evaluations of the model if it was with every 4 cyl., but this problem is nowhere to be seen in any "professional" review I've seen, and no one mentions it in any user reviews on any of the sites I've looked at.
  • npgmbrnpgmbr Posts: 248
    My suggestion is that you go back to the dealer and make then look into the problem other than just looking for a code. I'm am certain GM leadership wants to know about any problems their vehicles are having so can they fix them immediately.

    Something like this (if it is indeed a problem) can likely be resoled with some tweeks to the cars computer.
  • vanman1vanman1 Posts: 1,397
    What I did last time I had a problem that "could not be duplicated" is I took the tech for a drive so he could experience it first hand. Worked like a charm!
  • wallyuwlwallyuwl Posts: 166
    Yeah, I'm also sure they want to know about any problems since they are making such a big deal out of this vehicle. It is one of their "New GM" launch vehicles, so to speak, so I'm sure they want it to build a good reputation.

    We'll see what the dealer says tomorrow, but I plan on going on a drive with the mechanic if they tell me I'm nuts. It is so obvious I don't think it'll come to that. It also seems that while I'm not the only one who has noticed it, some have not. So it doesn't seem like it is "just the way it is", meaning it should be able to get fixed.

    Everyone please keep posting your experiences in driving the new Equinox regarding the downshifting problems and jitteriness, especially the 4 cylinder. The input is appreciated.
  • wallyuwlwallyuwl Posts: 166
    I talked to mechanic at the dealership and they said all the 6 speed autos are like that (the braking feeling when downshifting) now because of the "clutch-to-clutch" design of the trannys. This includes the trucks and Malibus, he said.

    But on forums I can't find anyone complaining about it except on the Equinoxes, and not everyone with Noxs is experiencing it.

    I did get a response from the "Ask Fritz" thing on GM's Re: Innovation web site. Asked me for a phone number so they could call me to talk about it. I hope this is a step toward it getting resolved. I'm also in conversations with a different dealer, and will talk to them again tomorrow.

    I will let everyone know what happens after talking to GM directly and this other dealer.
  • wallyuwlwallyuwl Posts: 166
    There are no Equinox vehicles to be found, but I drove a Malibu today. 2.4 L 4-cyl (same as in 4 cylinder Equinoxes), 6-speed tranny (model 6T40, in the Equinox it is a 6T45, mostly the same). It drove perfect. The tranny was smooth and shifted quick, up and down. They are nice vehicles for a sedan! GM should have put the soft dash materials in the new Nox, and I also like the HVAC controls better in the Malibu.

    Anyway, this confirms the problems I've listed on this board (and some others have noticed in their vehicles/test drives) are not things that were designed to be that way on purpose, there is a problem with a batch of these trannys (at least it seems like it is a tranny problem).

    I'll keep people updated after I talk to the GM Executive Office (hopefully they try and contact me on Monday at the phone number I gave them in my reply email to them wanting it to call me).

    Please keep posting your eperiences with any downshifting or jitteriness problems on the Equinox. Also list if you are not experiencing these problems. Please list engine, and whether AWD or FWD.
  • I purchased a 6 cylinder, FWD, Equinox 2010 a couple of weeks ago and I've noticed the shift down concern you folks are talking about. I think it is the tranny adjusting to the slow down when you take your foot off of the accelerator. I kind of like the effect since, it seems to me, you are saving having to use the brakes as much. So, when I approach a stop I take my foot off of the accelerator and only apply the brakes as needed to come to a stop. I've also noticed the effect when I have set the cruise control and start going down hill, the tranny will drop down a gear or two to keep the car at about the same speed I set it to prior to going down hill. To me this is a good feature, otherwise the vehicle will accelerate significantly going down hill and draw attention from those who are concerned about cars being over the speed limit!
  • wallyuwlwallyuwl Posts: 166
    Thanks for the info. pete. The downshifting while going downhill is intentional with these trannys. I initially thought the same thing with the downshifting not going down a hill - i.e.: it is to save on brakes. But after finding out some people who own/test drove the new Equinox experience this, and some don't, and after learning the other GM 6-speeds don't do this, I think it is a flaw with some of the trannys put into these vehicles. Plus it drives me nuts. I'll keep everyone updated. I've already started looking at Rogues again in case GM doesn't satisy me on this issue, knowing I'll take a few thousand dollar hit over if I'd have just gotten the Rogue to begin with.
  • godeacsgodeacs Posts: 481
    LOL Have you read the Rogue Forum? Many people there are complaining about the CVT tranny..... :sick:
  • cmhj2000cmhj2000 Se, Pa.Posts: 381
    Apples and oranges.
  • vanman1vanman1 Posts: 1,397
    I like it in my V6 Malibu also. I don't really notice it but like you said, it likely saves a little brake which is all good.
  • godeacsgodeacs Posts: 481
    Not really....seems like the same thing to me...... :P
  • wallyuwlwallyuwl Posts: 166
    So an update on the tranny issues in the 2010 Equinox. I talked with the person from the GM Executive Office today and they are going to contact the dealer I took the vehicle to last week, and will get back to me in a couple days. Later this week I'm probably going to take it to the other dealer in town.

    I called the other dealer in town today (mentioned above) and asked them if they've ran into any of these problems on any of their 6-speeds. They said no. They did say some of the Allison trannys have some roughness to them, but none of the Hydramatics (of which are in the new Equinox). So the mechanic at the first dealership was, as expected, full of... well, you know. :mad: :)

    So nothing new in terms of fixed or not, but I'm almost certain many of these trannys (or the computer component of them) are bad, based on many on here not experiencing these problems, driving the Malibu and it being fine, and this other dealer saying they've never heard of this problem on any of the other 6-speeds.

    Hope to know more by the end of the week.
  • vanman1vanman1 Posts: 1,397
    I have never read about a 6-speed issue on the Malibu, I am thoroughly impressed with mine. Hope they get the issue with yours resolved soon!
  • snawdjjsnawdjj Posts: 6
    I’ve got a 2010 Equinox 4Cyl FWD, had it for a couple of weeks now. I noticed the slower deceleration when coasting. I’m big into Hypermiling and part of that is coasting to maximize your momentum, so I notice it quite frequently. Here is what I’m seeing, when I get down to about 20-25mph I see a downshift and the associated (heavy) deceleration. Being a Hypermiler I have a Scan Gauge hooked to the OBDII port and I see something interesting during the 20-25 downshift. The motor enters Deceleration Fuel Cutoff (DFCO) mode. I assume the fuel cut is the cause of the increased deceleration, as the speed decreases below about 10-15mph the DFCO stops and there is an associated decrease in coasting resistance.

    Just want to throw that out there as a cause as I’ve not see anyone else mention it and because I see a correlation between DFCO and the decelerations.
  • wallyuwlwallyuwl Posts: 166
    Some good comments. I have thought the same regarding the jitteriness I feel most of the time when decelerating from 17-12 mph. This still doesn't explain the increase in RPM at downshift (seems like a timing thing, shifting too soon), and it does this in ECO mode and regular mode. I don't know how involved DFCO is in non-ECO mode? Something else to look into, though. But again, it doesn't seem like everyone is experiencing these symptoms. I still think it is a tranny computer problem but this is something I'll definitely bring up next time I have it looked at (Tuesday).
  • mabe40mabe40 Posts: 2
    I purchased 2010 Equinox AWD 1LT two weeks ago (ordered from dealer in May). I was disappointed that the USB was missing and was not given an explanation why, just a credit on the invoice. Reading this forum I see that it was not installed on several of these vehicles. I have not been able to get the blue tooth running either, the display panel indicates it is not available. Does anyone have any suggestions? I was looking forward to this feature.
    My major problem, which hopefully is fixed, started 5 days after I bought the Equinox. When I started the car for my commute home, a low battery warning appeared on the dash and the display indicated that it was going into battery saver mode. As a result, the AC and fan would not turn on. Being a 90 degree day, I was not a happy camper. The engine turned over easily, so I didn't think it was a battery issue. I drove it home and the AC and fan never kicked on, even after the battery had been charged by driving 40 miles. Later that evening I went out and the AC and fan worked. Go figure. The next morning, I started the car for my daily commute and the low battery warning was on again (no fan and no AC) so I drove it straight to the dealer. 5 days and two body control modules (BCM) later I got my car back. This seems to have worked. I'm keeping my fingers crossed. By the way, my rental was a 2009 Malibu. I really liked the way it drove.
  • wallyuwlwallyuwl Posts: 166
    Yeah, many of the 1LT vehicles that are supposed to have the USB port don't. One dealer I was working with was unable to find one with it within a 300 mile radius, so I ended up settling w/o. I also was looking forward to it. For the Bluetooth ours worked great by doing the directions in the book. Make sure your phone is Bluetooth capable and you have it set up properly to sync with the vehicle. Try calling OnStar if you need more help or to see if may be there is a defect with the feature on your vehicle.

    Do you notice any of the transmission issues with your Equinox explained in this forum with the braking feeling with the downshifting, especially from 4-3 and 3-2nd gears? See earlier in this thread to see what I'm talking about further. I also drove a 2.4L 6-speed Malibu (tranny model 6T40, Equinox tranny model is it's brother, 6T45) and it was great.
  • snawdjjsnawdjj Posts: 6
    Not sure why the bump in RPM’s is so noticeable. I guess there is a big ratio difference in the gears, or the torque converter is locking and making the shift feel harder.

    The eco button should make the engine enter DFCO more aggressively. But my experience shows it does not enter DFCO much at all (eco on or off). Other cars I’ve had the ScanGauge in regularly enter DFCO when coasting. With the Equinox I only see DFCO when decelerating from ~60mph to about 40, and then again in the 20-25mph to 10mph range.

    I know with some cars you can feel a little lunge when the RPM’s get too low and the motor has to stop DFCO. But I think what we are seeing in the Equinox is the opposite, increased deceleration when in DFCO. It’s not a deal breaker for me, I don’t find it annoying. But I would like to see GM tweak the transmission program. They just have to be aware of the issue.
  • wallyuwlwallyuwl Posts: 166
    snaw, your analysis seems right on. Your last sentence about GM being made aware of the issue especially.

    Please call GM and let them know about the problem, or even go to your dealer (dealers have a direct means of letting GM know about the problem and if enough complaints are received by GM they come up with a fix).

    So far two dealers say it is probably a computer problem with the tranny (as you also think it is), but they can't/won't do anything w/o a new program put out by GM. I am taking it to a third dealer tomorrow.
  • The problem could have been something simple like the battery connectors coming loose. You said you ordered your vehicle so it was shipped to your dealership for you, it wasn't a tester. Sometimes in transit, things like the battery connectors come loose. Maybe your dealer didn't check it thoroughly enough or it had only begun to loosen so your driving loosened it more as time went on. This happened to one of our marketing vehicles (I work as a product specialist for some Chevy models) last week. We had been out showing the Equinox and stopped for lunch and the car wouldn't start, not even catch. A quick look under the hood showed the connector had come loose, probably from shipping it from MI.
  • I work as a product specialist for certain Chevy vehicles and I know from first-hand driving experience that even our automatic 2SS Camaro has a "braking feeling" when it downshifts from 2nd to 1st gear around 15mph. The Camaro is a RWD vehicle so this has nothing to do with FWD vs AWD. I didn't notice it in the Equinox, but have only driven it one weekend (2 weeks ago) and was still getting acclimated to the vehicle. I'll have it again this coming weekend and will see then. I don't believe that this is a problem with the vehicle. I don't want to leave a detailed (or vague for that matter) explantion of why the vehicles do that until I have a concise explanation for you, but I've put a call into our training specialist and will post back when I have the information you're looking for.
  • wallyuwlwallyuwl Posts: 166
    Any perspective from an engineering perspective is appreciated. It is doing more than just the braking feeling, to elaborate. It also has a "suddenness" feeling when you take your foot off the gas, similar to what you feel in most vehicles when you are driving and switch from N to D while coasting or something. It shudders back to front when coasting from 17-12 mph, decelerating. It also shifts hard from 2-3 and 3-4 sometimes when accelerating. And tonight, it slipped into gear very hard from 3-4 during a normal (not hard) acceleration from a stop. It made a big clunking feeling and noise. :mad:

    I have a feeling GM is going to be getting a lot of complaints about these in the next few months and they'll be forced to do something.
  • steverstever Posts: 52,462
    It looks like you've been around CarSpace for a while and it sure is nice to have someone with access to real product knowledge posting. Welcome to the Equinox forum!
  • roxanne3roxanne3 Posts: 23
    Wow, after reading these posts, I am not sure if I should go ahead and purchase the Equinox I have on order or not !!! It should be delivered sometime in the next 2-3 weeks. Maybe I should cancel. If I don't get the Equinox, I'm thinking of a RAV4. Can anyone give me their opinion on that ? Are you sorry you purchased an Equinox? I'm getting scared to buy one. :( :confuse:
  • wallyuwlwallyuwl Posts: 166
    I guess what I would do is test drive the one you ordered before signing anything or handing any money over. If you'd even sense an inkling of the problems discussed on this board, run away FAST! We thought it was the brake assist and a minor annoyance, but found out it is a much bigger transmission issue once we owned it.

    back2front on here said his dealer contacted GM and they are aware of the problem and working on a fix, but who knows how serious they are about fixing it and who knows when a fix might be coming. And this is assuming the people at his dealer were even told the truth by GM that they are in fact working on it.

    We drove a RAV4 and thought it to be loud and unrefined. As for the other main competitors of the Equinox, we didn't drive the Honda CR-V because we don't like how it looks, and we didn't drive the Escape because after looking at the interior it wasn't as nice as some, especially the Equinox.

    But we did drive many vehicles, including a lot of hatchbacks. The only other one we liked enough to seriously consider was the Nissan Rogue. It drove and rode great (might be a little firm for some), and was very nice inside.
  • I have just gone over 2000 Miles on my Equinox and I have not experienced any of the problems with the transmission that others have talked about. I have had absolutly no issues with this vehicel whatsoever.
  • mabe40mabe40 Posts: 2
    Since the computer problem, I have had no issues. I have driven the Equinox about 1500 miles so far and have not seen any additional problems (I don't have the transmission problem that others have reported). I am averaging 25 MPG (2/3 highway, 1/3 city), which is really nice. It should save me 250 gallons of gas/year over my last car, which got 20 mpg.
  • My wife has 2K miles on her 2010 LT1, 4cyl, FWD. No problems so far. She loves her car. The CRV felt more chintzy and less accomodating in the rear for our teenagers.

    Every auto line has problems. read the Honda message board and you will find people with issues (they will post more than the vast majority that are content). Some are throughout and some are small events that impact a small group. Take message board complaints with a grain of salt. I don't discount someone complaining about a problem like wallyuwl. I can only say we definately do not have a similiar experience.

    Test drive your car thoroughly before you sign the papers. Have the salesman demonstrate your bluetooth, XM, Onstar USB, etc. Enjoy your car. I really believe Chevy got this vehicle right and I have been one of their worst critics.
  • I have had some of the discussed tranny problems but mine doesn't seem to be to the extreme as others. Yesterday I drove on a 7 hr trip [31/2 there and 3 1/2 back} and I didn't have any problem at all. This was through a lot of construction work with constant start and stopping and open road at 70mph driving. I had absolutly no trouble at all and the Nox was a pleasure to drive. I turned off the AWD and ran the A/C and got around 30mpg, I can't explain why I didn't have the issues I had at first, only maybe I have more miles [1,600] on it now. My 26 yr old son was in the back seat and he loved all the leg room, he is 6'6" tall. Overall I love this vehicle so far and wouldn't hesitate buying it again.
    PS Onstar eNav worked like a charm and got me through Chicago without any problems.
  • ronwelronwel Posts: 57
    I picked up my 2010 Equinox a few weeks ago and have just over 1000km on it. I have not experienced the tranny problem, but I do have a problem with my radio.

    There seems to be an issue with the volume and tuning dials. The radio will start to tune to a diffferent station (AM 590, 600, 610, 600, etc...) all by itself. Just yesterday the volume started acted up and would get louder and softer. The tuning slider and volume slider appear on the radio screen, just as if someone was turning the dials. It seems to only happen when the interior temp is hot.

    I called my dealer and he said to bring it in for them to look at.

    I've also noticed that I am not getting very good fuel efficiency, definately not as advertised.

    However...with all things considered...I still really like my Equinox.
  • runoxrunox Posts: 156
    There is a noticeable differenece in MPG in ECO mode. Also, what kind of gas are you burning? I know of 3-4 off brands that deliver 8-10% lower MPG. Here in NJ, Delta is one and in PA Sheets. is a MPG killer.
  • we bought a '10 Equinox 4cyl AWD LS about a month ago and we have the same problem with the trans, not only downshifting, the upshifting is also sluggish and lot of hesitation, and gas mileage is not as good as they claim. it feels like the torque converter is locked up all the time, definitely a computer issue. does anyone here know how to contact GM directly?
  • I have the same vehicle as you, mine does exactly as you describe but when the engine warms up it seems to go away for the most part. It gets really cold here in the winter where I live and it worries me how it will do then. As for the milege mine got an average of about 29.6 on a trip with highway driving [ a lot of construction stop and starting].
  • yyyyyy...,

    I have someone I've been in contact with at GM's Executive Office. So far it has been an exercise in futility, but I keep pressuring her. If you email me ([email protected]) I will get you her contact information.

    I would highly suggest going back to the dealer and describing your problem, and letting them know you are not the only one having the problem, but also that most others are NOT experiencing these problems and it is NOT "normal" for this or any other vehicle. This is the BS I'm getting from two dealers in town I've taken mine to. :mad: See if they know of an avenue for you to contact GM directly in the engineering dept. or something, or at least see if the dealer can call them about the problem (only if you trust they'll actually do it).

    Anyway, going to the dealer(s) will put the problem into GMs database and give corporate another data point regarding the problem. The more people that complain to them and take it to dealers for the problem, the sooner they'll acknowledge the problem and get a fix.
  • My wife parked and double locked our 1LT 2010 Equinox, went into work and eight hours later returned to find ALL the windows down. She was shocked! I called the dealer and he said we would have to wait until it happened again since it would have to be duplicated by the dealership. I mentioned that I would rather not wait until it happened again, especially if it happens on a rainy day.

    Anyone have any suggestions/comments about this?
  • I know that on the remote if you hit the unlock button and then hit it again holding it down, all the windows will go down. Also beneath the window buttons on the driver side there is a button and it will also lower all the windows [haven't used this one yet but the salesman showed me how it works].
  • oops I meant the third time---first unlocks the drivers door, second unlocks all the doors and the third time holding it down lowers all the windows.
  • rjbdrjbd Posts: 1
    Just purchased a 2010 Chevrolet Equinox LS. We were waiting at a stop light, but when the light changed the car did not move. Had to turn off the engine and turn it back on for it to reset so that we could drive again. What if this happened if we were at a busy intersection and got stuck there? It appears to be a manufacturer's defect. Are not looking forward to the dealership giving us a difficult time for a defect that we did not create.
  • What you are experiencing is normal for a 2010 Equinox with a production date up to June 26, 2009. To have this happen you are pressing AND holding the unlock bottom on your remote. There is mention of reprogramming your BCM (at the dealership) to remove this feature but once this is done you will no longer be able to get it back. There is a document (TSB) referring to this condition.
  • Thanks! That's exactly what happened (holding down the unlock button). Appreciate your quick response.
  • Sounds like a wife defect, not an Equinox defect. ;)
  • runoxrunox Posts: 156
    Just tried it on my '10 and it didn't work. Since I bought July 31, odds are it was a pre-June 24 production unit. Maybe the dealer reprogrammed it before I bought it. At first I thought it would be great way to vent the car quickly on a hot day, but the risk of accidently activating it isn't worth the risk.

    Also beneath the window buttons on the driver side there is a button and it will also lower all the windows [haven't used this one yet but the salesman showed me how it works].

    That is the window lockout switch which prevents passengers (children) from operating the windows. I tried lowering all of the windows with this switch also and it didn't work.

    By the way, did you may also lose use of the power windows if you disconnect the battery or drain it down? Instructions on how to reprogram the windows is in your manual.

    It's amazing what you'll find out reading this manual since there are so many new programmed features.
  • So GM's Executive Office said they are just going with what the dealer says. The dealer says the transmission behavior is "normal" and insist they can't do anything about it, though they acknowledge what I'm experiencing. So the Exec. Office offered me a token 2 year maintenance plan. Big whoop. :mad:

    So I'm glad to hear about this new GM program where you can return your vehicle for a full refund within 60 days, and am going to be contacted (so I've been told) by the manager at the dealer to talk about it.

    There was also a person who works for GM and saw my posts on here and emailed me, said he'd get me in contact with an engineer. So far that has not happened, been about a month.

    So if I return this vehicle I'll be in the market for another (I'm just waiting for GM to say it is not valid on recently purchased vehicles, and only valid going forward). Anyone have any suggestions? We liked the Rogue, but you sit lower than in the Equinox and it is a little smaller. The Murano is a little expensive and has bad gas mileage. Any suggestions?
  • The problem you're experiencing could be based on your own driving behavior. All GM transmissions are "learning transmissions" which means they "learn" your driving patterns and adjust to them every 7 cycles. If you are someone who likes to drive your car hard it will adjust to that to try to get you the best gas mileage possible. If you have multiple drivers in your household on the vehicle it just averages the cycles. The stopping your feeling could be the transmission trying to steadily slow you to get the best gas mileage for you.

    If you still think the problem you're experiencing is limited to your vehicle and not all Equinox's just get a new Equinox. Obviously you'd be happy with the purchase if it wasn't for the issue, so find one that you think doesn't have that issue. Why settle for a vehicle you don't like (more expensive, worse mileage, etc) instead?
  • Thanks for the comments. I do not believe it is a driving issue since we do not drive the vehicle hard at all. Thus shifts should be smooth, and over time it should learn to shift even smoother. Also from being on here many others have the problem, but certainly not everyone. And the symptoms are present from when the vehicle is brand new. So it is obviously a "batch" of vehicles affected. GM doesn't acknowledge this.

    I am going to drive a Terrain when they come out in a couple weeks. Same drive train. I would love to keep the vehicle if the tranny was fixed, but GM is unwilling to even attempt to fix it. Simply putting in new tranny hardware/software that came from a different "batch" than the one the hardware/software in my vehicle came from would seemingly fix the problem, since two dealers insist it is a software issue (but they can't just reload the software). The dealer and GM at the national level won't do it. So I won't support them any more with an additional purchase.
Sign In or Register to comment.