Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Saturn Vue Electrical Problems

1235717

Comments

  • I recently had to jump my 06 Saturn Vue. Now the radio does not work. The fuse is fine and it will take and eject a cd but nothing else. Nothing comes up on the screen accept when you push eject and there is no disc in it displays NO DISC. Any ideas?
  • I need help or ideas, or anyone or any mechanic know of any similar problem. I am single mom of 3 and about to lose everything due to the problems this vehicle is having. I can't afford to keep paying people to look at it with no answers. My 2004 vue maybe 6 months ago started acting strange - stalling out in the middle of driving. Dashboard lights would go out and car would stall, sometimes lights would come back on and car start back up and continue driving - other times just stall out completely. Sometimes it won't start, no dashboard lights work at all each time it won't start. Then it goes days acting normally. Then there are days where it is stalling and not starting constantly. Sometimes when it stalls the dashboard lights flicker on and off like crazy. This is a dangerous situation especially with kids in the car, and I am limited to how far I can go and not going on the highway due to not knowing when this is going to happen. This sometimes seems to happen more often when I have the DVD player plugged into the lighter outlet, or when the radio is on, but not all the time. My mobile mechanic first replaced the ignition switch but that did not solve the problem. He told me, and I have been told by others, that electrical problems are difficult if not impossible to find. I am looking for some help or answers or similar experience. thanks to anyone with some suggestions. :cry:
  • I have a 2006 Saturn Vue - V6 AWD. What just started is the 10amp fuse blows inside the car for my tail lights as soon as I turn on my car. The engine does not need to be running. The if I press the brake my 15amp fuse in the engine compartment blows. I had a trailer hitch installed last summer 2009 but have not had any problems with it. Could the trailer hitch wiring be causing the problem or could it be the BCM or could it be the ground. I know if I go to the dealer it will be more than I want to spend.
  • gmcustsvcgmcustsvc Posts: 4,001
    Hello,
    I am from GM Customer Service. I know you don't want to go to the dealership, however I would recommend at least going to get the vehicle diagnosed. It could very well be something from the wiring from your trailer plug but, you cannot be sure without someone looking at it. Thank you,
    Mariah GM Customer Service
  • Am having trouble deciding, with GM having shut down Saturn wondering if major purchase like this worth it. Considering a used '09 21K miles, carfax 1-owner/1 accident (rear-end collision): will problems start AFTER 36K miles, extended wrnty who covers? GM dealer? Interior comfort a plus, a SUV that doesn't look like a truck my other considerations...please help?

    M
  • gmcustsvcgmcustsvc Posts: 4,001
    Hello,
    I am from GM Customer Service. As far as the warranty is concerned it depends on who it’s through. If it’s a GM warranty then any GM dealership should honor the warranty on the vehicle. GM warranty transfers to the new owner. However, if it’s a dealer warranty, you will have to have the work done at that specific dealership in order for it to be covered under warranty. Thank you,
    Mariah GM Customer Service
  • scott192scott192 Posts: 1
    I had the same problem with my 1999 Mitsubishi Montero. It seems that it was a grounding issue. I had someone run an extra ground wire from my alternatator to the the negative post on my battery or to any good ground on the car. I have not had a problem since. I read a lot of posts that said they all had the same problem after the battery or alternator had been replaced. That was when my problems started also. It should cost you very little to have someone run the wire.
  • m0mmylovem0mmylove Posts: 2
    edited April 2010
    my dash lights are blinking like crazy, lost power steering, no sound from radio, electric locks wont work, its starts just fine and my windows work just fine? anyone know what part this could be to fix it..
  • my 2003 saturn vue just started doing the same thing? what was wrong with yours? what part was it? and how much did it cost?
  • 442dude442dude Posts: 373
    One of 2 problems:

    1 - Body Control Module failure - A dealer only repair about $ 600-700

    2- Body Control Module grounding issue - a lot cheaper than # 1 since they have to clean the grounds under the hood.
  • I have a 2002 saturn vue, andthe 15 amp fuse keeps blowing!! I have to change the fuse after 30 min. of driving...such a hassle. Could it be the brake light switch?? Please help me... mother with active kids and tired of changing fuses constantly :(
  • Finally got this electrical problem fixed!! ugh... it was a bad post in the electrical harness that goes to the dashboard. I noticed that for months the radio was acting funny... then the stalling and not starting randomly problem. All related to the same thing! not too expensive... $370 at Saturn. Not as bad as I thought it would be!! :blush:
  • skingsleyskingsley Posts: 2
    I loaned my '06 Vue (V6 AWD) to a friend recently. She didn't realize that it has daytime running lights and turned the lights from 'auto' to 'on' and drained the battery. After I jumped the battery to get it going again, I notice that the clock is not working, the radio and CD player also are not functioning. I checked the fuses under the hood, the only one that seemed to refer to the stereo was labeled 'prem sound', but that fuse wasn't blown anyway.
    Is there another fusebox that I need to check? Or does anybody have a suggestion that will help me fix this?
  • thalwachsthalwachs Posts: 3
    edited June 2010
    Has any one had problems with their DLR not working? Mine stopped working but every once in a while the green dash light blinks than goes out. I've checked the DRL relay & that is good.
  • thalwachsthalwachs Posts: 3
    There is another on the passengers side of the center council , about where your left foot would be
  • 442dude442dude Posts: 373
    There is a resistor in the DRL circuit as well as the relay - I believe its located front left in the harness in the fender. As long as all of your wiring is good, your relay checks out OK and your headlights are not burned out, its likely the problem - its an issue that turns up from time to time. There is a TSB about it & it might have been part of a recall at one time. I think its especially prevalent in areas which see a lot of road salt...

    good luck..... :shades:
  • sardog13sardog13 Posts: 2
    My warning lights are randomly turning on and off. The Service Engine light is on but the code comes up blank when it's checked. The ABS and Brake light illuminate off and on. The Speedometer and Tach Gauges randomly drop to zero and pop back to normal with in a second or so. This is usually accompanied by the ABS/Brake/Check Engine Light(s). On top of all that, if I turn on the Rear Windshield Wiper and then the Rear Window Defroster, the Security Light flashes and the Defroster turns off. Separately, they work as advertised. The engine,power steering and brakes are not giving me any problems. :confuse:
  • thalwachsthalwachs Posts: 3
    Thanks for the Info. I'll check it out
  • mirandajmirandaj Posts: 1
    I have a 2002 Saturn Vue, and for a long time my service engine soon light has been on, and a couple weeks ago my service light came on, along with my reduced power light (along with reducing my actual power). I took my Vue to the dealership and they replaced the thermostat, oil cooler, and throttle body control module, and the lights went away and everything was great. Well now my service engine soon light is back on, and also the reduced power. Before my reduced power light comes on, my RPM's fluctuate a little for no reason so I have no idea what could be going on. I called the dealership and they told me it could be a number of reasons, and to bring it in on Monday (it's currently Friday), but I am so irritated that I don't know if I even trust them anymore. Any ideas what could be causing this??
  • skingsleyskingsley Posts: 2
    Turns out there were no blown fuses for the radio. It is an 'anti-theft feature'. If you replace the battery, or disconnect the radio or run down the battery, it needs to be connected up with the GM network to be re-authorized. This way the punk that steals your radio, can't use it. Funny thing was, it's also supposed to say that it's LOCked out, and mine didn't show that. It just cost me $99.50 to get my radio re-authorized.
Sign In or Register to comment.