Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Are you under 40 and think that you might not be able to afford a brand new vehicle when you purchase your next car? If so, a reporter would like to talk to you. Please reach out to [email protected] by 12/16 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Dodge Ram Cummins Diesel Questions

2456717

Comments

  • Hey james59, I had the exact same problem with my 95 Ram 3500 Cummins. It was a bad throttle position sensor; I'm 90% sure this is your problem. It could also be a faulty speed sensor, (I THINK) it is located on the back of the transmission. Inaddition, clean all wires where they plug into the trans. Let me know what happens GOOD LUCK Carnut17
  • HEY james59, there is a section soley for Ram transmission issues on this site; you may find some more valuable info. there. Thanks carnut17
  • The idle adjustment screw is near the left end of your injector pump. You want the low idle adjustment which is vertical and has a lock nut beneath. It helps to have another person hold the accelerator pedal down a tad while you make the adjustment because the idle cam rests on the bolt and make it difficult to turn with the weight on it. Not a big deal but you do need a good light and a glass eye on the end of a stick to see it. 750 rpm in Drive with A/C on.

    Don't know how to tell if the cable is obsolete.
  • Correction on the left end. It is the right end toward the rear of the engine if you are on the left (drivers side) looking at the engine.

    Sorry, my bad.
  • My 97 Dodge will not start after sitting overnight. I have replace fuel hoses and clamps. Bled air at filter. Don't know what to look for. I'm pretty sure it is losing prime.

    Any suggestions?
  • Thanks dlbjones!! I found the darn thing thanks to you, not easy to get to. Well i may be able to help you out with your starting problem. My Cummins did the exact same thing yours did and i spent a lot of money replacing fuel lines and it turned out to be a bad fuel pump, NOT INJECTION PUMP. The shop i took it to says they should be repleced every 130,000 to 150,000 miles becuause they seem to lose gradually lose psi and sometimes just completly fail, let me know what happens also try www.dieselram.com Thanks Carnut17
  • I just took delivery of a 07 Ram 2500 w/ the 5.9l Cummin's. This is my first diesel. So I'm unsure of the little things that are inharent to the diesel. When I test drove the vehicle it had a vibration at any speed and the dealer replaced the drive shaft and rear U-joint. Most of the vibation has gone away except between 55 - 70 mph. My wife and I have checked the tire pressures and have made sure the lug nuts are torqued properly. Any sugestions what to look for?
  • Hello backtoram, Is the vibration like a harmonic type vibration or a shuddering. Do you have oversized tires. Is it a automatic or manual. Let me know, and maybe myself or someone else can help you figure it out. However; if the forum can't lead you to the problem, i would take it back to the dealer and raise hell. Thanks Carnut0399
  • It seems to be a harmonic type rumbling vibration. It has an automatic transmission, stock 265R70x17 tires mounted on aluminum wheels. I'm going to run it for another 1000 miles until I get to the first oil change then I'll raise hell.
  • I pulled a tree trunk pretty big .It made my truck jump a few inches off the ground
    I had a transmission problem right after. I thought I had messed up my trans.I took it in to 2 trans shops ,they told me my trans had to be rebuilt.
    Problem RPM fluctuation .
    They charged me $1500.00 and I got my truck out the same way it went in.Still rpm fluctuation.Now I find out from you guys that it might be my electrical,sounds right,some electrical connection could have been loosen when I pulled the stump.My radio came unplugged. nowwhat I am out $1500 mMybe someone else can benefit from my lose,A bad conection
  • What kind of MPG can I expect out of a 2006 2500 CTD QC auto 4x4?
    I have heard milage increases significantly after 10K, any truth to this?
    Should I wait on a chip until after 10K breakin?

    Will 2wd offer significantly better MPG?

    THX
  • I have the same truck and have got as high as 21 MPG until the winter and ULSD fuel went into play. I now get 17-18 average and 14 while towing 8,000 lbs TT. My mpg never went up with miles, almost 30k now. Be carefull with a chip it may void the warranty.
  • Thx for the response... believe it or not I am going from an econobox (scion) to the big truck I've always wanted. I get 27-29MPG in my toaster, but it has 1/6 the torque and over 1/3 less HP all while it weights 1/3 of this truck. It will be a fun switch from kiddie meal to supersize. :-)
  • It is an awesome truck and you will have a grin from ear to ear when you drive it.
  • I did when I test drove it, I came underneath a freeway underpass while making a u-turn onto the feeder and decided while I was make the turn to punch it.... thank God no one was coming because I slid sideways for a bit. Yeah I am definitely gonna enjoy the power. It sounds cheesy but this is a dream come true.
  • I just got a 06 2500 and it's geared too low whats the biggest tire I can safely put on the stock rims. I've heard 35s will fit (was in a magazine)any one got any experience with this I use my truck for basic transportation with minimal towing or hauling
  • I want to remove the emblems from my 06 2500 anyone know if they are pinned or just stuck on with adhesive I won't do it if I have to patch holes
  • I have seen alot debadged without holes remaining so I bet money the are adhesive... I cant remember a car I've had in the last ten years that use anything other than adhesive. I'd call parts department to make sure... they should know off the top of their head.
  • adhesives! some guys like to de-chrome and therefore debadge their truck. check out www.dodgetruckworld.com, the technical forums have some VERY knowledgeable people. I have learned alot form the guys in the diesel, tire/wheel and suspension forums.
  • I have a 97' 3500 2wd with the Cummins. My baby has just under 250,000 miles on it and it just started having trouble starting. Sometimes it fires right up on the first try the sometimes it takes 3,6 or 9 times to get it to go. I will say this once it's going it runs great just like there was never a problem. I just changed the fuel filter and that made no difference so no I'm onto the fuel pump I guess?? Any help would be great!
  • Gunflint you have 250,000 miles, i see it;s just breaking in. Is it hard to start only when cold or all the time. If this site can't ultimitely help you try dieselram.com thanks carnut17 (Jeff)
  • Thanks for the fast response! It doesn't matter what the temp is outside. I just drove it around tonight to finish up some X-mas shopping and once out of the five times I started it - it started on the 1st try. The other 4 times it took 3-4 tries to get it going.
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    Hard starting on my 96 3500 Cummins always meant battery. If they're more than 2 years old, get the terminals cleaned up and the batteries tested. if they're more than 3 years old, buy a new pair.

    kcram - Pickups Host
  • I will saw this it turns over fine it just won't fire. It's like it's not geeting fuel to the engine. Could this still be the batteries?
  • I wonder if your having a problem with the intake manifold heating element. Thats why i originally asked if the truck is hard starting when cold or when hot. If the truck is hard starting regardless of whether it's hot or cold you might have a bad fuel pump. Let me know whats going on Thanks carnut17 (Jeff) HAVE A GREAT HOLIDAY
  • Jeff - I see that this thing has two fuel pumps. Which one would you start with? Also do you know of a way to check the heating element? Thanks Again!
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    If it appears you're not getting fuel, you probably need to check the fuel filter and fuel pumps.
  • Gunflint, I checked the intake heater because it seemed mine failed to start on cold days. Heater fine. I thought the "O" rings etc in the filter may be letting air by. I replaced them also. I finally bit the bullet and bought a transfer pump (lift pump) but have not had time to install it yet. However, it runs too good other than loosing prime to be batteries, injectors, or injector pump. I planned to check the fuel pressure, but guess what; you have to do that with the engine running and guess what; the fuel pressure is fine when the engine is running.

    So, I'm betting on mine being the transfer pump.
  • I am having the some or similar problem on my 95 2500. My truck always starts but sometimes i have to crank it for awhile.. This is an intermittent problem. It will start as normal sometimes and at other times i will have to crank and crank.. My truck has 160000 miles.. The thing is I don't have to wait over night for this problem to occur.. Also when I went on vacation for 1 month and returned home the problem was gone for awhile??? Help
  • I got in touch with a guy named Kurt Lincoln today, and he walked me through my problem. It is the Fuel Shutdown Solenoid. I was about to purchase a fuel pump in the morning. If you need any help drop me a line.
    Thanks for everyone's help!
  • I am glad you foung the answer gunflint, I feel i dropped the ball regarding your problem. The reason why is i had the exact same problem w/my Cummins P.U. I was just getting on line after being away for the holiday to tell you to check the fuel solenoid; AND BEHOLD!! I see you figured it out Have a great day Jeff (carnut17)
  • Hello bactoram, I too experience vibration at those speeds.
    I have an 06 Ram 1500 QC with 3100 miles. The vib has been there since new, June 06. I'm in So Calif; the dealer has installed three drive shafts. At first, the vib occured at 38 MPH. They took out the second DS, sent it to a DS repair/balance shop. No improvement. A factory rep: (engineer), installed shims under the Automatic transmn. to bring the driveshaft angle within factory spec of 1 deg. The vib went away at 38 MPH, but came in worse at 58 MPH. Then he put another drive shaft in and balanced it on the truck, and according to his service report, he said the vib was "GONE". When I drove the truck the next day, the vib WAS NOT gone. He stated that the vib is caused by the torque converter when it "locks up", and is transmitted through the drive train. Now read this CAREFULLY! He calls this vibration "DRONE". Now I've looked at the "DodgeForum.com" and owners are having the smae type vibrations. But I've NOT found any that has been told it is "DRONE" from THE TC. I have not seen it here either.
    This is a long post and I've posted it on the Dodge forum so "WE" can be more aware of this issue. I've written letters to Daimler Chrysler about these attempts,(so far), to correct it and more information about this "drone". Haven't heard anything yet. The service mgr at the dealer in Cerritos CA has been very helpfull in getting to this point. He said, "he has not had this vib complaint before"! He has done all he knows to do, (I guess). I'll keep this forum posted as things progress. I hope this helps! One owner on the DF is/has gone thru the lemon law so far. Mine is not a lemon....YET!
    Happy New Year to all!
  • Thanks,

    I had already bought a transfer pump but had not yet installed it. After reading your message I took my solenoid off and the dust boot had deteriorated and gotten into the spring and was preventing it from working so after cleaning it up it works fine.

    Thanks, again.
  • This is where I got my parts from and now my truck runs like new! I can't believe that I fixed a dead diesel for under $20.00. Thanks again for everyone's help! http://fostertruck.com/dodge/default.htm
  • Has any body heard of a pin on the front of the engine comming out and taking out the timing gears and case and who knows what all? My brother in law got a letter from a diesel mechanic in Spokane saying they have a fix for it but it is a 7-8 hr job but way cheaper than what can happen if the pin comes out but neither of us have heard of it. Any body else?
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    Known among long-time Cummins owners as the "Killer Dowel Pin" - if you do an internet search on that phrase, you'll come up with lots of resources. Thankfully, my 96 Cummins went 9 years in my hands without it happening, but others are not so lucky.

    kcram - Pickups Host
  • Hey 41pawpaw I went back to a dealer (not the dealer I bought the from)for my first oil change and to see if they could pin point this vibation. I was also told that it was the "drone" of the diesel exhaust. Now come on you don't feel an exhaust drone in the steering wheel. I didn't have time on that day to take the truck out with the Service Manager. They had to order a right side interior door panel because it looked like they stressed it installing the one on the truck from the factory. So when the door panel comes in we'll go for a ride and maybe then I can show him what vibration I'm talking about. the truck is on its second shaft now and the SM admits they are having problems with joints. I also got some feedback from a friend that Dodge is having problems with U joints. So maybe I'll go the route of having them change out all the joints first. Did they mention anything about shimming the rear end gears or maybe the input shaft on the rear end? I'm wondering if the initial vib damaged the bearing? Keep U posted on what happens. Thanks for the reply.
  • ckleincklein Posts: 4
    I had a similar problem with my 1998. The answer was the low idle on the engine over eight years of driving had slipped. on the 12 valve diesels, the low idle is a manual adjustment on the fuel injection pump which is hard to reach and must be done when the engine is cold. I had a dealer do it ($100 for a ten minute job). If I could reach the 10mm nuts I could have done it myself. Since the adjustment was done vehicle does not die. The new low sulfur diesel fuel has also been a problem. Rumors I have heard is the new fuel is less slippery and there is not enough low sulfur kerosene available for winterization resulting in gelling fuel and inefficient starting.
    Treatments (Power Service) were ineffective so I stated using a gallon or so of gasoline to thin the fuel. Mercedes used to recommend this alternative for my old 1972 220 D. This seems to work better.
  • ckleincklein Posts: 4
    There may be a fuel jelling problem. Try adding a gallon of gasoline if additives are ineffective. New low sulfur fuel may be the problem if not adequately winterized. This is the oil companies' fault! PS park downhill, not uphill, since gelling would be at the back filter leaving the fuel line empty.
  • Hey everyone i am considering a 06 Dodge 2500 4x4. My biggest question is the new Ultra low sulfur Diesel, is it going to hurt the engine in the long run or should i go after a 07 with the 6.7?? engine. What is everyone doing about the fuel?? in their older trucks?
  • akanglakangl Posts: 3,651
    We have two 06 Ram CTD trucks and a 97 F-250 PSD, so far no problems with the new fuel. Most stations here in Alaska have been running it since June so its pretty much all the trucks have known. I lost an injector in mine a week ago at 15k miles, but I'm not convinced the fuel had anything at all to do with it. Our older PSD is handling it just fine as is our 1978 Treefarmer C5D log skidder with a Detroit 353 diesel engine.

    Personally, I would go with the tried and true 5.9L 6-cyl CTD and let them work the growing pains out of the 6.7L before I become a test rat.
  • I have had a problem with my 2006 Dodge diesel getting very poor fuel economy, it also produces excessive black smoke and large amounts of soot. I average about 11 MPG around town with no load. I have had it to the dealer several times, talked with Cummins and Chrysler but they all say there is no problem OR there is a problem but they have no idea what it is and therefore cannot fix it. At one point the engine light came on after the truck stalled on the interstate and the dealer said the code came up as a problem with the fuel delivery system but because the light had gone out before reaching the dealer there was nothing they could do. Has anyone else had this problem?
  • akanglakangl Posts: 3,651
    At one point the engine light came on after the truck stalled on the interstate and the dealer said the code came up as a problem with the fuel delivery system but because the light had gone out before reaching the dealer there was nothing they could do. Has anyone else had this problem?

    Sounds like time to find a new dealer. Even if the light was out there's still a code stored. You can check the codes yourself by turning the ignition on and off 3 times ending with it in the on position. Watch the odometer, it will display the codes (example P0514 or P0537, just like that) and end with ---done---. So its ON-OFF-ON-OFF-ON and then watch the odometer. You can then do a search online for the codes and what they mean. Hope this helps.
  • THANK YOU FOR THE COME BACK RELAYED THE MESSAGE TO MY BROTHERINLAW ALONG WITH THE INFRO I GOT ON THE WEB SITES SO HE IS GETTING SERIOUS ABOUT GETTING IT FIXED. THANKS AGAIN A GREAT HELP.
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    Been running ULSD in my 2005 Cummins with no ill effects. One thing you will want to check on that 2006 is how long it's been on the lot and if they have done any fluid changes to it. Coinciding with ULSD, there was a new diesel motor oil standard issued (CJ-4) which is specifically designed to work properly with ULSD and 2007 engines' emissions systems. Make sure you get a fresh fill of motor oil that's labeled CJ-4 instead of CI-4 before you take delivery.

    kcram - Pickups Host
  • Thanks for the information its all been helpful!
  • I Bought a Longblock 5.9L cummins From a Engine Rebuild Shop and had it installed at my local Truck shop.When I got it back The Engine was blowing out freeze plugs.The local Shop replaced them free but, after being stranded on the side of the road twice I decided to take it somewhere else.The other shop said the thermostat was installed backwards.That seemed to fix the problem for awile now six months later it's doing the same thing.Can anybody give me some useful information.
  • kjt09kjt09 Posts: 1
    Hello all, I'm new to this arena so please bare with me. I would like to purchase a 07 Ram 2500 with the ever reliable Cummins. Can anyone please give me some advice, pros and cons. Also will the 07 Cummins 5.9 work with the new fuel offered ULSD? Any information and advise will be much appreciated.
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    Can tell you firsthand that the 5.9 is just fine on ULSD... my 05 is the same engine as used in the early 07s. I've been running ULSD since the late summer/early fall, with no problems at all.

    kcram - Pickups Host
  • crowe5crowe5 Posts: 6
    This truck has no power. i mean i have to put it in 4x4 just to get up a curb.. please help?? also i have a driveline vibration @ 52--53mph..this truck only has 72kon it ..can anyone help????
Sign In or Register to comment.