Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Have you recently bought/leased a new car online and requested a home delivery due to coronavirus? A reporter would like to speak to you; please reach out to [email protected] by 4/5 for more details.
Did you get a great deal? Let us know in the Values & Prices Paid section!
Meet your fellow owners in our Owners Clubs

Chevy Silverado and GMC Sierra Starting Problems

1235711

Comments

  • aflinnaflinn Posts: 1
    We purchased a 2007 SilveradoHD in June, everything is running fine until about two weeks ago when we went to the gas station, filled up and it was having problems starting. Thought it was a fluke thing and it was extremely cold. Now though it is happening everytime we go to put gas int he tank. It doesnt matter if we only fill up half way or if we completely fill up. It always ends up starting, but it takes a few cranks to get it going. Im planning on taking it in to the dealer---but wanted to see if there was an easy fix that we are overlooking before we take it in and they charge us an insane amount to fix something easy.

    Thanks
  • So my truck was sitting in the driveway for 2-3 weeks and last sunday I turned it on and left it running for a bit. Came back 20 minutes later, engine was off, lights running etc.. Now it just cranks like there's no tomorrow but it won't fire.
    It's a 4.3L 2wd with plenty of miles but very well taken care of mechanically (thus far). Very basic, no alarm, central door locks and such, so its not a security shut-off issue.
    Here's a run-down of things I tried:
    - Fuel pump makes ticking noise when priming, wasn't sure if that's what it's supposed to sound like so i tried starting fluid and still nothing. Checked the valve on the fuel rail while priming and there's pressure.
    - Wires and plugs are a few months old so I ruled that out.
    - replaced distributor cap and rotor (both looked pretty bad) but that didn't solve the problem either.
    - there's about 1/4 tank of gas, put in a bottle of water remover yesterday just in case, still nothing.

    I'm a decent "backyard mechanic" and do a lot on my own cars, but obviously I suck at diagnosing anything past the obvious. Any help/suggestion is greatly appreciated since it's a bit tight financially for me to pay for towing and the shop.
  • obyoneobyone Posts: 7,841
    - replaced distributor cap and rotor (both looked pretty bad) but that didn't solve the problem either.

    I didn't think that the 2001 had a cap and rotor.
  • 4.3L does ('99 - '02), in the back behind the throttle body
    1999-2002 CK1(03-53) ENGINE ASM-4.3L V6
  • delltdellt Posts: 2
    My brother has a 2003 Silverado HD and for about a year he has had intermittent starting problems like those described here. We thought it was the ignition so a couple of months ago he replaced it himself and thought everything was alright, then the problem returned. No error codes every came up, so he replaced his starter and as yet the problem appears to be solved.

    Just a thought to those who can't seem to find the problem. He also took his truck to the dealer and I'm sure the idiots should realize there is a problem however if no codes come up on their computer they are almost useless.

    Maybe this will help some, the symptoms all appear to be the same, erratic starts for no reason, fully charged battery, no clicking from the starter at all.
  • obyoneobyone Posts: 7,841
    You're right. I thought I read 5.3.
  • jimsamjimsam Posts: 2
    I encountered the no-start problem on my 2004 Sierra again, where lights came on when I turned the key but there was no sound/clicking from the starter such as with a low battery. I took it into the dealer and it started while they were checking things out. There were no codes in the system, so they were stumped and I took the vehicle home.
    A week later, this past week, it occurred again. I asked the dealer/service manager if I could pickup a mechanic and bring them to the vehicle to conduct testing to avoid towing which they did. The mechanic determined the solenoid was sticking which accounted for no codes as power was reaching the starter, but the solenoid would not move. He indicated sometimes lightly tapping the solenoid with a hammer would loosen/unfreeze it, of course this would only be useful to get you into a shop for repair.

    In summary, the irractic sticking of the solenoid was the problem which was resolved with an aftermarket starter installed by the dealership for $244. This to me was very acceptable as the vehichle had ~100K miles when the starter was acting up which I would not consider as an unreasonable lifespan for a starter.

    Nice to have a good dealership to work with also.

    Fay Motors of Massena NY, thank you!
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    Be sure to give that dealer some props at our Dealer Ratings and Reviews page!

    kcram - Pickups/Wagons Host
  • 96 Chevy 1500 Silverado, 5.7L V8, 126K miles
    I have had starting problems in past and I took the P/U to my mechanic. They told me that the crank sensor for the timing was the problem.I again after just 1 1/2 years have the same issue. I don't want to keep going to the shop when this issue arrises. Now the check engine light comes on "service engine soon", and the engine is running rough. The last time it did this the truck just over night did not start. I have always done the maintence repairs and fuel pump issues but now I want to handle this issue.
    My question if any one knows is what and where is the crank sensor and I looked in my Hayes repair book and could not find it. That was strange. Does this part excist or did my mechinc rip me off?
  • brian357brian357 Posts: 4
    I have a 95 GMC 1500 4wd with the 350 . Ever since I purchased the truck it has had a starting glitch. When the engine is cold or has sat for several hours it I have to let the engine crank more than normal to start than when it is warm. If i hit the starter like normal, let off and then hit the starter again the truck starts fine when cold. After the truck has ran it starts fine and runs well. Any ideas as to why it has to crank longer when it is cold? And what can i do to fix this. I have wondered what would fix this for years but have not found a solution. Could it be electrical or something with the fuel system.
    Thanks,
  • brian357brian357 Posts: 4
  • brian357brian357 Posts: 4
    I had a similar issue where my truck died and would not start. So i replaced spark plugs, plug wires, distributor cap and a fuel pump which did not solve the problem. The truck would then start but place a load on the engine such as engaging the ac and it would die. What turned out to be the issue was the MAP sensor (mass air pressure sensor) came unplugged. There is a hose that sits somewhere around the distribtor cap that came loose. Plugged the hose back in and the truck started fine.
  • I am pretty sure my fuel line froze when the temp stayed around -20 for a week. Now the fuel is not reaching the injectors. Fuel filter has been changed and the fuel pump is working. If I spray starting fluid in the carb it turns right over. Any Ideas?
  • Similar to my truck's problems. Starts fine after sitting all night, but tough starting if it has only sat for an hour or two. I also get a gas smell when it does finally start. Stumbles once it starts, and rough idle. Someone told me it was a leaking fuel injector, which tends to flood the engine. When it sits overnight, the gas evaporates, letting it start fine in the morning. Also, not injecting properly so that it idles roughly. Nobody can tell me how to figure out which injector is bad, I'm just going to check plugs to see which cylinder is running rich.
  • gmcustsvcgmcustsvc Posts: 4,252
    edited April 2010
    Hello Sdavid1205,
    I am from GM Customer Service. Can you please email me with more information about your concern so I can look into you situation a little further? You can get my email address by clicking on my name. Thank you,
    Mariah GM Customer Service
  • brian357brian357 Posts: 4
    The truck must turn over several times (4 seconds ) or so before it starts. It only does this after the engine has cooled down. If the engine is warm it starts fine. There are no other issues with it other than starting.
  • tanner292tanner292 Posts: 1
    I have the same problem with my 2002 gmc serria. I dont know if youve found a fix for it but if you did could you tell me whats up with it.
    thanks
  • rxqserxqse Posts: 2
    I had posted a while back....
    2003 Silerado w/ 60,K miles.
    When cold would crank, but not start. Yet when warm I had no problem. Checked many things. I finally replaced the fuel pump. This took care of my problem and I have put another 5000 miles on it.
    I had 2 choices, drop the fuell tank or remove the bed.
    I removed the bed as I do not have a vehicle lift. A dozen bolts, a few wires, and 4 people with strong backs and weak minds ( a 12 pack of COLD BEER helped :P )

    I hope this helps someone.
  • akjbmwakjbmw Posts: 231
    Most of us read the postings on these Forums to learn about our vehicles.
    You offer to provide assistance, but I have yet to see your resolution posted.
    If you don't bring enough candy to class to share with everyone, don't bring the candy.
  • gmcustsvcgmcustsvc Posts: 4,252
    Hello Akjbmw,
    Unfortunately, we don't post other people's private information. If the customer would like to post an outcome of their situation that is fine. However, if you need to know the outcome of any situation I would suggest talking to them. Thank you,
    Mariah GM Customer Service
  • rock32rock32 Posts: 1
    Try something called a 'neutral safety switch' ... there is another name for this and it is some kind of digital control for the automatic transmission. Cost me about $60 at a shop to have it done, but I could have got it at Autozone for under $10 and fixed it myself.
  • odierockyodierocky Posts: 1
    Here is the deal, 1997 chevy truck, 280,000 miles, 1/2 ton, 5.7 engine. For a couple of days it ran a little rough at the start, like it was cold, then it would smooth out and run fine. Then it was hard to start, engine just cranked and no fire, pumped the pedal and it started but was real rough. Took off down the road and a 1/2 mile later the engine died and wouldn't start. Towed home and now she sits.

    What I thought was the fuel pump is bad, already replace 5 of them but that is another story. Towed to a local mechanic and check fuel pump pressure and had 65 lbs. Did a scan and no codes were found. It sat there for 3 days and they couldn't fix it. Hauled home and call brother in law, who is a mechanic, just hate to always call him to fix, family you know. He gets here and it starts but some black smokes come out the tail pipe. He puts a gauge on the fuel line to see if it is holding pressure at the injectors and it has 60 lbs while running but as soon as you turn in off if leaks down to about 15 lbs in a matter of seconds. He thinks the fuel injector assembly is bad, the spider tubes is what he called it, may be bad and one or more may be leaking. Tear a part and all tubes look good. It will still start if you pump the pedal and crank for while but runs rough and then smooths out. Afraid to drive, can't afford the tow bill.

    So what's up?

    Mark
  • sdavis1205sdavis1205 Posts: 2
    Sounds like a leaky injector. It's actually flooding the cylinder a little bit at idle, making it run rough. It won't start right away till it clears out the flooded fuel, but then stumbles a bit. This problem won't show a code. My truck is doing this right now, Hopefully I can change the bad injector this weekend..
  • flog62flog62 Posts: 2
  • flog62flog62 Posts: 2
    my 2007 silverado has no crank no start. windows, door locks, wipers, hi-beam headlights, interior lights and flashers/blinkers will not work. I can turn the key on and it chimes as normal before starting. The gear selector comes on and I get a message to service 4 wheel drive and air bag. The radio, ac blower, compass/temp. in mirror and electric mirrors all work. But again no crank. I have checked all fused and relays and everything seems fine. Mechanic has told me it is the BCM. I want to be sure before I shell out the money for one and also if it is the BCM what caused it to go out in the first place. I need to add that I was listening to the radio for about 15-20 minutes and when I went to start the truck it would not start. First thought was dead battery, tried to jump it.
  • gsmom1091gsmom1091 Posts: 1
    After owning only Ford trucks for his whole life, my husband bought a Silverado 1500 used about 3 months ago. It's fully loaded down to heated seats, etc. However, it randomly will not start; it doesn't turn over, nothing. All of the lights come on, all the electrical seems to be working it just won't crank at all. We've had it in the shop 5 times since. The battery, ignition switch and wiring harness have been replaced but the problem continues. There isn't any specific event that causes it not to start. It can sit for a week and start right up but then we run it all day and go out in the evening and it won't start. Of course, most of the time when we take it into the shop, it starts for the mechanic over and over. Anyone had a problem like this or can GM offer any advice? We're getting desperate here!
  • obyoneobyone Posts: 7,841
    When the event occurs (not starting), how many attempts or how long before it finally does start up? or is there anything that you specifically do to get it started?
  • gmcustsvcgmcustsvc Posts: 4,252
    Hello Gsmom1091,
    I apologize that you are experiencing a concern with your vehicle. Can you please email me your VIN and current mileage so I can look into the concern further? You can get my email by clicking on gmcustsvc. Thank you,
    Mariah GM Customer Service
  • vicashvicash Posts: 1
    i have a 2003 silverado it acted like the starter was bad we had the starter rebuilt, they said the celenoid was bad and changed that now the starter acts like it is draging ,if it is not the starter what could it be, the battery keeps a charge;
  • johnnydogjohnnydog Posts: 1
    I have a 1998 gmc sierra 1/2 ton 4wd pickup.It has 260,000 miles. I have installed a reman. distributer, cap, rotor. Timing is correct, its been running great til now. In stopped traffic the truck just shut off and left me stuck in the fast lane with no shoulder, scary. Anyway, while waiting for a tow I tried starting the truck after an 45min. and it started long enough to get the truck to the right side of freeway, then it shut down again. By the time tow got the rig home the truck started I was able to drive it around. What could be the problem, maybe coil overheated? Hopefully you can give an idea. Thank You, Mike
  • on problem with fuel line replace the fuel regulator does the one is not hold the pressure it look like little container
  • heavypheavyp Posts: 1
    I have a 2000 gmc sierra, 5.3,4wd. The check engine light keeps coming on with code 404. It also is hard to start when engine warm. HELP!
  • My 2006 Seirra would not crank. Got out the Haynes repair book and saw only ignition switch and neutral safety switch in starting string. Changed both, one at a time. Still nothing, except check engine and security lights on steady. Starts if I jump starting relay, but won't shut off unless I pull ignition relay, and stop lights stay on unless I pull ign-E 10 amp fuse.I can't find a common thread between the stop lights,the starting system, and check engine light( which will stay on with the key removed until I remove the fuse)
  • How's it going everyone?

    I need some help with a problem I have had for a few months now. I have a 2003 GMC Sierra 1500hd 6.0L pick up with 86,000 miles and it will not start the first turn over. If I then proceed to try again it will start either the second or the third time. If I have driven it recently it usually starts up the first time. I replaced the fuel pressure regulator and that did not help the problem. I noticed if I turn the key from the on and off position quickly 5 or so times, it starts right away. It seems I am not getting the fuel into the motor right away, is this the fuel pump? Fuel filter?

    Any help would be appreciated.
  • hi did you ever recieve an answer to nyour start prob. im curious aS I HAVE SAME PROB. TY RIC B.
  • Check under the fuse compartment under the hood, seems the engineers left room for a mouse condo. When I opened mine up, all I saw was a tangle of bear wire. I spliced and sealed all the damaged wires yesterday and all worked normally. hope this helps.
  • I have a 03 2500hd 6.0 has exact same problem that started about 2 years ago and now it has 170,000 starter is get worn out due to this issue. wish it break so it might be easier to figue it out , anyway any info u find would be a blessing !
  • I have a 03 Chevy 1500HD 6.0L. I am having the same issues! I changed the Battery, Starter Relay, Fuel Pump Relay, Fuel Pressure Regulator and Ran Injector Cleaners. Still does not start for the first several attempts. However, if I turn "on" the truck without Cranking it? Starts with no problem.

    I am wondering if its the Fuel Pump? However that is a expensive and difficult part to "guess" at.

    I am wondering if you figured this out for yourself? Any ANY ANY help would be great! lol :)
  • I went to start my truck but the ignition switch was locked and the steering wheel could not be turned to help release the ignition switch. Have tried rocking and pushing on truck to get it out of a bind but with no success. Even tried to shift gear shift but it is locked as well. Truck can't be towed because front wheels are turned and can't get transmission into neutral. Any idea what has happened? It's parked on level ground and front wheels are only turned 1/4 turn.
  • EXACT SAME PROBLEM WITH MY 02 GMC SIERRA WITH THE 5.3. HOWEVER I DO HAVE 286,000 MILES ON MINE. HAVE NEVER REPLACED THE STARTER. USUALLY STARTS AT THE FIRST TOUCH OF THE STARTER. ANY IDEAS?
  • I have a 1990 chevy silverado truck with a 5.7 engine. The truck was running fine until I parked it and since then I cannot start the truck. It has no fire at all, I have replaced the IGN Module, coil, dist cap and rotor. I'm wondering if my problem might be the ECM?? Any help is appreciated.
  • Hello, I found my problem was different. It turned out to be my fuel injector. I have a 96 Vortex 5.7 SFI. It has the spider injection system. I found that it was dumping fuel in the #8 cylinder causing it to run ruff.

    Can you find an auto parts store in your area that can bench test your ECM? If so take it in to test. If not go to a auto wrecker and buy a used one to try out first. If it works buy a new one later on. You don't know how long the used one will last.
  • I have a 1990 silverado pickup, 5.7 engine. It wont start and with further checking I found it has no fire. Have replaced the IGN module, coil, dist cap and rotor. Any suggestions with my problem? I'm wondering if the trouble may be with the ECM??
  • my 4.8 L 99 chevy silverado will runs really rough like its getting too much air to the intake and boggs down. i hooked dio. up to it and it read two codes. one for the maf censor and one for the purge valve. i changed them both and then cleared the codes. well it was still doing the same thing after this. it wouldnt idle even, but when i unplugged the clip running from the coolant resi. to the maf. it idles. when i plug it in it jst gets choked up and dies. but i jst replaced the maf and 0 other codes came up? wut do i do? i have had people look at it and they arent to sure. i dont know where else to look i need help if possible timing, fuel pump, cat? censors. i confused
  • my 4.8 L 99 chevy silverado will runs really rough like its getting too much air to the intake and boggs down. i hooked dio. up to it and it read two codes. one for the maf censor and one for the purge valve. i changed them both and then cleared the codes. well it was still doing the same thing after this. it wouldnt idle even, but when i unplugged the clip running from the coolant resi. to the maf. it idles. when i plug it in it jst gets choked up and dies. but i jst replaced the maf and 0 other codes came up? wut do i do? i have had people look at it and they arent to sure. i dont know where else to look i need help if possible timing, fuel pump, cat? censors. i confused
  • obyoneobyone Posts: 7,841
    Check your idle air controller and your throttle position sensor.
  • truck will start but rough then smooths out will run for about an hour then will stall. starts and stalls. we have tried cleaning the idle air controler and replaced the mapair flow sensor. fuel pump is less then a year old and fuel filter was replaced about two months ago this all started when I fueled up one day the truck was backfiring the flow sensor seems to have fixed that problem and if I am saying that wrong it is the one right next to the air filter also new plugs were installed to chevy dealer said that the fuel filter is probably ok. also if you give it the gas when it first starts it will stall. should I replace the filter also I was told to replace the engine temp. sensor we cannot find it thanks for any help
  • obyoneobyone Posts: 7,841
    check the throttle position sensor
Sign In or Register to comment.