Buick Regal Electrical Problems

12467

Comments

  • My TRAC LIGHT will start to flash and then come on steady. After about an hour or if I shut the car off and restart it will go out. I also notice that when the press the Trac Off button by the shifter the light does not come on. Any suggestions.
  • ricko3ricko3 Posts: 2
    i have a 2000 Regal with this odometer problem (light going off ) took it apart and found 5 of the resistor off the boards laying in the dash housing. my question, should i replace them, and where to get them if so?
  • ricko3ricko3 Posts: 2
    where can you get the resistor for the cluster board?
  • rosco04rosco04 Posts: 1
    Have the ignition module checked out.Had the same type of shutdown/tranny lockup/key lockup with my 1999 regal. This is what my mechanic did. That was over 100,000 kms ago. No problems at all since.
  • The VICTIM::::: 1998 Buick Regal LS 3.8 l non turbo no leather/no heated seats ect.
    THE SUSPECT::::: Origonal BUICK REGAL OWNER!!!!

    THE CRIME::: Besides blowing up the motor by not using dexcool I replaced april 07. The car ran fine but the brake lights never worked...I never knew why because all the fuses are good relays good ect. I just drove it. I ran in to a guy the other day who knew a particular problem with the turn singal switch.I changed the switch and sure enough the brake lights started to work.
    About 2 days later I had to pick up some 2X4's in my car and since the interior backseat has a access panel it is easy to transport a few in there. Little to my knowledge that the previous owner had some crazy wires jumped from the middle brake lights in the back window ...I didnt know but you want to know how I found out...Here is the kicker... When I pulled in my driveway I had black electrical fire smoldering out of the vents...I quickly shut the car off and pulled my 2X4's out and noticed these wires and seen that he did a very bad job using black tape. The tape due to heat fell off from the 2X4 interaction and then touched eachother.
    I took the whole dash appart and found a wire (marked stop lights) from the fuse panel had burned all the way accross to the brake switch by the foot.. I also noticed the other (white wire) in the brake switch was burned as well..The other 4 wires were affected too(light pink,purple,green with white stripe, and pink) I cut out all the affected bad wiring and replaced properly and put it all back together.. Now I dont have a horn,the transmission is shifting funny in low gears,and the stop light fuse pops the moment u touch the brakes.
    Brake switch was changed after fire,all affected fire wires are cut out and replaced .. The trans is almost new and is not the problem, Its electrical.
    My question is help to find what little box or plug is bad or shorted out. The cars parked and the junk yard has the exact same car sitting in their yard.I can cut up and do anything I want to it and take anything too...SO I am looking for help to find out what to do so I can take the whole dash appart again and fix the problem again.....PLEASE HELP ME!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! SOMEONE with scematics or something HELP.
  • easy fix...One screw on the passanger side (open door and see) then unclick the molding by pulling downa nd forward...That will remove the total plastic piece going across the dash and radio ect...This will expose 4 screws that hold the odometer cluster ect in place....remove those and u will pull it out unclip it and check ur bulbs in the back by turning them counter clockwise....No problems have fun fixing your problems...
  • My dashboard and shifter lights (along with various other lights associated with the headlight switch) won't come on. I need to replace the headlight switch on my 2002 Buick Regal, non-super charged. How do you go about removing the dashboard to get to the switch? I remember the good ol' days where you just removed a few screws and the dashboard could be removed.

    Thanks,
    Keith
  • jzar1jzar1 Posts: 2
    They don't blink, they just remain on whenever I use them. Is it just a bulb problem, or is it electrical?
  • jzar1jzar1 Posts: 2
    Both the odometer and the trip reads "ERROR". What causes this and is it something that can be fixed easily or a dealership(or otherwise expensive) issue?
  • I have a 98 regal gs and I have just started having problems with it. When I try to turn the car on sometimes I get nothing , nothing at all then after trying a few times it will start up. Then what happens is when I put the car in drive my ABS/PARKING/TRACK OFF and SERVICE ENGIN SOON lights come on. Now something even more funky happend tonight, when I got home and turned the car off the headlight went off right away ( they normaly stay on for a min or 2 ) and had no int lights,my remote door/trunk lock would not work either. Took several tries to get the car to start , when I shut it off the lights stayed on like they were supose to but after 20-30 seconds my 4 ways started going off and all my dash lights were flashing on and off buzzing. It did this 3 times befoer it finall turned off like it should have.
    Does anyone knwop what the problem is? Please help!!!
  • jipsterjipster Louisville, KentuckyPosts: 6,061
    Have you had your battery checked?
    2020 Honda Accord EX-L, 2011 Hyundai Veracruz, 2010 Mercury Milan Premiere, 2007 Kia Optima
  • creevecreeve Posts: 1
    I have just had the turn signal switch replaced on my 92' Buick Regal. The radio controls on the steering wheel are not working now. Do I need to reset something on the radio? The new switch I bought is for steering wheel radio controls.

    Thanks.
  • Did you find a solution to this problem? I have the same problem.

    My shop had my car for a total of three weeks to no avail. I took it to an electronics specialist with ten years experience and saw doe eyes when I told him about the problems with my '97Buick. The only things that they said were in common were the grounds, (checked ok), the alternator, (replaced twice) and the ignition, which I haven't done yet. Might as well buy a new car and start over.

    Desperate
  • I have a 1998 Buick Regal and the headlights are very dim. When I checked on internet I found a couple of recalls but the only thing they did was send a supplement to the manual telling you how to readjust the head lamp. My husband said when he looked at the headlamp the inside plastic was cloudy. Has anyone had this problem? There was also listed a recall regarding rack and pinion steering. How long are these recalls valid? And does the recall cover a used car?
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,482
    Make: BUICK Model: REGAL Model Year(s):1998
    NHTSA Campaign ID Number : 98V102000
    Component: EXTERIOR LIGHTING:HEADLIGHTS

    Ask your dealer to look this up and what can be done.
  • jipsterjipster Louisville, KentuckyPosts: 6,061
    Should still be covered under recall. I had my front lights (99 Regal) replaced under recall about 3 years ago. I am the second owner of said vehicle. There is a product out there that can remove headlight cloudiness if that is the problem.
    2020 Honda Accord EX-L, 2011 Hyundai Veracruz, 2010 Mercury Milan Premiere, 2007 Kia Optima
  • hello,
    i have a 97 Buick Regal LS which was given to me, so i dont know its history. But ive had it for about a month now and just within the past week my battery, anti-lock, oil, brake, and low track indicator lights have been going on whenever they feel like it! Mainly the battery light. Ive had my battery and alternator tested. no problem there. i checked for loose wires, the battery terminals and the brakes themselves. Im confused and was wondering if this was something serious or if its just a quick fix i could possibly do myself before going to a shop... any ideas? :confuse:
    Thank you,
    Carla
  • jipsterjipster Louisville, KentuckyPosts: 6,061
    any ideas?

    Could be the sensors going bad for those particular items.... or a loose connection. The coolant level sensor went bad in my 99 Regal LS. The coolant level light has been on for about 6 months now... hopefully it will burn itself out shortly.

    OR, YOUR CAR COULD BE POSSESSED BY DEMONIC SPIRITS.... :surprise:
    2020 Honda Accord EX-L, 2011 Hyundai Veracruz, 2010 Mercury Milan Premiere, 2007 Kia Optima
  • My 1998 buick regal is having an electrical problem, the head lights turn off, the fan stops working, also the interoir lights dim, cruise control shuts off, main dash board light flickers.

    I have checked the battery and the grounds and haven't ffound any problems.
  • know anyone who does exorcisms on cars? :P
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,482
    A Switch Doctor? :shades:
  • its a switch? I was driving today and ALL the indicator lights went on, and odometer/ clock started flickering. then my car seized up and died while i was driving... took 20 minutes before i could start it again and drive home with the hazards on at least. could this be the ignition or just electrical problems just in the dash? :confuse:
  • hoodlatchhoodlatch Mid-westPosts: 255
    Seadog - Did you find the solution to your dash lights? I have a 2000 Century that the dash lights went out. The fuses and dimmer check out OK. The tail lights and head lights work fine. Any help is appreciated. :confuse:
  • tonyf2tonyf2 Posts: 24
    I have a '01 and a '98 Regal, I had this same problem with my '98. Took it to the dealer, they replaced the ignition switch, it's been fine now for the last 6 mo. Cost $626.
  • I have a 2001 Buick Regal. I have started having trouble getting the key out of the ignition when I turn the car off. the key will only go far enough to turn off the battery and will stop there not letting me be able to take the key out. any suggestions as to what is causing this?
  • jipsterjipster Louisville, KentuckyPosts: 6,061
    Your battery is going bad.
    2020 Honda Accord EX-L, 2011 Hyundai Veracruz, 2010 Mercury Milan Premiere, 2007 Kia Optima
  • The only practical solution is to unsolder the bulbs and replace them with the new ones. This applies to all recent LeSabre, Regal, Century and Park Avenue. By recent I mean 1999 and later, and maybe some earlier models as well, but I haven't seen those. The problem is not limited to the dash lights; nearly everything in these cars is lit with miniature incandescent bulbs: buttons on the steering wheel, on the doors, radio, and the climate control module.

    GM did not plan for those bulbs to outlast the cars. My guess is that if you are experiencing this problem, your car has a lot of miles on the clock (== many hours of work for the bulbs). When my wife bought her LeSabre at 156k miles (and those miles were not honest, I'm estimating it had done close to 200k), about one-third of all bulbs were dead. One month later, more than half of them were dead. They were at the end of their mortality curve.


    Another possibility is that they can be blown by a faulty charging circuit. The life span of an incandescent bulb decreases as the 7-th power of over-voltage! They must be substantially under-rated for the voltage range in the car (where it's normal to see voltages reaching 15V). The bulbs used in those cars are rated for 12V.

    That sucks. Not only because it's a pain to replace them, but also because they are hard to find. My guess is that they are custom made for the factories supplying the assembled boards to GM. I could not find them in the general suppliers' catalogs, and it was useless to ask the dealers: they told me those bulbs don't have a part number and can only be replaced with the component they're in. Which, if you count them all, far exceeds $1000.

    If you are lucky, you might find all that stuff at a junkyard, but there is hardly any sense in that, because the bulbs are likely to be old. Replacing the instrument panel will give you trouble, too. It keeps a copy of the odometer value, and it will scream if the value is incorrect; some simply refuse to work, requiring re-programming.

    My solution was much better, overall, but I screwed up in the middle and it ended up costing me more than I planned (but still less than replacing components, or putting up with the dead lights).

    I think I bough these bulbs from Radio Shack:

    http://www.radioshack.com/product/index.jsp?productId=2102815

    I can't recall for sure -- 5 years after the fact, but they sort of look like this. I vaguely remember having to remove the black tubing and possibly also the multi-stranded leads and replacing them with solid wire. At any rate, if you go to Radio Shack and ask for the smallest 12V bulb, that will be it. I couldn't find anything that would be even nearly as small. This bulb is still larger than the original GM bulb, but it fits in most places without surgery. In some parts, you might need to widen the hole, but that should be it.

    Some of the original bulbs are colored. They have pull-over silicone filters on them. These can be pulled off and replaced on the new bulbs.

    Disassembling all those parts and replacing all bulbs, some possibly requiring "custom fit" is a bit tedious, but that's fine, considering the cost of any alternative. I did not count, but I think I spent between 5 and 10 hours over several months, whenever I had time and courage to rip out one component or another.

    CAUTION: those Radio Shack bulbs are crap! They have a manufacturing defect that makes some of them fail almost instantly, and when they fail, they can cause damage to the circuit they're in. Because when they blow (for whatever reason), they create a short circuit, and it's a very good short circuit. One of those rejects blew my instrument cluster a few hours after I put it in. Instead of dying quietly, it shorted the printed circuit in the cluster, and its leads got so hot that they fried the adjacent area of board to charcoal, sending stray current into the processor chip, whose pins were right next to it. That cost me $120, because I had to send the cluster for repair. If anyone is interested, I might be able to locate the company in Illinois that did the repair -- their prices were not that bad compared with the cost of the new components.

    Anyway, I did not give up, but I had to remove all new bulbs again and subject them to a simple endurance test, which you can start with, if you want to follow this path. Connect all these bulbs to a 15V source for several days. If you don't have a suitable source at home, connect them to the car and ride with them for a week or two. My prediction is that 10-20% of those bulbs will blow during the test. The rest can be safely used in the car.

    I did this 5 years ago; the car (and myself) have since moved to Scotland. The car is still running and the bulbs are shining, and I had no more failures. It would be a bummer if I had: there is no Radio Shack in Scotland.

    One more thing: I had to visit 6-7 different Radio Shacks to gather enough bulbs to do the complete repair. They don't stock them in large quantities.

    FWIW,

    --Gene
  • I have a 94 regal. 2 injectors are not getting electricity any thoughts?
  • I have the exact same car and it doesnt sound electrical at all - sounds like a wheel bearing, the sensors for the anti-locks and traction control is in the wheel bearing for our car's. chances are, your wheel bearing is barely holding on and loses the sensor when you hit a bump. changed mine and havent had a problem since (over a year). The reason why it works again when you restart is that it resets the system. If you keep driving with the problem, eventually you will end up hearing some almost grinding like noises when you turn hard, and if I remember right, that means the bearing on the opposite side (the one that gets stressed the most).
  • not a switch at all. it was the alternator. as soon as it was replaced my car was like new again :shades:
  • Mr_ShiftrightMr_Shiftright Sonoma, CaliforniaPosts: 64,482
    Sorry I was just making a joke "Switch Doctor" / Witch Doctor.

    Not so funny I guess..... :cry:
  • Have a 98 Regal that the battery went dead on and after putting a new battery the
    odometer went from 97,000 to 388,000 .
    And now it does not change at all.
    Is there a cheap fix?
  • jipsterjipster Louisville, KentuckyPosts: 6,061
    IHave a 98 Regal that the battery went dead on and after putting a new battery the odometer went from 97,000 to 388,000 .
    And now it does not change at all.
    Is there a cheap fix?


    You sure you weren't abducted by aliens... and blacked out during the drive to Mars?
    2020 Honda Accord EX-L, 2011 Hyundai Veracruz, 2010 Mercury Milan Premiere, 2007 Kia Optima
  • Ok here is what happened..
    If you take the screw out from the dash panel (mine is grey) on the right hand side of the car (where you put the fuses) And some models have a screw on the left...You can pop the plastic retaining dash cover off...Don't be afraid to yank a little ITS NOT GOING TO BREAK!!!! Then you will need a 7mm socket and a rachet to taKE OUT the 4 bolts holding the odometer cluster in the dash...
    Then send it in to a company and explain its the digital screen..Chances are depending where you are from this could cost 300$ so I send mine to a compnay u can locate on the internet in Florida...He told me on the phone exact costs and I fixed one for approx 140$ through him...

    Also I dont recomend driving without the cluster due to damage that can be caused to airbag and other components...

    Or you can go to a junk yard try to get lucky and find a cluster with around the same miledge... By law it is illegal to tamper with the odometer readings..But in this case I believe it is legal... I had 144,000 on my 1998 buick regal and I got one out of a junkyard instead of sending it out..The junkyard one said 188,000 but I didnt care because I like seeing my miles...See its not like they are going to come for me because I put more miles on my car...LOL

    Also if u lose you brake lights which is notorious to happen it is the turn signal switch...You can change it without having to take off the steering wheel...I know I have done it....

    Also flush you coolant frequently....Dexcool will errode away the intake gaskets on the car...

    If the key ever gets stuck in the ignition they put a button under the steering wheel u can push...U have to take off the round pplastic circle looks like a pennie size...Inside there is a release button...

    Also at about 144,000 miles the power steering pump hose will go bad...GUranteed gm mess up...Easy fix if u have a few hours and patience...

    I built a 98 buick regal ls from the ground up...There is nothing I dont know about this car.....If u keep the car...keep this message....my advice will :mad: suit u well.
  • beth1303beth1303 Posts: 1
    For the last 3 days my 99 Regal turn signals have been acting up. If you turn the left one on the ABS, service vehicle soon, and Trac off light come on. If you turn on the right turn signal ALL lights come on and car dies. If you do not touch any turn signals at all then, no lights will come on. When you turn the car off and back on all lights go away. I have been looking around and saw that it COULD be the ignition switch. Is this right?
  • daboo54daboo54 Posts: 1
    This 1999 Regal has the 3.8 liter engine. It has started stalling without any warning. Engine can be warm or cold. Can be giving gas or stepping on brake. When engine stops all other electrical things (lights, radio, etc) are still on. No fault codes show up and check engine light does not come on. Can start the car right up and it runs fine and usually won't stall out again.

    As you can tell there is no way to predict when this will happen or any way to make it occur. Anyone know what is wrong???
  • yarnallyarnall Posts: 2
    I have a 94 Regal with 100K and the dashboard lights going on for no reason: Brake lights, ABS, Check engine. Dealer found loose connection to battery's positive terminal. Cleaned, rethreaded. $250. Got home. Airbag light goes on and off while driving. Day passes. Turn signal lights don't go on. Back to dealer. Dealer says turn signal switch is gone. Is this hard to change on our own? :cry:
  • no it is not and htis can be accomplished without having to take off the airbag ect....I have done it and so can you...if you reply ill give u instructions
  • yarnallyarnall Posts: 2
    OK. Yes please provide directions. Thanks. Also, we have now found that the brake lights aren't working either. Different problem? :lemon:
  • fontaj28fontaj28 Posts: 1
    Gary,
    I just recently purchased a '01 Regal LS. I live in wisconsin (Milwaukee), and it recently has started to become warm outside. I had been having the same problems as you were. The first thing I did was I pulled out the spring from the Gearshift button. I noticed a lot of gunk built up in there, and once I cleaned that it started working. This worked for about 100 starts. The problem flared back up again... this time I went much more in-depth. I actually took off the "wood" around the gear-shift, and then started digging through the center console until I removed that completely. Once I could see completely around the gearshift assembly, I took off the cover that has the PRND32L on it. Underneath, I watched as I pushed in and out the gearshift button to see what part was not moving. Found out there was a lever towards the corner by the glove box that had soda spilled on it that was making it stick. Once I sprayed it with WD-40, the lever started to move. It has been around 1000 starts since then and I have had no problems whatsoever.

    I hope this helps.

    Joe
  • SAME PROBLEM !!!!!!!
    100% guarenteed...

    Ok here is the procedure..
    You take the screws out of the plastic cover around the steering wheel..!!
    On my regal I took a dremel took and cut around the lock cylendor so I didnt have to remove it...
    Then you will see the exposed turn signal switch...There is a star screw on top and in the front holding it on...BUY A STAR TOOL SET that has the right angle on them...U can use them to get in to the screw on the front and use a normal star tool for the top.. AF^TER YOU REMOVE these two screws you will notice the turn signal switch comes right off....Then down at the wire connnection (where the turn signal switch/ignition switch plugs in to the cars wires..) You unscrew the 7mm bolt in the center...Then with a flat head screw driver you carefully remove the turn signal switch wiring...(VERY EASY TO DO)
    Go to the junkyard and get the switch for 25$ and change it out repeat the steps and put back together...
    HOPE THIS HELPS IF U HAVE ANY QUESTIONS I had shops tell my tranny was bad and it was a vaccuum problem I found/alot of issues I found out and saved alot of money ...ANY QUESTIONS just ask..I rebuilt this car from the ground up...THERE IS NOTHING I DONT KNOW!!!!!!! :cry:
  • SAME PROBLEM !!!!!!!
    100% guarenteed...

    Ok here is the procedure..
    You take the screws out of the plastic cover around the steering wheel..!!
    On my regal I took a dremel took and cut around the lock cylendor so I didnt have to remove it...
    Then you will see the exposed turn signal switch...There is a star screw on top and in the front holding it on...BUY A STAR TOOL SET that has the right angle on them...U can use them to get in to the screw on the front and use a normal star tool for the top.. AF^TER YOU REMOVE these two screws you will notice the turn signal switch comes right off....Then down at the wire connnection (where the turn signal switch/ignition switch plugs in to the cars wires..) You unscrew the 7mm bolt in the center...Then with a flat head screw driver you carefully remove the turn signal switch wiring...(VERY EASY TO DO)
    Go to the junkyard and get the switch for 25$ and change it out repeat the steps and put back together...
    HOPE THIS HELPS IF U HAVE ANY QUESTIONS I had shops tell my tranny was bad and it was a vaccuum problem I found/alot of issues I found out and saved alot of money ...ANY QUESTIONS just ask..I rebuilt this car from the ground up...THERE IS NOTHING I DONT KNOW :mad:
  • HORRIBLE ADVISE IT IS THE IGNITION SWITCH get lucky at the junkyard for 25$ and find one with a key or new...EITHER way the problem is in the switch...GLAD GUYS LIKE U DONT WORK AT REAL SHOPS!!!!! :cry:
  • jipsterjipster Louisville, KentuckyPosts: 6,061
    I had the exact thing happened to my 99 Buick. It was a weak battery... not the ignition switch. You have to look at all possiblities, can't blame everything on a faulty ignition switch. :surprise:
    2020 Honda Accord EX-L, 2011 Hyundai Veracruz, 2010 Mercury Milan Premiere, 2007 Kia Optima
  • After an accident on my right front, the odometer of my 97 Buick Regal GS is always 388607, and my radio is not on any more. The dealer does not know how to fix the problem and they just replace the key cylinder and switch.
  • regal99regal99 Posts: 4
    I have A 99 buick regal . and i need sum help..if i use the turn signal.the car shuts off...since then i've stop using the turn signal..now the car shuts off without any notice..I was told i need to replace the steering wheel. so i went an bought one from the junk yard..also anotha issue..the air bag is already out of it. But the air bag in my old steeing wheel is intact..if i take the airbag out of the old one and place it in the one i bought at the junkyard..do you think once its connected..will it send a signal that its been in an accident and expell the the i replaced??? :confuse:
  • bfoubertbfoubert Posts: 1
    I own a 1999 Buick Regal GS, The lights work fine but whenever i shut the car off the brights just dim down. I was told by the previous owner that they're suppose to shut off after 30 seconds but i've sat and watched them stay on for almost 15 minutes before i pulled the fuses. any ideas whats going on?
  • pharma1pharma1 Posts: 1
    I have a 2002 Regal LS. The problem I have 5 fan control settings (Fan speed) not counting the "OFF". When I'm using the "Air" or "Heater" nothing works from "Low" to 4th level the only one that works is "Hi". Understand that both air and heat works but when I turn the knob I get nothing until I turn it to "Hi". Is this easy to fix myself and how do I do it?
  • maj1952maj1952 Posts: 4
    Have a 3.8 engine and would like to know if you can test the fuel relay?
    If so how, dont want to buy one if I dont have to. If Its good will have to
    put in fuel pump I asume.
    Thanks :)
Sign In or Register to comment.